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Chapter 1 mView software introduction

1.1 How to install mView software
(Please go to the official website :WWW.COOLMAY.COM to download the

latest version)
This chapter will detaily introduce the installation process of mView

software.
■Hardware requirements

The basic hardware requirements for installing mView editing software are
as follows:

1. Personal computer host: It is recommended to use a CPU of 80486 or
higher.

2. Memory: It is recommended to use more than 128MB RAM to expand
the memory.

3. Hard disk: The hard disk must have more than 100MB of space.
4. Display: General VGA or SVGA display card.
5. Mouse: Use a Windows compatible mouse.
6. Printer: Use a Windows compatible printer.
Before you install it, please check whether the computer hardware is as

above or higher. In order to avoid problems with hardware incompatibility,
please use the recommended specifications as much as possible. If you have
any questions, please contact our customer service.
■ Software source

You can enter our company's website WWW.COOLMAY.COM to obtain
the latest version of the software.
■ Installation steps (take the simplified Chinese version of mView as an

example), note that "mView ***" software version is subject to the official
website.
Select mView 13802.exe in the installer window to start the installer and

start the installation;
●Set the storage path of the installation file, select the default, or enter the
address, or click the [Browse ...] button to select the address, and then click
the [Next] button;

http://www.coolmay.com
http://www.coolmay.com
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●Set the name of the saved folder. It is recommended to select the default and
click the [Next] button directly.

●Choose whether to create a desktop shortcut icon, and then click the [Next]
button.
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●Confirm the installation path and other installation information, and then click
the [Install] button to install.

●The installation process is shown below:
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●Click [Next] to install the driver wizard

●The driver installation is completed
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●Finally, click [Finish] to complete the installation.

1.2 How to open mView software
After the installation of mView software is completed, a shortcut will be
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placed on the desktop , At the same time, the corresponding mView

program group has been added to the Windows start menu:

Choose one of the above two methods to open the mView programming
software. When the application is started, a startup window will pop up, as
shown in the following figure. After the software is opened, it will be checked
according to the menu bar [View]->[Option...]->[File]->Program start
automatically open file, to determine whether to start the last project file when
the software is opened, or not to open any file.

1.3 Introduction to the mView software interface
mView editing interface layout:
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●Title bar: Displays the currently opened project path and file name, window
number, and window name.
●Menu bar: A menu that displays various commands of CoolMayView. These
menus are pull-down menus.
●Standard toolbar: Shortcut buttons for placing some commands.
Corresponding buttons and editing tools for displaying files, editing, printing
and other functions.
●Design components: Command buttons for component objects.
●Screen management: The management window of the screen used by the
project.
●Communication management: engineering designers to manage, set up a
window to communicate with PLC or other serial devices.
●Label management: Set labels for system variables and external variables to
facilitate users to quickly find the corresponding variables.
●Status bar: Displays the current operation status, human-machine interface
parameters, and communication equipment.
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Chapter 2 Introduction of mView Software Running

Menu

2.1 File menu
Use the mouse to directly click [File], or use the keyboard to press [ALT] +

[F], the [File] drop-down menu appears, as shown in Figure 2-1.1. In order to
facilitate users to quickly select, shortcut icons are also provided in the toolbar,
as shown in Figure 2-1.2.

2-1.1

2-1.2
File toolbar
（1）New File…
（2）Open File…
（3）Save File

2.1.1 New File…

To create a new project, you can directly click [New File] under [File] menu,
Or click the icon in the toolbar, Or use the hot key Ctrl + N set by the
system. The dialog box shown below is displayed:
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Title: Enter the name of the new project;
Model: select the model of the human-machine interface (HMI);
Direction: select whether the editing screen is displayed horizontally or

vertically;
Description: Enter a help description for the newly created project, or

choose not to enter it.
After completing the project-related information input, click the [OK] button

to enter the communication information setting dialog box, as shown in the
following figure. For specific settings, please refer to section 2.4.2
Communication Management.
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2.1.2 Open File…

To open an existing file, you can directly click [Open File…] under [File]
menu, Or click the icon in the toolbar, Or use the hot key Ctrl + O set by the
system. The dialog box shown below is displayed:

Select the file with the suffix vxf that needs to be opened, press the [Open]
button, or double-click the selected project file with the mouse.
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2.1.3 Save File

To save the currently edited project to disk, you can directly click [Save
File] under [File] menu, Or click the icon in the toolbar, Or use the hot key
Ctrl + S set by the system.

When saving a new project, the save vxf file box as shown above will pop
up, enter the name of the project you want to save in the file name field, and
click the [Save] button. If the project has already been saved, pressing [Save]
will not display any dialog box, but only save the latest information of the
current project.

2.1.4 Save As File

Save the currently edited screen data to another specified file name on
the disk. This item can only be selected by [Save As File] under [File] Whether
it is a new project or an old project, the Save New File dialog box will pop up:
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After entering the new project name, click [Save] to save the project as a
new project file.

2.1.5 Close File

Close the currently edited project file. This item can only be selected by
[Close File] under [File]. If the project file is modified, the following dialog box
will pop up to save the modified project file.

Click the [Yes ] button to save the newly modified file, and then exit the
current project file;

Click the [No ] button to save the newly modified file, and then exit the
current project file;

Click the [Cancel] button to exit the dialog box and do nothing with the
newly modified file;
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2.1.6 Import

2.1.7 Export
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2.1.8 Exit

End the application and save the project, select the [Exit] option under the

menu [File], Or click the button in the main window. If the project has

changed, or has not been saved, the following dialog box will appear:

Click the [Yes ] button to save the newly modified file, and then close the
current software program;

Click the [No ] button to save the newly modified file, and then close the
current software program;

Click the [Cancel] button to exit the dialog box and do nothing with the
newly modified file;

2.2 Edit menu
Use the mouse to directly click [Edit], or use the keyboard to press [ALT] +

[E], the drop-down menu of [Edit] appears, as shown in Figure 2-2.1. In order
to facilitate users to quickly select, shortcut icons are also provided on the
toolbar, as shown in Figure 2-2.2.
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2-2.1

2-2.2

(1) Undo【Ctrl+Z】 (9) Order
(2) Redo【Shift+Ctrl+Z】 (10) Group
(3) Cut【Ctrl+X】 (11) UnGroup
(4) Copy【Ctrl+C】 (12) Lock
(5) Paste【Ctrl+V】 (13) Propertie
(6) Alig (14) Same bevel
(7) Size (15) Same font
(8) Jog

2.2.1 Undo

To undo the last edited action, you can select the [Undo] option under
[Edit], Or click the icon in the toolbar, Or use the hot key Ctrl + Z set by the
system.
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2.2.2 Redo

To restore the previous undo action, you can select the [Redo] option
under [Edit], Or click the icon in the toolbar, Or use the hot key shift + Ctrl +
Y set by the system.

2.2.3 Cut

Cut the selected components to paste in the new location. You can select
the [Cut] option under [Edit], Or click the icon in the toolbar, Or use the hot
key Ctrl + X set by the system.

2.2.4 Copy

If the components used are the same, you can use the copy operation to
make the same components. You can select the [Copy] option under [Edit], Or
click the icon in the toolbar, Or use the hot key Ctrl + C set by the system.

2.2.5 Multi-Copy

Select a specific component to make multiple copies, you can select the
[Multi-Copy] option under [Edit], or use the hot key Ctrl + M set by the system.
After clicking, the selection box as shown below will appear:

Multiple copy settings
Number of horizontal copies: Set the number of copies in the horizontal

direction.
Number of vertical copies: Set the number of copies in the vertical

direction.
Horizontal interval points: Set the distance between horizontal elements.
Vertical spacing points: Set the distance between vertical components.
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Component variable modification
Uncorrected: No processing is performed on the copied components.
Increasing in the horizontal direction: Set the order in which the device

reads the soft elements to increase horizontally and then vertically.
Vertical increment: set the order in which the device reads the device to

increase vertically first and then horizontally.
Address offset value: Set the number of increments of the device reading

device value.
●Example of multiple copying: select the horizontal number = 2 and the

vertical number = 3 above the number of copies

●Example of multiple copy: Click [OK] to complete multiple copy. The result is
shown below:

2.2.6 Paste

To insert the copied or cut components, you can select the [Paste] option
under [Edit], Or click the icon in the toolbar, Or use the hot key Ctrl + V set
by the system.



TK Series HMI Programming Manual

18 www.coolmayplc.com

2.2.7 Alignment

Select the components that need to be aligned, and there must be more
than two components. Click [Align] under [Edit], as shown below, Or click the

icon in the toolbar.

In this example, select [Upper Edge Alignment]. This alignment method
uses the top edge of the reference object as the object alignment. As shown
below:



TK Series HMI Programming Manual

19 www.coolmayplc.com

2.2.8 Size

Select the components that need to be set with the same size. There must
be more than two components. Click [Size] under [Edit], as shown below, Or

click the icon in the toolbar.

When selecting more than two graphic components, in order to speed up
the editing of the component size, you can use this alignment function to first
select the graphic component whose size you want to modify, and then select
which component is the main one. Then select [Same Width] or [Same Height]
or [Same Size]. As shown in the following figure [same width]:
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2.2.9 Jog

Use this function to finely move the position of the selected component.
After selecting the component, click [Fine Adjustment] in the [Edit] menu as

shown below, Or click the icon in the toolbar, You can move the selected
component position up, down, left, and right in detail, or you can use the
keyboard up, down, left, and right keys (fine adjustment), or you can use Shift
+ keyboard up, down, left, and right keys (with a grid point) Main), Ctrl +
keyboard up, down, left, right button (change the selected component size
fine-tuning) for rapid movement and size adjustment.

2.2.10 Order

After selecting the component, click [Sequence] in the [Edit] menu as

shown below, Or click the icon in the toolbar, When the components
overlap, the components can be moved to the upper layer, the next layer, the
uppermost layer, and the lowermost layer according to requirements.
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2.2.11 Setup

Select the component components that need to be set with the same
border and the same font. There must be more than two components. Click
[Setup] under [Edit] as shown in the figure below. Or click or icon in the
toolbar, You can set the border or font of multiple components to be the same
as the border or font of the selected reference component.
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2.2.12 Group / Ungroup

When selecting multiple components, when moving or copying, in order to
be able to edit quickly and easily. You can click [Group / Ungroup] under the

[Edit] menu, Or click or icon in the toolbar.

To group multiple components into one component, namely [Group], you
can also use the hot key [G]. Select the previously assembled components
and click [Cancel Group] to separate them, or use the hot key [U].

2.2.13 Lock object / unlock object

After selecting one or more components, click [Lock Object] under the
[Edit] menu to fix the component. The fixed component cannot be moved and
its attributes cannot be modified. To release the setting, select the component
to be released and click [Lock Object] under the [Edit] menu again to release.

Or click or icon in the toolbar to lock or unlock the component, you
can also use the hot key [L] to fix or cancel.
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2.2.14 Object properties

Since the object property window of each component is different, please
refer to the detailed description in the [Chapter 3 Components] chapter of this
manual.

2.2.15 Copy Screen Picture

Click [Copy Screen Picture] under the [Edit] menu to copy the current edit
screen window, as shown in the figure below. After copying, you can paste the
screen picture into drawing software or office software such as WORD to
facilitate file sort out.



TK Series HMI Programming Manual

24 www.coolmayplc.com

2.2.16 Save to BMP

After selecting the component you want to save as a picture, click [Save to
BMP] under the [Edit] menu, a dialog box as shown in the figure below pops up,
select the save path, enter the name of the picture to be saved, and click [Save
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(S)】 button to save the selected component as a picture.

2.2.17 Add Repository

This function puts the component into the component library. When using
it, you can open the component library and quickly select the component
according to the component setting classification and name in the component
library. After selecting any component, click [Edit]-> [Add Repository], the
following dialog box will pop up:

Type : Set the category of the component in the component library.
Group: Set the group of components in the category of the component

library.
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Name: Set the name of the component in the component library.
Description: Fill in the auxiliary description of the description component.

After the setting is completed, click the [OK] button, and the selected
component will enter the software component library, as shown in the following
figure:

When in use, you can double-click the component directly in the
component library, which can save the details such as setting the appearance
font, which greatly improves the speed of program writing.

2.3 View
Use the mouse to directly click [View], or use the keyboard to press [ALT]

+ [V], the [View] drop-down menu appears, as shown in Figure 2-3.1. In order
to facilitate users to quickly select, shortcut icons are also provided in the
toolbar, as shown in Figure 2-3.2.

.
2-3.1

2-3.2
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(1) Project
(2) Option
(3) Scale
(4) Zoom in
(5) Zoom out

2.3.1 Project management

The project management window refers to the comprehensive display and
management of the screen and communication of the current editing project.
Click [Project Management] under the [View] menu, there are the following four
sub-options.
1. Scene: After clicking scene, a window for screen management will appear
on the left of the software (this window is also the default display window), or
directly click [Screen] in the lower left corner of the software. The picture
management window is shown in the figure below. The management window
is responsible for the organization and planning of all screens of the
man-machine interface. For details, refer to 4.1ScreenManagement.

2. Communication: After clicking communication, a window for link
management will appear on the left side of the software, or click [Link] in the
lower left corner of the software. The link management window is shown in the
figure below. This management window is responsible for the man-machine
interface and programmable control The communication protocol and
configuration settings between the PLC (PLC) or other serial communication
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devices. For details, refer to 4.2 Link Management.

3. Tag: After clicking Tag, the tag management window will appear on the left
of the software, or directly click [Tag] in the lower left corner of the software.
The tag management window is shown in the figure below. For details, refer to
4.3 Tag Management.

4. Language : After clicking Language, a dialog box for language setting as
shown in the figure below will pop up. For details, please refer to Chapter 5
Language Management.
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2.3.2 Message window

Click [Message] under the [View] menu, and the grammar check window
as shown below will appear. When running, if there is a setting error, it will be
displayed in the syntax check window for program modification.

2.3.3 Repository

Click [Repository] under the [View] menu, or use the keyboard shortcut
[F12], the repository as shown below will appear. When performing interface
programming, use this window to conveniently access the required
components.
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When in use, select the component classification as required. As shown in
the figure below, select the component to be used in each category,
double-click the component, and the component is placed in the right screen
window.

2.3.4 Component list

Click [Component List] under the [View] menu, or use the keyboard
shortcut [F10], and the component list window as shown below will appear. In
the component list window, you can intuitively see all the components used in
the current screen window.
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2.3.5 Option(H)

Click [Option(H)] under the [View] menu, and the auxiliary setting dialog
box as shown in the figure below will appear.

Snap/Grid: The dialog box is shown above
Snap ON: This option refers to whether the upper left corner of the set element
must be on the set grid when editing the screen.
In the snap combo box, the distance between the snap is set separately in the
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XY direction, and the allowable setting range is 1 to 32. It is recommended that
the setting be consistent with the grid XY direction.
Grid ON: This option refers to whether to display background auxiliary grid
when editing the screen.
In the grid combo box, set the spacing of grid points in the XY direction, and
the allowed range is 1 ~ 32.
Grid color: Set the display color of the grid.
Object snap: This option refers to whether to display the alignment guideline
when the moving element is aligned up, down, left, and right when editing the
screen.
In the object alignment spacing combo box, set the alignment spacing in the
XY direction, and the allowable setting range is 1 ~ 32. The alignment
guideline is displayed when the distance between the moved component and
other components is equal to the set alignment distance.
Option: This option sets whether the screen displays a background grid when
the screen display ratio is greater than 400%.
Aux. Data of Obj.: The settings dialog box is shown below

Only Selected Obj.: Check this option, the following options are only displayed
for the selected components, otherwise all components in
the screen are displayed.

Obj. Sequence: Check this option, the order of each component will be
displayed on the screen.
Obj. Name: Check this option, the name of each component will be displayed
on the screen.
Parameter (Normal): Check this option, the screen will display the complete
information of the variables corresponding to each component.
Parameter (Simplify): Check this option, the simple information of the variables
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corresponding to each component will be displayed on the screen
Display font: Click the [Font] button to pop up a font selection dialog box, as
shown in the figure below, you can set the default font, font style, size, effect,
underline, and color of the displayed font.

Component Edit: The settings dialog box is shown below
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Set up
After adding a new component, the editing window is automatically opened:
Check this option, after adding a new component, the system immediately
opens the component properties dialog box. Otherwise, you need to manually
double-click the component to open the properties dialog box.
Fast moving components: Check this option, select the component and press
the up, down, left, and right buttons of the keyboard or the left mouse button to
move the components quickly.
Recovery settings
Memory limit of recovery function: It is the undo function. Choose to close, not
subject to this restriction; choose 8M-512M, that is, to revoke the memory size
limit.
Limit the number of recovery function: Choose Close to cancel the unlimited
number of times; choose 1 time, irrevocable; choose 2-64 times, you can
cancel 1-63 times.
When the editing screen is closed, clear and restore function: Check this
option to close the editing screen and clear the editing memory cached by the
software at the same time, that is, when the page is opened again, the undo
operation cannot be performed.
File: The settings dialog box is shown below
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1. After a new project is created, a communication protocol is automatically
added: Check this option. After a new project is created, a dialog box for
adding a new communication protocol is automatically displayed to
facilitate the user to set the communication protocol. Otherwise, it needs
to be set manually in the communication management.

2. When closing the screen window, ask if you want to save: check this option,
when closing the file, if the file adds new content, it will prompt whether to
save.

3. Automatically back up files when saving a project: Check this option to
automatically back up files when saving a project. The backup file has the
same location as the source file, and the file name is different.

4. Automatic backup when opening the old version project: Check this option to
back up the old version file when opening the old version file.

5. Automatically open old files when the program is opened: Check this option
to open the file from the last close when the software is newly opened.
Otherwise, you need to create a new file or manually open the old file after
opening the program.

6.Interval time backup: you can choose to close or 1-10 minutes, preset 3
minutes; after selecting the number of minutes, the project will be backed
up according to the selected time interval; the same project can backup up
to 32 files, namely backup00-backup31, and then will be overwritten in a
loop. Backup path [C:\Users\<user name>\Documents\HMI
Backup]\backupxx,[xx=00~31]

7. Add decompiled information: Check this option to add decompiled
information when compiling the project file. That is, the project file read
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from the HMI can be modified by programming.
8. Program compression: When the program is downloaded, the project file will
be compressed to save download time.
Frame Size Transfer: The settings dialog box is shown below

Mini Size：After setting the model conversion, the minimum size of the
component text size is 8

Max Size: After setting the model conversion, the maximum size of the
component text size is 32

In the same program, when the model is converted, due to the different
screen size, the screen components will be enlarged or reduced proportionally.
The font size is set here. During the conversion process, the font size will be
modified according to this setting to make the converted screen The layout is
more coordinated.

2.3.6 Auxiliary data of Object

For the content of this section, please refer to Auxiliary data of Object in
Section.

2.3.7 Scale

Click [Scale] under the [View] menu, as shown below:
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You can choose the size ratio of the picture window according to your
preferences. To adjust the size ratio of the screen, you can also use the
zoom-in hotkey [I] and zoom-out hotkey [O] set by the system.

50% magnification display
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100% magnification display

2.3.8 Toolbar

Click [Toolbar] in the [View] menu, you can freely select and display the
tools in the shortcut tool, as shown in the following figure:

2.4 Project
Use the mouse to directly click [Project], or use the keyboard to press

[ALT] + [P], the [Project] drop-down menu will appear, as shown in Figure 2-4.1.
In order to facilitate users to quickly select, shortcut icons are also provided in



TK Series HMI Programming Manual

39 www.coolmayplc.com

the toolbar, as shown in Figure 2-4.2.

2-4.1

2-4.2
(1) Screen
(2) Communication
(3) Tag
(4) Language
(5) Keyboard Define
(6) Alarm
(7) Password
(8) Sound
(9) Protection
(10) Data Sync
(11) Record
(12) Data Schedule
(13) Recipe
(14) System Configuration
(15) Macro
(16) Report Manager
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2.4.1 Screen

Click [Screen] under the [Project] menu, the options shown in the figure
below appear, and users can perform operations such as adding, copying,
editing, and deleting screens according to the needs of the program. When the
mouse focus is on the current screen group of the software program, the
options of adding, editing, deleting a group, and opening and closing the group
screen will be highlighted and can be used.

1. Add Screen Group: Click [Add Screen Group], and the setting dialog box
shown as below will pop up.

Group Name: Enter the name of this group.
Security: Operation authority 1 ~ operation authority 9, the greater the

number, the lower the authority.
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Description: Enter the help description of this group, you can leave it blank.
2. Edit Screen Group: Click [Edit Screen Group] to pop up the setting dialog
box as shown in the figure below. This function refers to when the group
description is not perfect when creating a new group, or when the original
group description needs to be modified, use this function to modify the relevant
information of the group.

3. Delete Screen Group: Click [Delete Screen Group], and the setting dialog
box shown as below will pop up. After clicking the [OK] button, the system will
delete all the screen information under the group. After clicking the [Cancel]
button, the system does not perform any operation on the group.

4. Open Screen Group: click this option to open all the screen information in
the selected group.
5. Close Screen Group: click this option to close all screen information in the
selected group.
6. Add Screen: When you click this option, the New Screen dialog box as
shown below will pop up.
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Screen
Name: Enter the name of the newly created scene.
ID: Enter the number of the newly created screen. The setting range of the

number is 1 ~ 32767. The number of each screen cannot be
repeated.

Type: Click on the drop-down arrow and 4 options appear.
Normal Screen: Basic editing operation screen.
Dialog box: Select this option to set the screen as the dialog box page.

Dial box specific functions refer to 4.1.1 chapter.
Boot Screen: Select this option, the current page is the first screen that

appears when you open the touch screen, similar to the startup screen of a
computer.

Initial screen: The first screen after the touch screen is turned on (the
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startup screen has been displayed).
Security: Operation authority 1 ~ operation authority 9, the greater the

number, the lower the authority. Corresponding authority password setting is
set in [Project]-> [Password]

Set by screen group: The operation authority is the same as the screen
group authority.

Inherit: Select this option to make the screen inherit the settings of the
selected screen.

The inherited picture is called the parent, and the current inherited picture
is the child. When the child inherits the parent, all the components of the
parent will be inherited together, but the child cannot change the parent's
components, and can only create or modify their own components. If you want
to modify the parent components in the child screen, you need to open the
parent screen and then modify the components At this time, all the parent
symbols in the child pictures inheriting the parent will be modified at the same
time.

Description: Enter a help description for the current screen.
Auto Switch

Delay Time: The time interval when switching between scenes.
Jump to: After setting the selection screen, when the delay time is reached,

it will jump to the set screen.
Load BG Image: Click this button to select the desired picture as the screen
background.
Clear BG Image: Click this button to delete the screen background image.
Position: Set the position of the background image.
Macro:

Screen OPEN Macro: Click here to pop up a dialog box to edit the macro
program when the screen is opened.

Screen CLOSE Macro: Click here to pop up a dialog box to edit the macro
program when the screen is closed.

Screen CYCLE Macro: Click here to pop up a dialog box to edit the macro
program executed in this screen.

CYCLE Macro Interval : Set the interval time when executing the macro
program of this screen.
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Quick jump page:
Set the screen page for page change when using the gestures left, right,

up, and down.
Controlled condition: refers to the necessary conditions for the

establishment of this slide function, as shown in the above figure, when N0 =
100, slide the HMI touch screen to the left, and the screen jumps from the
current screen to screen 1.

Apply all screens: Check this option, the slide screen pages of all screens
in this group are the same.
Sub Screen:
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Display Addr: Set the variable position. Bit0-bit3 of the variable control sub
screen 1-sub screen 4 respectively. When the variable is
changed, the corresponding sub screen will be displayed,
but the sub screen is only in the display state. As shown in
the figure above: when N0.0=1, sub screen 1 is displayed;
when N0.1=1, sub screen 2 is displayed; and so on...

Control Addr: Set the address of the control screen variable, bit0-bit3 of
this variable control the variables of sub screen 1 to sub
screen 4 respectively; when the [Display Addr] changes,
the corresponding sub screen will be displayed, at this
time [Control Addr ] You can operate the sub-screen when
changing. As shown in the figure above: when N0.0=1,
sub-screen 1 is displayed, and when N1.0=1, the variables
of sub-screen 1 can be operated. And so on...

Sub-Screen 1/2/3/4: Set the sub-screen to be displayed when the variable
changes.

For details, please refer to the official website "Sub-screen example"
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Fast Communication:
Namely fast reading area, set the fast communication variable of the

current screen, so that the set variable can be read quickly.
7. Copy Screen: When you click this option, the current screen will be copied
to the PC pasteboard, which is convenient for quickly creating a new screen.
8. Edit Screen: Click this option to edit or modify the attributes of the current
screen.
9. Delete Screen: When you click this option, the current screen will be
deleted.

The confirmation dialog box for deleting the screen is displayed as shown
in the figure below. Click [OK] to delete the screen, and click [Cancel] to do
nothing on the current screen.
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10.Lock Screen: Click this option to fix the current screen components. You
cannot add, delete, or modify the components in the screen.
11. Open Screen: click this option, the screen jumps to the screen where the
focus is in the screen management.
Example: The current screen is screen 1, click screen 2 in screen
management, and then click [open screen], then the current screen jumps to
screen 2.
12. All Screen to BMP: Click this option to output all pictures in the current
project as pictures and save them in the path specified by the user.

2.4.2 Communication

Click [Communication] under the [Project] menu, and the options shown in
the figure below appear. The user can add, edit, and delete communication
protocols and controllers according to the needs of the program.

1. Add Protocol: After selecting a communication port that has not been
configured with a communication protocol, click [Communication], and then the
option [Add Protocol] will be highlighted. Click this option, the following dialog
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box will pop up:

Protocol: Use the drop-down options to select the communication protocol
to be used.

Controller: Display the manufacturer and model selected by the
communication protocol.

Port: There are four options for selection, automatic identification, RS232,
RS422, RS485.

Baud Rate: from 150 ~ 115200 rate, available for selection.
Parity: [none], [odd parity], [even parity], [mark], [space].
Data Bit: [5], [6], [7], [8].
Stop Bit: [1 digit], [2 digits].
Delay: from no delay, delay 10ms to delay 5000ms, available for selection.
Timeout: [0.1 sec], [0.2 sec], [0.5 sec], [1 sec], [1.5 sec], [2 sec], [3 sec], [5

sec], [10 sec] total 9 Options.
Retry Count: Set the number of retransmissions when the communication

is unsuccessful.
Multi-Station Smart Link: see Appendix 5 for details.
OK / Cancel: After setting, press [OK] to save the completed settings,

press [Cancel] to exit the dialog box without setting the communication
protocol.
2. Edit Protocol: After setting up a new communication protocol, if there is a
setting error, you can use this function to modify it.
3. Delete Protocol: delete the communication protocol that has been newly
created.
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4. Add Controller: After the communication protocol is added, the controller to
which the protocol belongs needs to be set. Click the [Add Controller] option, a
dialog box as shown below will pop up:

ID: ID number of the controller.
Station: the station number of the controller, that is, the ID number of the

PLC,
Controller: Display the selected manufacturer, model, description and

other information.
Description: Enter a description or help for this controller.
OK / Cancel: After setting, press [OK] to save the completed settings.

Press [Cancel] to exit the dialog box without setting the controller.
5. Edit controller: Select an existing controller and click this option to modify its
settings.
6. Delete controller: Select an existing controller and click this option to delete
it.
7. Variable Window: Click this option to pop up the dialog box as shown in the
figure below,
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Controller: Provide HMI internal variables or controller variables set in the
communication protocol for selection.

Variable/Para.: Displays the specific information of the variables included
in the selected controller.

Number: Open this window in the component properties window, you can
directly enter the variables of the system or controller.

2.4.3 Tag

There are many types of controllers that communicate with the
human-machine interface. The communication protocol and memory numbers
of different manufacturers are not the same. In order to facilitate the function of
memorizing contacts and memory numbers, you can use tag management to
increase readability. For example, when adding a label, we want to replace the
X1 contact with the name "for testing". After the addition is complete, enter "for
testing" in the write or read position only when the component needs to use X1
"Or click the drop-down option to select" for testing ", the system will treat" for
testing "as X1. After setting to tag management, users can replace the names
of contacts and memory on the communication protocol specifications with
names that are easy to remember.

Click [Tag] under the [Project] menu, and the options shown in the figure
below appear. The user can perform operations such as adding, editing, and
deleting communication protocols and controllers as required by the program.
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1. Add Tag Group: classify tags for easy management and editing.
Click [Add Tag Group], a dialog box as shown below will pop up:

Enter the name of the newly added tag in the tag group name and click the
[OK] button. The newly added tags are newly added to the tag management,
as shown in the following figure:

2. Edit Tag Group: modify the name of the currently selected tag.
3. Delete Tag Group: modify the currently selected tag.

Click this option to pop up the dialog box as shown in the figure below.
Click the [OK] button to delete the selected tag group. Click the [Cancel] button
to keep the selected tag group.
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4. Add Tag: add a new tag.
Click this option to pop up the dialog box shown below:

Tag Group: The current tag group is written by default and can be selected
using the drop-down list.

Tag Name: Enter the identification name corresponding to this location,
you can replace the location.

Address: Enter the correct contact or memory location of the controller to
be used, and the register address D101 of Mitsubishi PLC FX3U is used in the
above figure.

Max: Enter the maximum value of this contact or memory, you can not
enter it.

Min: Enter the minimum value of this contact or memory, you can not enter
it.

Description: Enter the description of this label, you can not enter it.
OK / Cancel: After setting, press [OK] to save the completed settings,

press [Cancel] to not proceed Set the label and exit the dialog box.
5. Edit Tag: modify the content of the existing tag and other operations.
6. Delete Tag: delete the existing tag.

2.4.4 Language

Click [Language] under the [Project] menu, and the options shown in the
figure below appear. The user can add, edit, delete language selection, and
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set the initial language translation according to the needs of the program.

1. Add Language: add a new language.
Click this option to pop up the dialog box shown below:

Name: Click the drop-down list to select the language to be created.
Local ID: The region code of the region where the selected language is

located. This item is added by default.
Font: displays the selected preset default font.
Font: Click this button to pop up the font selection dialog box, as shown in

the following figure, you can set the default font, font style, size, effect,
underline and color of the new language.
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Test: display the template of the selected font.
Decimal: Set which symbol to display when displaying the decimal

symbol.
Separate: Set which symbol to use when displaying the separator.

2. Edit language: Click this option to set the font, font style, size, effect,
underline and color of the existing language.
3. Delete language: Click this option to delete the existing language.

4. Initial language: click this option under multiple languages to set the initial
language.
5. Translate: Click this option to convert the language on the screen to the
selected language.
6. Dictionary: Set the corresponding language translation by yourself.
For a detailed introduction and application examples of language management,
please refer to Chapter 5 Language Management.

2.4.5 Keyboard Define

This model does not have this function temporarily.

2.4.6 Alarm

After clicking [Alarm] under the [Project] menu, the setting dialog box
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shown below will pop up to set the alarm information. For detailed introduction
and cases of specific alarm management, please refer to Chapter 6 Alarm
Management.

Add Alarm: Add a new alarm information area.

Name: Enter the name set for the newly added alarm zone.
Address: The position of the input variable can be selected by the drop-down

arrow symbol or directly input the variable position. As shown in the
above figure, the icon button behind the input box indicates that
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this position must be WORD. Click this button to pop up the variable
window shown below The type of variable. At the same time, you can
also enter or select the desired variable in the number edit box in the
figure below.

Mask: When the alarm is triggered, this function can be used to mask the
alarm, that is, the alarm information and sound are not
displayed. The method of selecting the mask address is the
same as the method of selecting the address of the alarm
area.

Update: You can choose how often to update. If you select 3 seconds, it means
that you will check whether the alarm is triggered every 3
seconds.

Delay: choose whether to wait for the controller to start to create data and then
start the alarm time.

Group: You can check the group to which this alarm will be classified.
Double-click the left mouse button in the group to edit the
group name.

Description: Enter the help description for this alarm.

2.4.7 Password

After clicking [Password] under the [Project] menu, the setting dialog box
shown below will pop up to set the password for setting the user authority. For
a detailed introduction and case of specific password management, please
refer to Chapter 7 Password Management.
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2.4.8 Sound

After clicking [Sound] under the [Project] menu, a dialog box for setting
audio as shown in the figure below will pop up to set the audio that the user
needs to use. For a detailed introduction and case of specific audio
management, please refer to Chapter 8 Sound Management.
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2.4.9 Protection

After clicking [Protection] under the [Project] menu, a dialog box as shown
below will pop up to set the upload / download password of the HMI program.
To achieve the function of data protection.

Password protection for project uploading, downloading, uploading and
editing, and setting of passwords and password prompts.
After setting the [Download Password], use the [Save Project to File] function
under the [HMI] menu to save the project as a vho file. If you want to use this
vho file to download to HMI later, select [Tool]-> [Download HMI program ...], a
dialog box as shown in the figure below will pop up to select the vho file.

After confirming the vho file selection, click the [Open] button, and the
download password input box will pop up as shown in the figure below. After
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entering the password correctly, click the [OK] button to download the program
to the HMI.

2.4.10 Data sync

After clicking [Data Sync] under the [Project] menu, a dialog box as shown
below will pop up. For a detailed introduction and case of data synchronization
management, please refer to Chapter 9 Data Synchronization Management.

2.4.11 Record

After clicking [Record] under the [Project] menu, the following dialog box
will pop up.
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Add: Click this button to pop up the dialog box for defining a new data record
as shown in the figure below.
Edit: Click this button to re-edit the selected existing data record.
Delete: Click this button to delete the selected existing data record.
Import: Click this button to import the data record of the vdr file stored in the
computer into the HMI project.
Export: Click this button to export the data records in the HMI project to a
computer and store them in a vdr file.
The Add data record definition dialog box is shown below:
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Name: Enter the name of the data record.
Data Format: Select the type of data. There are five types of contacts,

16-bit signed / unsigned, 32-bit signed / unsigned.
Source: Set the location of the data source.
Data Length: set the length of the data, the range is 1 ~ 16. For example, if

it is set to 4, and the source address of the data is set to D0, it means that the
data is read from D0 ~ D3, which has 4 register addresses.

Record Count: set the total number of records of the data, the range is 1 ~
32767.

Update Time: set the interval time record data. That is how often to record.
Record Flag: Set a variable, and use this variable to control start recording

and stop recording.
Clear Flag: Set a variable to control the clearing of previously recorded

data. For example, select M0 here, when M0 is turned on, clear the previously
recorded data.

Clear [clear flag]: Check this option to clear the flag while disconnecting
the clear flag. That is, when M0 is turned on, after clearing the previously
recorded data, M0 is turned off.

Stop Count: Set to stop recording when recording to the set quantity.
When set to 0, this function is not used, that is, the data is always

recorded.
Description: Provide supplementary explanation for this record, you can

leave it blank.
Record Date/Time: Check this option to record the time when recording

data when recording data.
Retentive: Check this option, the data will be saved when the HMI is

powered on again.

2.4.11.1 Case of Record use

Click the software menu-> [Project]-> [Record...], Data record
management dialog box as
shown below pops up.

Click the [Add] icon, and in the pop-up New Data Record Definition dialog
box, set each record as shown below:
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After the setting is completed, click the [OK] button, and the data record
management display is as shown below.

After the data is added, the data record can be used. When using
[Element]-> [Display Element]-> [Historical Trend Graph], the [Historical Trend
Graph] property screen as shown below.
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In the data record drop-down list, select the data to be recorded. In this
example, select the NNNN data. After selection, the following figure is shown.

As set in this example, when the recording flag condition is reached, that is,
when N10.0 = 1, the data of N0 and N1 will be displayed in a curve, and the
record is shown in the figure below
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When you need to delete the curve, set the value of the clear flag to 0, that is,
N10.1 = 0. In this example, set N10.0 to 0, as shown in the following figure.

2.4.12 Data schedule

After clicking [Data Schedule] under the [Project] menu, the following
dialog box will pop up. It can be used to implement the scheduling
requirements for a fixed time or a specific time to perform control.
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Add: Click this button to pop up the new data schedule definition dialog box as
shown in the figure below:
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Condition: Select the time condition of data scheduling, which can be set
by four modes, which are explained separately below.
Use fixed time setting (month, week, day, hour, minute, second)

Check this option, the user can use the action to the nearest second to
trigger. As shown in the above figure, the value of register D100 is passed to
D101 at 0:20:37 on January 1 and August 4 of January and August. The
setting method is shown in the figure above.
Use fixed time setting (month, week, hour, minute)

Check this option, the user can use the action trigger to the nearest minute
or a period of time (to avoid the situation that the power is turned on after the
set time point and the action is not completed), as shown in the picture, every
Thursday in January When 0, transfer the value of register D100 to D101, the
setting method is shown in the figure below. It should be noted that the
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"minute" setting column needs to select all, so to avoid if only select 0 points, if
the boot time is at 0: 1 or after, this action can still be completed.

Use time variable settings (month, week, day, hour, minute, second)
Check this option, the user can choose the controller by himself, use a

continuous register (8 Words) as the time variable, this option can change the
time condition at any time through the variable setting, as shown in the
following figure:
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Use time variable setting (week, hour, minute)
Check this option, the user can select the controller by himself, and use a

continuous register (3 Words) as the time variable. This option can change the
time condition at any time through the setting of the variable, as shown in the
following figure:
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Edit: Click this button to re-edit the selected existing data schedule.
Delete: Click this button to delete the selected existing data schedule.
Import: Click this button to import the vdh file data stored in the computer into
the HMI project.
Export: Click this button to export the data schedule in the HMI project to a
computer and store it as a vdh file.

2.4.13 Recipe

After clicking [Recipe] under the [Project] menu, the following dialog box
will pop up. Set the data recipe that the user needs to use. For detailed
introduction and cases of specific recipe settings, please refer to Chapter 10
Recipe Management.
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2.4.14 System Configuration

After clicking [System Configuration] under the [Project] menu, the
following dialog box will pop up. Can set the screen control and power saving
mode.

Scene Control: Set the variable, and control the automatic switching of the
man-machine screen through the change of the variable data.

Control Address: select the variable address or label name to control the
screen switching. The variable must be a 16-bit unsigned number.

Update Time: Set the update time of screen switching.
Manu Switch Frame: Set the variable value change after manual screen
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switching, by "variable writing 0" and "variable writing switching screen ID
(number)".
Power Down Mode: set whether the system uses power saving mode

Use power saving mode: After checking this option, the items shown in the
figure below can be set to set the time of power saving mode.

Switch screens when entering power saving mode: After checking this
option, the settings shown in the figure below appear.
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Screen switch: Select the screen to switch to when entering the power
saving mode.

After the action, set to the lowest operation authority: After checking this
option, when entering the power saving mode, the operation authority is set to
the lowest.

When recovering, jump back to the previous screen: After checking this
option, touch the screen in the power saving mode to jump back to the
previous screen when the screen is switched.

2.4.15 Macro

Click [Macro] under the [Project] menu, as shown in the figure below, you
can select the macro to be set to write the macro. The preparation of specific
macro instructions and case introduction, please refer to Chapters 11 and 12
for details.
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2.4.16 Report Manager

This model does not have this function temporarily.

2.4.17 Setup (Station ID / Model)

Station ID
Click [Setup]-> [Station ID] under the [Project] menu to open the station

number setting dialog box as shown in the figure below. In general use, the
man-machine interface can be master or slave. This product provides a total of
191 (0 ~ 190) groups of Master station numbers for users. Group) station
number, you can set multiple display units to use in the same group.
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Model
In general use, planning a human-machine interface solution is very

time-consuming, so the engineer will choose to modify or apply the previously
used solution. If you need to modify the model when using different models,
click [Setup]-> [Model] under the [Project] menu to open the conversion model
inquiry dialog box as shown in the figure below.

Selecting the [Yes] button will save the unconverted project, and selecting
[No] will not save anything, and a dialog box for modifying the model, number
and other information as shown in the figure below will pop up directly.
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After inputting the project title, model number and display direction of the
new project, click the [OK] button to pop up the dialog box as shown in the
figure below. You can click the corresponding button to replace the project as
required.

2.5 HMI
Use the mouse to directly click [HMI], or use the keyboard to press [ALT] +

[M], the drop-down menu of [HMI] will appear, as shown in Figure 2-5.1. In
order to facilitate users to quickly select, shortcut icons are also provided in the
toolbar, as shown in Figure 2-5.2.
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2-5.1

2-5.2
(1) Syntax Check
(2) On-Line Run
(3) Off-Line Run
(4) Stop
(5) Download to HMI

2.5.1 Syntax Check

Click [HMI] menu bar [Syntax Check] or directly press the shortcut key [F8]
or directly click the toolbar icon . When running [Syntax Check], check
whether the variable names or settings are correct during the compilation of
each screen in the project, and provide error information in the [Grammar
CHK], so that we can eliminate the error information. In addition, the [Syntax
CHK Mes.] dialog box will pop up, displaying information such as memory
usage, data type ratio, memory font data, etc., for the user to refer to when
editing. As shown below:
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2.5.2 On-Line Run

Click [HMI] menu bar [On-Line Run] or directly press the shortcut key [F9]

or directly click the toolbar icon . Execution of this function requires actual

connection with the controller, and during execution, the project will modify the
corresponding variable register set by the controller to verify whether the set
controller action can be performed normally.

Before [On-Line Run], you need to set the communication, click [HMI]
menu bar [Setup]-> [Communication Setup], the communication port setting in
the upload / download page refers to the use of the designated PC Which port
of the terminal is connected to the display unit. The communication port setting
in the emulation communication setting page refers to the communication port
on the display unit. Screenshots of the two pages are shown below.
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2.5.3 Off-Line Run

Click [HMI] menu bar [off-Line Run] or directly press the shortcut key [shift

+ F9] or directly click the toolbar icon . When using this function, there is no

need to connect with the actual man-machine interface, so that the customer
can use it to check whether the project can be executed normally and verify
whether each function is correct.

2.5.4 Stop

When [Offline Execution] is not executed, this option is grayed out and
cannot be selected. This option is highlighted when the offline execution of the
computer needs to be ended. You can click [HMI] menu bar [Stop] or directly
press the shortcut key [Ctrl + F9] or click the toolbar icon directly. Stop the
execution of offline.

2.5.5 Download to HMI

Before downloading the project to the HMI, you need to set up the
communication settings first. Here you can refer to the communication settings
in 2.5.2 online execution.

After the project is completed, you need to download the project to the
HMI. You can click the [HMI] menu bar [Download to HMI] or directly press the

shortcut key [Ctrl + Alt + S] or directly click the toolbar icon . The dialog box

shown below is displayed.



TK Series HMI Programming Manual

79 www.coolmayplc.com

Turbo Download: After checking, the download speed is faster.
Com Port Set: Here, select the PC port where the host PC and HMI are

connected.
Init Register: After checking, the buffer is initialized when downloading.
Update Password: After checking, the password table will be updated

when downloading.
Clear Retentive Reg.: After checking, the data in the power-off retention

buffer will be cleared when downloading..
Init Station ID Group: After checking, the station number group setting will

be updated when downloading.
Update RTC: After checking, set the HMI time to be the same as the

computer time when downloading.
[Download]: Click the download button to download the program to the

HMI.
[Cancel]: Click the Cancel button to cancel the download of the program.
[Setup]: Click the setting button, a communication setting dialog box pops

up to set upload / download and COM port.

2.5.6 Save To File

In addition to downloading the created program directly to the HMI, the
software also provides a specific project to save the user-made program as a
suffix (.vho) for users to download the program.

Note：if unchecked the menu bar [View]->[Option...]->[File]->[Add
Decompiled Information],then this file of(.vho) can only be downloaded, and
the program cannot be modified.

Click the [HMI] menu bar [Save project to file], a dialog box will pop up
shown as below. Click the [Save] button to save the project as a HMI specific
file with the extension (.vho). Click the [Cancel] button.
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If you need to download this program to the HMI in the future, you can
click the [Download HMI program ...] under the [Tools] menu to select the
desired file with the suffix (.vho) to download to the HMI Interface.

2.5.7 Setup

Click [Setup]-> [Communication Setup] under the menu bar of [HMI], and a
dialog box as shown below will pop up.

Upload/Download
Connection Device: Set the COM port of the computer that the display unit

is connected to.
Fixed Baud Rate (115200, N, 8,1): Select this option to use only this

communication rate to communicate with the PLC.
Auto. Baud Rate: Select this option, you can select multiple speeds. When
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the HMI communicates with PLC, you can use the
selected speed for communication.

Simulate COM Set
COM1: Select the COM port on the computer.
COM2: Select the COM port on the computer.
After the simulation communication setting is completed, select [HMI

(M)]-> [Online Simulation] to enable the PC to communicate with the controller
as an HMI, so that the user can check whether the set function has achieved
the desired effect.

After the COM1 / COM2 settings on this page is completed, the
communication tap in the software is shown as below.

2.6 Component
Click [Component], or press [ALT] + [C], the [HMI] drop-down menu

appears, as shown in Figure 2-6.1. In order to facilitate users to quickly select,
shortcut icons are also provided on the toolbar, as shown in Figure 2-6.2.
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2-6.1

2-6.2
For the use of each component, refer to Chapter 3 [Component] for details.

2.7 Tool
Click [Tool], or press [ALT] + [T], then the [Tool] drop-down menu will

appear, as shown in figure 2-7.1.

2-7.1

2.7.1 Download HMI...

Click the [Download HMI program ...] option under the [Tool] menu bar, and
the dialog box shown below will pop up. The purpose is to download the saved
file with the suffix name (.vho) from the HMI. The file is for download only and
cannot be modified.

Create a (.vho) file, click the [Save Project to File ...] option under the [HMI]
menu bar, and the current project will be saved as a (.vho) file to the
user-specified location.
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After selecting the (.vho) file to be downloaded, select and click the [Open]
button. The following download dialog box pops up. After selecting the correct
port number, click the [Download] button.

The project download process is shown below.
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After the download is complete, click the [Finish] button to complete the
download process.

2.7.2 Upload HMI...

Use this function to read the project in the HMI to the PC and save it as
HMI project for modification and subsequent download. Click the [Upload HMI
Program ...] option under the [Tool] menu bar, a dialog box as shown in the
figure below pops up. After selecting the correct communication port, click the
[Upload] button.
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After selecting and clicking the [Upload] button, if an upload password is
set in the program, the following password input screen will pop up:

Input password and click [Confirm], an upload picture will be shown as
below.

After the transfer is completed, the user will be asked to save the project
as a dedicated project with the suffix (.vho), as shown in the figure below.
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Select the path to save the (.vho) and click the [Save] button to save the
file that read from the HMI. Click the [Finish] button in the upload program
dialog box below, and the HMI reads the program is finished.

2.7.3 Update HMI OS...

For this software, if the new mView software version is released, it will be
matched with the corresponding version of the OS. The role of the OS is to the
software compatible with the lower computer. If users need to use the
functions provided by the new software version, they need to use the new
version of the OS. The download steps of the HMI OS are as follows.

1. Click [Update HMI OS ...] in the [Tool] menu bar, shown as below.
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2. In the pop-up dialog box, select the OS version to update, as shown in the
figure below. It is recommended to update as the software version of the host
computer used.

3. After selecting the OS file, click the [Open] button, the following dialog box
pops up, click the [Update] button to start updating the OS system.
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4. The update process is shown as below.

5. After the update is completed, you need to power on the display unit again,
the following prompt box pops up, click [OK].

2.7.4 Language Selection

There are three editing software languages available, [Chinese
(Traditional)], [English], [Chinese (Simplified)]. The software for each language
is shown below.
[Chinese (Traditional)]

[English]
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[Chinese (Simplified)]

2.8 Window
Click [Window], or press [ALT] + [W], the drop-down menu of [Window]

appears, as shown in Figure 2-8.1.

2-8.1
When you need to use multiple screens in a project, in order to facilitate

viewing and editing, you can select this way to edit the screen, as shown in the
following figure, you can choose [Cascade], [Tile Horizontal], and [Tile
Vertical].

[Cascade]
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[Tile Horizontal]
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[Tile Vertical]

2.9 Help
Click [Help], or press [ALT] + [H], the [Help] drop-down menu appears, as

shown in Figure 2-9.1.

2-9.1
Click [mView Help],pop up the user manual of this software. Users can

find related contents.
Click [About...], the software version will appear, as shown in the figure

below. Please pay attention to whether it is the latest version. If you have any
questions, please contact us.
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Chapter 3 mView Component Function Description

The components provided by this software are divided into the following five
categories:
1. [Graphic].
2. [Static].
3. [Button].
4. [Display].
5. [Edit].

3.1 Graphic
To use a graphic component, you can click [Graphic] under the

[Component] menu bar, and the drop-down options appear, as shown in the
following figure 3.1-1, or you can directly click this option on the shortcut bar of
the tool, as shown in the following figure 3.1-2 Shown

3.1-1

3.1-2

Select the component you need. Click the component and press the right
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mouse button to select the object properties, or double-click the mouse directly
on the component to be edited, the component property settings appear. The
[Point] and [Line] property window are shown as below:

Style: The display of point or line is available.
Color: Modify the color of the component.
Position: X1 / Y1 represents the leftmost point of [Line], X2 / Y2 represents
the rightmost point of [Line].
X: Modify the coordinates of X so that the component X coordinates move to
the modified X coordinates.
Y: Modify the coordinates of Y so that the component Y coordinates move to
the modified Y coordinates.

The properties of other components are the same. There is an example here.
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Pen:
Style: Select the style of the ellipse frame.
Color: Select the color of the ellipse frame.

Brush:
Style: display and set the style of ellipse inner frame.

Position:
X: Enter the X coordinate position of the ellipse element.
Y: Enter the Y coordinate position of the ellipse element.
W: Enter the width of the ellipse element.
H: Enter the height of the elliptical element.

3.1.1 Brush Settings

The previous section introduces brushes. This section explains the brush
setting steps and details.
Click the preview image in the Brush Style, there will pop up the variable brush
dialog box shown as below.

Brush Effect: Select normal or flash effect in the drop-down list.
Click the preview of the brush style, and the brush selection dialog box will

pop up.
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Pattern: Select the brush pattern to be displayed.
Foreground Color: set the brush pattern color.
Background color: Check the background color to display the

background, otherwise there is no background color. Set the background color
of the brush pattern.

[OK]: After setting, click [OK] to save the settings.
[Cancel]: Click [Cancel] to not save the selected settings.

Variable Brush: Check this option to set the parameters that control
brush changes. The dialog box is shown below.
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Data Format: Select the type of variable that controls the brush change.
Condition: Set specific variables.
Condition: Set the conditions of the brush changes, providing a total of six

conditions to choose from: equal to, not equal to, greater than, equal to, less
than, less than or equal to.

Condition: Set the contrast variable. As shown in the figure above, set D0
to display different brushes when compared with D1 / D2 / D3.

Pen Style: Select the style of the brush frame.
Pen Color: Select the color of the brush frame.
Brush Style: Select the pattern displayed by the brush.
Brush Effect: Select normal of flash effect.
[OK]: After setting, click [OK] to save the settings.
[Cancel]: Click [Cancel] to not save the selected settings.

3.2 Static Component
Click [Static] under the [Component] menu bar, and the drop-down option

for the static component appears, as shown in the following figure 3.2-1, or you
can directly click this option on the tool shortcut bar, as shown in the following
figure 3.2-2 Shown
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3.2-1

3.2-2

3.2.1 Static Bevel/ Text

After selecting the component to the editing area, right-click the mouse to
select [properties], or double-click directly on the component to be edited, the
properties of the component will appear, the static bevel and text property
dialog boxes are shown in the figures below.
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Bevel
Select: Select the bevel style of the component, click [Select] to pop up the
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box as shown below.

Out color: select the color of the frame of the component.
In color: select the inner frame color of the component.

Brush
Style: Select the brush style of the component, refer to 3.1.1 for details.

Position
X: Set the X coordinate position of the element.
Y: Set the Y coordinate position of the element.
W: Set the width of the element.
H: Set the height of the element.

Text
Language: Select the language to be used by the component.
Color: Select the text color of the component.
Word Wrap: Check this option. When the length is insufficient, the text will
automatically wrap. Otherwise, no line feed processing will be performed.
Align: Select the text alignment position of this component.
Effect: Select whether the text is displayed as normal or move.
Flash: Select whether the text is displayed normally or blinked.
Font: Select the font of the text. A dialog box for selecting specific font

properties is displayed as shown in the figure below.
Text: Enter the text to be displayed. This component supports the display

function of the embedded numeric value of the character string. For detailed
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settings, please refer to Appendix 6 for the display function of the embedded
numerical value of the character string.

Font: Select the font style of the text.
Font style: Select the font style of the text.
Size: Select the font size of the text.
Effect-Strikeout: Select whether the text needs to be displayed with

strikeout.
Effect-Underline: Select whether the text needs to be underlined.
Effect-Color: Select the color of the text display.
Sample: Display the effect of the selected text style.
Script: Select the language range when entering characters.

3.2.2 Scale

The property dialog box of the scale component is shown in the figure
below. Since the [Bevel] setting is the same as that in Section 3.2.1, there is
not much to repeat here, please refer to the [Bevel] setting in Section 3.2.1.
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Scale
Position: Select the scale direction.
Master Count: select the main scale number, including the top and bottom

scale.
Slave Count: select the minor scale number, the small scale in the main

scale.
Scale: Check “scale”, the scale will be displayed when editing the screen,

and it will not be displayed if it is not checked.
Axis: Check “axis”, the coordinate axis will be displayed under the scale of

the editing screen, and if it is not checked, it will not be displayed.

Pen
Style: Select the scale style.
Color: Select the color of the scale style.

Option
Display Marks: Check the display marks, and the scale will display the

value of the large scale, subject to the maximum and minimum settings.
Max: Set the maximum value on the scale.
Min: Set the minimum value on the scale.
Color: Set the display color.
Decimal Pos .: Set the number of decimals in the display mark.
Suffix: Set the display unit of the display mark, which can be left blank.
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Font: Set the font of the display mark. For detailed settings, please refer to
the font setting in 3.2.1.

3.2.3 Table

The property dialog box of the table component is shown below. Since the
[Bevel] is the same as that in Section 3.2.1, there is not much to repeat here,
please refer to the [Bevel] setting in Section 3.2.1

Table
Row Count: Select the number of lines in the horizontal grid.
Column Count: Select the number of lines in the vertical grid.
Separator Line: Check the separator line, a diagonal line will be generated

in the upper left corner of the field, as shown in the blue circled part below.

Pen
Style: Select the line style of the table component.
Color: Select the line color of table components.
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3.2.4 Picture

The property dialog box of the picture component is shown below. Since
the [Bevel] setting is the same as that in Section 3.2.1, there is not much to
repeat here, please refer to the [Bevel] setting in Section 3.2.1.

Image / Picture
Display the display effect after loading the graphics.

Load: Click this button to pop up the dialog box, select the graphic or
animation pattern to be loaded.

Available formats: png, gif, jpg, jpeg, bmp, ico, emf, wmf.
Clear: Click this button to clear the previously selected graphic.

Offset
X: Use the center point of the picture element as the base point to shift left

and right in the X direction.
Y: Use the center point of the picture element as the base point to shift up

and down in the Y direction.

Option
Stretch: Tick stretch and the graphics will be automatically scaled

according to the window size.
Transparent: Tick transparent to make the selected graphics appear

transparent.
Transparent Color: Select the color that needs to be transparent.
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3.2.5 Memo

For details of attribute setting, please refer to chapter 3.2.1 Static Bevel/
Text.

3.3 Button
To use the button component, you can click [Button] under the

[Component] menu bar, and the drop-down option of the button component
appears, as shown in the following figure 3.3-1, or you can directly click the
option on the tool shortcut bar, as shown in the following figure 3.3-2.

3.3-1

3.3-2

3.3.1 ON/ OFF Button and Switch/ Hold Button

After selecting the component, right-click the component to select the
component properties, or double-click the component to open the component
properties dialog box. The property dialog box of the ON/ OFF button and
Switch/ Hold button components is shown below.
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1. Button
As the properties of the [Button] page are the same as the [Bevel] settings

in Section 3.2.1, there is no need to repeat here. Please refer to the [Bevel]
settings in Section 3.2.1.

2. Control

Action: There are four actions to choose from, and you can choose the
state the button action.

Read Address: Read the value of the position of input relay or system
variable.
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: Represents the reading position, and the type is bit.
Write Address: Write the value to this location of the input relay or system

variable.
: Represents the writing position, and the type is bit.

Notification: If a value is written to the position of the input relay or system
variable, the position will be notified.

On Macro: Click the drop-down arrow to select the macro command
edited in advance, and execute the selected macro command when the button
is ON.

Off Macro: Click the drop-down arrow to select the macro command
edited in advance, and execute the selected macro command when the button
is OFF.

Option
Security: Since you have the authority to set the screen when creating a

new screen, please refer to Section 2.4.1 Screen. If the authority set here is
higher than the screen authority, the account and password will be required to
enter when the button component is run on the emulation or human-machine
interface.

Confirm: Release. action: Run the action when the button component is
released.

Wait Sec: Set waiting time in order to avoid accidentally pressing. When
press the button, you will wait for the time as set here before running the
component action.

Press. action: Run the action when the button element is pressed.
Key Def: After setting the keyboard definition in Section 2-4.5, you can

select the function you need.
Key Window: This function is only available when the screen properties

have dialog box properties. Press the button, the selected
dialog box window will appear. If this function is oprated, a
dialog box window will appear to determine whether to run a
certain function.

Sound: Set the sound when the button is clicked.
Enabled Flag: Set the condition variable. If set variable as 1, the button

can perform the corresponding action, otherwise the button
does not act.

Hide Object: Check this option to hide the component.
Hide Object when disabled or security: Check this option, the component

will be hidden when the authority is not reached, or the
controlled conditions are not met.

Prompt if Priority Lack: Check this option, when the permission is
insufficient, the component will display a prompt symbol (small
lock) to indicate that it cannot be operated. The lock will not be
canceled until the permission is sufficient.
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Set Last Priority after Play: After the action, set the last priority. Check this
option, click the button, after the action is completed, modify
the [Option]-> [Security] – “Use Level 9 (Low)”.

3. Status

Language: Select the current language. For details, please refer to
Section Chapter 5 Language Management.

Preview: You can see the input text preview here to prevent input errors.
Status
Add: Since there is only 0 or 1 status, there is no new function here.
Delete: Since there is only 0 or 1 status, there is no new function here.
Brush: For specific settings, please refer to 3.1.1.
Image: For specific settings, please refer to 3.2.4.
Text: For specific settings, please refer to 3.2.1.
Copy: Since there is only 0 or 1 status, there is no new function here.
Index | Text: Index 0 is the text displayed when the button is pressed, and

index 1 is the text displayed when the button is not pressed.
Text: Input text to be displayed here.

: Click this button to copy current text to all status.

3.3.2 Set Value/ Const Button and Inc/ Dec Button

After selecting the component, right-click the component to select the
component properties, or double-click the component to open the component
properties dialog box.
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1. Button
As shown in the figure below, the properties of the [Button] page are the

same as the [Bevel] settings in Section 3.2.1, please refer to the [Bevel]
settings in Section 3.2.1.

2. Control
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Data
Action:

Input: Used in conjunction with the keyboard window, input data
from the screen to the contact variable position.

Var/Const: Select this option, the value to be input to the contact
variable can be input by the writing rule.

Inc/Dec: Select this option, and click the button once to add or
subtract the data set in the rule once to the contact variable.

Format: Select the data format to be written.
Write Address: Enter the position of the contact variable to be written.
Rule: Set the calculation method of the written data or variables.

When the action selection is variable / constant, directly input the
value to the contact variable.

When the action selection is Inc/ Dec, if the value is increasing, the
symbol [+] should be added in front of the value, and if the
value is decreasing, the symbol [-] should be added before
the value.

: This icon is the identifier of the arithmetic element variable, indicating
that the calculation between variables is supported here. For example: N100 +
N200 are filled here, when writing data, the system will calculate the result of
N100 + N200 and write it in. For details, please refer to Appendix 4 Instructions
for Using Operation Variables.

Max: The maximum value of the reading range of the input position.
Min: The minimum value of the reading range of the input position.

The maximum and minimum value can be not input. When not input,
the value range refers to the set data type.

Notification: The input relay or system variable position will be notified
when a value is written to the position.

Notification Type: Used in conjunction with write notification, you can
choose to write 1 or write 0. If the write notification is set to
[M0] and the write notification mode is [write 1], if a value is
written to the write location, M0=1.

Before Macro: Enter the name of the edited macro directly or click the
drop-down arrow to select an existing macro. The macro
is triggered when the button is pressed.

After Macro: Enter the name of the edited macro directly or click the
drop-down arrow to select an existing macro. The button
will trigger when the macro pops up.

Option
Please refer to option instructions in 3.3.1.

Format
Decimal Pos.: Set the number of decimal places.
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Data arrangement swap: high and low bytes swap. 16 bit: high and low
BYTE swap; 32 bit: high and low WORD swap.

Dec: Check this option to display as a decimal value.
Hex: Check this option to display it as a hexadecimal value.
32bit Float: Check this option to display 32-bit floating point values.

3. Status
For details, please refer to the status instructions in 3.3.1.

3.3.3 Jump/ Back Button

After selecting the component, right-click it to select the component
properties, or double-click it to open the component properties dialog box.

1. Push Button
Please refer to the [Bevel] settings in Section 3.2.1.

2. Control

Control
Scene Switch: When there are multiple screens in the project, this function

can be used to switch screens, and we can choose which screen to jump to or
return to.
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Switch Notes: Set the notification action when the screen is switched, i.e.
you can set a certain register to be turned on or off when the screen is
switched.

Before Macro: Enter the name of the edited macro directly or click the
drop-down arrow to select an existing macro. The macro is triggered when the
button is pressed.

After Macro: Enter the name of the edited macro directly or click the
drop-down arrow to select an existing macro. The button will trigger when the
macro pops up.

Option: Please refer to option instructions in 3.3.1.

3. Status
For details, please refer to status instructions in 3.3.1.

3.3.4 Fun Button

The details of the function button property settings, please refer to chapter
3.3.1. This section only explains the different settings.

Action:
Set to last priority: Select it to set the screen attribute authority to the

minimum.
Inputs password again: Select it to input password again.
Clear all alarm event: Select it to delete all alarm events.
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3.3.5 Key Button

The detailed instructions of Button and Status, please refer to chapter
3.3.1. This section only explains the different settings.

Normal: The action to be performed when the button is pressed.

: Click this icon to copy the function set by the current button to the
other three buttons.

Shift: The action to be performed when you press the [Shift] key and then
press the button.

Ctrl: The action to be performed when you press the [Ctrl] key and then
press the button.

Alt: The action to be performed when the [Alt] key and then the button is
pressed.

Notification: Click the button and write 1 into the set position.
Before Macro: Enter the name of the edited macro directly or click the

drop-down arrow to select an existing macro. The macro is triggered when the
button is pressed.

After Macro: directly enter the name of the edited macro or click the
drop-down arrow to select an existing macro. The macro is triggered after the
button pops up

Key Def.: It can be used when the man-machine model supports keyboard
keys.
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The Shift, Ctrl, and Alt keys here refer to those that set with the key buttons,
not those of the computer keyboard. As shown in the following figure, the Shift
key is used as an example, and this button will be used as the functions of
shift.

In the status, all the texts are typed into shift since this button is only used
as a shift function and has no other functions. If it contains other functions,
please set according to the function name.

As shown in the figure below, the index value is 0 ~ 3, which means that
the normal key is 0, Shift is 1, Ctrl is 2, and the Alt state is 3, so if we want a
key button to have many functions, we can set the functions according to it.
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The setting of the shift key is completed as shown above. When the button
is pressed in the screen, it means that the shift key is pressed, so that the
above-mentioned Shift, Ctrl, Alt state can be used accordingly.

3.3.6 Set Status Button

The detailed instructions of Button and Status, please refer to chapter
3.3.1. This section only explains the different settings.
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Control
Format: Set the format of the register variable.
Write Address: Set the location to write data.
Value Address: Set the content that written in. For example, set it as D0,

and the writing position as D1. When the action occurs, write the contents of
D0 to D1.

Notification: When writing, set the variables set by the notification.
Press Macro: Enter the name of the edited macro directly or click the

drop-down arrow to select an existing macro. The macro is triggered when the
button is pressed.

Release Macro: Enter the name of the edited macro directly or click the
drop-down arrow to select an existing macro. The macro is triggered after the
button is released.

3.3.7 Target Button

The detailed instructions of Button and Status, please refer to chapter
3.3.1. This section only explains the different settings.
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Project making: when there is a series of parameters to be set, in order to
facilitate the settings and avoid misoperation to hit other settings, you can use
the trigger button.

Read Address: Select a variable as the basis for switching the number of
columns.

Base Address: Set according to the serial number of the first column of
components, click [F4] to view the component serial number. For example, if
the serial number of the first element of the parameter element needs to be set
as 8 on this line, the cardinal position is selected as 8.

Scale Address: Set according to the number of rows of the group where
the component is located. For example, if the row is the third row, set it to 3.

3.3.8 Data Move Button

The detailed instructions of Button and Status, please refer to chapter
3.3.1. This section only explains the different settings.
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Read Address: Set the start position of the variable that needs to read
data.

Write Address: Set the start position of the variable that needs to write
data.

Data Length: Set the number of data to be read and written.
For example: As shown in the figure above, when you click the button, the

values of 10 data in D0-D9 will be read and then written into 10 registers in
D10-D19 respectively.

3.3.9 Numerical set ON/ OFF button and Alternate / Hold type button

After selecting the component, right-click in the component to select
component properties, or double-click the component to open the component
properties dialog box. The property dialog box of Numerical set ON / OFF
button and Alternate/Hold button components is shown in the figure below.

1.Button: As shown in the figure below, since the page properties of [Button]
are the same as the settings of [Bevel] in Section 3.2.1, there is no need to
repeat the explanation here. Please refer to the [Border] settings in Section
3.2.1 for yourself.
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2.Control: as shown in the figure below.

Action
Action: There are four actions to choose from, you can choose which state

the button action is.

Control
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Data Format: Select the type of data, there are two types: 16-bit unsigned
and 32-bit unsigned.

Reading Addr.: The position of the input system variable.
Read bit offset (U16): Set the bit of the variable to be read; 0-15.
Write Addr.:The position of the input system variable.
Write bit offset (U16): Set the bit of the variable to be read; 0-15.
Write Notification: The input relay or system variable position, if a value is

written to the writing position, the position will be notified.
Notification Type: Used in conjunction with write notification, you can

choose to write 1 or write 0. If the write notification is set to [M0] and the write
notification mode is [write 1], if a value is written to the write location, M0=1.

On Macro: Click the drop-down arrow to select the pre-edited macro
command, and execute the selected macro command when the button is in the
ON state.

Off Macro: Click the drop-down arrow to select the pre-edited macro
command, and execute the selected macro command when the button is OFF
Options

Priority: Because there is the authority to set up the screen when
creating a new screen, please refer to section 2.4.1 Screen Management. If
the authority set here is higher than that of the screen, when this button
component is run on the emulation or HMI, it will be asked to enter the account
password.

Use confirmation:
Action when released: Run action when the button element is released.
Wait X seconds: In order to prevent us from accidentally pressing it, so

here is set to wait for the set time after pressing the button before running the
component action.

Action when pressed: Run the action when the button element is
pressed.

Keyboard Def.: After setting the keyboard definition in chapter 2.4.5, you
can select which function you need to set before.

Keyboard Window: This function can only be used when the screen
attribute has a dialog box attribute. When the key is pressed again, the
selected dialog box window will be displayed. Generally, this function is used
to display a dialog box window to determine whether to run a certain function.

Destine Voice: Set the sound to be emitted when the button is clicked.
Enable Provision: Set the condition variable. When the set variable is 1 or

0, the button can perform the corresponding action, otherwise the button will
not operate.

Enable condition: Used in conjunction with controlled condition, when the
variable can be set to 1 or 0, it is controlled. If the controlled condition is set to
[M1], the controlled condition mode is [when the variable is 1, controlled]; when
M1=1, the button can perform the corresponding action, otherwise the button
will not work.
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Hidden Obj.: Check this option, the component will be hidden.
Hide as priority lack or disable: Check this option, and the component will

be hidden under the following conditions: when the permission is not met, or
when the controlled condition is not met.

Prompt as priority lack: Check this option, when the authority is insufficient,
the component will display a prompt symbol (small lock) to indicate that it
cannot be operated, and the lock will not be cancelled until the authority is
sufficient.

Set last priority after play.: Check this option, click the button, after the
action is completed, modify the minimum operation authority of [Options] ->
[Usage Authority].

3.Status: as shown in the figure below.

Language: Select the language currently in use. For details, please refer
to Section 5 Language Management.

Preview: You can see the input text preview screen here to prevent input
errors.
Status
New: Since there is only 0 or 1, there is no new function here.
Delete: Since there is only 0 or 1, there is no delete function here.
Brush: Refer to section 3.1.1 for specific settings, and will not repeat the

description.
Image: Refer to section 3.2.4 for specific settings, so the description

will not be repeated.
Text: Please refer to section 3.2.1 for specific settings, and the

description will not be repeated.
Copy: Since there is only 0 or 1, there is no copy function here.
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Index/Text: Index 0 is the text displayed when the button is pressed,
and index 1 is the text displayed when the button is not pressed Text.

Text input: Input the text to be displayed here。

: Click this button to copy the currently entered text to all states.

3.4 Display
To use the Status component, you can click [Status] under the

[Component] menu bar, and the drop-down option of the status component
appears, as shown in the following figure 3.4-1, or you can directly click this
option on the tool shortcut bar, as shown in the following figure 3.4-2.

3.4-1

3.4-2
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3.4.1 Lamp

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Control and Status.
1. Control

Data Type: Set the variable type or variable data format displayed by the
lamp.

Read Addr.: Set the variable position displayed by the lamp.
Max: When read a register, the maximum value is the one you set. If not

set value here, the value is decided by data format.
Min: When read a register, the minimum value is the one you set. If not set

value here, the value is decided by data format.
Visibility: Set the variable position that makes this lamp show or hide.

2. Status
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For details, please refer to the description of the status page in 3.3.1, only
the differences are introduced here.

Add: Click this button to add a new condition.
Delete: Click this button to delete the selected condition.
Condition: Set the comparison condition of the selected condition. There

are six types of comparison conditions: equal, not equal, less
than, less than or equal, greater than, and greater than or equal
to choose from.

Connection / Para .: Enter the 16-bit register to compare with the

register displayed by the lamp. According to the comparison
results, the lamp shows different status.

3.4.2 Numeric Display

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Control and Text.

1. Control
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Data
Data Format: Select the data format to be read.
Read Addr.: Set the variable address to be read.
Max: Set the maximum value of the variable to be read.
Min: Set the minimum value of the variable to be read.
Display Flag: Set the variable that makes the numerical display

component show or hide.
Display Condition: Use with visibility, and display when the selectable

variable is 1 or 0. If the visibility is set to [M0] and the display condition mode is
[When the variable is 1, display], then when M0=1, the component is visible.
Display Format

Integer: Set how many digits to display for integers.
Decimal Pos .: Set how many digits to display for decimals.
Zero of Hi Bites: When the integer number is set to 4, the value will be

filled with 0 to 4 digits if this option is checked.
Decimal: Select this option, the value is displayed in decimal form.
Hex .: Select this option to convert the displayed value to hexadecimal

display.
32 Bits Float. Point: Select this option to display as a 32-bit floating point

number.
Data arrangement swap: high and low bytes swap. 16 bit: high and low

BYTE swap; 32 bit: high and low WORD swap.

2. Text
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Text
Language: Select the language type displayed.
Color: Select the color of the value displayed.
Align: Select the alignment of the numeric display when displaying.
Flash Effect: Select whether the value is normal or flashing during display.
Font: Set the font type and size of the value when displaying, please refer

to 3.2.1 for details

3.4.3 Text Display

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Control and Text.

1. Control
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Control
Data Format: Select the display format of the text.
String Length: Set the length of characters that can be displayed.
Read Addr .: Set the read variable address.
Visibility: Set the variable that controls the display or hiding of the text

display element.

2. Text
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Text
Language: Select the language type displayed.
Color: Select the color of the value displayed.
Align: Select the alignment of the numeric display.
Auto. Linefeed: Check this option, when the total length of the font is

greater than the length of the component, it will automatically display the line.
Otherwise, no line breaks.

Word Effect: Select whether the text display is normal or mobile.
Flash Effect: Select whether the value is normal or flashing display.
Font: Set the font type and size of the value when displaying, please refer

to 3.2.1 for details.
Text: Enter the text to be displayed.

3.4.4 Alarm String

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Text and Option.

1. Text
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Text
Language: Select the language type displayed.
Color: Select the color of the value displayed.
Align: Select the alignment of the numeric display.
Word Effect: Select whether the text display is normal or mobile.
Flash Effect: Select whether the value is normal or flashing display.
Font: Set the font type and size of the value when displaying, please refer

to 3.2.1 for details.
Visibility: Set the variable that controls the display or hiding of this alarm

text component.
Continue: Check this option, the alarm text will be displayed continuously,

otherwise the alarm information will reappear after the alarm information
moves and disappears in the alarm text component.

Move Speed: Set the speed of alarm text movement.
2. Option
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Option
Index Number: Check this option, the alarm text will appear with the

alarm number, otherwise only the alarm text will be displayed.
Group Option

Read Address: Set the address of the read alarm zone.
Date / Time

Language: Select the language type displayed.
Custom: Set the alarm text.
Preview: Preview the display of the alarm text for easy modification in

time.
Brush

Type: Set the brush style.

3.4.5 Time/Date

The detailed instructions of Bevel and Text, please refer to chapter 3.3.1.
This section only explains the different settings of Control.
1. Control
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Control
Display Format:

Custom: When this option is selected, enter the format to be
displayed in the custom format on the text page.
For the time format, refer to the table below.

hh: mm: ss: The time will be displayed as hour: minute: second.
hh:mm: The time will be displayed as hour: minute.
MM / dd / yy: The time will be displayed as month / day / year.
dd / MM / yy: The time will be displayed as day / month / year.
Dd.MM.yy: The time will be displayed as day, month, year.

Format Descriptions Input string Display string
“” string “Year” Year
yyyy 4-digit year yyyy 2004
yy 2-digit year yy 04
M 1-digit month M 7
MM 2-digit month MM 07
d 1-digit date d 5
dd 2-digit date dd 05
H 1-digit hour (12

hour system)
H 9

HH 2-digit hour (12
hour system)

HH 09

h 1-digit hour (24
hour system)

h 9
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hh 2-digit hour (24
hour system)

hh 09

m 1-digit minute m 7
mm 2-digit minute mm 07
s 1-digit second s 7
ss 2-digit second ss 07
AM AM/PM AM AM/PMA

Visibility: Set the variables that control the display or hide of the display
element.

3.4.6 Progress Bar

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Control.

1. Control

Control
Data Type: Select the data format to be read.
Read Addr .: Set the variable address to be read.
Max: Enter the maximum value of this contact or memory, or you can not

enter it.
Min: Enter the minimum value of this contact or memory, or you can not

enter it. If not, the maximum and minimum value range is the default
value range of the variable.

Visibility: Set the variables that control the display or hide of the display
element.
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Option
Direction: Adjust the direction of the progress bar. The default is the

horizontal direction. If you select vertical, the graphics on the screen
should also be adjusted to be vertical.

Grid Color: Set the color of the grid of the progress bar.

3.4.7 Bar/ Float Bar

The detailed instructions of Bevel, please refer to chapter 3.3.1. This
section only explains the different settings of Control.

1. Control

Control
Data Type: Select the data format to be read.
Read Addr .: Set the variable address to be read.
Max: Enter the maximum value of this contact or memory, or you can not

enter it.
Min: Enter the minimum value of this contact or memory, or you can not

enter it. If not, the maximum and minimum value range is the default
value range of the variable.

Visibility: Set the variables that control the display or hide of the display
element.

Option
Type: Select to use Bar or Float Bar.
Direction: Select the direction of Bar or Float Bar.

Bar:
Type: Select the type of Bar or Float Bar.
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3.4.8 Meter

The detailed instructions of Bevel and Control, please refer to chapter
3.3.1 and 3.2.4 respectively. This section only explains the settings of Scale.

1. Scale

Scale
Graduation: Select the direction and angle of the meter display.
Master Count: Select the number of main scales.
Slave Count: Select the number of minor scales.

Length: Select the length of the scale display.
Disc size: Select the size of the disc in the center of the meter.
Scale: Tick it and scale will appear, otherwise not.
Axis: Tick it and the arc-shaped coordinate axis will appear below the

scale. Otherwise not.

Pen
Type: Select the line style of scale and coordinate axis.
Color: Select the color of the line style.

Indicator Pen
Type: Select the line style of the meter pointer.
Color: Select the color of the line style.
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Disc color: Select the color of the disc.

Option
Display Marks: Tick it and the digital marks of the main scale will appear.

Otherwise not.
Max: Enter the maximum value of this contact or memory, or you can not

enter it.
Min: Enter the minimum value of this contact or memory, or you can not

enter it. If not, the maximum and minimum value range is the default value
range of the variable.

Color: Select the color of the digital mark.
Decimal Pos.: Set the number of decimal places.
Suffix: Set the displayed quantity unit.
Font: Set the font type and size of the numeric value when displaying,

please refer to 3.2.1 for details.
2. Adv.

Fill Pie
File Pie: Tick it and Bush settings will appear, otherwise not.
Graphic Distance: Set the interval time between graphics display.

3.4.9 Dynamic Picture

The detailed instructions of Bevel, Image/ Picture, please refer to chapter
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3.3.1 and 3.4.7 respectively. This section only explains the settings of Control.

1. Control

Coordinate
Type: According to the way represented by the X and Y coordinates, the

absolute value and the offset value can be selected.

X/Y
Data Format: Set the variable data format.
Read Addr .: Set the read variable address, so as to change the position of

the picture according to the value of the address.
Max: Set the maximum value of X / Y coordinates.
Min: Set the minimum value of X / Y coordinates.

3.4.10 Path Picture

Click [Component]-> [Status]-> [Path Picture]. When the mouse moves to
the edit screen, a cross cursor will appear. When moving to the desired
position, press the left mouse button, as shown in the following figure, then
move to the relevant position of the desired path in sequence, then press the
left mouse button, and finally confirm the path position, press the right mouse
button to end the drawing.
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Right-click or double-click to enter the property setting page. The detailed
instructions of Bevel, Image/ Picture, please refer to chapter 3.3.1 and 3.4.7
respectively. This section only explains the settings of Control.

1. Control

Control
Type: There are four options including read address, increasing cycle,

decreasing cycle and trapeze cycle.
Read Address: The picture moves to the corresponding coordinate point

according to the value of the variable in the read position.
Inc cycle: According to the value of the variable in the read position X

milliseconds, automatic coordinate increases with cyclic
movement.

Del cycle: According to the value of the variable in the read position X
milliseconds, automatic coordinate decreases with cyclic
movement.
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Trapeze cycle: The picture moves automatically in a coordinate cycle
according to the value of the variable X milliseconds in the
read position. When the picture is in the initial coordinate, it is
an increasing cycle, and in the final coordinate is a decreasing
cycle, which is equivalent to moving back and forth.

Control Para.
Format: Set the variable data format.
Read Address: Set the read variable address, so as to change the position

of the picture according to the value of the position.

Path Information
Point Count：Display how many positions of the set path coordinates.

3.4.11 Dynamic Lamp

The main purpose is to use variable control, so that the components
display different screens or different text at different positions.

Right-click or double-click to enter the property setting page. The dynamic
coordinate display property setting dialog box is shown in the figure below.
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1. Bevel: Please refer to chapter 3.3.1 for detailed instructions.
2. Control: Please refer to chapter 3.3.2 for detailed instructions.
3. Status: Please refer to chapter 3.3.1 for detailed instructions. Only

differences are explained here.

Add: Click this button once to add a new state.
Delete: Select a state and click this button once to delete the selected

state.
Copy: Select a certain state and click this button once to copy the selected

state once. The copied content includes conditions, text content, brushes, and
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images.
4. Coordinator Control: Please refer to chapter 3.4.9 for detailed instructions.

3.4.12 Path Lamp

The component combines dynamic path picture and dynamic lamp. The
main purpose of using the dynamic path is to display different pictures or
screens when using variables to control different states. At the same time, the
components can be displayed in different positions.

Click [Component]-> [Display]-> [Path Lamp]. When the mouse moves to
the edit screen, a cross cursor will appear. When moving to the desired
position, press the left mouse button, then move to the relevant position of the
desired path in sequence, then press the left mouse button, and finally confirm
the path position, press the right mouse button to end the drawing.

Right-click or double-click to enter the property setting page. The path
lamp property setting dialog box is shown in the figure below.

1. Bevel: Please refer to chapter 3.3.1 for detailed instructions.
2. Control: Please refer to chapter 3.3.2 for detailed instructions.
3. Status: Please refer to chapter 3.3.1 and 3.4.11 for detailed instructions.
4. Coordinator Control: Please refer to chapter 3.4.9 for detailed instructions.

3.4.13 Trend Graph

The man-machine interface reads the continuous data of the
corresponding address and presents it to the user intuitively and graphically in
real time. For example: if the display points are 50 points and three curves are
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set, then a total of 50 * 3 data of 150 WORDs will be taken and data
processing needs to be done in the PLC program.

Click [Component]-> [Display]-> [Trend Graph] to display the trend graph
in the editing screen. Right-click or double-click to enter the property setting
page.

1. Bevel: Please refer to chapter 3.3.1 for detailed instructions.
2. Control:

Control
Data Type: Set the starting position of the register variable address for

data reading.
Source Address: Set the length of the read data, i.e., the number of

displayed curves. For example, the source address is D10
and the data length is 10, i.e., the data from D10 to D19 is
read, and 10 curves are displayed in the trend graph.

Record Count: Set total times to record data, i.e., the maximum record
times to be recorded for each curve.

Update Time: Set the time interval for each record of data. For example, as
set in the figure above, D10 ~ D19 data is recorded once
every second, and a total of 10 (number of records) are
recorded.

Record Flag: Set the condition to start recording data, i.e., the variable
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starts to record data when it is 1, and does not record when it
is 0.

Clear Flag: Set the conditions for clearing the recorded data, that is, when
the variable is 1, all data is cleared, and 0 is not cleared.

Clear Flag aft. Clear Rec.: Check this option to clear the flag together
when clearing the recorded data.

Stop Count: Set the number when stop recording automatically, and set to
0 means not to use this function (the value here must be less
than or equal to the number of records).

Display Flag: set the variable that makes the trend graph component show
or hide.

Display Condition: Use with visibility, and display when the variable is 1 or
0. If the visibility is set to [M0] and the display condition mode
is [When the variable is 1, display], then when M0=1, the trend
graph is visible.

Record Date/Time: Check this option, the system records the time of data
recording.

3. Curve Set

Curve
Add: Click this button to add a curve.
Delete: Click this button to delete the selected curve.
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Copy: Click this button to copy the selected curve.
Point: Check this option, the curve is displayed in the form of points.
Point Style: Set the form of the point.
Point Color: Set the color of the point.
Line: Check this option, the curve is displayed in the form of a line.
Pen Style: Set the brush style.
Pen Color: Set the color of the pen.
Fill: Check this option, the curve is displayed in the form of a brush.
Brush Style: Set the brush style and color.
Max: Set the maximum value of a single curve.
Min: Set the minimum value of a single curve.
Visibility: Set a single curve display and hidden variables, when the

variable is 1, the curve is displayed, and 0 is not displayed.
Data arrangement swap: select this option, the high and low bytes will be

swapped. 16 bit: high and low BYTE swap; 32 bit: high and low WORD swap.

4. Display

Preview: Shows the style of curve display.
Show Setting

Type: Set the direction of movement when the curve is displayed.
Show Data Num .: Set the number of points for displaying data, that is,

the trend graph starts moving when it comes to the quantity of



TK Series HMI Programming Manual

143 www.coolmayplc.com

the data set..
Page Down Gap: Set the interval between two pages when turning pages.
Show Break: Check this option, each curve is displayed with its own

unique area.
Grid of Num./Time

Show Grid Num .: Set the number of grids to be displayed.
Point / Grid: Set the number of grids required for time display.
Pen Style: Set the brush style.
Pen Color: Set the color of the pen.

5. Scale

Left/ Top Scale
Left / Top Scale: Check this option, the scale value will be displayed on the

left side of the trend graph, and it will not be displayed when it is not checked.
Max: Set the maximum value displayed on the scale.
Min: Set the minimum value of the scale display.
Color: Set the color of the scale display on the left.
Decimal Pos.: Set whether display decimals. 0 means no decimal.
Suffix: Set the unit symbol indicated by the scale. If it is not filled in, the

unit symbol will not be displayed.
Font: Set the font for the scale display. For detailed settings, please refer

to the font setting in 3.2.1.
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Right/ Bottom Scale
Refer to the parameter introduction on the left/top scale.

6. Display Time

Display time
Display Time: Check this option to display the time of recorded data below

the trend graph.
Display format: Set the time display format.
Color: Set the color of time display.
Font: Set the font for time display.

Start Record Time
Start Record Time: Check this option, the upper left of the trend graph

displays the time to start recording data.
End Record Time

End Record Time: Check this option, the time at the top right of the trend
graph shows the time when the data recording is ended.

7. Time Scroll
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Time Scroll
Time Scroll: Check this option, the time scroll will display under the trend

graph.

3.4.14 Historical Trend

The man-machine interface reads the continuous data of the
corresponding address and presents it to the user intuitively and graphically in
real time.

Click [Component]-> [Display]-> [Historical Trend] to display the historical
trend in the editing screen. Right-click or double-click to enter the property
setting page. Historical trend graph property dialog box as shown below.
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1. Bevel: Please refer to chapter 3.3.1 for detailed description.
2. Control: as shown above.
Data

Data Record: Select the required data record in the data record
management as the display of the historical trend graph. For the detailed data
setting, please refer to Section 2.4.11
3. Curve setting: For details, please refer to section 3.4.13 Curve Setting Page
Setting.
4. Display: For details, please refer to section 3.4.13 Display page settings.
5. Scale: For details, please refer to section 3.4.13 Scale page settings.
6. Time display: For details, please refer to section 3.4.13 Time display page
settings.
7. Time scroll bar: For details, please refer to section 3.4.13 Time scroll bar
page settings.

3.4.15 Record Table

The man-machine interface reads the continuous data of the
corresponding address in the programmable controller, and can also be
presented to the user in the form of a table.

Click [Component]-> [Display]-> [Record Table] to display the record data
table in the editing screen. Right-click or double-click to enter the property
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setting page. The record data table property setting dialog box is shown in the
figure below.

1. Bevel: For details, please refer to Section 3.3.1.
2. Control: For details, please refer to Section 3.4.13.
3. Colum Set: as shown below.
Column

Language: Set the language to be used.
Color: The text color in the table.
Font: Set the font in the table.
Add: Click this button to add a column of data information to be displayed.
Delete: Click this button to delete the selected data column information to

be displayed.
Caption Text: Set the title of the data to be displayed in the selected

column.
Width: Set the width required for displaying the selected column data.
Align: Set the alignment of the selected column data display.
Color: Set the color when the selected column data is displayed.
Display Format: Set the data source for the selected column data display.
Integer: Set the number of integer digits when the selected column data is

displayed.
Decimal Pos.: Set the number of decimal places when the selected

column data is displayed.
Zero of Hi Bites: Check this option to perform zero padding automatically
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when there is no data in the high position.
Decimal: Select this option, the data is displayed in decimal form.
Hex .: Select this option, the data is displayed in hexadecimal form.
Data arrangement swap: select this option, the high and low bytes will be

swapped. 16 bit: high and low BYTE swap; 32 bit: high and low WORD swap.

4. Adv. Set

Title
Select Bevel: Set the display style of the title bar border. For details,

please refer to Chapter 3.3.1.
Out Color: Set the color of the outer frame of the title bar.
In Color: Set the color of the inner frame of the title bar.
Brush Style: Click the brush button and select the brush style in the

pop-up dialog box.
Select: When a row of data is selected, the display form of that row.
Brush Style: Set the brush style of the selected row.
Write Addr. : Set a 16-bit unsigned number, and display the selected line

number in the 16-bit unsigned number.
Option

Sort by latest information shows: Check this option to display the latest
data at the front when displaying. Otherwise, the
latest data is displayed at the last.
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Hide title bar: check this option. Hide the header column of the table.

3.4.16 Alarm Display/ Alarm Count Display/ Current Alarm Display

Click [Component]-> [Display]-> [Alarm Display]/ [Alarm Count Display]/
[Current Alarm Display] to add an alarm component to the edit screen, as
shown in the figure below.

Right-click or double-click to enter the property setting page. The dialog
box for setting the alarm table properties is shown below.
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1.Bevel: refer to 3.3.1
2.Column Set: as above picture.
Column

Language: Select the language displayed.
Color: Select the color of the title text.
Font: Select the font to be displayed in the title text.
Display Flag: Sets the variable position where the alarm element is

shown or hidden.
Caption Text: Set the text to be displayed for the selected title.
Display width: Set the width of the selected title bar.
Display content: Set the alarm content to be displayed in the selected

title bar.
There are five options: alarm time, recover time, message, number, and

passed time.
Alignment: Set how text or data is aligned when the column of the

selected title is displayed.
Display color: Set the color of the selected display content.
Display Format: Set the format of the selected title display. Depending on

the display content selection, the selection provided by the
format here is also different.

3. Advanced settings: The page is shown below.



TK Series HMI Programming Manual

151 www.coolmayplc.com

Title
For detailed settings, refer to the parameter settings in the title bar of the

advanced setting page in section 3.4.15.
Option
“Show Frame when Sel. Item”: When this option is selected, if the alarm

display is selected, the corresponding viewing screen that is set is displayed. If
no selected, it is not displayed.

“Index Big->Small Index”: When this option is selected, the alarm serial
numbers are displayed in descending order of index values.

Group option
Read position: Set the read position, which can be selected as the alarm

group you want to read.
Select
For detailed settings,, refer to the parameter settings in the selection items

of the advanced setting page in section 3.4.15.

3.4.17 Status Polygon

Click [Component]-> [Display]-> [Status Polygon]. When the mouse is
moved to the edit screen, a cross cursor will appear. Press the left mouse
button when moving to the desired position, then move to the relevant position
of the desired path in sequence and then press the left mouse button. After
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confirming the path position, press the right mouse button to end drawing. As
shown below.

Right click or double click to enter the property setting page. The Status
Polygon property setting dialog box is shown in the figure below.

1. Location: Refer to section 3.2.1
2. Control: Refer to section 3.4.2.
3. Status: The page is shown below.
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3.4.18 Graph

The HMI reads the continuous data of the corresponding address in the
programmable controller. In addition to displaying it to the user in the form of
trend graphs and tables, it can also choose to display it to the user in the form
of a graph.

Click [Component]-> [Display]-> [Graph] to display the graph in the editing
screen. Right click or double click to enter the property setting page. The graph
property setting dialog box is shown in the figure below.
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1. Bevel: refer to section 3.3.1.
2. Control: The page is as shown above.

Read Addr.: Set the address of the variable to be read. The first variable is
the number of points, and the value is less than or equal to the
display point setting value. The reading address starts from the
second variable of the reading position. As shown in the figure
above, D10 reads number of points, D10 <10 (display the
number of points setting value), read data from D11.

Data Type: Only 16-bit signed numbers are available.
Curve count: Set the number of curves to be displayed. The setting range

is 1 ~ 4.
Number of Points: Set the number of points to be displayed for each curve,

that is, the number of registers to be used. The setting range is
2 ~ 128.

Number of H Grids : Set the number of horizontal grid lines in the graph.
H grid line Style: Set the display form of the horizontal grid line in the

graph.
H grid line color: Set the color of horizontal grid lines in the graph.
Curve display flag: Set the variable position to make the curve show or

hide. When the condition is reached, the curve is displayed.
Clear flag: Set the variable position of the clear curve. When the condition

is reached, the displayed curve is cleared.
Visibility: Set the variable position that makes the graph component show

or hide. When the condition is reached, the graph is displayed.
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Note: As shown in the figure above, if the number of curves is set to 1, only one
curve is displayed, so the number of points displayed on the curve is a line
chart composed of a total of 10 points D10-D19.
As shown in the figure above, if the number of curves is set to 2, two curves
need to be displayed. At this time, the 10 points of the first curve are D10 / D12
/....../ D28 and the 10 points of the second curve are D11 / D13 /.../ D27.
If The number of curves is set to other, the number of points displayed on the
curve can be like this sample, and so on.
3.Curve : The page is as shown in the figure below.

Add: Click this button to add a new state. When in multiple states, different
states are displayed according to the read variable data.

For detailed parameter settings, refer to section 3.4.13.
Pen Style: Set the pen form.
Brush color: Set the color of the brush.
Brush form: Set the form and color of the brush.

Fill Type: Set “which direction area to fill” when selecting the fill area.
Delete: Click this button to delete the selected state.
Copy: Click this button to copy the selected state.

3.4.19 XY Graph

The HMI reads the continuous data of the corresponding address in the
programmable controller. In addition to displaying it to the user in the form of a
trend chart and a table, it can also choose to display it to the user in the form of
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an XY curve.
Click [Component]-> [Display]-> [XY Graph] to display the XY graph in the

editing screen. Right click or double click to enter the property setting page.
The graph property setting dialog box is shown in the figure below.

1. Bevel：refer to section 3.3.1.
2. Control：as shown above.

(Refer to 3.4.18 for specific settings. Only the differences are described
here.)

Number of H Grids：Set the number of vertical grid lines in the XY graph.
V grid line Style: Set the vertical grid line display format in the XY graph.
V grid line Color: Set the color of vertical grid lines in the XY graph.

For example
Set as above, the number of graph is 2, and the number of displayed points is
5, that is, two graphs are displayed, and each graph consists of 5 points. The
read position is D10 and the format is X0X1Y0Y1.

When displaying a graph, the value of D10 indicates the number of graph
points. This value can be set, and must set be less than or equal to the number
of displayed points. When the set value is greater than the number of
displayed points, the system treats as the set value equal to the number of
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displayed points.
Data arrangement X0X1Y0Y1:
Reads a total of 20 register data of D11-D30, where D11-D20 is the value

of the first graph, and the coordinates of the 5 points are (D11, D16) (D12, D17)
(D13, D18) (D14, D19) (D15, D20). Then D21-D30 are the values of the
second graph, and the coordinates of the five points are (D21, D26) (D22, D27)
(D23, D28) (D24, D29) (D25, D30).

If the secondary material arrangement is selected as X0Y0X1Y1
It means read a total of 20 register data of D11-D30, where D11-D20 is the

value of the first graph, and the coordinates of 5 points are (D11, D12) (D13,
D14) (D15, D16) (D17, D18) (D19, D20). Then D21-D30 are the values of the
second graph, and the coordinates of the five points are (D21, D22) (D23, D24)
(D25, D26) (D27, D28) (D29, D30).

3. Curve: refer to section 3.4.13

3.4.20 QR code

Can store some simple ASCII characters, that is, all uppercase and
lowercase letters, numbers 0 to 9, punctuation marks, etc.;

In the touch screen, it can be used with the [text editing] control, and the
user can scan the corresponding QR code to get the corresponding
information.

1. Bevel: Please refer to section 3.2.1 for detailed page description.
2. Control: The page is shown in the figure above.
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Control
Data Format: select the format of the text string corresponding to the writing
position

0, AB: The first word is written into the high bit of the variable, and the
second word is written into the low bit of the variable.

1. BA: The second word is written into the high bit of the variable, and the
first word is written into the low bit of the variable.

2. _A: Each variable only stores one text in the low position.
3. A_: Each variable only stores one text in the high position.
4~7. Same as 0~3, except that no text is displayed, only "*" is displayed.
String length: Set the number of characters to be displayed, 1~64

characters can be displayed.
Reading Addr.: Set the variable position of QR code display.
Display Flag: Set the variable position to show or hide the QR code.
Display Condition: Use with visibility, and display when the selectable

variable is 1 or 0.
If the visibility is set to [M0] and the display condition mode is [When the

variable is 1, display], when M0=1, the QR code display is visible.
QR code

Error correction rate: It means that the QR code can be scanned normally
after being blocked, and the maximum area that can be blocked is the error
correction rate;

The higher the error correction rate, the larger the part of the
two-dimensional code picture that can be blocked. (Note: The three positioning
boxes on the side of the QR code and the small positioning block in the middle
cannot be blocked, otherwise the error correction rate cannot be scanned even
if it is high.)

The error correction rate of the two-dimensional code is indicated by
letters, and the error correction ability level is divided into four levels: L, M, Q,
and H:

L 7%
M 15%
Q 25%
H 30%

Foreground color: set the color of the QR code pattern.
Background color: Set the background color of the QR code.
Prefix text: Set the front text displayed after scanning the QR code, for

example, you can set the company logo, address, etc.
Suffix text: Set the text displayed after scanning the QR code, such as

company phone, etc.
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3.4.21 Pipe Line

1. Bevel: Please refer to chapter 3.2.1 for detailed page description.
2. Control: The page is shown in the figure above.
Control

Type: Set the flow direction of the pipe line. Options: Horizontal to the left;
Horizontal to the right; Vertically downwards; Vertically upwards.

Enable Provision: Set the condition variable. When the set variable is 1 or
0, the pipe line can execute the corresponding action, otherwise the pipe line
will not act.

Enable Condition: Used in conjunction with controlled condition, when the
variable can be set to 1 or 0, it is controlled. If the controlled condition is set to
[M1] and the controlled condition mode is [when the variable is 1, controlled];
when M1=1, the pipe line can execute the corresponding action, otherwise the
pipe line does not act.

Data Format: Select the format of the data to be written.
Move Speed: Set the movement speed of the pipe line, the larger the

value, the faster the movement speed.
Display Flag: Set the variable position to show or hide the pipe line.
Display Condition: Use with visibility, and display when the selectable

variable is 1 or 0.
If the visibility is set to [M0] and the display condition mode is [When the

variable is 1, display], when M0=1, the pipe line display is visible.
Block/blank area

Height (width): Set the height and width of the flowing block/blank block.
Brush: Please refer to section 3.1.1 for page details.

3.5 Edit
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After the HMI is connected to the programmable controller, some data in
the programmable controller can be modified by the editing component. At this
time, the editing component is used to complete the modification operation.

Click [Component]-> [Edit]-> to find different edit option as figure 3.5-1,or
directly click the option from the tool shortcut bar, as figure 3.5-2

3.5-1

3.5-2

3.5.1 Multiple Status Edit

Click [Component]-> [Edit]-> [Multiple Status Edit] to display the mutil
Status Edit element in the edit screen. Right click or double click to enter the
property setting page. The mutil Status Edit property setting dialog box is
shown in the figure below.
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1. Bevel：refer to section 3.3.1
2. Control：as shown above, please refer to section 3.3.2. (Difference below)

Read position: Set the position of the variable to be read, and then read
the value of that position.
3. Status：as shown above, please refer to section 3.3.2. (Difference below)
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Conditional expression: Set the value of the conditional expression, that is,
you can set different values to make the component display different states.

3.5.2 Numeric Entry

Click [Component]-> [Edit]-> [Numeric Entry] to display the value editing
element on the editing screen. Right click or double click to enter the property
setting page. The Numerical property setting dialog box is shown in the figure
below.
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1. Bevel： As shown above, refer to section 3.3.1.(Difference below)
Select button: Click the select button to pop up the dialog box as below.

You can choose the shape of the editing component. There are 5pages
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about 36 to choose .

2. Control：Page as below.

Refer to section 3.3.2. (Difference as below)
Read address: Set the position of the variable to be read, and then read

the value of that position.
Engineer Transfer

Offset: Set the offset value after entering numeric data.
Gain: Set the magnification value after inputting numerical data.
Auxiliary calculation: When the offset value and magnification value are

not calculated, click this button to pop up the auxiliary calculation dialog box as
shown in the figure below.
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Parameter calculation of Eng. Transfer：Set the maximum and minimum
values to read.

Eng. Transfer Data：Set the maximum and minimum values after reading
position transfer data.

Cal. Result: The system automatically calculates the offset value and the
magnification value according to the input variable value and the project
converted value.

OK: Click this button to exit this setting dialog and display the calculation
result at the corresponding position on the previous page.

Cancel: Click this button to exit this setting dialog without making any
changes.

For example:
When the HMI communicates with the PLC, the analog value in the PLC

needs to be read, but the digital value in the PLC is 0 ~ 4000, but the HMI
needs the operator to see the temperature value of 0 ~ 50 ℃. In this case, you
can set the offset and magnification values in the engineering conversion data.
Thus reducing the amount of calculation in the PLC.

Parameter calculation of Eng. Transfer set in the example above:
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After clicking [OK], the properties of the numeric entry component are
shown below:

After setting, when the corresponding digital value is read in the PLC, the
converted value is displayed in the HMI, as shown in the figure
below
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3.5.3 Text Entry

Click [Component]-> [Edit]-> [Text Entry] to display the value editing
element on the editing screen. Right click or double click to enter the property
setting page. The text entry property setting dialog box is shown in the figure
below.
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1. Bevel: refer to Chapter 3.3.1 and Chapter 3.5.2.
2. Control: The page is as shown above, please refer to section
3.3.2.(Differences as below)
Data Type: Select the format of the text string corresponding to the writing
position

0. AB: the first word is written to the high-order bits of the variable, and the
second word is written to the low-order bits of the variable.
1. BA: The second word is written to the high-order bits of the variable,
and the first word is written to the low-order bits of the variable.
2. _A: Each variable only stores one text in the low position.
3. A_: Each variable only stores one text in the high position.
4 ~ 7, same as 0 ~ 3, But no text is displayed, only "*" is displayed.

String Length: Set how many characters to display. It can display 1 ~ 32
characters.
3. Text: refer to section 3.4.2 .

3.5.4 Password Edit

Click [Component]-> [Edit]-> [Password Edit] to display the password
editing element in the editing screen. Right click or double click to enter the
property setting page. The password edit property setting dialog box is shown
in the figure below.
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1. Bevel: refer to Chapter 3.3.1 and Chapter 3.5.2.
2. Data: The page is as shown above. (refer to section 3.3.2, Difference as
below)
Password index: Set the second to eighth passwords. At this time, the
keyboard window in the option section on the right needs to set the input
screen as the password input dialog box, otherwise it cannot be entered.
3. Text: refer to section 3.4.2.

After setting the parameters, click this component during execution, and
the previously edited input screen will appear. After the input is completed, the
password setting operation is completed.

3.5.5 Track Bar

Using the slider element, you can use the adjustment knob to quickly set
the value of the element.

Click [Component]-> [Edit]-> [Track Bar] to display the slider component
in the edit screen. Right click or double click to enter the property setting page.
The slider property setting dialog box is shown below.
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1. Bevel: refer to section 3.3.1.
2. Control: refer to Section 3.3.2.
3. Display: The page is as shown above.

Display form: Set the position display mode of the component display
scale.

Scale form: Set the display form of the scale.
Scale color: Set the display color of the scale.
Select Bevel: Set the form of selecting the internal border display.
Adj. Key Sel.: Set the display mode of the selection adjustment button.
Scale Numbers: Set the number of scales to be displayed. The setting

range is 1 ~ 100.
Scale Length: Set the length of the scale line, the setting range is 3 ~ 12.
Outer frame color: Set the outer frame color of the inner frame and the

adjustment button separately.
Inner frame color: Set the inner frame color of the inner frame and the

adjustment button respectively.
Brush Style: Set the brush form of the inner border and the adjustment

button separately.

3.5.6 Scroll bar

Quickly set the value of the component. In addition to using the slider
component, you can also use the scroll bar.

Click [Component]-> [Edit]-> [Scroll Bar] to display the scroll bar
component in the edit screen. Right click or double click to enter the property
setting page. The scroll bar property setting dialog box is shown below.
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1. Bevel: refer to section 3.3.1.
2. Control: The page is as shown above.(refer to section 3.3.2,differences
below)
Para. Edit(Format=16Bit Unsign)

Normal offset: Set the general offset value, that is, the data that moves
every time you click the left and right arrows of the scroll bar.

Fast offset: Set the value of fast movement, that is, the data that moves
every time the scroll bar is clicked once.

Form size: Set the width of the slider.
Note: The setting in the parameter editing column is only effective when the
data format is set to 16-bit signed / unsigned number.
3. Display: refer to section 3.5.5.

3.5.7 List box

In addition to the scroll bars and sliders described in the previous sections,
you can also use list boxes to quickly change the data of register elements.

Click [Component]-> [Edit]-> [List Box] to display the list box component in
the edit screen. Right click or double click to enter the property setting page.
The list box properties setting dialog box is shown in the figure below.
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1. Bevel: refer to section 3.3.1.
2. Data: refer to Section 3.3.2.
3. Status: refer to Section 3.3.2.
4. Display: refer to section 3.5.5.
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Chapter 4 Project management

4.1 Screen management
The [Screen] allows us to quickly understand all the current pictures. Add,

edit, delete, preview all pictures. For details of this chapter, please refer to
2.4.1 Scene. After we create a new file, we can see the screen section shown
in the figure below, which is divided into two parts: screen and preview.

Screen management
Use a tree structure to represent the relationship between each group.

Example: Only the scenes belonging to this group will be displayed under the
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initial screen group.
[TK6070FH]: indicates the HMI model set when creating a new file.
[Init Screen Group]: The system's preset starting screen group is convenient

for us to edit the screen and can be clearly classified. When the
screen is edited to a considerable degree, the group function
becomes more important. You can also create a group according to
your needs. Right-click the TK6070FH or start screen group, and
select [New Screen Group] in the pop-up scene. Set the group name
and permissions for this group. For example, the system in the figure
above Preset group.

[Start Screen]: Under each group, you can create a screen belonging to the
group, which is convenient for us to edit and browse, and can quickly
know the current relationship between all the scenes and groups.

Preview
When a certain picture is selected, the screen preview will display the

preview graphic of the selected picture, and the size of the preview picture size
can also be adjusted. Therefore, when there are many scenes, you can
directly click the screen in the screen management, and you can see the
preview graphic of the selected screen in the screen preview.

4.1.1 Dialog box screen

The purpose of the dialog box is that when we press a certain function
button, such as when confirming or canceling, in order to avoid human
negligence, pressing the button first causes loss of important data, so the
dialog box window is set to prompt when the button is pressed to ask whether
OK to avoid the loss caused by accidentally pressing the button.

The dialog box made in the case is only a basic form. Of course, users
can make dialog boxes of different styles according to their own ideas or needs.
After reading this chapter, Hope it can give you useful information.

Add, edit, delete dialog boxes
Click [Project]-> [Screen]-> [Add Screen],
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or right-click [Init Screen Group] in the Windows management, as shown
in the figure below.

After selecting [Add Screen], a window for adding a screen will pop up as
shown in the figure below. Select the dialog box in the [Screen Type] . For
other settings, refer to section 2.4.1. Click the [OK] button to add a dialog box
window.
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When editing or deleting a screen, you can select the screen to be edited
or deleted, and then click [Project]-> [Screen], or right-click on the selected
screen to select the edit or delete screen. The settings for the edit screen are
the same as those for adding new screen.

4.1.2 Case of dialogue box

After adding the dialog box window, you can start editing the dialog box
screen you need, as shown below. The examples given here are examples of
extending multiple languages and components. Please refer to Chapter 5
“Language Management”.
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Step 1. Add new screen and set the screen property as dialogue box. As
shown in picture 2 above , the name is set to [Confirmation dialogue
box].

Step 2. Place two key buttons on the screen, and set them to [Confirm] and
[Cancel].

Step 3. Set the properties of the [Confirm] button, refer to section 3.3.5. The
settings of the data page are shown in the figure below.

Normal: The action to be performed when this button is pressed.
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Shift: The action to be performed when the [Shift] key and the button are
all pressed.

Ctrl : The action to be performed when the [Ctrl] key and the button are all
pressed.

Alt: The action to be performed when the [Alt] key and the button are all
pressed.

In the definition of the keys in the figure above, there are too many
functions to choose from. In this Case, we take two examples to explain. The
OK button is used as the OK key, so select [OK] in all four fields columns.
Step 4. Select the [Status] page to set the parameters of this page. Because
the main function of this button is to use it as the OK key, all the text in the 0 ~
3 index value is entered Confirm. As shown below.

Step 5. Set the Other language text. Otherwise, the language text cannot be
displayed normally. As shown below.
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Step 6. Set another key button as the cancel key. For the method, refer to Step
3, Step 4, and Step 5.
Step 7. After setting the properties of the two buttons, the Chinese confirmation
dialog box is completed.
As shown below.

Step 8. When we press the two buttons [Chinese] and [English] in the start
screen, the dialog box screen must appear for confirmation, so two
dialog boxes must be created. Here you can right-click [Confirm
Dialog Box] in the screen management and click [Copy Screen] in the
pop-up shortcut menu. Modify the screen properties, as shown below
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Step 9. Click the [Confirm] button in the screen properties to successfully add a
new dialog box screen. After modifying the attributes of the components in the
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new screen, the project is shown in the figure below.

Step 10. In the initial screen, modify the properties of the [Chinese] button
component as shown in the figure below. After completing the
modification, click the [Confirm] button to save the settings.
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Step 11. In the initial screen, modify the properties of the [English] button
component as shown in the figure below. After completing the
modification, click the [Confirm] button to save the settings.

Step 12. Complete all design operations as above. The execution test screen
is shown below.

When the [Chinese] button is pressed, a confirmation dialog box appears
as shown below.
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When the [English] button is pressed, a confirmation dialog box appears
as shown below.

In this way, we can apply this case to other same functions, so as to avoid
the situation where the button is accidentally pressed.

4.2 Link management
When you select Link management, you can see a tree structure diagram

as shown in the figure below. You can quickly know which communication
protocol and how many controllers are currently set in COM1 and COM2. You
can select the communication protocol or controller by using the mouse. After
pressing the right mouse button, you can quickly create, edit, and delete
communication protocols or controllers to improve the timeliness of Link
management operations. It is also easy to create, edit, and delete
communication protocols or controllers.
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【TK6070FH】：Indicates the HMI model set when creating a new file.
【COM1】：Set the communication protocol that COM1 on the computer

belongs to. After clicking, you can quickly create, edit, and delete
communication protocols, but only one communication protocol can be set for
a serial port.

【COM2】：Set the communication protocol that COM2 on the computer
belongs to. After clicking, you can quickly create, edit, and delete
communication protocols, but only one communication protocol can be set for
a serial port.

【Controller】：Set the controller to which the communication protocol
belongs in this serial port. You can set multiple controllers, but the station
number and ID must be unique (for details, refer to section 4.2.1).

Right-click on any serial port and select [Add Protocol] to pop up the New
Communication Protocol window. As shown in the figure below, select the
communication protocol you want to use.
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Protocol: Use the drop-down options to select the protocol to be used.
Controller: Displays the manufacturer and model selected by the

communication protocol.
Electrical: Four options for selection, automatic identification, RS232,

RS422, RS485.
Baud Rate: from 150 to 115200 speeds, which can be selected.
Parity: [None], [Odd parity], [Even parity], [Mark], [Space].
Data bit: [5], [6], [7], [8].
Stop bit: [1 bit], [2 bit].
Delay: no delay, 10ms delay to 5000ms delay, optional.
Timeout: [0.1], [0.2], [0.5], [1], [1.5], [2], [3], [5], [10] a total of 9 options.
Retry Count: Set the numbers of re-transmissions when the

communication is unsuccessful.
Multi-Station Smart Link: Select this function flag
Click the [OK] button to complete the setting of the communication

protocol. The [Add Controller] pops up as shown in the figure below. You need
to select the controller model you want to operate.
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ID: The ID number of the controller.
Station : the station number of the controller, that is, the ID number of the

PLC,
Controller: Display the selected manufacturer, model, description, etc.
Description: Enter a description or help for this controller.

4.2.1 ID and station number

The station number (HMI station number) in the HMI unit setting is the ID
(PLC ID) corresponding to the connected controller, and the ID (HMI ID) set by
the human machine is the corresponding controller in the software setting. For
the setting of the station number, COM1 and COM2 of the HMI are
independent. Therefore, COM1 and COM2 can be set to connect the controller
with the same station number, but for the setting of ID, each HMI cannot be
repeated. Because the ID describes that this controller is which controller
connected to HMI unit, as shown below.
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4.3 Tag management
Because there are many types of controller models, and the numbers of

contacts and registers of communication protocols defined by different
manufacturers are not the same, in order to facilitate the memorization of the
contact or register numbers, the software design uses label management to
increase readability.

For example, when creating a new label, we replaced the X1 contact with
the name [test]. After the new construction is completed, as long as the
component needs to use X1, type [test] in the write position or read position or
click the drop-down menu to select [test], then the system will treat [test] as It is
X1. In this way, each contact and register can be set with a convenient and
easier name instead of the name of the contact and register on the original
communication protocol.

4.3.1 Tag management case

Step 1. Click [Project]-> [Tag]-> [Add Tag Group], as shown in the figure below.
Using label classification can make labels more detailed, and it can be more
convenient and quicker to use.

Step 2. In the pop-up “Add Tag Group” dialog box, set the name of the newly
added tag classification, as shown in the following figure.
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Step 3. Click the [OK] button to add a new tag group. At this time, you need to
click [Project]-> [Tag ]-> [Add Tag] to pop up the dialog box for adding labels,
as shown in the figure below.

Set the content of each parameter, refer to section 2.4.3.
Note: If you do not need to subdivide the label classification, you can omit step
1 and step 2. When you add a new label, start directly from step 3.
Step 4. After clicking [OK] in step 3, the "For monitoring pages" tag will be
added with a "TEST" tab, as shown below:

Step 5. Add “numeric entry” elements to the start screen, as shown in the
figure below.
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Step 6. Open the property page of the component, as shown in the figure
below. After setting the label, you can directly use the pull-down option to
select [Test] at the reading position instead of typing. Therefore, the use of tags
can greatly improve the visibility of contacts and memories during operation,
and reduce human error.
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Chapter 5 Language management

This software supports multiple languages. The purpose is to allow
anyone to use the language and symbols they are familiar with to edit the
required projects on this software platform. As a result, hmi can be used
quickly, the readability can be improved visually, and the work efficiency can be
increased.

Multi-languages can only be used in components that can display
numbers or text. When we create a new project, the system will use the
language preset by the operating system (here Simplified Chinese is taken as
an example), so the text or numbers entered on the component are classified
Under Simplified Chinese language. If we create a new English language, as
shown below. At this time, you can choose Chinese or English here. If we
previously set the component and set the component to text or number, we can
find that when Chinese is selected, the component displays the text or number
we entered, but when English is selected, the text and the numbers on the
component disappeared because we did not enter text or numbers in the
English language, so they did not appear.

Therefore, to display several new languages, you must enter various new
languages and characters on the component. We can create multiple
languages in the language management. The object properties window of the
component can select the language under [Status], [Text ] can input the text of
the language we selected, so that no matter which language is selected, the
text we entered for this language on the component will appear.

5.1 Add, edit, delete languages
After selecting [Project]-> [Language], there will be six options, as shown

in the figure below.
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Directly click the language management icon in the toolbar ,the
language management dialog box shown as below.

Index: The index field is the index value of each language and it is unique.
Each index value corresponds to the system preset parameter N65342
[current screen language index]. Therefore, when the value of the system
parameter is changed, the corresponding language will be switched according
to the index value filled in the write position.
Add language: When you click this option, will pop up “setting dialog box”.
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Name: Click the drop-down list to select the language to be added.
Local ID: The area code of the selected language area. This item is added

by default.
Font: Displays the preset default font you selected.
Select font: Click this button to pop up the font selection dialog, as shown

in the figure below. You can set the default font, glyph, size, effect, underline,
and color of the new language.

Test : Display the template of the selected font.
Decimal: Set which symbol is displayed when the decimal point symbol is

displayed.
Separate: Set which symbol to use when displaying the separator.
After clicking the [OK] button, a new language is added to the language

management screen, as shown in the figure below.

Edit language: Click this option to set the font, glyph, size, effect,
underline, and color of the existing language. The editing screen is the same
as that displayed in adding new language.

Delete language: Click this option to delete the existing language.
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Set initial language: Click this option under multiple languages to set the
initial language.

String translation: Click this option to convert the language on the screen
to the selected language, as shown in the figure below.

Among them, the software program sets Chinese and English as preset
translation functions. In addition, you can use the function of the translation
dictionary to set the corresponding language text, as shown in the figure
below.
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Dic. Translate： Set the corresponding language translation by yourself.
Translation text export:When multiple languages are selected in the
program, such as Chinese (Simplified) and English (UK), the text can be
exported in batches, and the export format is a txt file, as shown in the figure
below:
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Open the document and manually translate each language: For example, 深圳

市顾美科技有限公司 translates to Shenzhen Coolmay Technology Co., Ltd.
(note that the format of the document should not be changed when translating,
that is, the text should not be shifted and line-wrapped)

After the translation is completed, import the translated text through the
[Translate text import] option.
Translate text import: Export from the above translated text and import it into
the project for use after the translation is completed.
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The effect is as follows:
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5.2 Multi-language and component cases
Step 1. Create a new project file.
Step 2. Add English language.
Step 3. Select the component. Here, take [Static Text] in [Static] as an example.
As shown below.

Step 4. Open the Static Text Properties dialog box. First set the English
language as shown below.
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Step 5. Set the Chinese language again as shown below.

Step 6. When both languages are set, click the [OK] button. The static text will
now display the font of the selected language. As described in the
previous chapter, when Chinese or English is selected, different fonts
are displayed.

Step 7. Add [value button] to the initial screen, open the object property
window , select [variable or constant] in [action], and select [language
index of present screen] in [write ADDRESS]. [Rules] Please enter [0],
which refers to the index value mentioned in section 5.1, which
indicates that the language family is Chinese, and 1 indicates English,
as shown in the figure below.
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[Status] page, set the language of Chinese status and the language of English
status, as below.

Step 8. Add a second [Value button], set the setting button properties as shown
below



TK Series HMI Programming Manual

201 www.coolmayplc.com

Set its status page to Chinese and English text as shown below.

Step 9. The setting is completed, and the project can be downloaded to the
HMI. Or select [HMI (M)]-> [Offline Execution] or use the hot key Shift + F9 to
check the effect.
When you click the [English] button, the effect is as shown in the figure below.
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When you click the [Chinese] button, the effect is as shown below.
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Chapter 6 Alarm management

Click [Project]-> [Alarm] in the menu bar or directly select the [Alarm ] icon
in the toolbar to open the window, as shown in the figure below.

Click the New Alarm Area button to open the New Alarm Area window, as
shown in the figure below.

Name: Enter the set name for the newly added alarm zone.
Address: Enter the position of the variable, you can select it through the

drop-down arrow symbol or directly enter the position of the
variable. As shown in the figure above, the icon button behind
the input box indicates that the position must be WORD. Click
the button to pop up the variable window as below to check
which variable is in WORD type. At the same time, you can also
enter or select the required variable in the number edit box as
below.
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Alarm shielded address: When the alarm is triggered, this function can be used
to shield the alarm, that is, the alarm message and sound are not
displayed. The selection method of the shielded address is same
as that of the alarm area address.

Update cycle: You can choose how often you want to update. If you select 3
seconds, it means that the alarm will be checked every 3
seconds.

Classification group: You can check which group this alarm will be classified
into. Double click the left mouse button in the group to edit the
group name.

Start-up delay: Select whether to wait for the controller to start the alarm time
after the completion of data creation.

Help: Type a help statement for this alarm.
When the alarm area is added, the [Alarm] is shown in the figure below. At

this time, there are two setting buttons added in the toolbar of the window,
which are [Edit Alarm] and [Delete Alarm], [ Edit Alarm] means to edit the data
of the current alarm area again. [Delete alarm] is to delete the data of the
selected alarm event area.
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As below figure, at the selected message to be set, and then press [Alarm
Setting] or double-click directly on the selected message, will pop up the alarm
setting window as below .

Alarm define
Alarm definition

Index value: Because the alarm location is stored in WORD, the size of
WORD is 2bytes. When WORD is 1, it will be converted to binary [0000 0000
0000 0001]. Please refer to the table below.
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Level: After setting the level, it is convenient for users to edit which level
this alarm is.

Trigger method:
Positive edge: When the data changes from 0 to 1, trigger the alarm.
Negative edge: When the data changes from 1 to 0, trigger the alarm.
Positive and negative edge: When the data changes from 0 to 1 or from 1

to 0, trigger the alarm.
High level: When the data is 1, trigger the alarm.
Low level: When the data is 0, trigger the alarm.
Positive edge and high level mixing: When the positive edge and high level

conditions are met, trigger the alarm.
Negative edge and low level mixed: When the negative edge and low level

conditions are met, trigger the alarm.
Alarm screen: Select the screen that appears during the alarm. You must

add a new dialog box before editing the screen to be used during the alarm.
Alarm screen settings:
Dialog box: 1. When selecting a dialog box, please note that the set

screen must have the function of leaving the dialog box; otherwise, when the
alarm occurs, the set dialog box will cause the problem of being unable to
leave.

2. When operating the screen (screen type is dialog box),
if the alarm occurs at this time, the screen that has not been completely
operated before will disappear.

Screen change: Select the display screen to jump to when the alarm
occurs, such as the current alarm display table screen.

Message: When selecting message, you can choose seconds for the
message to appear, will not affect the function of the current operation.

View screen: You can add a dialog box to edit the screen. When an
alarm occurs, you want to see what kind of alarm occurred before, this screen
will appear. We set the screen expressed by this alarm, and can do convenient
alarm point to search screen.

Alarm sound: Select the sound when the alarm occurs, you must first
set the sound in the sound management.

Description: A description of this setting.

Alarm message
Alarm message
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Language: Set the language when the alarm message is displayed.
Color: Set the color of the text when the alarm message is displayed.
Text: Set the text displayed in the alarm message.

Click the [Alarm Configuration] button. The alarm configuration dialog box is
displayed as below:

Alarm record
Record Numbers: Set the number of recorded alarms, ranging from 2 to

2048. When the number of alarms exceeds the set number, the first recorded
data will be deleted one by one to increase the latest alarm record.

Use power-off retention: Select this option to save the data in the alarm
log when the HMI is powered off and then Restart on.

6.1 Alarm case
This chapter uses a simple case to explain how to set the alarm (trigger,

shield), and uses the alarm record table to display the occurred alarm
information.

Step 1. Before setting the alarm information, you need to edit the alarm
screen, as shown in the following figure .



TK Series HMI Programming Manual

208 www.coolmayplc.com

Step 2. Click [Project]-> [Alarm] in the menu bar or directly select the
[Alarm] icon in the toolbar to open the it, As shown in the following figure.

Step 3. Click the [Add Alarm] button to open the new alarm area window
and set the parameters as shown in the following figure.
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After the settings are completed, click the [OK] button to save the settings.
Show as shown in the following figure.

Step 4. Select the information bar with an index value of 2 and click the
[Alarm Setting] button, or double-click in the information to open the alarm
information setting dialog box. The setting contents are shown in the following
figure.
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After the settings are completed, click the [OK] button to save the settings.
Show As shown in the following figure.

Step 5: Return to the starting screen, design the starting screen, set the
value of N0 by using the increment and decrement buttons, and use the
display lamp to display N0 bit situation. As shown in the following figure.
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The new added screen is set as a shielding screen, design the shielding
screen, set the value of N0 by using the increment and decrement buttons, and
use the display lamp to display N0 bit situation. As shown in the following
figure.

Use [Alarm Display Table], [Alarm Count Table] and [Current Alarm Table]
respectively to design one screen to record the alarm, as shown in the
following three figures. Please refer to section 3.4.16 for specific instructions
on the alarm record table.
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Step 6. After all screen settings are completed, you can start executing
actions. Click [Offline Execution] or press [Shift]+[F9], and the execution
screen is shown in the following figure.

At this time, we can find that when clicking the [+] button, the value of N0
changes from [0] to [1], but the alarm is not triggered until [4]. Setting the high
level trigger, why does it being triggered when value is 4? the alarm location
is stored in WORD. In step 4, we select index 2 in [Alarm] to set, that is, when
the second bit of N0 is 1, the value of N0 must be 4 to trigger. Because the
WORD data size is 2bytes and is [0000 0000 0000 0000] (refer to the table in



TK Series HMI Programming Manual

214 www.coolmayplc.com

this chapter) in binary terms, when in the high level triggers, the binary value
corresponding to index 2 is 1, that is, [0000 0000 0000 0100], and the
corresponding binary screen is 22 power, 1 *22 power = 4, so the setting of
index 2 will only be triggered when N0 value is 4.

Step 7. If the user does not turn off the alarm or shield the alarm after the
alarm occurs, the alarm screen will be reproduced every other update cycle
according to the update cycle which is set in [Alarm (Event) Management] (3
seconds in this case) until the alarm is turned off or shielded.

When an alarm occurs, the display information of [Alarm Display Table],
[Alarm Count Table] and [Current Alarm Table] are shown as below.

[Alarm Display Table] will be compiled into a record table according to the
alarms that have occurred.

[Alarm Count Table] All the number of alarms that have occurred so far will
be counted and compiled into a count table.
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[Current Alarm Table] Displays the alarm information that is currently
happening and has not been cleared into the record table.

Step 8: After the alarm occurs, the alarm information sent needs to be
closed or shielded. The method of closing the alarm information is to restore
the value of N0, namely restore the bit corresponding to the index value to 0.
Shield alarm information refers to setting the value of alarm shielded address
N1 to be the same as that of N0. As shown in the following figure, alarm
information can be shielded.



TK Series HMI Programming Manual

216 www.coolmayplc.com

At this time, the display information of [Alarm Display Table], [Alarm Count
Table] and
[Current Alarm Table] are shown in the following three figures.

[Alarm Display Table] records all alarms that have occurred. If the alarm
has been cleared or shielded, the recovery time will be displayed.

[Alarm Count Table ] is the same as before, and will always count the
times each alarm occurs.
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Because the alarm has been cleared, there is no record of any alarm in
[Current Alarm Table].

So far, the basic description of the alarm information settings is completed.
The following steps will introduce to use the inspection screen to mark

fault points.

Step 9. First add the viewing screen in the alarm setting dialog, as shown in
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the figure below.

Step 10. Change the screen editing of the current alarm screen to below.

Enter [Current alarm table] property setting page. On the advanced setting
page, when selecting the items in [Options], the viewing screen is displayed.
select it. As shown below.
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Plan [View Screen 1], [View Screen 2], and [View Screen 3] as shown
below
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Step 11. Repeat step 4 to set the actions of alarm indexes 1, 2, and 3, and
set the viewing screen like View screen 1,View Screen 2, View Screen 3. That
is, when the value of N0 is 14, three alarm messages are triggered
simultaneously. As shown below
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At this time, enter the [Current Alarm Screen] and you can see that there
are three alarm
information in the [Current Alarm Table], as shown in the figure below.

When selecting the alarm item in the [Current Alarm Table], the relative
position of the fault alarm table will be displayed on the screen on the right side
of HMI.
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Chapter 7 Password Management

When operating the equipment, it is often necessary to provide users in
different responsibilities with operating functions of different permissions.
Some important functions are only available to users who have a password
and have sufficient permissions. In this regard, password management
provides protection layer and convenience in rights management.

Click [Project]-> [Password] to open the password edit form, as shown in
the figure below. This software provides 8 sets passwords and 8 types
permission levels for users to set. The first set of systems enforces the highest
permissions to avoid insufficient permissions when setting incorrectly.

Generally, the default level of the new added screen is [set by screen
group], the default level of the screen group is the lowest authority, and the
default level of all components is [set by screen]. Therefore, unless
otherwise specified, the user can use all the functions of the editing, because
all functions are available at the lowest level of authority.

7.1 Component setting
If some users needs to be restricted to a certain component ( button

component & editing component), you can set the use permission of this
component when setting the component. As shown in the figure below, set the
usage permission of [Screen Button] to [User level 4].
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When using this button, the authority is lower than the setting authority, the
password input screen will shown as below, requiring the correct password
before continuing to use this function.

7.2 Screen settings
If you need to restrict the user to the components of the entire screen, you can
set the use Screen Property when editing the screen, and are restricted by the
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settings when using the screen component. The settings are shown below.

7.3 Password screen setting
In addition to planning the HMI project, you can edit the password to be

used in [Project]-> [Password Management], or you can design a password
page specifically for password management in the man-machine interface
project. Show. The input element is [Password Edit] in [Edit].
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[Password Edit] The property setting page is as below, you can choose to set
several groups of passwords. Only the first group of passwords, that is, the
password with the highest authority, cannot be set and needs to be set during
project planning.
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Chapter 8 Sound Management

In this software, users are allowed to edit various sound effects to use, click
[Project]-> [Sound Management] to open the sound management window, as
shown below.

The part in the circle above is the sound preset by the system. By default, the
system sets the index 0 and index 1 in the figure as the sound of the button
and the dialog box.

Click the [Add Sound] button, and the [Add Sound Window] as shown
below will pop up.
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Index: The system automatically adds the index value in sequence.
Name: Enter the name defined for this sound.
Repeat Count: choose the number of repetitions when using this sound,

you can choose not to repeat up to 7 times.
Description: Enter a help description for this sound.
After setting, click [OK] button to save the above settings. Click the [Add

Item] button, and the [Add Sound Item] as shown below will pop up.

Frequency: Input the frequency of sound. The high and low sound will
change with the frequency. The high frequency means sharp sound, and the
low frequency means low sound. For the setting of sound frequency, please
refer to [Appendix 3 Scale Frequency Table]

Time: Enter the time to make a sound, in ms, 500ms is equal to 0.5s,
indicating that the sound will stop after 0.5 seconds.

The triangle button in the circle in the figure is the function of trying to play
the sound. After setting the sound frequency and duration, you can press this
button to play to confirm whether it is the sound you want to set.

This completes the setting of each parameter of sound. In the process of
setting the attributes of components, if there is a demand for sound, you can
choose to use it, as shown in the following figure.
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Chapter 9 Data Synchronization Management
When the device is actually running, there are some materials that need to be
updated synchronously, or when you need to use one data to affect another
data, you can use [Data Sync] to complete.
Click [Project]-> [Data Sync…] to open the [Data Sync] Window, as shown in
the figure below.

Click the [Add] button to open the [Add Data Sync] window as shown below.
You can edit the data to be synchronized.
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Time: Select the time to achieve synchronization, that is, when the data of
the source address changes, how long the data of the destination address will
be synchronized after the condition variable reaches. In other words, the time
when the synchronization condition is valid. For example, synchronization
condition mode: high level; condition variable: N10.0; synchronization time: 10
minutes; then N10.0==1 after 10 minutes, the data starts to synchronize, if it is
a falling edge, then the condition must be maintained More than 10 minutes,
otherwise the falling edge cannot be detected, so there is no special
requirement. Generally set the synchronization time of 0.2 seconds (that is, the
trigger condition is very sensitive, and the condition variable is synchronized
immediately).

Format: select the type and type of variable used for synchronization data.
Condition: Set the condition variable and decide whether to synchronize

according to the synchronization condition mode of this condition variable.
Type: In this case, the high level is set to achieve synchronization.
Rising edge: When the data changes from 0 to 1, synchronization is

achieved.
Falling edge: When the data changes from 1 to 0, synchronization is

achieved.
Rising and falling edges: When the data changes from 0 to 1 or from 1 to 0,
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both are synchronized.
Positive level: when the data is 1, synchronization is achieved.
Negative level: when the data is 0, synchronization is achieved.
Source: Set the address of the data source, that is, the address where the

data is read. In this case, the system variable N0 is used.
Destination: Set the address of the data destination, that is, the address where
the data is written. In this case, the system variable N1 is used.

Description: Enter the definition description for this synchronous data, you
can not enter it.

After the above parameter setting is completed, the editable
synchronization screen can be edited. This screen changes the value of N0 by
the increment and decrement buttons. After the value of N0 changes for 3
seconds, the value of N1 changes to the same value as N0. Show.
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Chapter 10 Recipe Management

When the HMI is connected to the PLC, there are often a large number of
values with the same nature of the data that need to be transmitted. We
categorize and sort these data and transmit them at the same time. This is the
recipe. When the general equipment is in actual operation, there are some
production materials that need to be transmitted to the PLC by the
man-machine interface, or when the man-machine interface is required to
record the data, you can use [Recipe] to achieve.

Click [Project]-> [Recipe] to open the [Recipe] Management Window, as
shown below.

Click the [Add] button to open the [Add Recipe] Definition Window, as
shown in the figure below, you can edit the new recipe data .
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Index: The system automatically adds the index value of the recipe data in
sequence.

Name: Set the name of the recipe.
Work: Use the recipe to temporarily store the starting address of the

corresponding variable (the size is 1 group recipe capacity).
Control: variable address that controls the recipe action (the size of the

control area is 4 WORD)

Addres
s Name Content Remarks

+0 Index0 0..65535
+1 Rev 0 Keep
+2 Rev 0 Keep

+3 Control

Bit0=Read(Move from backup area
to work area)
Bit1=Write(Move from backup area
to work area)

Automatically
cleared after
moving parts

Backup Addr: Choose recipe backup, currently only 2 options are
available.

Data read-only: data is stored in the HMIT program, suitable for read-only
recipes.

Use system variable area (N0-N61439): data is stored in the system
variable area, suitable for reading and writing recipes.

Remarks: For the system variable area, please check the power failure
holding section of individual models.

Backup Addr: The storage address of the backup recipe.
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Recipe Count: The total number of recipe groups.
Description: Enter the description text of this recipe, you can not enter it.
Formula variable definition:

Add / Delete Variables: Click the Add / Delete button directly to add /
delete variables.

Set variable format: Click any column that needs to modify the variable
format, and then click the corresponding variable format required by this
column.

S16: Set to 16-bit signed number.
U16: Set to 16-bit unsigned number.
S32: Set to 32-bit signed number.
U32: Set to 32-bit unsigned number.
F32: Set to 32-bit floating point.
Definition of recipe variables: Recipe actions are controlled by reading

and writing variables in the control area.

Read recipe action:：
Address Name Content

+0 Index0 0
+1 Rev 0
+2 Rev 0

+3 Control Set 1(Bit0：Move from backup area
to work area)

Move the group 0 recipe from the backup area to the work area
Write recipe action：
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Address Name Content
+0 Index0 7
+1 Rev 0
+2 Rev 0

+3 Control Set 2(Bit1：Move from backup area
to work area)

Moved from group 0 recipe in working area to group 7 in backup area.
In addition, in order to write the recipe into the controller PLC or read it out

from the same controller PLC, it is necessary to match the data movement
button component, as shown in the figure below.

10.1 Recipe use cases
This case is used to explain how to set the usage data recipe.
Step 1. Click [Project]-> [Recipe] on the menu bar to open the [Recipe]

Management Window, as shown in the following figure:

Step 2. Click the [Add Recipe] button to open the [Add Data Recipe
Definition] window and enter each parameter value, as shown in the following
figure.
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Step 3. After setting the parameters, click the [OK] button to return to the
[Recipe] Management window. The newly added recipe data is displayed on
the right side of the window, as shown in the following figure.

Step 4. Click the [Add] Recipe Variable button , add the recipe variable

to N13, and enter the numerical value of the recipe, as shown in the following
figure.
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Step 5. Close the [Recipe] window, return to the project editing screen,
and add the numeric editing elements in the work area addresses N10 ~ N13,
as shown in the figure below.

Step 6. Add the numeric display elements of backup addresses N100 ~
N123. Generally, it is not necessary to plan the editing of this part during the
actual operation. As shown below.
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Step 7. Add a numeric editing component for the number of recipe groups,
which can be used to read and write the number of specified recipe groups.
The format is shown in the figure below.

Step 8. Add an ON button component, which is used as recipe data to
write into the backup address of the specified recipe group number from the
work area address, and its variable position is input as N3.1, as shown in the
figure below.
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Step 9. Add an ON button component written back to the storage area,
which is used as recipe data to read from the backup address of the specified
recipe group number to the work area address, and enter N3.0 as the variable
position, as shown in the following figure.

Step 10. The screen editing settings are completed, at this time click the
menu option [HMI]-> [offline execution], the execution screen as shown in the
figure below appears.
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Step 11. Enter 3 in the recipe group number edit box and press [Backup
Addr-> Work area] to write the third group of recipe data from the backup
address to the work area address, as shown in the figure below.

Step 12. Change the value in the formula group number edit box to 4, and
then modify the value of each recipe in the work area. After modification, press
[Work Area-> Backup Address] to read out the recipe data in the work area
address to The fourth group of backup addresses is shown below.



TK Series HMI Programming Manual

242 www.coolmayplc.com

Step 13. The use of general recipes must be matched with the PLC
register, so the numerical editing components of PLC positions D0 ~ D3 are
added as shown in the figure below.

Step 14. Click [Project]-> [Data Synchronization Management] in the
menu bar to add 2 data synchronization from [PLC-> Working Area] and
[Working Area-> PLC], as shown in the figure below, more details please refer
to Chapter 9.
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Step 15. Modify the two ON buttons on the edit screen as shown below.

Step 16. Click the menu option [HMI]-> [Off-Line Run], the execution
screen is as shown in the figure below.
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Step 17. At this time, click the number of recipe groups to enter 2, and
then click [Backup Addr-> PLC], the recipe data of the third group can be read
from the backup address area to the PLC address, as shown in the figure
below.

Step 18. Modify the number of recipe groups, enter 1, change the data in
the PLC location D0 ~ D3, and then click [PLC-> Backup address], the recipe
data in the PLC location can be written to the third group backup address, as
shown below.
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Chapter 11 Macro Types and Grammar

11.1 Types of macros
INITIAL macro
Macro command that starts when the HMI is powered on or restarted. This
macro instruction is executed only once, and is generally used for setting the
initial value. By default, it can execute 4096 steps.

BACKGROUND Macro
After the HMI is powered on or restarted, the program will be executed all the
time. Similar to the background program, 1024 steps can be performed by
default 50ms.

CLOCK macro
After the HMI is powered on or restarted, the program will be executed at
intervals, and the interval is set to 500ms to execute 4096 steps.

Screen Open Macro
When the screen is switched to the currently set screen, the OPEN macro
program will be executed, and the default can perform 4096 steps at a time.
Screen Close Macro
When the current screen is switched to another screen, the CLOSE macro
instruction program will be executed. By default, it can perform 4096 steps at a
time.
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Screen Cycle Macro
When the screen is switched to the currently set screen, the CYCLE macro
command program will be executed all the time. The interval time is preset to
500ms, and the preset can perform 4096 steps at a time.

Component action macro (button component and editing component)
When the button component or editing component is activated, the
corresponding macro program will be executed. The preset can perform 4096
steps at a time.
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Sub Macro
The sub-macro instruction is equivalent to the sub-program in the macro
instruction program. The number is provided from 1 to 512 sub-programs.
Common and general functions can be written in the sub-program to facilitate
the main program call.



TK Series HMI Programming Manual

249 www.coolmayplc.com

Among them, there are 16 groups of sub-macro 496-512, which are reserved
for system use. Using Macro communication, when the communication
receives data, the system will automatically execute [496: Sub Macro (496)]
without calling it.

11.2 Macro Editor
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There is a toolbar at the top of the editing screen, with five options: add, delete,
Check, Import and export.
Add: Add a component action macro.
Delete: delete a component action macro.
Check: Check the current macro program for errors.
Import: Imported from the project to the currently edited macro program, the
current edited program will be cleared.
Export: Save the currently edited macro program to the project.
The left side of the editing screen provides a tree diagram of the macro
program, which displays all the macro commands. It is convenient to edit and
preview the macro program.
The right side of the editing screen is the main body of the editing program
screen.
At the bottom of the edit screen is the check program information window. It
will be displayed when the check program is executed. When the check finds a
problem, it will be displayed in the window. Double-click the mouse at the
displayed problem, the edit macro program screen will automatically jump To
the corresponding program position.

11.3 Introduction to Macro Syntax

11.3.1 Data format, operator, command list
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Data format setting table

forma
t Bit

8bit
Signed
number

8bit
Unsigned
number

16bit
Signed
number

16bit
Unsigned
number

32bit
Signed
number

32bit
Unsigned
number

32bit
Floating
point

defini
tion BIT INT8S INT8U

INT16S
or

SIGNED
INT16U

INT32S
or

SIGNED
DW

INT32U
or
DW

FLOAT32
or

FLOAT

Set operator column table

Set operator Explanation
= Setting

+= Addition
settings

-= Subtraction
setting

*= Multiplication
setting

/= Division setting

%=
Integer

remainder
setting

<<= Left shift
setting

>>= Right shift
setting

&= Bits and
settings

^= Mutually
exclusive or set

|= Bit or setting

Operator column table
Operation
symbol Explanation

+ addition
- Subtraction
* Multiplication
/ Division

% Integer
remainder
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！ Logical inverse
~ Bitwise inverse
== equal
!= not equal to
< Less than

<= Less than or
equal to

> More than

>= More than or
equal to

|| or “OR” Logical or
Operations

&& or “AND” Logical and
Operations

& Bits and
operations

^ Bit-exclusive
OR operation

| Bits or
operations

<< Left shift
>> Right shift

Command list
instruction Explanation

LABEL (constant) Program position label (constant range is
0-65535)

GOT (constant) Jump to the program position label
unconditionally (constant range is 0-65535)

CALL <Expression> Call sub macro (sub macro number 1-512)
RET Return to calling program location

IF <Expression> THEN GOTO LABEL
<constant>

When the variable condition is established (not
equal to 0), jump to the program position label,
otherwise continue to the next line of
instructions.

IF <Expression> THEN DO

When the variable condition is established (not
equal to 0), continue to the next line of
instructions, otherwise jump to the next
judgment (ELIF) or (ELSE DO) to continue to
execute or execute the next line of instructions
of ENDIF.
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ELIF <Expression> THEN DO

When the variable condition is established (not
equal to 0), continue to the next line of
instructions, otherwise jump to the next
judgment (ELIF) or (ELSE DO) to continue to
execute or execute the next line of instructions
of ENDIF.

ELSE DO

In conjunction with the IF or ELIF instruction, it
indicates the position to be executed when the
variable condition is not established (equal to
0).

ENDIF
With the IF or ELIF instruction, it indicates the
position to jump when the variable condition is
not established (equal to 0).

FOR <Expression>

Program loop, using the value of the
expression as a fixed number of cycles, the
program range is the program from FOR to the
corresponding NEXT.

NEXT In conjunction with the FOR instruction, it
indicates the range of the program loop.

END End macro program
SETB (Bit variable address) Set bit variables
CLRB (Bit variable address) Clear bit variables
INVB (Bit variable address) Antiphase variable

System internal address variables N0-N65535
N0-N65535 are address variables planned by HMI internally, with a total of

65536 WORDs (16Bits).
When the data format is set to DWORD, the system will automatically

read a WORD after the number, which is defined as the high bit, Hi WORD,
and together with the selected variable low bit, Lo WORD, to form a DWORD.
For example, DWORD N0, then N0 is Lo WROD and N1 is Hi WROD, forming
DWORD.

When the data format is WORD, you can directly use the defined variable
name, namely N0-N65535.

When you want to use bit to define the address, you need to add a "."
Symbol after the definition name before bit position 0 ~ 15. For example, the
fifth bit of N0 can be written as "N0.5", and the eleventh bit of N100 can be
written as "N100.11".

11.3.2 Instructions

1. LABEL <constant>
Program position label (constant range is 0-65535)
The position of the label can be any line in the program.
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Examples of label macros:
N0 = 100
#Define label number 10
LABEL 10
N1 = 200
...
GOTO LABEL 10
...
GOTO LABEL 20
...
#Define tag number 20
LABEL 20

2. GOTO <constant>
Unconditionally jump to the program location label (constant range is

0-65536)
N0 = 100
LABEL 10
N1 = 200

...

...
# Jump to the position of label number 10

GOTO LABLE 10

3. CALL <variable / constant / expression>
Call sub macro (sub macro number 1-512)
The parameters of the call sub-macro instruction can be variables or

constants or expressions
N0 = 100
#CALL <variable>

CALL N0
...

#CALL <constant>
CALL N100
...
#CALL <expression>

CALL 100 + N0
4. RET

Return to the initial position of the call macro
5. IF <variable> THEN GOTO LABEL <constant>
When the variable condition is established (not equal to 0), jump to the
program position label, otherwise continue to the next line of instructions

LABEL 10
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...
#When the variable (N0 + N1) is equal to 200, jump to the position of label

10
IF (N0 + N1) == 200 THEN GOTO LABEL 10

6. IF <variable> THEN DO
When the variable condition is established (not equal to 0), continue to the

next line of instructions, otherwise jump to the next judgment (ELIF) or (ELSE
DO) to continue to execute or execute the next line of instructions of ENDIF. IF,
ENDIF support structure up to 16 layers.

#When the variable N0 is not equal to 100, execute the instruction of N1 =
1000 on the next line
IF N0! = 100 THEN DO
N1 = 1000
#IF ... THEN DO must be paired with ENDIF

ENDIF

7. ENDIF <variable> THEN DO
When the variable condition is established (not equal to 0), continue to the

next line of instructions, otherwise jump to the next judgment (ELIF) or (ELSE
DO) to continue to execute or execute the next line of instructions in ENDIF.

#When the variable N0 is equal to 100, execute the instruction of N1 =
1000

#When the variable N0 is equal to 200, execute the instruction of N1 =
2000
IF N0! = 100 THEN DO
N1 = 1000

#ELIF must follow the IF THEN DO syntax
ELIF N0 == 200 THEN DO
N1 = 2000
ENDIF

8. ENDIF
With the IF or ELIF instruction, it indicates the position to jump when the

variable condition is not established (equal to 0). IF, ENDIF support structure
up to 16 layers.
#When the variable N0 is equal to 100, execute the instruction of N1 = 1000
IF N0! = 100 THEN DO
N1 = 1000

#IF ... THEN DO must be paired with ENDIF
ENDIF

9. FOR <variable>
Program loop, the loop takes the value of the variable as a fixed number,

and the program range is from FOR to the program corresponding to NEXT.
FOR, NEXT support structure up to 16 layers.
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#Calculate the total number of 1 to 10 in the N0 variable
N0 = 0
N1 = 1
FOR 10
N0 + = N1
N1 + = 1
NEXT
10. NEXT

With the FOR instruction, it indicates the range of the program loop. FOR,
NEXT support structure up to 16 layers.
#Calculate the total number of 1 to 10 in the N0 variable
N0 = 0
N1 = 1
FOR 50
N0 + = N1
N1 + = 1
NEXT
11.END

End macro program
12. SETB <Bit Variable Position>

Set bit variables
#Set the fifth bit of N100 variable to 1
SETB N100.5

13. CLRB <Bit Variable Position>
Clear bit variables
#Set the 12th bit of the N10 variable to 0
CLRB N10.12

14. INVB <Bit Variable Position>
Antiphase variable
#Reverse the 15th position of the N1 variable (0 becomes 1, 1 becomes 0)
INVB N1.15

11.4 Introduction to Macro Operator Syntax
In View Macro, in addition to instruction usage, there are two important
syntaxes: operator syntax and set operator syntax.

11.4.1 Operator syntax
Provide mathematical operations or logical operations between

variables. These operation symbols are called operands. The currently
available operators are listed in the table Macro Operators, there are 20
operations in total. The expression is mainly used to set the expression syntax
and the in-command syntax.

Use Cases:
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Pure expression
(N0 + N1) / 2
(N0 + 100)

Collocation operator
N0 = (N1 << 2)
N0 + = (N1 + 2) / 2

Collocation instruction
IF (N0 == 100) && (N1 == 200) THEN GOTO LABEL 10
ENDIF
CALL (N0+100)

11.4.2 Set operator syntax
The setting operator syntax is the most important syntax for setting the value of
variables in macro commands. This setting symbol is called the setting
operator. There are currently 11 kinds of setting operators.
Use Cases:
N0 = 100
N0 = (N1 + N2) / 2
N0 + = 100
N0 * = 2
N0 << = 2
11.4.3 Data format setting of variable data
Variable information: The only variables that can be used in the macros
currently provided are system variables. The default data format of the system
variable is 16-bit symbol number. If you need other format operations, you
must add the data format setting. The data format setting is to add
parentheses before the variable and fill in the data format definition in the
bracket .
Case:
#Indicates the use of 32-bit signed number operation, the data position is in N0
(INT32S) N0

11.4.4 Setting the data format setting for calculation
Setting operation: When the set variable needs to set the data format, the end
of the variable command line must be set with parentheses, and the data
format definition is filled in the parentheses. For example, N0 = (INT32S) N100
(INT32S) means that the 32-bit signed number N100 is used for calculation,
and the value of the N100 is set to the 32-bit signed number N0.
Case:
#Bit address and settings
N0.3 = (BIT) N10.4 && (BIT) N10.5 (BIT)
#If the variable data format of the same line is the same, you can only set the
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data format of [Set Calculation]
N0.3 = N10.4 && N10.5 (BIT)
# 32 bit signed number operation
N0 = N2 + N4 (INT32S)
N0 = N2 + N4 (SIGNED DW)
# 32-bit floating point arithmetic
N0 = N2 + N4 (FLOAT)
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Chapter 12 Macro Function

12.1 Introduction to calculation functions and syntax

12.1.1 Function column table

Fun.
Name Fun. function Return

value
Paramet
er 1

Para
meter
2

_PI Returns π floating point value FLOAT3
2

_BCD Convert BIN values to BCD
format INT32U INT32U

_BIN Convert BCD value to BIN
format value INT32U INT32U

_SQRT Square root floating point valueFLOAT32
FLOAT3
2

_LOG Natural logarithmic floating
point value

FLOAT3
2

FLOAT3
2

_LOG10 Base 10 log floating point valueFLOAT32
FLOAT3
2

_RADIAN Convert degrees to radian
floating point values

FLOAT3
2

FLOAT3
2

_DEGRE
E

Convert radians to degrees
floating point

FLOAT3
2

FLOAT3
2

_SIN trigonometric function sine
value floating point value

FLOAT3
2

FLOAT3
2

_COS Trigonometric function cosine
value floating point value

FLOAT3
2

FLOAT3
2

_TAN Trigonometric function tangent
floating point value

FLOAT3
2

FLOAT3
2

_ASIN Trigonometric function arc sine
value floating point value

FLOAT3
2

FLOAT3
2

_ACOS Trigonometric function inverse
cosine floating point value

FLOAT3
2

FLOAT3
2

_ATAN Trigonometric function arc
tangent floating point value

FLOAT3
2

FLOAT3
2

_ABS Absolute floating point value FLOAT3
2

FLOAT3
2
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12.1.2 Introduction to Function Syntax
1. Floating-point constant
Directly set floating point constants to variables

N0 = 1.2345 (FLOAT32)
2._BCD
Convert BIN values to BCD format

Function syntax: INT32U _BCD (INT32U)
Input data format: INT32U 32-bit unsigned value
Return data format: INT32U 32-bit unsigned value
Example: N2 = _BCD (N0) (INT32U)

3._BIN
Convert BCD value to BIN format value

Function syntax: INT32U _BIN (INT32U)
Input data format: INT32U 32-bit unsigned value

Return data format: INT32U 32-bit unsigned value
Example: N4 = _BIN (N2) (INT32U)

4. _SQRT
Calculate the square root floating point value

Function syntax: FLOAT32 _SQRT (FLOAT32)
Input data format: FLOAT32 floating point value
Return data format: FLOAT32 square root floating point value
Example: N0 = _SQRT (1.15129) (FLOAT32) # 1.5129 = 1.23 * 1.23

5. _LOG
Calculate natural logarithmic floating point values

Function syntax: FLOAT32 _LOG (FLOAT32)
Input data format: FLOAT32 floating point value
Return data format: FLOAT32 natural logarithmic floating point value
Example: N0 = _LOG (N2) (FLOAT32)

6. _LOG10
Calculate a logarithmic floating point value with base 10

Function syntax: FLOAT32 _LOG10 (FLOAT32)
Input data format: FLOAT32 floating point value
Return data format: FLOAT32 base 10 logarithmic floating point value
Example: N0 = _LOG10 (N2) (FLOAT32)

7. _RADIAN
Convert degrees to radian floating point values

Function syntax: FLOAT32 _RADIAN (FLOAT32)
Input data format: FLOAT32 degree floating point value
Return data format: FLOAT32 radian floating point value
Example: N0 = _RADIAN (N2) (FLOAT32)

8. _DEGREE
Convert radians to degrees floating point

Function syntax: FLOAT32 _DEGREE (FLOAT32)
Input data format: FLOAT32 radian floating point value
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Return data format: FLOAT32 degree floating point value
Example: N0 = _DEGREE (N2) (FLOAT32)
9, _SIN
Calculate trigonometric function sine value floating point value

Function syntax: FLOAT32 _SIN (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 sine floating point value
Example: N0 = _SIN (N2) (FLOAT32)

10._COS
Calculate trigonometric function cosine floating point value

Function syntax: FLOAT32 _COS (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 Cosine floating point value

Example: N0 = _COS (N2) (FLOAT32)
11, _TAN
Calculate trigonometric function tangent floating point value

Function syntax: FLOAT32 _TAN (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 tangent floating point value
Example: N0 = _TAN (N2) (FLOAT32)

12, _ASIN
Calculates the trigonometric function arc sine value floating point value

Function syntax: FLOAT32 _ASIN (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 arc sine floating point value
Example: N0 = _ASIN (N2) (FLOAT32)

13, _ACOS
Calculate trigonometric function inverse cosine value floating point value

Function syntax: FLOAT32 _ACOS (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 arc cosine floating point value
Example: N0 = _ACOS (N2) (FLOAT32)

14. _ATAN
Calculate trigonometric function arc tangent floating point value

Function syntax: FLOAT32 _SIN (FLOAT32)
Input data format: FLOAT32 radian floating point value
Return data format: FLOAT32 arc tangent floating point value
Example: N0 = _ATAN (N2) (FLOAT32)

15, _ABS
Calculate absolute value floating point value

Function syntax: FLOAT32 _ABS (FLOAT32)
Input data format: FLOAT32 input calculation floating point value
Return data format: FLOAT32 absolute value floating point value
Example: N0 = _ABS (-1.23) (FLOAT32)
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16, _PI
Returns π floating point value

Function syntax: FLOAT32 _PI ()
Input data format: none
Return data format: FLOAT32 returns π floating point value
Example: N0 = _PI () (FLOAT32)

Macro option register
N65152.0 (bit 0)
0 = When the controller variable is set, modify the value through

communication.
1 = When the controller variable is set, directly modify the HMI memory data

and modify the value through communication.

12.2 Introduction to register related functions and syntax

12.2.1 List of register functions
Fun. Name Function
_MEMCPY Memory copy
_MEMCMP Memory comparison
_MEMSET Memory settings
_REGCPY Variable area copy
_REGCMP Variable area comparison
_REGSET Variable locale
_MWORD2
BYTE

Convert multiple word data to
multiple bytes

_MBYTE2W
ORD

Convert multiple bytes of data to
multiple words

_RBREAD Read the data in the bank memory
area after power off

_RBWRITE Write data to keep Bank memory
area after power off

12.2.2 Introduction to Function Syntax

1._MEMCPY
Memory copy: copy data from variable memory area to another variable
memory area
INT32S _MEMCPY (INT32S destRegNum, INT32S srcRegNum, INT32S len)
The use range of destRegNum is 0 ~ 64511
The use range of srcRegNum is 0 ~ 64511
len use range is 1 ~ 256
The returned value indicates the number of bits copied. 0 means the memory
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range is wrong; 1 ~ 256 means the number of copied bits.
Example 1:

N100 = _MEMCPY (200, 250, 10)
It means that 10 BYTEs starting from the N250 variable (that is, 5

variables N250-N254) are copied into N200-N204, and the number of copy bits
(BYTE) 10 is placed in N100.
Example 2:

N100 = 1000
N101 = 1500
N102 = 20
N500 = _MEMCPY (N100, N101, N102)
It means that the 20 BYTEs starting from the N1500 variable (that is, the

10 variables N1500-N1509) are copied into the N1000-N1009, and the number
of copied bits (BYTE) 20 is placed in the N500.
related functions

_MEMCMP, _MEMSET, _REGCPY, _REGCMP, _REGSET

2. _MEMCMP
Memory comparison: compare the same number of bits (BYTE) in the memory
area of 2 variables
INT32S _MEMCMP (INT32S destRegNum, INT32S srcRegNum, INT32S len)
The use range of destRegNum is 0 ~ 65535
The use range of srcRegNum is 0 ~ 65535
len use range is 1 ~ 256
The returned value indicates the comparison result. -1 means that the memory
range is wrong; 0 means the variable content is the same; 1 means the
variable content is different.
example:

N100 = _MEMCMP (1000, 2000, 10)
Compare whether the variable values of N1000-N1004 and

N2000-N2004 are the same.
related functions

_MEMCPY, _MEMSET, _REGCPY, _REGCMP, _REGSET

3._MEMSET
Memory setting: set all elements in a variable memory area to a specific value
INT32S _MEMSET (INT32U regNum, INT32S value, INT32S len)
regNum use range is 0 ~ 64511
len use range is 1 ~ 256
The returned value indicates the set number of bits. 0 means the memory
range is wrong; 1 ~ 256 means the set number of bits.
example:

N100 = _MEMSET (1000, 55H, 10)
Set the value of N1000-N1004 to 5555H. (The default setting is 8 bits),
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and the N variable is 16 bits.)
related functions

_MEMCPY, _MEMCMP, _REGCPY, _REGCMP, _REGSET

4. _REGCPY
Variable area copy: copy data from the variable memory area to another
variable memory area

INT32S _REGCPY(INT32S destRegNum, INT32S srcRegNum, INT32S
len)
The use range of destRegNum is 0 ~ 64511
The use range of srcRegNum is 0 ~ 64511
1en use range is 1 ~ 256
The returned value indicates the number of variables copied. 0 means

that the memory range is wrong; 1 ~ 256 means the number of copied
variables.

Example 1:
N100 = _REGCPY (200, 250, 10)
Copy the value of the N250-259 variable into the N200-N209 variable.

Example 2:
N100 = 1000
N101 = 1500
N102 = 20
N500 = _REGCPY (N100, N101, N102)
Copy the N1500-N1519 variables to the N1000-N1019 variables.

Related functions
_MEMCPY, _MEMCMP, _MEMSET, _REGCMP, _REGSET

5. _REGCMP
Variable area comparison: compares a certain number of variables (16Bits) in
two variable memory areas
INT32S _REGCMP (INT32S destRegNum, INT32S srcRegNum, INT32S len)
The use range of destRegNum is 0 ~ 65535
The use range of srcRegNum is 0 ~ 65535
len use range is 1 ~ 256
The returned value indicates the comparison result. -1 means that the memory
range is wrong; 0 means the variable content is the same; 1 means the
variable content is different.
example:

N100 = _REGCMP (1000, 2000, 10)
Compare whether the variable values of N1000-N1009 and

N2000-N2009 are the same.
related functions

_MEMCPY, _MEMCMP, _MEMSET, _REGCPY, _REGSET
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6. _REGSET
Variable area setting: Set all variables in a variable memory area to a certain
value
INT32S _REGSET (INT32U regNum, INT32S value, INT32S len)
regNum use range is 0 ~ 64511
len use range is 1 ~ 256
The returned value indicates the set number of bits. 0 means the memory
range is wrong; 1 ~ 256 means the set number of bits.
example:

N100 = _REGSET (1000, 1234, 10)
Set the value of N1000-N1009 to 1234.

related functions
_MEMCPY, _MEMCMP, _MEMSET, _REGCPY, _REGCMP

7. _MWORD2BYTE
Convert multiple word data to multiple bytes: The return value indicates the
number of conversions
INT32U _MWORD2BYTE (INT32S destByteRegNum, INT32S
srcWordRegNum, INT32S len)
The use range of destByteRegNum is 0 ~ 64511
The use range of srcWordRegNum is 0 ~ 64511
len use range is 1 ~ 256

The returned value indicates the number of conversions. 0 means the
memory range is wrong; 1 ~ 256 means the number of conversions.
example:

_STRW (N200, "ABCD")
_MWORD2BYTE (100, 200, 4)

Results of the
N100 = 4241H
N101 = 4443H
N200 = 0041H
N201 = 0042H
N202 = 0043H
N203 = 0044H
related functions
_MBYTE2WORD

8. _MBYTE2WORD
Conversion of multiple bytes of data to multiple words: the return value

indicates the number of conversions
INT32U __MBYTE2WORD (INT32S destWordRegNum, INT32S

srcByteRegNum, INT32S len)
destWordRegNum is used in the range of 0 ~ 64511



TK Series HMI Programming Manual

266 www.coolmayplc.com

The use range of srcByteRegNum is 0 ~ 64511
len use range is 1 ~ 256

The returned value indicates the number of conversions. 0 means the
memory range is wrong; 1 ~ 256 means the number of conversions.
example:

_STRW (N200, "ABCD")
_MBYTE2WORD (100, 200, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N200 = 4241H
N201 = 4443H
related functions

_MWORD2BYTE

9, _RBREAD
Read the data in the bank memory area after power off: the return value

indicates the number of registers read
INT32S _RBREAD (INT32S bank, INT32S destRegNum, INT32S scrAddr,

INT32S cnt)
Bank usage range is 0 ~ 6 (currently only open 0: Bank0)
destRegNum the number of the destination register location for reading data
scrAddr read the number of the bank's source location
cnt can be used in the range 1 ~ 8192

When the returned value is 0: it means that the variable range is wrong
or the operating model does not provide the power-off retentive bank memory;
other values ​ ​ read represent the number of registers read.
Note: This macro function is only supported for models that provide bank

memory to keep power off.
example:

N100 = _RBREAD (0, 1000, 3000, 100)
Results of the
N100 = 100
N1000 ~ N1099 = RBank.3000 ~ RBank.3099
related functions

_RBWRITE

10. _RBWRITE
Write the data in the bank memory area when power off: the return value

indicates the number of registers written
INT32S _RBWRITE (INT32S bank, INT32S scrRegNum, INT32S destAddr,

INT32S cnt)
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Bank usage range is 0 ~ 6 (currently only open 0: Bank0)
ScrRegNum data source register location number
destAddr writes the number of the destination location in the Bank
cnt can be used in the range 1 ~ 8192
When the returned value is 0: it means that the variable range is wrong or

the running model does not provide the power-off retentive bank memory;
other values ​ ​ read represent the number of registers written.
Note: This macro function is only supported for models that provide bank

memory to keep power off.
Example:
N100 = _RBWRITE (0, 1000, 3000, 100)

Results of the
N100 = 100
RBank.3000 ~ RBank.3099 = N1000 ~ N1099
related functions
_RBREAD

12.3 Introduction to string related functions and syntax

12.3.1 List of string functions
Name Function

_STR Set ASCII (bit) string to variable
memory

_STRW Set Unicode (word) character
string to variable memory

_STRLEN Returns the ASCII (bit) string
length

_STRWLEN Returns the length of the Unicode
(word) string

_STR2DEC Convert decimal string to numeric
value

_STR2HEX Convert hexadecimal string to
numeric value

_STR2BIN Convert binary string to numeric
value

_DECSTR Convert numeric value to decimal
string

_HEXSTR Convert numeric value to
hexadecimal string

_BINSTR Convert numeric value to binary
string

12.3.2 Introduction to String Function Syntax
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1._STR
Set ASCII (bit) character string to variable memory: Write ASCII (8 Bits)
character string to variable memory area
INT32S _STR (REG reg, STRING str)
Reg can be used from N0 to N64511
Str is an ASCII string, the string length is 1 ~ 256

The return value indicates the length of the bit, 0 indicates that the
memory range is wrong; 1 ~ 256 indicates the length of the set bit.
In addition to the general text in the string format, you can also use the "\"
escape symbol to add non-string text
Escape
symbol Character value

"" 22H=34
\' 27H=39
\" 22H=34
\? 3FH=63
\\ 5CH=92
\r 0DH=13
\n 0AH=10
\000~\777 Octal code character
\x00~\xFF Hexadecimal code character
example:

N100 = _STR (N1000, "ABCD")
Results of the
N100 = 5
N1000 = 4241H // ’BA’
N1001 = 4443H // ’CD’
N1002 = 0000H // End of string
related functions
_STRW

2._STRW
Set Unocode (word) character string to variable memory: write Unicode (16Bits)
character string to variable memory area
INT32S _STRW (INT32U regNum, STRING str)
regNum can be used in the range of 0 ~ 64511
Str is a Unicode string, the string length is 1 ~ 256

The return value indicates the length of the bit, 0 indicates that the
memory range is wrong; 1 ~ 256 indicates the length of the set bit.
note:

When the string uses Unicode encoding, when the HMI displays the
string, the internal encoding is only the lower 7 bits (0-127 English font) the
same as Unicode, so when the Unicode encoding exceeds 127 in the string,
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the HMI will display incorrect or unable display.
example:

N100 = _STRW (N1000, "ABCD")
Results of the
N100 = 10
N1000 = 0041H // ’A’
N1001 = 0042H // ’B’
N1002 = 0043H // ’C’
N1003 = 0044H // ’D’
N1004 = 0000H // End of string
related functions
_STR, _STRLEN, _STRWLEN
3. _STRLEN
Returns the length of the ASCII (bit) string: the return value represents the
length of the ASCII string
INT32U _STRLEN (INT32S regNum)
regNum can be used in the range 0 ~ 64383
The return value indicates the length of the character string. 0 indicates that
the variable range is incorrect or the length exceeds 256 or the length of the
character string is 0;
example:

_STR (N200, "ABCD")
N100 = _STRLEN (200)

Results of the
N100 = 4
N200 = 4241H
N201 = 4443H
related functions
_STR, _STRW, _STRWLEN

4. _STRWLEN
Returns the length of the Unocode (word) string: the return value represents
the length of the Unicode string
INT32U _STRWLEN (INT32S regNum)
regNum can use the range 0 ~ 64255
The return value indicates the length of the string, 0 indicates that the variable
range is wrong or the length exceeds 256 or the string length is 0; 1 ~ 256
indicates the length of the string.
example:

_STRW (N200, "ABCD")
N100 = _STRWLEN (200)

Results of the
N100 = 4
N200 = 0041H
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N201 = 0042H
N202 = 0043H
N203 = 0044H
related functions
_STR, _STRW, _STRLEN

5. _STR2DEC
Convert a decimal string to a numeric value: The return value represents the
converted numeric value
INT32S _STR2DEC (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
cnt can use the range 1 ~ 256 (when the value range is exceeded, an overflow
error will occur, resulting in an incorrect value)
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted value.
Example 1:
_STRW (N100, "12345")
N200 = _STRWLEN (100)

N500 = _STR2DEC (100, N200)
Results of the
N100 = 0031H
N101 = 0032H
N102 = 0033H
N103 = 0034H
N104 = 0035H
N200 = 5
N500 = 12345
Example 2:
_STRW (N100, "1234567")
N200 = _STRWLEN (100)

N500 = _STR2DEC (100, N200) (DW)
Results of the
N100 = 0031H
N101 = 0032H
N102 = 0033H
N103 = 0034H
N104 = 0035H
N105 = 0036H
N106 = 0037H
N200 = 7
N500 = -10617
N501 = 18
Double word N500 = 1234567
related functions
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_STR2HEX, _STR2BIN

6. _STR2HEX
Convert hexadecimal string to numeric value: The return value represents the
converted numeric value
INT32S _STR2HEX (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
Cnt can use the range 1 ~ 256 (when the conversion exceeds the value range,
an overflow error will occur, resulting in an incorrect value)
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted value.
Example 1:
_STRW (N100, "55AA")
N200 = _STRWLEN (100)
N500 = _STR2HEX (100, N200)
Results of the
N100 = 0035H
N101 = 0035H
N102 = 0041H
N103 = 0041H
N200 = 4
N500 = 55AAH
Example 2:
_STRW (N100, "1234567")
N200 = _STRWLEN (100)
N500 = _STR2HEX (100, 2)
Results of the
N100 = 0031H
N101 = 0032H
N102 = 0033H
N103 = 0034H
N104 = 0035H
N105 = 0036H
N106 = 0037H
N200 = 7
N500 = 0012H
related functions
_STR2DEC, _STR2BIN

7, _STR2BIN
Convert a binary string to a numeric value: The return value represents the
converted numeric value
INT32S _STR2BIN (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
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Cnt can use the range 1 ~ 256 (when the conversion exceeds the value range,
an overflow error will occur, resulting in an incorrect value)
Binary strings can use ‘H’ or ‘1’ to represent the value of 1
Binary strings can use ‘L’ or ‘0’ to represent the value of 0
Binary strings can use ’:’ or ’_’ to delimit
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted value.
Example 1:
_STRW (N100, "10100000_00000001")
N200 = _STRWLEN (100)
N500 = _STR2BIN (100, N200)
Results of the
N100 ~ N116 = "10100000_00000001"
N200 = 17
N500 = A001H
Example 2:
_STRW (N100, "HLHL: LHLH: HHHH: LLLL")
N200 = _STRWLEN (100)
N500 = _STR2BIN (100, N200)
Results of the
N100 ~ N118 = "HLHL: LHLH: HHHH: LLLL"
N200 = 19
N500 = A5F0H
related functions
_STR2DEC, _STR2HEX

8. _DECSTR
Convert the numeric value to a decimal string: The return value indicates the
length of the converted string
INT32S _DECSTR (INT32S destRegNum, INT32S data, INT32S format)
destregNum can use the range 0 ~ 64255
data The converted value entered
Format converts the value format
0: 8-bit signed number
1: 8-bit unsigned number
2: 16-bit signed number
3: 16-bit unsigned number
4: 32-bit signed number
5: 32-bit unsigned number
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted string length.
Example 1:
N200 = _DECSTR (100, 12345, 2)
Results of the
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N100 ~ N104 = ”12345”
N200 = 5
Example 2:
N200 = _DECSTR (100, -12345, 2)
Results of the
N100 ~ N104 = ”-12345”
N200 = 6
related functions
_HEXSTR, _BINSTR

9. _HEXSTR
Convert the numeric value to a hexadecimal string: The return value indicates
the length of the converted string
INT32S _HEXSTR (INT32S destRegNum, INT32S data, INT32S format)
destregNum can use the range 0 ~ 64255
data The converted value entered
Format converts the value format
0: 8-bit unsigned number, convert string lowercase 0-9, a-f
1: 8-bit unsigned number, converted string uppercase 0-9, A-F
2: 16-bit unsigned number, conversion string lowercase 0-9, a-f
3: 16-bit unsigned number, converted string uppercase 0-9, A-F
4: 32-bit unsigned number, conversion string lowercase 0-9, a-f
5: 32-bit unsigned number, converted string uppercase 0-9, A-F
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted string length.
Example 1:
N200 = _HEXSTR (100, 0AA55H, 2)
Results of the
N100 ~ N103 = ”aa55”
N200 = 4
Example 2:
N200 = _HEXSTR (100, 55AAFF00H, 5)
Results of the
N100 ~ N107 = "55AAFF00"
N200 = 8
related functions
_DECSTR, _BINSTR

10._BINSTR
Convert the numeric value to a binary string: the return value indicates the
length of the converted string
INT32S _BINSTR (INT32S destRegNum, INT32S data, INT32S format)
destregNum can use the range 0 ~ 64255
data The converted value entered
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Format converts the value format
0: 8-bit unsigned number, convert string 0, 1
1: 8-bit unsigned number, convert character string H, L
2: 16-bit unsigned number, conversion string 0, 1
3: 16-bit unsigned number, convert string H, L
4: 32-bit unsigned number, conversion string 0, 1
5: 32-bit unsigned number, convert character string H, L
A return value of 0 indicates that the variable range is incorrect or the value is 0;
other values ​ ​ indicate the converted string length.
Example 1:
N200 = _BINSTR (100, 0AA55H, 2)
Results of the
N100 ~ N115 = ”1010101001010101”
N200 = 16
Example 2:
N200 = _BINSTR (100, 55AAFF00H, 5)
Results of the
N100 ~ N131 = "LHLHLHLHHLHLHLHLHHHHHHHHLLLLLLLL"
N200 = 32
related functions
_DECSTR, _HEXSTR

12.4 Introduction to Mathematical Calculation Related

Functions and Grammar

12.4.1 A column table of mathematical calculation related functions
Name Function

_MIN Take the minimum of multiple
16-bit signed numbers

_MAX Take the maximum of multiple
16-bit signed numbers

_AVE Take the average of multiple 16-bit
signed numbers

_MIND Take the minimum of multiple
32-bit signed numbers

_MAXD Take the maximum of multiple
32-bit signed numbers

_AVED Take the average of multiple 32-bit
signed numbers

_MINF Take the minimum of multiple
32-bit symbol points
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_MAXF Take the maximum of multiple
32-bit symbol points

_AVEF Take the average of multiple 32-bit
symbol points

12.4.2 Introduction to Mathematical Calculation Related Function Syntax
1. _MIN
Take the minimum value of multiple 16-bit signed numbers: the return value
indicates the minimum value of the multiple data
INT32S _MIN (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
Cnt can use the range 1 ~ 256

The return value of 0 means that the variable range is wrong or the
minimum value is 0; other values ​ ​ are the minimum value returned.
example:
N100 = 156
N101 = 6578
N102 = -578
N103 = 4568
N200 = _MIN (100, 4)
Results of the
N200 = -578
related functions
_MAX, _AVE

2. _MAX
Take the maximum value of multiple 16-bit signed numbers: the return value
indicates the maximum value of the multiple data
INT32S _MAX (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
Cnt can use the range 1 ~ 256

A return value of 0 means that the variable range is wrong or the
maximum value is 0; other values ​ ​ are the maximum value returned.
example:
N100 = 156
N101 = 6578
N102 = -578
N103 = 4568
N200 = _MAX (100, 4)
Results of the
N200 = 6578
related functions
_MIN, _AVE
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3. _AVE
Take the average of multiple 16-bit signed numbers: the return value
represents the average of the multiple data
INT32S _AVE (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65535
Cnt can use the range 1 ~ 256

A return value of 0 means that the variable range is wrong or the
maximum value is 0; other values ​ ​ are the maximum value returned.
example:
N100 = 156
N101 = 6578
N102 = -578
N103 = 4568
N200 = _AVE (100, 4)
Results of the
N200 = 2681
related functions
_MIN, _MAX

4. _MIND
Take the minimum value of multiple 32-bit signed numbers: the return value
represents the minimum value of the multiple data
INT32S _MIND (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128

The return value of 0 means that the variable range is wrong or the
minimum value is 0; other values are the minimum value returned.
example:
N100 = 1564 (DW)
N102 = 6573458 (DW)
N104 = -574358 (DW)
N106 = 4568 (DW)
N200 = _MIND (100, 4) (DW)
Results of the
N200 = -574358
related functions
_MAXD, _AVED

5. _MAXD
Take the maximum value of multiple 32-bit signed numbers: the return value
indicates the maximum value of the multiple data
INT32S _MAXD (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128
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A return value of 0 means that the variable range is wrong or the
maximum value is 0; other values ​ ​ are the maximum value returned.
example:
N100 = 1564 (DW)
N102 = 6573458 (DW)
N104 = -574358 (DW)
N106 = 4568 (DW)
N200 = _MAXD (100, 4) (DW)
Results of the
Double word N200 = 6573458
related functions
_MIND, _AVED

6. _AVED
Take the average of multiple 32-bit signed numbers: the return value
represents the average of the multiple data
INT32S _AVED (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128
The 32-bit signed number is used to calculate the average value. Please pay
attention to whether the total value overflows.

A return value of 0.0 means that the variable range is wrong or the
maximum value is 0.0; other values ​ ​ are the maximum value returned.
example:
N100 = 1564 (DW)
N102 = 6573458 (DW)
N104 = -574358 (DW)
N106 = 4568 (DW)
N200 = _AVED (100, 4) (DW)
Results of the
Double word N200 = 151308
related functions
_MIND, _MAXD

7. _MINF
Take the minimum value of multiple 32-bit symbol points: the return value
represents the minimum value of the multiple data
INT32S _MINF (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128

The return value of 0 means that the variable range is wrong or the
minimum value is 0; other values ​ ​ are the minimum value returned.
example:
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N100 = 15.64 (FLOAT)
N102 = 6573.458 (FLOAT)
N104 = -5743.58 (FLOAT)
N106 = 45.68 (FLOAT)
N200 = _MINF (100, 4) (FLOAT)
Results of the
Floating point N200 = -5743.58
related functions
_MAXF, _AVEF

8. _MAXF
Take the maximum value of multiple 32-bit symbol points: the return value
indicates the maximum value of the multiple data
INT32S _MAXF (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128

A return value of 0.0 means that the variable range is wrong or the
maximum value is 0.0; other values ​ ​ are the maximum value returned.
example:
N100 = 15.64 (FLOAT)
N102 = 6573.458 (FLOAT)
N104 = -5743.58 (FLOAT)
N106 = 45.68 (FLOAT)
N200 = _MAXF (100, 4) (FLOAT)
Results of the
Floating point number N200 = 6573.458
related functions
_MINF, _AVEF

9, _AVEF
Take the average of multiple 32-bit symbol points: the return value represents
the average of the multiple data
INT32S _AVEF (INT32S regNum, INT32S cnt)
regNum can be used in the range 0 ~ 65534
Cnt can use the range 1 ~ 128
The 32-bit signed number is used to calculate the average value. Please pay
attention to whether the total value overflows.

A return value of 0.0 means that the variable range is wrong or the
maximum value is 0.0; other values are the maximum value returned.
example:
N100 = 15.64 (DW)
N102 = 6573.458 (DW)
N104 = -5743.58 (DW)
N106 = 45.68 (DW)
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N200 = _AVEF (100, 4) (DW)
Results of the
Floating point number N200 = 222.8
related functions
_MINF, _MAXF

12.5 Introduction to Time-Related Functions and Syntax

12.5.1 A column of time-related functions
Name Function
_TICK Get the current time tick value
_TICK2TIM
E

Time tick value conversion to date
and time data

_TIME2TIC
K

Conversion of date and time data
to time tick value

12.5.2 Introduction to Time-Related Function Syntax
1._TICK
Get the current time tick value: The return value indicates the current time tick
value
INT32U _TICK ()
Parameter: None
example:
N100 = _TICK () (DW)
N102 = N65448 (DW) // (DW) N65448 has the same function as _TICK
Results of the
Double word group N100 = 1287635383 // The value varies with time
Double word N102 = 1287635383
related functions
_TICK2TIME, _TIME2TICK

2. _TICK2TIME
Time tick value conversion to date and time data: the return value indicates
whether the conversion is successful
INT32U _TICK2TIME (INT32S destRegNum, INT32U tick)
The range of destRegNum that can be used is 0 ~ 64255. 7 data registers are
required to convert data
Tick value entered by tick
The return value 0 indicates that the variable range is incorrect or the
conversion fails, and 1 indicates that the conversion is successful.
Conversion register data configuration
0: sec [0 ~ 59]
1: min [0 ~ 59]
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2: hour [0 ~ 23]
3: day [1 ~ 31]
4: month [1 ~ 12]
5: year [1970 ~ 2069]
6: week [0 ~ 6]
example:
N100 = _TICK () (INT32U)
_TICK2TIME (200, (INT32U) N100)
Results of the
Double word group N100 = 1277639390 // The value varies with time
N200 = 30 // 30 seconds
N201 = 36 // 36 minutes
N202 = 5 // 5 hours
N203 = 21 // 21st
N204 = 10 // October
N205 = 2010 // 2010
N206 = 4 // Thursday
related functions
_TICK, _TIME2TICK
3. _TIME2TICK
Date and time data is converted to time tick value: the return value indicates
the time tick value
INT32S _TICK2TICK (INT32S destRegNum)
The range of destRegNum that can be used is 0 ~ 64255. 7 data registers are
required to convert data
The return value of 0 means that the variable range is wrong or the conversion
fails, and the other values are time tick values.
Conversion register data configuration
0: sec [0 ~ 59]
1: min [0 ~ 59]
2: hour [0 ~ 23]
3: day [1 ~ 31]
4: month [1 ~ 12]
5: year [1970 ~ 2069]
6: week [0 ~ 6]
example:
N200 = 30 // 30 seconds
N201 = 36 // 36 seconds
N202 = 5 // 5 hours
N203 = 21 // 21st
N204 = 10 // October
N205 = 2010 // 2010
N206 = 4 // Thursday
N100 = _TICK2TICK (200) (INT32U)
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Results of the
Double word group N100 = 1287639390 // The value varies with time
related functions
_TICK, _TIME2TIME

12.6 Introduction to Functions and Syntax of Data Conversion

12.6.1 List of register functions
Name Function

_HIBYTE Variables take high-order
metadata

_LOBYTE Variables take low-order metadata
_HIWORD Variable takes high byte data
_LOWORD Variables take low byte data
_SWAPBYT
E

Variable high and low bit metadata
exchange

_SWAPWO
RD

Variable high and low byte data
exchange

_BIN2GRAYConvert binary data to Gray code

_GRAY2BINGray code conversion into binary
data

_MAKEWO
RD

Two bits of data combined into
one word

_MAKEDW
ORD

Two words combined into one
double word

12.6.2 Introduction to Function Syntax
1._HIBYTE
Variables take high-order metadata: the return value is the high-order
metadata of the input value

INT32U _HIBYTE (INT32U data)
example:

N100 = _HIBYTE (1234H)
Results of the
N100 = 0012H
related functions

_LOBYTE, _HIWORD, _LOWORD, _MAKEWORD, _MAKEDWORD

2._LOBYTE
Variables take low-order metadata: the return value is the high-order metadata
of the input value

INT32U _LOBYTE (INT32U data)
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example:
N100 = _LOBYTE (1234H)

Results of the
N100 = 0034H
related functions

_HIBYTE, _HIWORD, _LOWORD, _MAKEWORD, _MAKEDWORD

3. _HIWORD
Variable takes high byte data: the return value is the high byte data of the input
value

INT32U _HIWORD (INT32U data)
example:

N100 = _HIWORD (12345678H)
Results of the
N100 = 1234H
related functions

_HIBYTE, _LOBYTE, _LOWORD, _MAKEWORD, _MAKEDWORD

4. _LOWORD
Variables take low byte data: the return value is the low byte data of the input
value
INT32U _LOWORD (INT32U data)
example:

N100 = _LOWORD (12345678H)
Results of the
N100 = 5678H
related functions

_HIBYTE, _LOBYTE, _HIWORD, _MAKEWORD, _MAKEDWORD

5. _SWAPBYTE
Variable high and low bit data exchange: the return value is the data after the
exchange of high and low bits of the input value
INT32U _SWAPBYTE (INT32U data)
example:

N100 = _SWAPBYTE (1234H)
Results of the
N100 = 3412H
related functions
_HIBYTE, _LOBYTE, _HIWORD, _LOWORD, _MAKEWORD,

_MAKEDWORD, _SWAPWORD

6. _SWAPWORD
Variable high and low byte data exchange: the return value is the data after

the exchange of high and low bytes of the input value
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INT32U _SWAPWORD (INT32U data)
example:

N100 = _SWAPWORD (12345678H)
Results of the
N100 = 1234H
N101 = 5678H
related functions

_HIBYTE, _LOBYTE, _HIWORD, _LOWORD, _MAKEWORD,
_MAKEDWORD, _SWAPBYTE

7, _BIN2GRAY
Convert binary data to Gray code: return the binary data whose input value

is converted to Gray code
INT32U _BIN2GRAY (INT32U data)
example:

N100 = _BIN2GRAY (55555555H) (DW)
Results of the
N100 = FFFFH
N101 = 7FFFH
related functions

_GRAY2BIN

8. _GRAY2BIN
Gray code conversion to binary data: Gray code data whose return value is

input value is converted to binary data
INT32U _GRAY2BIN (INT32U data)
example:

N100 = _GRAY2BIN (7FFFFFFFH) (DW)
Results of the
N100 = 5555H
N101 = 5555H
related functions

_BIN2GRAY

9. _MAKEWORD
Two bits of data combined into one word: the return value is the data

combined into one word
INT32U _MAKEWORD (INT32U hiData, INT32U loData)
example:

N100 = _MAKEWORD (12H, 34H)
Results of the
N100 = 1234H
related functions

_MAKEDWORD
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10. _MAKEDWORD
Two words combined into one double word: the return value is the data

combined into one double word
INT32U _MAKEDWORD (INT32U hiData, INT32U loData)
example:

N100 = _MAKEDWORD (1234H, 5678H)
Results of the
N100 = 1234H
N101 = 5678H
related functions
_MAKEWORD

12.7 Introduction to Functions and Syntax Related to

Calculation Check Code

12.7.1 Column table related functions of calculation check code
Name Function

_REGLRC Using LRC method to calculate the
variable area check code

_REGCRC1
6

Use CRC16 method to calculate
variable region check code

_REGCRC3
2

Use CRC32 method to calculate
variable region check code

_REGCCITTUse the CCITT method to calculate
the variable area check code

_REGBCC Use the BCC method to calculate the
variable area check code

_REGBCC2 Use BCC's complement method to
calculate the variable area check code

12.7.2 Introduction to the Function Syntax Related to Calculation
Check Code
1._REGLRC
Use the LRC method to calculate the check code of the variable area: the

return value is the value of the LRC check code
INT32S _REGLRC (INT32S regNum, INT32S cnt)

regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value 0 indicates that the variable is incorrect or the value is 0,

and the other values are the values of the LRC check code.
example:
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_STRW (N100, "1234")
N200 = _REGLRC (100, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
N200 = 202 // 202 = 0CAH
related functions
_REGCRC16, _REGCRC32, _REGCCITT, _REGBCC, _REGBCC2

2. _REGCRC16
Use the CRC16 method to calculate the variable area check code: the return

value is the value of the CRC16 check code
INT32S _REGCRC16 (INT32S regNum, INT32S cnt)
CRC16 algorithm (X16 + X15 + X2 + 1)
regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value of 0 means that the variable is wrong or the value is 0, and

the other values are the values of the CRC16 check code.
example:

_STRW (N100, "1234")
N200 = _REGCRC16 (100, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
N200 = 30BAH
related functions
_REGLRC, _REGCRC32, _REGCCITT, _REGBCC, _REGBCC2

3. _REGCRC32
Use the CRC32 method to calculate the variable area check code: the return

value is the value of the CRC32 check code
INT32S _REGCRC32 (INT32S regNum, INT32S cnt)
CRC32 algorithm
(X32 + X26 + X23 + X22 + X16 + X12 + X11 + X10 + X8 + X7 + X5 + X4 +

X2 + X1 + 1)
regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value of 0 means that the variable is incorrect or the value is 0,
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and the other values are the values of the CRC32 check code.
example:

_STRW (N100, "1234")
N200 = _REGCRC32 (100, 4) (DW)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
Double word N200 = 09BE3E0A3H
related functions
_REGLRC, _REGCRC16, _REGCCITT, _REGBCC, _REGBCC2

4. _REGCCITT
Use the CCITT method to calculate the variable area check code: the return

value indicates the value of the CCITT check code
INT32S _REGCCITT (INT32S regNum, INT32S cnt)
CRC-CCITT algorithm (X ^ 16 + X ^ 12 + X ^ 5 + 1)
regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value 0 indicates that the variable is incorrect or the value is 0,

and the other values are the values of the CCITT check code.
example:

_STRW (N100, "1234")
N200 = _REGCCITT (100, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
N200 = 9741H
related functions
_REGLRC, _REGCRC16, _REGCRC32, _REGBCC, _REGBCC2

5. _REGBCC
Use the BCC method to calculate the check code of the variable area: the

return value indicates the value of the BCC check code
INT32S _REGBCC (INT32S regNum, INT32S cnt)
regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value of 0 means that the variable is incorrect or the value is 0,

and the other values ​ ​ are the values ​ ​ of the BCC check code.
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example:
_STRW (N100, "1234")
N200 = _REGBCC (100, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
N200 = 0004H
related functions
_REGLRC, _REGCRC16, _REGCRC32, _REGCCITT, _REGBCC2

6. _REGBCC2
Use the BCC's complement method to calculate the variable area check

code: the return value is the value of the BCC's complement check code
INT32S _REGBCC2 (INT32S regNum, INT32S cnt)
regNum can be used in the range of 0 ~ 65535
Cnt can be used in the range of 1 ~ 256
The return value of 0 means that the variable is incorrect or the value is 0,

and the other values ​ ​ are the values ​ ​ of the BCC check code.
example:

_STRW (N100, "1234")
N200 = _REGBCC2 (100, 4)

Results of the
N100 = 0041H
N101 = 0042H
N102 = 0043H
N103 = 0044H
N104 = 0000H
N200 = 00FBH
related functions
_REGLRC, _REGCRC16, _REGCRC32, _REGCCITT, _REGBCC

12.8 Introduction to Communication Related Functions and

Syntax

12.8.1 A column table of communication-related functions
Name Function

_LWRITE Data is sent through the
communication port
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12.8.2 Introduction to Communication Related Function Syntax
1._LWRITE
Data is sent through the communication port: the return value indicates

whether the sending is completed
INT32S _LWRITE (INT32S handle, INT32S regNum, INT32S cnt)
Operation value of the handle communication connection (Handle is

displayed after the [Link Management] parameter in the Link Management
window)

regNum data source register address number
Cnt can use the range 1 ~ 256
The return value 0 means that the variable range is wrong or the handle is

wrong or there is a problem with the development.
example:

_STR (1000, "A0 = 1234 \ r \ n")
N100 = _STRLEN (1000)

N101 = _LWRITE (0, 1000, N100)
Results of the
The character string is sent through the communication port "A0 = 1234 \ r \

n"
N100 = 9
N101 = 1
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Chapter 13 Description of Macro Communication

Using Macro communication, when the communication receives data,
the system will automatically execute [496: Sub Macro (496)] without
calling it.

Receive data and send data is up to 253 bytes (Byte).
N63744 [0xf900] Length of received data (BYTE). (0 ~ 253)
N63745 ~ N63871 Received data The received data is stored from the lower

byte, that is, the first BYTE stores the lower 8 bits of N63745, the second
BYTE stores the upper 8 bits of N63745, and so on.
When the system receives the data from the communication port, it will store

the data in sequence to N63745, and store the number of bytes received to
N63744.
N63872 [0xf980] Length of data to be transmitted (BYTE). (0 ~ 253)
N63873 ~ N63999 Transmitted data The transmitted data is stored from the

lower byte, that is, the first BYTE stores the lower 8 bits of N63873, the second
BYTE stores the upper 8 bits of N63873, and so on.
When the system recognizes that N63872 is greater than 0 and less than

254, it will begin to transmit the data at the variable position of N63873 to the
number of bytes recorded by N63872. Commands sent twice. (When data is
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sent to the communication buffer, the system will sequentially send the data to
the corresponding communication port)

Note: The Macro communication protocol does not support the
simultaneous use of multiple communication ports.
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Appendix 1 Definition of mView Project Editing

Keyboard

keyboard action remark
Ctrl+Z Undo the last action
Ctrl+Shift+Z Undo last action
Ctrl+X Cut
Ctrl+C copy
Ctrl+M Multiple copy
Ctrl+V paste
Ctrl+Del delete
Del delete
Ctrl+A select all
Up Component fine-tuning
Down Component fine-tuning

Left Component fine-tuning to
the left

Right Components fine-tuned to
the right

Shift+Up The component moves up
one grid

Shift+Down Move the component down
one grid

Shift+Left Move the component one
frame to the left

Shift+Right Move the component one
space to the right

Ctrl+Up Reduced component height
by one

Ctrl+Down Increase the component
height by one

Ctrl+Left Component width minus
one

Ctrl+Right Increase the component
width by one

ESC cancel selection
G Group
U Ungroup
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I Enlarged display
O Zoom out
L Fixed element
Space Edit symbol
F4 Display component order
Shift+F4 Display component name
F5 Display variables (simple)
Shift+F5 Display variables (general)

F6 Only display information
about selected components

F8 Grammar check
F9 Online execution
Shift+F9 Offline execution
Ctrl+F9 Stop
Ctrl+Alt+S Download to HMI

Shift+"+" Change the order of
components (to the top)

Shift+"-" Change the order of
components (to the bottom)

"+" Change component order
(up one layer)

"-" Change component order
(push back one layer)
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Appendix 2 List of mView System Preset Variables

The user-available variable range is N0~N65023, and the register range for
power interruption is N49152~N61439 (will be expanded to N32768~N49151
in the future). Note that the variables after N65024 are for system use and
cannot be customized by users.

1 System preset variables
Power off retentive

No. data Explanation Default
value

Read
and
write

N65024 Screenbrightness 0...100 70 R/W

N65025 Screencomparison 0...100 50 R/W

N65026 Backlight timer Unit: second，30...65535，65535=off 65535 R/W
N65027 volume 0...100 100 R/W

N65028 Power LEDstatus display 0=flash，1=stop 0 R/W

N65029 Signal generatorswitch 0=off，1=on 0 R/W

N65030 Key sound index 65535=off 0 R/W

N65031 Dialog box soundindex 65535=off 1 R/W

N65040 Auxiliary cursor 65535=off 65535 R/W

N65041 Auxiliary cursorcolor 0 R/W

N65044 Dialog box mask
Use dialog mask
0X0001, 0X0002 omit the
background picture

1 R/W

N65048
Screen
brightness
increase rate

1...20 10 R/W

N65049
Screen
brightness
reduction rate

1...20 2 R/W

N65050 Backlight powersaving ratio 0...100 0 R/W
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N65056 Time zone -32768...32767 0

N65072
Com port 1 is
connected to
electrical

0-auto recognition
RS232/RS422/RS485
1-RS232
2-RS422
3-RS485

0

N65073
Com port 1
communication
rate

0-150,3-1200,6-9600,9-57600,
1-300,4-2400,7-19200,10-115200,
2-600,5-4800,8-38400,

10

N65074 Com port 1 data
bit

0 - 5bit，1 - 6bit，
2 - 7bit，3 - 8bit 3

N65075 Com port 1 check
bit

0 - None，1 - Odd parity，
2 - Even parity，3 - mark，4 - Space 0

N65076 Com port 1 stop
bit 0 - 1bit，1 - 2bit， 0

N65077 Com port 1 delay Unit: ms 20

N65078 Com port 1
timeout setting

Unit: millisecond, minimum value
1000 1000

N65080
Com port 2
connected to
electrical

Setting as N65072 0

N65081
Com port 2
communication
rate

Setting as N65073 10

N65082 Com port 2 data
bit Setting as N65074 3

N65083 Com port 2 check
bit Setting as N65075 0

N65084 Com port 2 stop
bit Setting as N65076 0

N65085 Com port 2 delay Unit: ms 20

N65086 Com port 2
timeout setting

Unit: millisecond, minimum value
1000 1000

N65088
Com port 3
connected to
electrical

Setting as N65072 0

N65089
Com port 3
communication
rate

Setting as N65073 10

N65090 Com port 3 data
bits Setting as N65074 3

N65091 Com port 3 check
bit Setting as N65075 0
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N65092 Com port 3 stop
bit Setting as N65076 0

N65093 Com port 3 delay Unit: ms 20

N65094 Com port 3
timeout setting

Unit: millisecond, minimum value
1000 1000

N65096
Com port 4
connected to
electrical

Setting as N65072 0

N65097
Com port 4
communication
rate

Setting as N65073 10

N65098 Com port 4 data
bits Setting as N65074 3

N65099 Com port 4 check
bit Setting as N65075 0

N65100 Com port 4 stop
bit Setting as N65076 0

N65101 Com port 4 delay Unit: ms 20

N65102 Com port 4
timeout setting

Unit: millisecond, minimum value
1000 1000

N65104 Flashing timesetting 1 Unit: ms 1000

N65105 Flashing timesetting 2 Unit: ms 500

N65106 Flashing timesetting 3 Unit: ms 200

N65107 Flashing timesetting 4 Unit: ms 100

N65112 Dialog box inputeffect 0=off，1=on. 1

N65116 Componentenable display

0: Normal display,
1: When the enabling condition is
not established, the [Prohibition]
symbol is displayed on the upper
left.
2: When the enabling condition is
not established, the module sets
the network type shielding pattern

N65120 RFID_MODE RFID reading mode 0=Read UID,
1=Read UID+IID, 2=Write IID

N65128 MODBUS slave
station number

N65137 Screen language Bit0=1: Record the current
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options language
N65152 Macro options

N65168 Adjust columnheight
N65264 Last boot state 0=Normal，！=0 wrong 0

Working temporary register(R/W)

No. Data Explanation Read/
write

N65280 Perpetual
calendar-year 1960...2059 R/W

N65281 Perpetual
calendar-month 1...12 R/W

N65282 Perpetual
calendar-day 1...31 R/W

N65283 Perpetual
calendar-hour 0...23 R/W

N65284 Perpetual
calendar-minute 0...59 R/W

N65285 Perpetual
calendar-second 0...59 R/W

N65286 Perpetual
calendar-week

0...6，
0-Sunday，
6=Saturday

R/W

N65287 Current backlight time0...65535 R/W
N65288 Dialog box result R/W

N65289 Dialog box data
format R/W

N65290 Dialogue box decimal
point R/W

N65291 Number of dialog
boxes R/W

N65292 Maximum number of
text in dialog box R/W

N65293 Dialog box button
clear

0X8000(Loop
input0X00FF) R/W

N65294-N652
95 Dialogue text R/W

N65296-N653
27 Dialog box text R/W

N65328-N653
29

Enter the maximum
value R/W
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N65330-N653
31

Enter the minimum
value R/W

N65332 Right to use
password dialog box R/W

N65340 Current user rights 1...31 R/W
N65341 Current user ID 1...15 R/W

N65342 Current screen
language index 0...n R/W

N65343 Current screen ID 1...n R/W
N65344 Current key status 0...3 R/W
N65345 Input disable R/W

N65347 Control register Bit=0Update the current
backlight timing R/W

N65360-N653
75

Dialog box input max
string Display data format2：-A R/W

N65376-N653
91

Dialog box input min
string Display data format2：-A R/W

Working read-only register

No. Data Explanation Read/
wirte

N65408 HMI Model 0X5000 R
N65409 OS Version R
N65410 Screen width 320 R
N65411 Screen height 240 R
N65412 Screen color 1/4/8/16 R
N65413 screen size 5700 R
N65414 Product Number 1 R
N65415 Product Number 2 R
N65422 Screen update time Unit: ms R

N65423 Picture updates per
second R

N65424 CPU Usage rate 0...100 R

N65430
Type of alarm
occurrence
information

0...2 R

N65431 Alarm storage
capacity R

N65432 Number of alarms R

N65440 System Information
Number R
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N65448-N6544
9 Time TICK R

N65456-N6546
3

protocol name of
com port 1

Display format 1-BA display
length 16 R

N65464-N6547
1

protocol name of
com port 2

Display format 1-BA display
length 16 R

N65472-N6547
9

protocol name of
com port 3

Display format 1-BA display
length 16 R

N65480-N6548
7

protocol name of
com port 4

Display format 1-BA display
length 16 R

N65488 COM1Number of
write buffers

At present, each COM port has 32
write buffers R

N65489 COM2Number of
write buffers

At present, each COM port has 32
write buffers R

N65504 Signal generator1 [0...359] R
N65505 Signal generator2 [0...99] R
N65506 Signal generator3 [0...11] R
N65507 Signal generator4 [0...59] R
N65508 Signal generator5 Sine wave[0...327687] R
N65509 Signal generator6 Sawtooth wave[0...327687] R
N65510 Signal generator7 Triangle wave[0...327687] R
N65511 Signal generator8 Square wave[0...327687] R

N65528 Communication
abnormal alarm Bit0=COM1,Bit1=COM2. R

N65529 Boot time status
Bit0 = 1 after booting, Bit1 = 1
after 1 second,
Bit15 = 1 at the 15th second.

R

2 The usage of internal pointer variable V
The pointer V and the variable N appear in pairs, and the fixed relationship is
as follows

In mView, the relationship between the internal variable pointer V and the
variable N is one-to-one. When using it, you need to follow the corresponding
relationship in the above table. If you use V0, the other needs to use N0, and
so on...

Among them, the value of N represents the address that points to the
register, and the value of V represents the value of the register pointed to by N;
for example: use the group N0 and V0 for indexing, N0=100, N100=255, then
V0=255.
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Examples of batch assignment:
N0=10
FOR 61430
V0=555(INT16U)
N0+=1(INT16U)
NEXT
END
Analysis: N0=10, the register that specifies the start of the index is N10;

V0=555, specify the value to be transmitted, that is, N10=V0=555;
Use the FOR loop program to assign all values of 555 to N10-N61439.
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Appendix 3 mView Scale Frequency Table

scale Octave0 Octave1 Octave2 Octave3

Do
C 262 523 1047 2093
Db 277 554 1109 2217

Re
Db 294 587 1175 2349
Eb 311 622 1245 2489

Mi Eb 330 659 1329 2637

Fa
F 349 698 1397 2794
Gb 370 740 1480 2960

Sol
G 392 784 1568 3136
Ab 415 831 1661 3322

La
A 440 880 1760 3520
Bb 466 923 1865 3729

Si B 494 988 1976 3951
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Appendix 4 Instructions for Using Operation

Variables

Operation variable
It means that the general numerical data source location can be set using

the calculation between variables.
In this software, if a small icon appears on the right side of the edit box for

the input variable position, it means that the variable input position can use
arithmetic variables. As shown below:

The operational symbols that can be used are shown in the table below
Operation
category Operation symbol Case remarks

computation

addition + D100 + D101
Subtraction - D100 - D101
multiplication * D100 * D101
Descent / D100 / D101
Take the remainder % D100 % D101
Take a negative
number - -D101

Bit operation

and & D100 & D101
XOR ^ D100 ^ D101
or | D100 | D101
Shift left << D100 << D101
Right shift >> D100 >> D101
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Negate ~ ~D100

Relational
operation

Equal to == D100 == D101
Not equal to != D100 != D101
Less than < D100 < D101
Less than or equal to <= D100 <= D101
more than > D100 > D101
More or equal to >= D100 >= D101

logic operation

Logical OR || D100 || D101

Logical AND && D100 &&
D101

Logical inverse ! !D100
In the table above:
D100 and D101 refer to variables in the PLC (controller).
Operators can be used together, for example ((D100 + D101) / 2) == 100
To increase the convenience of reading, when the operator occupies a bit, a

space can be inserted between the variable and the operator. However, when
the operator occupies two bits, no space can be added between the operators,
as explained below:
D100 + D101 can be written: D100 + D101
D100 <= D101 The syntax check is correct here
D100 <= D101 The syntax check is incorrect here because the operator <=

has a blank character in the middle.

Definition of constant
Constant
type Definition description Case

Decimal Number0~9 123 or 100000

Hex
Numbers 0 ~ 9, English letters A ~ F, the last word
is 'H', but the first word must not be a letter, it must
be a number

100H or
1234H or
0ABCDH

Cases
Operation variable Explanation

(D0+D1+D2+D3+D4)/5 Take the average of D0 to D4
(D0+1234)/1000 Multiply D0 by 1.234

(D0==100H)||(D1==200H
)

When D0 is equal to 100 in hexadecimal or D1 is equal to
200 in hexadecimal, the value is 1, otherwise the value is
0.

D0>D1 When D0 is greater than D1, the value is 1, otherwise the
value is 0

(D0<=D1) && (D0==100) When D0 is less than D1 and D0 is equal to 100, the
value is 1, otherwise the value is 0.
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D0 & D1
D0 = [Binary] 0000000000001111-> Decimal = 15
D1 = [Binary] 0000000000010001-> Decimal = 17
D0 & D1 = [Binary] 0000000000000001-> Decimal = 1

D0 << 2 D0 = [Binary] 0000000000001111-> Decimal = 15
D0 << 2 = [Binary] 0000000000111100-> Decimal = 60
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Appendix 5 Function Description of Multiple

Intelligent Connected Machines of HMI

At present, more users will have more and more devices connected to the HMI.
One RS485 can be connected to multiple controllers. Under this structure, the
software can distinguish each controller by station number when designing the
HMI program stage, so that the HMI can read the data of each connected
controller. When each controller works normally, the communication will work
normally.
However, in some use cases, not all connected controllers must be powered
on, which will cause the HMI to always try to connect with the controller that is
not powered on during communication, which will affect the overall
communication speed.
When we designed the software, we added the [multiple intelligently
connected machines] function in the HMI software, and the setting page is
shown in the following figure:

[Multi-Station Smart Link] function basically records the connection status of
each controller to adjust the communication parameters and increase the
connection speed and stability. When the unpowered controller restarts, the
HMI will automatically discover and connect automatically.
The station number must be between 0 and 31 when the station number of the
controller is assigned by using the function of [Multiple Smart Links]. If you
need to know the status of the connected controller, you can check it from HMI
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internal system variables (COM1 = N65352, COM2 = N65354).
The station number corresponds to the bit of the variable, 0 = normal
connection, 1 = not currently connected. The specific corresponding table is as
follows.

CO
M1

Vari
a-bl
e

N65353 N65352

bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 15 14 1312 1110 9 8 7 6 5 4 3 2 1 0

Stat-
ion
No

31 30 29 28 27 26
2
5
2
4 2322

2
1 20 19

1
8
1
7 1615 14 1312 1110 9 8 7 6 5 4 3 2 1 0

CO
M1

Vari
a-bl
e

N65355 N65354

bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 15 14 1312 1110 9 8 7 6 5 4 3 2 1 0

Stat-
ion
No

31 30 29 28 27 26
2
5
2
4 2322

2
1 20 19

1
8
1
7 1615 14 1312 1110 9 8 7 6 5 4 3 2 1 0

Note: [Multiple Smart Links] only supports controllers with station number
communication protocol.



TK Series HMI Programming Manual

306 www.coolmayplc.com

Appendix 6 Function Description of Embedded

Numerical Value Display in String

The value embedded in the character string means that when a static text
component is used, the dynamic variable character string value is displayed in
a general static component using the [variable display character string]
function.
[Variable display character string]: Refers to the definition character string

that uses ‘{’ as the starting symbol and ‘}’ as the ending symbol. For example
{N0,4.2d}, {N100,81X}.
If you want to display the ‘{’ symbol in the character string, you need to type

two consecutive ‘{’ ’s of‘ {{’to recognize the‘ {’as a normal character string.
[Variable display string] The definition is divided into 6 parts: prefix, variable

definition part, integer part, decimal part, display format definition, suffix. The
variable definition part and the integer part are separated by a ’,’ comma
(English comma).

Variable display string format description

Prefix Variable
definitions Integer part decimal part Display format definition suffix

{

System variables
N0 ~ N65535
Index variable V0
~ V255

Value: 1-12.
When
high-order
zero padding
is required,
add a number
'0' in front.

Value: 1-12.
If this bit is 0,
that is, the
fractional part
is not needed,
this bit can be
omitted. When
it is omitted,
the separator
"." With the
integer part
needs to be
deleted.

d: Decimal signed number
(16Bits)
u: decimal unsigned number
(16Bits)
x: Hexadecimal display (16Bits)
ld: Decimal signed number
(32Bits※)
lu: decimal unsigned number
(32Bits※)
lx: hexadecimal display (32Bits
※)
f: floating point display (32Bits
※)

}

Note: There can be no white space in the variable display string definition
※ The reading of 32Bits is lower 16-bit data, and higher 16-bit data.

Examples of variable display string settings:
In {N0,4.2d},
Prefix: {;
Variable definition: N0;
Integer part: 4;
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Decimal part: 2;
Display format: d;
Suffix:}
An example of variable display character string display, taking decimal N0 =

123 as an example:
Set variable
display string

displ
ay Explanation

{N0,04x} 007B Display the value of N0 in the form of hexadecimal
high-order zero-filling

{N0,2.2d} 1.23 Display the value of N0 in decimal and 2 decimal
places

{N0,d} 123 Display the value of N0 in decimal format

Examples of software settings:
1. Newly added components [static text]

2. Set the [Label] property as shown below

3. [Static text] The display status is shown as below
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4. Executing the program, the display status of [static text] is shown in the
figure below
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Appendix 7 List of Communicable Controllers

518 Singlex Series
AD-4401 Series
Allen-Bradley DH-485
ARCUS Series
CoolMay PLC(2N)
CoolMay PLC(3U/3G)/FX3U
CSIM Series
DELTA DVP Series
DPS Series
Facon FB Series
Fama Series
Fuji MICREX-SX Series
GALIL Series
Jing Yi elevator Series
Keyence KV Series
Koyo K sequence
LG Master-K K120S Series
LUSTBUS Series
Macro Series
Matsushita FP Series
Mitsubishi A1SH Series
Mitsubishi FX Series
Mitsubishi FX Series-Computer link
Mitsubishi FX2N Series
Mitsubishi FX2N-10GM/20GM Series
Mitsubishi FX3U Series
Mitsubishi MR-J2S Series
Mitsubishi MR-J3 Series
Mitsubishi MR-J4 Series
Mitsubishi Q Series
Mitsubishi Q06HCPU Series
Mitsubishi QnA Series
Modbus ASCII Mode
Modbus RTU Mode
Omron C Series
Omron CompoWay
P900 Series
Phoenixtec UPS Series
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RM80 Series
SAMCO-Vm05 Series
Simatic S7-200 Series
SMAC LLC-10 Series
SmartMotor Series
TAIE Series
TECORP HC1 Series(ASCII Mode)
TECORP V5000 Series
TOHO TTM-004/X04 Series
TRIO Host link Series
Unidriver Series
UNIPULSE Series
VIGOR M/VB/VH Series
WDH IR-BOX Series
WDH Lamp Series
XP989 Series
Yamatake CPL
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Appendix 8 TK Series HMI Storage Data export

Operation Instruction

Software：xExpress
xExpress software is specially designed for mView TK series HMI. The

main function is to read the recipe data and record data of the TK series HMI in
operation through the communication port, and save it as a text file, which is
convenient for customers to further data analysis or make reports, output data
can be customized display format, so that the data display closer to actual use.
Simple operation steps
1. Edit mView software, design HMI program, and define recipe data or record
data.
2. Test the connected HMI program to confirm that is working properly.
3. Use mView software to export [cache definition export].
4. Open xExpress editor, connect device and communication parameters.
5. Import data definition (the file exported by step 3).
6. Read the data in the buffer area through the connection
7. Select the edited recipe or recorded data, and after editing the attributes,
export the data to a text file.
8. Use Microsoft Excel software to open text documents, and then do data
analysis and reports.
Step1

First of all, use mView to edit the HMI program. When the recipe data or
record data is used in the program, it can be used with xExpress software.

Note that editing recipe data [backup device: use system variable area
(N0-N61439)]
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Note that editing record data needs [retentive function]
Note: The maximum power-saving interval is 49152 words, which is

related to [Data Length] and [Record Count]

Step2
Download the program to the HMI test operation until the test operation is

confirmed to be normal.
Step3

Open the mView software to edit the HMI program, select
[File]-[Export]-[Register Define] to store the buffer definition file.
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Step4
Open the xExpress software, [File]-[Open a new file], press the [Add

Device] button in the lower right corner

This demo explain how to use com port to communication, after adding a
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device, please select the communication port; [device] parameter refers to the
com port between the PC and the HMI, and set the communication parameters
(default 115200, 8, none, 1 is enough)

Then click [Add HMI] to add an new HMI

Step5
After adding the HMI, you need to import the data definition (defined by

the buffer exported in step 3)
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Step6
The definition data of the HMI will record the data definition. After the data

definition is imported, please fix the connection line between the PC and the
HMI (the download line of the HMI) and press [Read Data] on the lower right
corner of the xExpress screen to start reading the HMI. data
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Step 7
At this time, the recipe data or recorded data has been read back to the

PC, select the edited recipe or record data, after editing the attributes, export
the data to a text file. (When data is not recorded in the running HMI, xExpress
is empty during data recording)
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Step 8
Use the Microsoft Excel software to open the text file saved in step 7 for
data analysis and reporting
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Appendix 9 HMI modbus RTU Communication

Instruction

Function codes supported by HMI as modbus host
Function No. 01: Read the coil status and get the current status of a group of
logic coils (ON/OFF)
Function No. 03: Read holding registers and get the current binary value in one
or more holding registers
Function 04: Read the input register to obtain the current binary value in one or
more input registers
Function No. 05: Force a single coil, force a logic coil on and off state (write bit)
Function No. 06: Load specific binary values into a holding register (write
register)
Function No. 15: Forcibly set multiple coils, force a string of continuous logic
coils on and off (write multiple bits)
No. 16 function: preset multiple registers, load specific binary values into a
series of continuous holding registers (write multiple registers)

1. Make the setting of the master with only one slave
1. 1. Communication parameter setting, use 485 communication to select
COM2 to add communication protocol.
[Project] → [Communication] → [Add Protocol], as shown below
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ID: ID number of the controller. (Unique, not repeatable)
Station: the station number of the controller, that is, the slave station number to
be read/written. (The station numbers of com1 and com2 can be repeated)

The station number (HMI station number) in the display unit setting is the ID
(PLC ID) corresponding to the connected controller, and the ID (HMI ID) set in
the display unit is the corresponding Several controllers. For the setting of the
station number, COM1 and COM2 of the display unit are independent, so
COM1 and COM2 can be set separately to connect the controller with the
same station number, but for the setting of ID, each HMI cannot be repeated.
Because the ID describes the controller which is the first controller connected
to the display unit, as shown in the figure below.

1.2.After the addition is successful, the corresponding communication protocol
will appear in the selected communication:
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1.3. Available variables are as follows
Controller: the device that communicates with the HMI; number: directly enter
the address of the variable.



TK Series HMI Programming Manual

326 www.coolmayplc.com

1.4.Place the corresponding variable on the HMI screen and use 485 to
connect the modbus communication device, that is, you can read/write the
data of the corresponding variable address, as shown in the following figure:

2. Set up the master with multiple slaves
2.1. Communication parameter setting, use 485 communication to select
COM2 to add communication protocol.
If you need to connect multiple slaves, you need to add multiple controllers.
Each controller corresponds to a device that reads/writes a different slave
station number. [Project] → [Communication] → [Add Controller], as shown
below Shown

Or directly select the communication protocol, right click mouse → [Add
controller]
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Note that when connecting multiple products for communication, you need to
tick [Mult-Station Smart Link] and select [Timeout, Non- retransmission]

2.2. After adding 3 controllers successfully, it is as follows:
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2.3. Add the variable requesting to read/write the slave station number in the
order of ①②③④ as follows, ②Select the slave station corresponding to
the variable address

For example, slave 2 variable address:



TK Series HMI Programming Manual

329 www.coolmayplc.com

Slave 3 variable address:

2.4.Place the corresponding variable on the HMI screen and use 485 to
connect the modbus communication device, that is, you can read/write the
data of the corresponding variable address, as shown in the following figure:
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3. Setting of HMI as slave

3.1 Note: Without adding any protocol and device, the HMI will act as
MODBUS RTU slave.

How to set the station number of the slave station:
①Project>Setup>ID.
②Use N65128 to set directly on HMI.
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Currently only supports MODBUS RTU. Two methods for setting
communication parameters on HMI:

① Draw a diagonal line from the upper left corner of the HMI to enter the
system settings.

②Use the jump screen button to switch the screen to [65005: System
setting screen]

3.2 The variables available when HMI is used as a slave are as follows
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The corresponding address number of HMI register in modbus
communication:

Modbus NO.
HMI internal
variables

400000~465535 N0~N65535

The corresponding address number of HMI bit component in modbus
communication:
In HMI, an internal variable N has 16 bits, where N0.0 corresponds to

0X0000, N0.1 corresponds to 0X0001, and so on...
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Appendix 10 Instructions of Coolmay TK series HMI

communicating with other band PLC

Hardware specifications:
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1.Coolmay CX series

Method 1: Use RS232 connection
TK software setting

Parameter item Recommended settings
Protocol CoolMay PLC(3U/3G)/FX3U
Communication port type RS232
Communication rate 9600
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Synchronization check Even parity
Number of data 7 digits
Stop digits 1 digit

Operable variable
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TK(COM1)-CX series PLC communication line connection diagram (use
CX2N series download line)

Method 2: Use RS485 connection
TK software setting

Parameter item Recommended settings
Protocol CoolMay PLC(3U/3G)/FX3U
Communication port type RS485
Communication rate 9600
Synchronization check Even parity
Number of data 7 digits
Stop digits 1 digit
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Operable variable

TK(COM1)-CX series PLC communication line connection diagram
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2. AD4401 (Japan AIAND weighing controller)
TK software settings

Parameter item Recommended settings
Protocol AD-4401 Series
Communication port type RS232
Communication rate 9600
Synchronization check Even parity
Number of data 7 digits
Stop digits 1 digit
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Variable

Diagram of TK(COM1)-AD4401 communication cable
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3. Fuji MICREX-SX Series（Fuji）
TK software settings

Parameter item Recommended settings
Protocol Fuji MICREX-SX Series
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Communication port type RS232
Communication rate 38400
Synchronization check Even parity
Number of data 8 digits
Stop digits 1 digit

Manipulable variable
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TK-Fuji MICREX-SX Series Communication cable connection diagram (using

232 crossover cable)

4.Mitsubishi FX series
TK software settings

Parameter item Recommended settings
Protocol Mitsubishi Fx Series
Communication RS232
Communication 9600
Synchronization Even parity
Number of data 7 digits
Stop digits 1 digit
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Manipulable variable

TK-FX Series Communication line connection diagram (using Mitsubishi

programming line, namely SC-11/SC-09)
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5. Keyence KV series
TK software settings

Parameter item Recommended
Protocol Keyence KV Series
Communication port type RS232
Communication rate 9600
Synchronization check Even parity
Number of data 8 digits
Stop digits 1 digit
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Manipulable variable
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TK-Keyence KV Communication line connection diagram

6.Koyo K sequence series
TK software settings

Parameter item Recommended
Protocol Koyo K sequence
Communication port RS232
Communication rate 9600
Synchronization check Odd parity
Number of data 8 digits
Stop digits 1 digit
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Manipulable variable

TK-Koyo K sequence Communication line connection diagram
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7.LG series
TK Software settings

Parameter item Recommended settings
Protocol LG Master-K K120S Series
Communication RS232
Communication 38400
Synchronization No information
Number of data 8 digits
Stop digits 1 digit
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Manipulable variable

TK-LG Master-K120S Communication line connection diagram
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8. OMRON C series
TK Software settings

Parameter item Recommended settings
Protocol Omron C Series
Communication port RS232
Communication rate 9600
Synchronization check Even parity
Number of data 7 digits
Stop digits 2 digits
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Manipulable variable

TK-OMRON communication cable connection diagram

9.Siemens S7-200 series
TK Software settings

Parameter item Recommended settings
Protocol Simatic S7-200 Series
Communication RS485
Communication 9600
Synchronization Even parity



TK Series HMI Programming Manual

352 www.coolmayplc.com

Number of data 8 digits
Stop digits 1 digit
Communication 1 second

Manipulable variable



TK Series HMI Programming Manual

353 www.coolmayplc.com

TK-Siemens S7-200 communication line connection diagram

10.Delta DVP series
TK Software settings

Parameter item Recommended settings
Protocol DELTA DVP Series
Communication port type RS232
Communication rate 9600
Synchronization check Even parity
Number of data 7 digits
Stop digits 1 digit
Communication timeout 1 second
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Manipulable variable

K-Delta DVP communication cable connection diagram
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11. Xinje PLC series
TK Software settings

Parameter item Recommended settings
Protocol Xinjie PLC Series
Communication port type RS232
Communication rate 19200
Synchronization check Even parity
Number of data 8 digits
Stop digits 1 digit
Communication timeout 1 second
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Manipulable variable

TK- Xinje PLC communication line connection diagram
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12. Matsushita PLC series
TK Software settings

Parameter item Recommended settings
Protocol Matsushita FP Series
Communication port type RS232
Communication rate 9600
Synchronization check Odd parity
Number of data 8 digits
Stop digits 1 digit
Communication timeout 1 second
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Manipulable variable

TK- Matsushita PLC communication line connection diagram
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Appendix 11 HMI program simulation and download

11.1 Program simulation
mView provides the function of simulating directly on the PC. You can use

this function to simulate the actions performed on HMI after planning HMI. On
the one hand, it increases the convenience of finding program errors, and on
the other hand, it can save downloading to the time HMI can connect to the
controller. The simulation function of mView is divided into two types: [On-Line
Run] and [Off-Line Run], as shown in the figure below.
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11.1.1 On-Line Run

This function needs to be connected to the controller, and the program will
modify the corresponding contacts and registers set by the controller during
execution. It can be used to verify whether the planned program can normally
act on the controller.

Before [On-Line Run], you need to set up the communication, as shown in
the figure below:

Among them, COM1 and COM2 on the left of [Communication Setup]
refer to the communication ports on HMI, and the setting on the right is the set
of communication ports designated by the user on the PC side to simulate the
sex-corresponding communication ports of HMI side ,As shown below:
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11.1.2 Off-Line Run

This function does not need to be actually connected to the controller, it
can be used to test the normal operation of the program and the verification of
various functions.

11.2 Program download and update O.S. version
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After using the PC to simulate and verify that the program is correct, you
can start downloading to the HMI and directly use HMI to connect to the
controller.

11.2.1 Download to HMI

Before downloading the program to HMI, you need to make
communication settings first, please select [HMI]→ [Setup]→ [Communication
Setup], as shown in the figure below:

Specify the communication port of the PC in the [Upload/Download] of the
communication setting window, that is, the port where the download cable is
connected to the PC. For example, COM3, you can select [Use fixed
communication rate] in conjunction with HMI [download screen], or let the PC
automatically try to download at different rates.

Then select [HMI] → [Download to HMI], and then start to download the
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HMI program to the HMI, as shown below:

11.2.2 Save as HMI program

In addition to directly downloading the planned program to HMI, mView
also provides the user to save the planned program into a specific file (*.vho).
For downloading and using in the future, it should be noted that this file is only
for downloading and its content cannot be modified.

Select [HMI]→[Save project as file...] to save the project as a special file
for man-machine of type vho, as shown in the figure below:
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After you need to download this program to the HMI, select
[Tool]→[Download HMI Program], as shown below, you can download this
program to HMI.
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11.2.3 Update HMI OS

Generally speaking, when the new version of mView software is updated,
it will be matched with the corresponding version of the OS. This OS supports
the old version of the planning software downwards, but if the user wants to
use the functions provided by the new version of the planning software, the
new version must be matched OS and HMI OS are updated as follows.

Step 1: Select [Tools]→[Update HMI OS].
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Step 2: Select the OS version to be updated (it is recommended to update with
the planning software version used).

Step 3: Start downloading. (Note: During the OS download process, the HMI
must not be powered off!)
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Step 4: After the download is complete, restart the power of the HMI.

11.3 Program upload
Use this function to upload the program in the man-machine back to the

PC and save it as an HMI program for later downloading or editing by the user.

11.3.1 Upload HMI program

Select [Tool]→[Upload HMI Program] to upload the program from the HMI
back to the PC. After the transfer is complete, the user will be asked to save
the file as a dedicated file named vho, as shown in the figure below:
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To make the uploaded program editable, you must add the decompiled
information before downloading the program, otherwise the uploaded program
can only be used for downloading, and the user cannot edit it.

Select [View]→[Option(H)]→[File], and tick [Add Decompiled Information].
As shown below:
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Appendix 12 HMI USB penetrating function

The penetrating communication function provided by HMI is to use PLC
programming software on the computer and connect to the PLC through the
man-machine interface connected to the computer. In this way, you can
monitor, upload, and download PLC programs.

As shown in the figure above, the connection between PC and HMI is
USB (virtual serial port), and the connection between HMI and PLC is serial
connection. For debugging convenience, the PC can directly download or
monitor PLC programs through HMI to improve work efficiency.

Note: Single screen COM1 means RS232, COM2 means RS485;
All-in-one machine COM1 means using HMI and PLC internal

communication port, COM2 means using HMI RS232 or RS485.
1. COM1 penetration communication

Step 1: Set a screen button on the HMI program interface, select [65021:
Virtual connection COM1] for [Screen Switch]; download the program to the
touch screen.
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Step 2: HMI and PLC are connected through HMI COM1, the touch
screen is switched to this page, and the PC can directly download or monitor
PLC programs through HMI.

2. COM2 penetration communication
Step 1: Set a screen button on the HMI program interface, select [65022:

Virtual connection COM2] for [Screen Switch]; download the program to the
touch screen.
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Step 2: HMI and PLC are connected through HMI COM2, the touch
screen is switched to this page, and the PC can directly download or monitor
PLC programs through HMI.

3. The data of COM1 and COM2 penetrate each other
Step 1: Set a screen button on the HMI program interface, select [65011:

Virtual Online] for [Screen Switch]; download the program to the touch screen.

Step 2: Connect COM1 and COM2 of HMI to serial controller respectively,
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the touch screen will switch to this page, and the controllers connected to
COM1 and COM2 of HMI can transmit data to each other;
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Appendix 13 Version Change Record

Date Changed
version Change content

Dec.2021 V21.121

 Appendix 8 -- Simple operation steps 6.,
correct the mistake

 12.2.2 Introduction to Function Syntax-- 4.
_REGCPY, change parameters
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