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Introduction

The SIMATIC C7-621 provides you with a wide range of features to automate your process in a
convenient, clearly structured system with a fully functional man-machine interface.

This booklet shows you just how easily and quickly you can create your own application for Windows 95
with the C7-621, the STEP 7 or STEP 7-Mini *) programming software and the ProTool or ProTool/Lite **)

configuring software. Using a real-life solution as an example, we will guide you step by step to your
finished application .

In self-contained chapters, we explain the main functions of the SIMATIC C7- 621, describe typical tasks
on a sample machine, and provide you with some extra tips and tricks.

All Chapters are built on the same principle:

- First, the task is explained.

- Then we take you through the individual steps of the solution with illustrations of selected dialog boxes.

- Finally, we show you the result, so that you can check your own result after each programming and
configuring step.

Conventions:

� The mouse indicates that you need to enter data on the PC/programming device.

� The hand indicates that you need to enter data/perform an operator action on the
C7-621.

quickmix.pdb Texts to be configured, program sections to be coded and inputs to be selected from a
range of options are formatted in Courier .

File → New Menus, menu items, dialog boxes and text in dialog boxes that you select are written
in italics.

*)
Referred to below simply as STEP 7

**)
Referred to below simply as ProTool



Introduction A 03/99

6 First Steps with the C7-621
6ZB5610-0AF02-0BA0

Hardware

only connect programming device/PG

d�ring con�ig�ring p�a�e

Programming �o�t�are

��� �� �P ���ini

 on�ig�ring �o�t�are

��� Pro�ool/!ite

Programming device / P 

3

1

2

" #$ %

MPI

6

5

4

&oc�mentation  &

F1 F2 F3 F4 F5

SF DC5V

FRCE

RUN

STOP

Hello, I am the
smallest SIMATIC C7!

1 2 3

7 8 96

4 5

0

SIMATIC C7-621

ENTER

ESC

S HIFT

+/-

Checklist of components required:

Components Order No. Included in starter kit

� PC or programming device No

� STEP 7-Mini programming software 6ES7 810-3CC04-0YX0 Yes

ProTool/Lite configuring software 6AV6 580-3BX05-1AX0 Yes

SIMATIC documentation on CD-ROM
in 5 languages

6ES7 398-8AE00-8YE0 Yes

� PC/MPI cable
RS232 cable

6ES7 972-0CA22-0XA0
6ES7 901-1BF00 0XA0

Yes
Yes

� SIMATIC C7-621 control system 6ES7 621-1AD01-0AE3 Yes

� C7-DI/DO simulator module 6ES7 620-0AA00-4AA0 Yes

� PS307+24V power supply 6ES7 307-1BA00-0AA0 No
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Checklist for startup

The following basic steps are necessary in order to start up the SIMATIC C7:

� Install STEP 7 or STEP 7-Mini on a PC/programming device
� Install ProTool or ProTool/Lite in STEP 7 or STEP 7-Mini on the PC/programming device
� Connect the PC/MPI cable (C7 ↔ PC/programming device)
� Connect the C7 to the power supply (+24V)
� Reset the memory on the C7-CPU and C7-OP
� Select STEP 7-Mini on the PC/programming device and create the PLC program
� Load the PLC program on the C7
� Select ProTool/Lite on the PC/programming device and create the OP configuration
� Load the configuration on the C7
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Example machine: Quickmix

Quickmix is a mixing and filling plant which takes orange and mango concentrate from two separate
tanks, mixes them with water to produce orange or mango juice and then bottles the finished product.
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The diagram shows the configurable aspects of the example machine. We will develop a PLC program for
this machine and get to know the steps involved in interfacing the integrated C7 operator panel.
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Preparations for programming

Start STEP 7

� When you install STEP 7, an icon for the SIMATIC Manager appears on the Windows 95 desktop
and the SIMATIC program group is included in the start menu. Like any Windows 95 application, you
start the program by double-clicking the SIMATIC Manager icon or selecting Start menu → SIMATIC
→ SIMATIC Manager.

� If STEP 7 is started, cancel the STEP 7 Assistant: New Project.

Online help

If you an encounter a problem during programming, or if you want further information on a topic, press the
F1 key. This action starts the on-line help, where you can find explanations of various STEP 7 topics.

General settings

Before you start programming, you need to select one of two mnemonic options in the SIMATIC Manager
for displaying program statements.

� You will find the Language catalog under Options → Customize. Select English as the language and
International mnemonics.

Select OK to close the dialog box and save the settings.
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� You also have to set the PC/programming device interface. To do this, select the menu item Options
→ Set PG/PC-Interface... Set the PC Adapter(MPI) in the dialog box that appears.

If the PC Adapter is not displayed in the window, you can install it now. Activate the Install button and
follow the instructions.

� Enter the following settings as the PC/programming device interface Properties:
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� For the local connection, select the COM port to which you connected the PC/MPI cable.

Save the settings with OK.

You can now start to create your project.

Create a project

� Select the menu item File → New. In the dialog box that appears, create a new project with the name
Getstart .

� Assign a hardware item to your project with the menu item Insert → Station → 2 SIMATIC 300
Station. The SIMATIC 300 Station(1) folder appears. Overwrite the name of this station with the new
name Quickmix .
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Define the hardware

� Open the Quickmix station by double-clicking. Select the Hardware folder and open it by double-
clicking again.

� In the Hardware Configurator call up the hardware catalog with Insert → Hardware Components. In
this box, select the C7-621 from SIMATIC 300 → C7. A short description of the control system is
displayed.

� Double-click C7-621 to insert the device in slot 2 of the Hardware Configurator. You have now de-
fined your hardware. The window displays the MPI address of the C7 CPU (default MPI address 2)
and the address allocation of the integrated digital I/O.
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� To save the configuration, select Station → Save and Compile.

� To quit the Hardware Configurator, select Station → Exit.

The folder C7 CPU621, which contains the S7 program, is created automatically by the SIMATIC Mana-
ger. This S7 program file contains the Blocks folder with an empty OB1 organization block.

� Open the folders by double-clicking.
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Program development

Start by programming the operating modes for the filling plant.

Conveyor control

I 124.0 Start

Manual/automatic mode

I 124.3 Manual/automatic
I 124.4 Accept mode
I 124.5 Jog forward
I 124.6 Jog back

Bottle sensor Filling hopper Bottle sensor

I 125.0 Q 125.5 I 125.1

Q 125.3 Conveyor forward

Q 125.4 Conveyor back

Program the mode section as follows:

� The start switch switches on the plant.
� When the plant is switched on, the indicator lamp at output Q 125.0 is lit.
� When the plant is switched on, the Manual and Automatic modes can be selected.
� The mode setting is accepted via a pulse.
� The mode setting should be displayed (Manual=Q 125.1, Automatic=Q 125.2)
� To prevent malfunction, the previously selected mode should be deselected when the mode is

changed or the plant is switched off.
� The conveyor can be moved forward and back in jog mode when Manual mode is active.

In your program, use the I/O addresses shown in the figure above.
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Insert a block

� Select the Blocks folder in the SIMATIC Manager and select Insert → S7 Block → 3 Function Block
to insert a new function. In the dialog box that appears, allocate the internal identifier FC15. Select
STL as the programming language and close the dialog box with OK.

Edit the block

� Now open the LAD/STL/FBD Editor from the SIMATIC Manager by double-clicking the Function
FC15 you have just created.

� Click Title beside block number FC15 and enter the block name Mode. You can enter a block
comment in the gray field directly below the block name.

� Now assign the name Plant ON/OFF to Network 1. Do this by clicking Title beside the network
number. Once again, you can enter a network comment in the gray field directly below the network
name.

� You can now insert the first program lines below the network comment. Use the mouse to click the
white area below the gray comment field. A box appears with the current cursor position. Please
remember to enter spaces between inputs (at least one space separating each of the command
code, operand and comment) in every program line, otherwise STEP 7 will not recognize the
statement and will highlight the line in red italics. Enter the following code in the first network:
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FC15: Mode

Network 1 : Plant ON/OFF

A I 124.0 // Start (if input 124.0 on /off)
= Q 125.0 // Plant ON (plant is then switched on/off)

Insert a network

� To insert a new network, click on the tool bar. You will program the MANUAL mode in this
network.

Network 2 : MANUAL mode

A Q 125.0 // Plant ON
AN I 124.3 // and MANUAL mode selected (switch=0)
A I 124.4 // Confirm acceptance of selected mode
S Q 125.1 // Manual mode activated
A( // If
ON Q 125.0 // plant OFF (LED of DO not lit)
O I 124.3 // OR AUTOMATIC mode selected (switch=1)
)
R Q 125.1 // Then select Manual mode

� Insert three further networks for the plant functions Automatic mode, conveyor forward and conveyor
back.

Network 3 : AUTO mode

A Q 125.0 // If plant ON
A I 124.3 // and AUTOMATIC mode selected (switch=1)
A I 124.4 // and acceptance of selected mode confirmed
S Q 125.2 // Then set automatic mode
A(
ON Q 125.0 // Plant OFF (LED of DO not lit)
ON I 124.3 // or Manual mode set
)
R Q 125.2 // Then select AUTOMATIC mode

Network 4 : Conveyor forward

A Q 125.1 // If MANUAL mode set
A I 124.5 // and Jog Forward is pressed (enabled)
AN I 124.6 // and Jog Back is not pressed (enabled)
= Q 125.3 // Then move conveyor forward

Network 5 : Conveyor back

A Q 125.1 // If MANUAL mode set
A I 124.6 // and Jog Back is pressed (enabled)
AN I 124.5 // and Jog Forward is not pressed (enabled)
= Q 125.4 // Then move conveyor back
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Save the block

� The mode section of the filling plant is now fully programmed. Now save function FC15 by activating

the symbol .

� For an executable program you still need to call FC15 in organization block OB1. Open OB1 in the
SIMATIC Manager and insert the following program line in the first network:

OB1 : Filling plant

Network 1 : Mode section

CALL FC 15

� Now save organization block OB1 and close the LAD/STL/FBD Editor.

Set the operating mode

���� Now press the
SHIFT 0

keys on the C7-621 to select the system function menu.

� Select the C7 CPU mode menu "KEY" by pressing
F1

.

� Select the STOP mode by pressing
F3

. The STOP LED lights up.

� If you have not yet entered a password, you are now prompted to do so. Password 100 is the default
setting when the C7 is delivered. Enter the digits 100 on the numeric keypad and press ENTER.
Now, select STOP mode again.

Clear the C7 CPU memory / reset the C7 OP

Before you load a project into the CPU for the first time, you need to establish a neutral state on the
C7-621. This is achieved by deleting both of the integrated C7 flash memories and then restarting the
C7-621. Proceed as follows to delete the C7 flash memory:

Delete C7 CPU memory:

� In the SIMATIC Manager select the Accessible Nodes symbol. In the dialog window that
appears, double-click the folders MPI=2 and Blocks to open them.

� Select all OBs, FBs, FCs and DBs. Delete the selected objects from the C7 CPU. The load memory
of the C7 CPU is then cleared.

� Select the folder MPI=2 and copy the contents of the load memory into the C7 CPU flash memory by
activating PLC → Copy RAM to ROM. This action clears the integrated CPU flash memory.

� Close the Accessible Nodes window.
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Reset the C7 OP:

� Activate transfer mode on the C7-621 by performing a reset:
� Switch off the power supply to the C7-621.

� Then press the keys
ESC

and and
� Hold down the above keys
� and switch the power supply on.
Do not release the keys until the message "Flash Test" appears on the display. A message is
displayed after the start-up tests are complete and the C7 OP has been reset.

Load blocks

There are two ways of loading blocks into the CPU. It is best to load blocks individually in large projects
when changes are made only to a small number of specific blocks. It is more practical to load all blocks in
smaller projects, or when changes have been made to a large number of different blocks.

Load all blocks:

� Select the Blocks folder in the SIMATIC

Manager and click the symbol on the
tool bar once.

Load individual blocks:

� Select function FC15 in the SIMATIC
Manager and load this block into the CPU of
the SIMATIC C7-621. You only need to click

the symbol on the tool bar once.
Then load organization block OB1 into the
CPU following the same procedure.

� Now select the system function menu on the C7-621 by pressing
SH IFT 0

.

� Select the C7 CPU mode menu "KEY" by pressing
F1

.

� Select RUNP mode by pressing
F1

. The RUN LED lights up.

� If you have not yet entered a password, you are now prompted to do so. Password 100 is the default
setting when the C7 is delivered. Enter the digits 100 on the numeric keypad and press ENTER.
Now, select RUNP mode again.

Test your program on the C7-621 using the simulator. The functions of the plant described on Page 15
must be fulfilled.

� You can simulate the pulse for accepting the selected mode by simulating a short on/off switch.
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Extend the program

Now extend the program with the filling process. The plant should operate as follows:

� The conveyor drive motor is switched on (Q 125.3) in Automatic mode and remains switched on until
the stop switch opens or the sensor (I 125.0) detects a bottle.

� The filling process starts when a bottle is positioned underneath the filling hopper. Filling is simulated
for a period of 3 seconds and is displayed via output Q 125.5.

� When the bottle has been filled, the conveyor must start up again automatically and remain switched
on until the next bottle is detected or the stop switch is pressed.

� After the plant is switched on, the full bottles should be counted via a further sensor (I 125.1).

� To implement the process, call up your project offline in the SIMATIC Manager and insert
another Function in the Blocks folder. Assign the internal identifier FC16, select STL as the
programming language and open the block.

� Insert the following program lines in the individual networks:

FC16 : Filling cycle

Network 1 : Fill bottles

A I 125.0 // Bottle sensor 1 has detected a bottle
L S5T#3s // Load filling time (3s)
SE T 1 // Set extended pulse (3s)
A T 1 // When timer 1 reaches level 1
= Q 125.5 // Open inlet valve

Network 2 : Scratchpad memory for conveyor, AUTO

A Q 125.2 // If AUTOMATIC mode set
A( // and
ON I 125.0 // no bottles have been detected by bottle sensor 1
O / / or
A I 125.0 // bottle sensor 1 has detected a bottle
AN T 1 // and filling process not running (valve closed)
)
= M 5.0 // Then the conveyor is moving

Network 3 : Count full bottles

A I 125.1 // Bottle sensor 2
CU C 1 // Increase counter by 1
A Q 125.0 // When plant is switched on
L C#0
S C 1 // Reset counter to 0

� Programming of block FC16 is now complete. The block can be saved and loaded into the CPU.
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� You now need to allow for the filling cycle in the mode section. Insert the program line O M 5.0 in
Network 4 of Function FC15. The complete network then appears as follows:

Network 4 : Conveyor forward

A Q 125.1 // If MANUAL mode is set
A I 124.5 // and Jog Forward is pressed (enabled)
AN I 124.6 // and Jog Back is not pressed (enabled)
O M 5.0 // or filling process running in AUTOMATIC mode
= Q 125.3 // Then move conveyor forward

� Save function FC15 and overwrite the block on the CPU by loading the new block.

� Finally, you need to modify OB1. Open OB1 in the SIMATIC Manager, insert a second network, and
call FC16.

OB1 : Filling plant

Network 1 : Mode section
CALL FC 15

Network 2 : Filling cycle

CALL FC 16

� Save OB1 and load it into the CPU to overwrite the old organization block.

To protect the PLC program in the C7 CPU against a power failure, you still need to transfer the program
to the C7 CPU flash memory. This is described in the following section.
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Copy RAM to ROM

Since the PLC program is only saved in volatile load memory and not automatically in the C7 CPU flash
memory when it is loaded into the C7-CPU, the program would be lost if you restarted the C7-621. To
prevent this from happening, you must copy the PLC program explicitly into the flash memory. The
procedure is as follows:

� Select the system function menu on the C7-621 by pressing the keys
SH IFT 0

.

� Select the C7 CPU mode menu "KEY" by pressing
F1

.

� Select the STOP mode by pressing
F3

. The STOP LED lights up.

� If you have not yet entered a password, you are now prompted to do so. Password 100 is the default
setting when the C7 is delivered. Enter the digits 100 on the numeric keypad and press ENTER.
Now, select STOP mode again.

� Select the Accessible Nodes symbol again in the SIMATIC Manager. In the dialog window that
appears, select the folder MPI=2. Copy the contents of the load memory into the C7 CPU flash
memory by activating the menu item PLC → Copy RAM to ROM. The PLC program is now secure.

� Close the Accessible Nodes window.

� Change back to RUNP mode on the C7-621 by pressing
F1

. The RUN LED lights up.

You can now test the program for your filling plant on the practice PLC.

� To check the function of the counter, call up the online database by selecting from the tool bar
in the SIMATIC Manager. Open Function FC16 and select the third network. Activate Test mode with
Debug → Monitor.

The status bit, the result of logic operation and the standard status are displayed for each program line. In
the last program line you will see the current counter state in hexadecimal notation.

� Then close the LAD/STL/FBD Editor and your Getstart online project in the SIMATIC Manager.

� Now open the Getstart folder.
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Preparations for OP configuration

Start ProTool, create a configuration

There are two ways to create an OP configuration. You can create a new (empty) configuration and add
all the necessary system functions manually (e.g. change mode, allocate passwords, etc.), or you can
base your project on a standard configuration supplied with ProTool.

We recommend you use the standard configuration the first time you use ProTool. The standard
configuration contains basic settings, e.g. Device: C7−621, Language: German, and standard screens for
access to frequently used functions, e.g. change mode, allocate passwords, etc.

Create a new configuration:

� In the SIMATIC Manager select Insert → Station → 8 SIMATIC OP and name the new OP station
Quickmix OP .

� Open the station (e.g. by double-clicking). ProTool/Lite and the Projekt Wizard are started auto-
matically.

� Select the C7-621 from the C7 Devices and confirm with Continue >.

� Define a name for the PLC which you use to reference it in the configuration: Quickmix.
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� To check and, if necessary, correct the PLC parameters, display the dialog box with the PLC para-
meters from the Driver window by activating the Parameters button (see dialog box directly below).

� When you have entered all the settings, close the dialog box by activating the button OK. In the
Projekt Wizard confirm this step with Continue>.

� Select Use Standard Projects and close the Project Wizard with Fertig stellen to create the Project
Quickmix OP in ProTool.

Online help

If you an encounter a problem during programming, or if you want further information on a topic, press the
F1 key. This action starts the on-line help, where you can find explanations of various ProTool topics.



A 03/99 Display and enter values in screens

First Steps with the C7-621 25
6ZB5610-0AF02-0BA0

Display and enter values in screens

You can start by configuring your first screen.

� Open the Screen Editor with the menu item Insert → Screen. This action calls up the Screen-PIC_6.

Configure texts

The first screen is to be the start screen on the C7. Only the plant name is to appear on this screen.

The plant name is configured as a text.

� The cursor is displayed in the first line of the first screen entry (see above). Enter the plant name
there: Plant Quickmix .

The C7 always displays the configured start screen when it has finished the start-up routine. The screen
configured above (text display: Plant Quickmix .) is to be displayed the next time the configuration is
loaded. You must therefore define the screen configured above as the start screen.

� Select the menu item Edit → Properties. In the Attributes dialog box, select Start Screen. Do not
change the other settings.

� You can also define a new name for the screen: Start_QM .

� Close the dialog box with OK.

You have now created the first screen. Now, transfer the configuration to the OP to see what the screen
looks like.

(1. Screen entry, 1. line)
(1. Screen entry, 2. line)

(2. Screen entry, 1. line)
(2. Screen entry, 2. line)
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Transfer the configured data

Before the actual transfer, you need to perform three steps:

� Save

� Generate the project

� Define the transfer parameters (once).

� To save the project, select the menu item File → Save.

� Then activate the menu item File → Compile to generate an executable file, which will run on the
OP, from the configuration file. During the generation process, a status window displays any
messages, warnings and errors relating to the configuration.

� Finally, set the parameters for the transfer:
Select the menu item File → Settings → Transfer. The following dialog box appears:

Define the OP address in the dialog box (default is 1).

Note
The transfer parameters are stored; you do not have to set them again before each new transfer.

� Then activate the transfer mode by resetting the C7-621:
� Switch off the power supply to the C7-621.

� Simultaneously press the keys
ESC

and and
� Hold down the above keys
� and switch the power supply on.
Do not release the keys until the message "Flash Test" appears on the display. A message is
displayed after the start-up tests are complete and the SIMATIC C7 OP has been reset.

� When the SIMATIC C7 has started up, press the ENTER key to select the system screens stored in
the firmware in English. Select System with the F4 key and OpMode with the F2 key. Simultaneously
press the keys SHIFT and Arrow Down to switch to MPI down and confirm the input with ENTER.
The message Ready for transfer appears on the C7-OP.

� If you have not yet entered a password, you are now prompted to do so. Enter the digits 100 again
on the numeric keypad and press ENTER. Select MPI down again and confirm with ENTER.

� Now activate the menu item File → Transfer to initiate the data transfer from PC/programming device
to the C7.

The C7 starts up when the transfer is complete. Press the ENTER key. If the start screen is displayed on
the C7, the transfer was successful.
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If the transfer was unsuccessful, repeat the steps beginning on Page 23.

Extend the configuration

Now add another screen to your configuration.

� Open another Screen with the menu item Insert → Screen.

� Now select Edit → Properties ... and change the screen name: Plant_QM .

In this screen, you want to enter the filling time and display the number of full bottles.

You can do this as follows:

� Define an input field for the filling time.

� Display the number of full bottles in an output field .

Configure texts

To distinguish the input field from the output field, configure a text before each field.

� Using the cursor, select the first line of the first screen entry, and enter the text: Filling time .
Then position the cursor in the first line of the second screen entry and configure the text: Full
bottles.

Then define the fields for input and output.
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Configure an input field

� Use the cursor to select the first line of the first screen entry. Using the cursor control keys, position
the cursor behind the text Filling time. Activate the menu item Insert → Input/Output Field or press

the button in the function bar. The Input/Output field dialog box appears.

� Set the Field Type: Input and specify a Field Length of 4. Do not change the settings Usage: Tag
or Display: Decimal .

� To establish the link between the field and the PLC, create a new variable with the button .

� In this box, enter Name: Time , Type: Timer , DB: 46 and DBW: 0.

� Click the OK button to close the Tag and Input/Output field dialog boxes. You have now defined the
input field. The variable is identified by {Time } in the Screen Editor.

� Position the cursor between the text Filling time and the input field {Time }. Now enter some
spaces to pad out the line, taking care not to exceed the maximum of 20 characters per line. Ten
characters of text plus 4 characters field length allow a maximum of 6 spaces.
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Configure an output field

� Position the cursor in the first line of the second screen entry behind the configured text Full
bottles . Activate the menu item Insert → Input/Output Field.

� In the Input/Output field dialog box, set the Field Type: Output and Field Length: 4.

� Then click the button . The Tag dialog box appears. Assign the variable name Count , type Word
and DB46 and DBW 2as the interface area and save the entries with OK.

� Position the cursor between the text Full bottles and the output field {Count }. Now enter some
spaces to pad out the line, taking care not to exceed the maximum of 20 characters per line. 14
characters of text plus 4 characters field length allow a maximum of 2 spaces.

Modify the PLC program

To allow data exchange between the C7 PLC and C7-OP, you will need to modify and reload the PLC
program.

� Set up data block DB46 on the PLC. DB 46 must be at least three data words in length. Select the
Blocks folder in the SIMATIC Manager and insert a data block with Insert → S7 Block → 4 Data
Block. In the dialog box that appears, assign the internal identifier DB46.

� Open data block DB46 and select Data Block as the desired type. Accept the settings with OK.

� In the DB Editor, use the mouse to activate the second item in the Name column. Assign the name
Fill_Time here for DW0 and press Return.

� This automatically activates the Type entry. Click the entry with the right mouse button, insert the
type Word via Elementary Types and press Return again.

� Assign 3sec. in BCD format W#16#2003 as the initial value for the filling time. The first digit defines
the time reference (2 = seconds). The three following digits contain the time value. Press Return to
complete the input.

� You can enter a comment in the Comment column. Accept your entry with Return. The editor auto-
matically inserts a new line in which you can enter the next data block word. Data word 2 is to be
named Full_Bottles , with type Word and an initial value of W#16#0.
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� Create data word 4 with the name Messages , type Word initial value W#16#0. You will need this
data word later in order to configure the event messages.

� You have now created DB46. Save the block and load it into the C7-621.

� You now need to change Function FC16. Open FC16 in the SIMATIC Manager and overwrite the S5
timer with L DB46.DBW0in the first network. In the third network, transfer the counter state to the
second data word of data block DB46 instead of to memory word MW 10.

FC16 : Filling cycle
Network 1 : Fill bottles
A I 125.0 // Bottle sensor 1 has detected a bottle
L DB46.DBW0 // Load filling time (3s)
SE T 1 // Set extended pulse (3s)
A T 1 // When timer 1 reaches level 1
= Q 125.5 // Open inlet valve

:

:

Network 3 : Count full bottles

A I 125.1 // Bottle sensor 2
CU C 1 // Increase counter by 1
A Q 125.0 // When plant is switched on
L C#0
S C 1 // Reset counter to 0
L C 1 // Write current counter state to
T DB46.DBW2 // data block word

� Save the block and load it into the CPU again. Activate the function Copy RAM to ROM via
Accessible Nodes so that the current program is also stored in the flash memory. Please make sure
that the C7 CPU is in STOP mode during the copy process. Then select the CPU mode RUNP
again. (see Page 22)
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The following figure shows the relationship between the value entered, the PLC program and the current
number of full bottles.
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� The values of the inputs are stored in the data interface (DB46).

� The PLC program evaluates the current inputs and updates the data in the interface for output.

� The C7 OP reads all the values independently from the interface and updates its display.

Link the screens and enable navigation via softkeys

To enable the second screen to be called up on the C7, you must use ProTool/Lite to configure the
screen change from start screen Start_QM to plant screen Plant_QM and back. Navigation from the
first screen entry to the second and back must also be configured for the plant screen.

To do this, assign a softkey to the Select Screen function in both of the screens. You will use these
softkeys to activate the screen change. In the plant screen, assign the Jump within Screen function in
both screen entries.

� Open the screen Start_QM and select the Softkey F5. The dialog boxes Softkey-F5 and Select
Object appear.

� In the dialog box Select Objekt choose the function Select Screen from the Screens. A short
description of the function is displayed.
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� Click the button <<Add. The dialog box Parameters - Select Screen appears. In this dialog box,
select the name of the screen you want to call up: Plant_QM . Do not change the parameters Entry
Number or Field Number.

� Close the dialog boxes Parameters - Select Screen and Softkey F5 by clicking the OK button. A
function is now assigned to the softkey.

The box in the function key is now checked. You can therefore see immediately which function
keys have been configured in the screen.
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Label the softkey

To inform the operator of the C7 which softkey is assigned, create a text for this softkey. The text will be
displayed in the appropriate screen. The procedure is as follows:

� Position the text cursor in the second line of the screen above the softkey you have assigned. by
entering a space. Enter the text Pla to label the softkey.

So that you can navigate from the Plant_QM screen back to Start_QM , repeat the procedure for
Softkey F1 in the Plant_QM screen. Enter Start_QM as the screen name and back as the text for the
softkey description.

� To enable navigation within the screen, select Softkey F5 in the first screen entry of the plant screen
and assign the function Jump within Screen. Assign Entry Number 2 and Field Number 0 as the
parameters.

� Label the softkey with the >> symbol in the plant screen.

To enable navigation from the second screen entry back to the first, repeat the procedure to configure
Softkey F1 in the second screen entry. Use 1 as the entry number and << as the symbol for the softkey
description.

All extensions to the project are now complete. You have:

- configured a second screen with an input and output field,
- configured a softkey in each screen in order to switch back and forth between the screens,
- configured a softkey in each screen entry in order to switch back and forth between the entries,
- labeled each softkey with text/symbol.

You can now display the configuration on the OP, change between the screens and perform
inputs/outputs.

� Now, activate transfer mode on the C7-621 by performing a reset:
� Switch off the power supply to the C7-621.

� Simultaneously press the keys
ESC

and and
� Hold down the above keys
� and switch the power supply on.
Do not release the keys until the message "Flash Test" appears on the display. A message is
displayed after the start-up tests are complete and the C7 OP has been reset.

� When the C7 has started up, press the ENTER key to select the system screens stored in the
firmware in English. Select System with the F4 key and OpMode with the F2 key. Simultaneously
press the keys SHIFT and Arrow Down to switch to MPI down and confirm the input with ENTER.
The message Ready for transfer appears on the C7-OP.

� If you have not yet entered a password, you are now prompted to do so. Enter the digits 100 again
on the numeric keypad and press ENTER. Select MPI down again and confirm with ENTER.

� Now activate the menu item File → Transfer to initiate data transfer from the PC/programming device
to the SIMATIC C7. The steps for saving and generation are performed automatically by the system
after a user prompt if you have made changes to the configuration. Confirm the prompt to save the
data with Yes.

The C7 starts up when the transfer is complete. The start screen will appear when you press the ENTER
key.
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� Then press Softkey F5 to call up the plant screen.

� Enter a value in the input field and, using the simulator, check the value change.
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back >>

� Press Softkey F5 to navigate to the second screen entry. Now check the functionality of the
counter.
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Include standard screens in the configuration

When you started configuring, you selected standard screens as the basis for your configuration and
saved the file under the name Quickmix .

You need the standard screens if you want to use the standard functions of the C7-621. These functions
are, for example, Change mode, Edit password, Log on and off with password, etc.

Once you have identified your configured screen (Start_QM ) as the start screen, the integrated standard
screens can no longer be selected on the OP. In order to use the standard screens, you can define a
softkey which you will use to select the standard screens.

� To do this, select Softkey F1 in the start screen and follow the instructions in ”Link the screens and
enable navigation via softkeys” on Page 31. Use the name of the standard main screen
Z_SYSTEM_MENas the screen name. Configure the abbreviation Sys at the beginning of the 2nd line
of the start screen to label the softkey.

You can now transfer the extended configuration to the OP and test it out.

� Activate transfer mode on the C7-621 by performing a reset:

Switch off the power supply to the C7-621, then simultaneously press the
ESC

and and ,
hold down these keys and switch the power supply on.

Do not release the keys until the message "Flash Test" appears on the display. A message is
displayed after the start-up tests are complete and the C7 OP has been reset.

� When the C7 has started up, press the ENTER key to select the system screens stored in the
firmware in English. Select System with the F4 key and OpMode with the F2 key. Simultaneously
press the keys SHIFT and Arrow Down to switch to MPI down and confirm the input with ENTER.
The message Ready for transfer appears on the C7-OP.

� If you have not yet entered a password, you are now prompted to do so. Enter the digits 100 again
on the numeric keypad and press ENTER. Select MPI down again and confirm with ENTER.

� Now activate the menu item File → Transfer to initiate data transfer from the PC/programming device
to the C7. The steps for saving and generation are performed automatically by the system after a
user prompt if you have made changes to the configuration. Confirm the prompt to save the data with
Yes.

The C7 starts up when the transfer is complete. The start screen will appear when you press the ENTER
key. The cursor is positioned in the first screen entry.

� Now, press Softkey F1 to call up the standard screens. Select the various screens to activate the
functions already implemented.

� Press the ESC key to quit the standard screens. You are returned to your own configuration.
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Configure event messages

Your plant is now virtually complete. The only missing element is event messages. These provide infor-
mation during operation of the plant.

Enter communication areas

To enable the PLC to communicate with the OP, you must define data areas which can be accessed on
both sides. The Area Pointers dialog box is used for this purpose.

� Select this dialog box via System → Area Pointers.

You already know that you want to configure screens with variable values (input, output) and messages.
You do not need a special data area for the variables, but you do need separate data areas for event
messages and fault messages.

� Since you only want to configure event messages, select Type: Event Messages in the Area
Pointers dialog box. Then click the Add button.

The Event Messages dialog box appears. Configure the event messages area as follows:

� Enter DB: 46 as the Address; enter DBW: 4 and Length: 1. For PLC Name select Quickmix .

� Click OK to close the Event Messages dialog box and return to the Area Pointers dialog box

� When you have completed the entries, close the dialog box by clicking OK. The entries are saved.

You can now start configuring the screens and messages.
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Configure event message texts

� Open the Message Editor with the menu item Insert → Message → Event Message.

� Configure six messages numbered from 001 to 006, e.g. Plant ON, Mode MANUAL, Mode
AUTO, Conveyor forward, Conveyor back and Filling in progress.

In the status line you will see the address which links the message to the PLC. In your example, the
address for message no. 002 is Quickmix: DB 46 DBX 5.1.

Modify the PLC program

To enable data exchange between the C7 CPU and the C7 OP, you must change the PLC program and
load it onto the C7 again.

� Open organization block OB1 in the SIMATIC Manager and create a new network with the following
program lines.

OB1 : Filling plant

Network 3 : Data interface

L QW 124
T DB46.DBW4

� Save the block and load it into the CPU again. Update the flash memory using the function Copy
RAM to ROM. Please make sure that the C7 CPU is in STOP mode during the copy process. Then
select the CPU mode RUNP again. (see Page 22)
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� Activate Softkey F1 on the C7-621 to select the standard screens, and switch the device to Transfer
mode with System → Mode.

� Transfer the ProTool configuration to the C7-621 again.

You can trigger the messages on the SIMATIC C7 using the PLC program and the configuration you
loaded.
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The relationship between the PLC and the OP on the occurrence of a message is shown in the figure
above. The procedure is described in detail below.

� The information, e.g. indicating that the plant has been switched on, must be evaluated in the user
program. This can be achieved by transferring output word 0 to data block 46.

� A bit area indicates the current status of the messages. Each enabled bit indicates that a message is
waiting.

� The area pointer you defined at the start of configuration scans the bit area cyclically, detects whether
a bit is enabled, and outputs the associated message on the C7 display.

� When you have transferred the configuration to the C7-OP (as described above), press the ENTER
key. The start screen appears.

� Switch the plant on using the start switch on the simulator. This action triggers an individual
message. The message interface is displayed with the message.
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You have now completed the configuration.

The Quickmix plant has introduced you to some of the functions of the C7-621, programming with
STEP 7-Mini and configuration with ProTool/Lite. The full functionality of the C7-621, STEP 7-Mini and
ProTool/Lite is described in the C7-621, STEP 7-Mini and ProTool/Lite manuals.
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Symbolic addressing

When you program a PLC with STEP 7, you use operands such as I/O signals, bit memories, counters,
timers, data blocks and function blocks. Up to now, you have used absolute addresses to reference these
operands in your program (e.g. I 124.0, M 5.0, FC15). It is more practical to assign symbolic names,
however (e.g. Plant_Start, M_Conv, FC_Mode). To define these symbolic names, proceed as follows:

� Select the Symbols folder in the S7-Program(1) folder in the SIMATIC Manager and open it by
double-clicking. The Symbol Editor displays the symbol table.

� In the Symbol column of the symbol table, activate the first field by clicking it with the mouse. Then
enter a symbol name (e.g. Plant_ON ).

� Use the TAB key to jump to the Address column and assign an address to the symbol name (e.g.
Q125.0 ).

� Skip the Data Type column by pressing the TAB key twice. A default value (e.g. Bool) is entered
automatically for the data type and the Comment field is active.

� Enter a comment in the comment field, and press the TAB key again. The second field in the Symbol
column is activated again. Repeat the steps to input further symbol names. After the input, save the
symbol table and close the Symbol Editor.

Note
Long symbolic names are intuitive but take time to enter. With a combination of short symbolic names
and detailed comments you can create good program documentation and an effective program.
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Set symbolic representation

To enable the symbolic names to be displayed in your program, you must set the appropriate type of
representation.

� Open Function FC15 in the offline database. In the LAD/STL/FBD Editor that appears, select the
menu item View → Display → Symbolic Representation. The absolute addresses are replaced by
the symbolic names.

� You can display the absolute addresses and the comments from the symbol table by activating View
→ Display → Symbol Information. The network comments are then no longer visible.

Note
If you want to include new operands during programming, you can assign symbolic names to individual
absolute addresses by activating the menu item Options → Simbol Table from the LAD/STL/FBD Editor.
The entries are automatically inserted in the symbol table.

Use symbolic names in ProTool

Before you can use symbolic names in ProTool you must define certain settings.

� To do this, open the Hardware folder in the SIMATIC Manager by double-clicking. The Hardware
Configurator appears.
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� Open the Properties - C7 CPU621 window in the Hardware Configurator by double-clicking the
C7 CPU621 symbol.

� Open the Properties - MPI Nodes window by clicking the button Properties ..., and select the Subnet:
MPI(1). Accept the settings with OK, save and compile the hardware configuration, and load it into
the C7 CPU again.
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� Now open your C7-621 ProTool configuration and select the folder Controllers.

� Open the PLC Quickmix by double-clicking.

� Click the Parameters... button. Select MPI(1) under Connect OP to network. MPI(1) appears under
Choose a communication peer/symbol list, and the network parameters are displayed on a gray
background.

� Double-click MPI(1) under Choose a communication peer/symbol list. The PLC: C7 CPU621(1)(S7-
Program(1)) appears. Select the PLC by double-clicking. Then accept the entries with OK.

The initial settings are now complete and you can include the symbolic names in your configuration.
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� Open the Plant screen, double-click the variable Time and click the Edit button in the Input/
Output field dialog window. In the dialog window that now appears, the symbolic names are
displayed under Symbol.

� Select the name DB_OP.fill_time under DB_OPin the variable list. The absolute addresses are
displayed on a gray background. Confirm the entry with OK.

� Repeat the steps for the variable Count with the symbolic name DB_OP_full_bottles . Close the
window again with OK.
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You must now assign the symbolic names to the event messages.

� To do this, open the Area Pointers window in ProTool from the Target System menu. Click the Edit...
button in the Area Pointers window.

� In the Event Messages window, select the symbolic name DB_OP.messages and confirm the
entries with OK.

� Save the revised configuration and transfer it to the C7 OP again.

This completes the conversion to symbolic addressing.
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How to operate the C7-621

To facilitate operation of the C7-621, here is a brief description of the main keys on the C7-621 and their
meaning.
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ESCAPE key

→ Pressing ESCAPE quits the current operating level and moves back one level.

Example: Press ESCAPE to close the plant screen Plant_QM and return to the start screen
Start_QM . Press ESCAPE again to reach the message level.

→ You can use ESCAPE to cancel entries, i.e. a value which you have already entered in an input field
is discarded.

ENTER key

→ ENTER is used to accept entries, i.e. the value you entered in the input field is transmitted to the
PLC.

Cursor control keys

→ The Up and Down cursor control keys are used to scroll between different entries within a screen.

Example: You can use the Down key in the Plant_QM screen to move the cursor down to the
second screen entry.
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Example program

You will have created and started up the following STEP 7 program by following the instructions.

DB46:

Address Declaration Name Type Initial Value Comment

0.0 stat Fill_Time Word W#16#2003

+2.0 stat Full_Bottles Word W#16#0

+4.0 stat Messages Word W#16#0

FC15: Mode

Network 1 : Plant ON/OFF

A I 124.0 // Start (if input 124.0 on /off)
= Q 125.0 // Plant ON (plant is then switched on/off)

Network 2 : MANUAL mode

A Q 125.0 // Plant ON
AN I 124.3 // and MANUAL mode selected (switch=0)
A I 124.4 // Confirm acceptance of selected mode
S Q 125.1 // Manual mode activated
A( // If
ON Q 125.0 // plant OFF (LED of DO not lit)
O I 124.3 // OR AUTOMATIC mode selected (switch=1)
)
R Q 125.1 // Then select Manual mode

Network 3 : AUTO mode

A Q 125.0 // If plant ON
A I 124.3 // and AUTOMATIC mode selected (switch=1)
A I 124.4 // and acceptance of selected mode confirmed
S Q 125.2 // Then set automatic mode
A(
ON Q 125.0 // Plant OFF (LED of DO not lit)
ON I 124.3 // or Manual mode set
)
R Q 125.2 // Then select AUTOMATIC mode

Network 4 : Conveyor forward

A Q 125.1 // If MANUAL mode set
A I 124.5 // and Jog Forward is pressed (enabled)
AN I 124.6 // and Jog Back is not pressed (enabled)
O M 5.0 // or filling process running in AUTOMATIC mode
= Q 125.3 // Then move conveyor forward

Network 5 : Conveyor back

A Q 125.1 // If MANUAL mode set
A I 124.6 // and Jog Back is pressed (enabled)
AN I 124.5 // and Jog Forward is not pressed (enabled)
= Q 125.4 // Then move conveyor back
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FC16 : Filling cycle

Network 1 : Fill bottles

A I 125.0 // Bottle sensor 1 has detected a bottle
L DB46.DBW0 // Load filling time (3s)
SE T 1 // Set extended pulse (3s)
A T 1 // When timer 1 reaches level 1
= Q 125.5 // Open inlet valve

Network 2 : Scratchpad memory for conveyor, AUTO

A Q 125.2 // If AUTOMATIC mode set
A( // and
ON I 125.0 // no bottles have been detected by bottle sensor 1
O // or
A I 125.0 // bottle sensor 1 has detected a bottle
AN T 1 // and filling process not running (valve closed)
)
= M 5.0 // Then the conveyor is moving

Network 3 : Count full bottles

A I 125.1 // Bottle sensor 2
CU C 1 // Increase counter by 1
A Q 125.0 // When plant is switched on
L C#0
S C 1 // Reset counter to 0
L C 1 // Write current counter state to
T DB46.DBW2 // data block word

OB1 : Filling plant

Network 1 : Mode section

CALL FC 15

Network 2 : Filling cycle

CALL FC 16

Network 3 : Data interface

L QW 124
T DB46.DBW4


