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Introduction
This instruction manual introduces you to the functions of the C7-613 using operator
steps and add-ons to the existing sample project “ZXX31_01_C7-613.” References to the
“C7-613 Control System” manual are provided to give you an initial overview of the infor-
mation you can find there.
You will need 1 to 2 hours to perform the sample project, depending on you level of expe-
rience.
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Task Definition
Start up the C7-613, perform simple input operations, and expand the existing configura-
tion by creating new HMI objects. You use the S7 program “C7-613 Basic” as the basis.
For comparison, the S7 program “C7-613 Extended V2” has been included with all the
expansions.

Requirements
The following requirements must be met to perform this task:

� You have a C7-613 with an inserted Micro Memory Card (recommended size of
128 Kbytes) and a 24 V DC power supply module.

� You have jumpered the authorization bridge Pin 1 (AT2) with Pin 2 (AT1) on the supply
connector (see Figure “C7-613 with Connector and Sockets”).

� You have connected the C7-613 to the 24 V DC power supply using the supply con-
nector (see Figure “C7-613 with Connector and Sockets”).

� STEP 7 ≥�V5.2 is installed correctly on your programming device/PC.

� You have the CD “Configuration Tools for SIMATIC C7-613”. The CD includes the
“C7 613” library with the required FBs, UDTs, and the sample program
“ZXX31_01_C7-613”.

� The programming device/PC is connected to the C7-613 using the MPI connector.
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Notes on the installation guidelines for fail-safe installation are provided in Section 2.5 of
the manual.

!
Warning

Operating the C7-613 as part of a plant or system requires that certain rules and stan-
dards be followed, depending on the application.
Observe the applicable safety and accident prevention standards, such as 
IEC 204 (Emergency OFF devices).
Failure to observe these standards may cause serious bodily injury, and may damage
machines and facilities.

!
Warning

You may come into contact with live electrical wires if the power supply module is swit-
ched on or the supply lead of the power supply module is connected to the network.
Wire the C7-613 only when it is disconnected!

Step 1: Installing the sample project and the library

Se-
quence

Action Result

1 Close all applications (for example, STEP 7, MS Word,
etc.). Insert the “Configuration Tools for
SIMATIC C7-613” CD into the drive. Start the installa-
tion program on the CD by double-clicking the
SETUP.EXE file in the SETUP folder.

This starts the installation program.

2 Follow the instructions of the installation program. If the installation was successful, the
“C7 613” library and the sample program
“ZXX31_01_C7-613” are stored on your
programming device/PC.
The library contains all of the FBs required
for the HMI functions, as well as the UDTs
and DBs for storing the HMI configuration
data.
The sample program “ZXX31_01_C7-613”
is stored in the ...\Siemens\Step7\Examples
directory.

Step 2: Setting up your own project

Se-
quence

Action Result

1 In the ...\Siemens\STEP7\Examples directory, open the
“ZXX31_01_C7-613” project with 
File > Open... > Sample projects.

A split window appears containing the title
of the project.

2 Create a copy of the project with File > Save As The “Project Save As” window is displayed.

3 Enter your choice of name for the new project in the
“Name” field, and then click “OK”.

Your project is created and opened.

4 In your project, double-click the
“SIMATIC C7-613 V2”.

The station is opened.
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Action ResultSe-
quence

5 Open the “C7-613 Basic” S7 program of the 
C7 CPU 613 and click the “Block” container. If needed,
change to the detail view with View > Details.

The blocks listed below are displayed.

Block Name Description
(in the toolbar)

System data  System data blocks for the C7-613
OB1 CYCL_EXEC Cyclic program processing

FBs from the “C7-613” library (called up in OB1):
FB1 HMI API FB for the basic HMI functions
FB2 HMI EVENT FB for the message output
FB3 HMI MENU FB for the screen hierarchy/display sequence

FB11  TIME FB for setting the time
DB1 API_IDB Instance DB of FB1 HMI API
DB2 EVENT_IDB Instance DB of FB2 HMI EVENT
DB3 MENU_IDB Instance DB of FB3 HMI MENU
DB10 WORK_DB DB for work data
DB11 TIME_DB Instance DB of FB11 TIME

Basic parameter assignment for the HMI functions:
DB99 MENU_DB_APP DB for the screen hierarchy/sequence 

(language-independent)
 DB100 CONFIG Configuration DB (language-independent)

DBs containing the HMI configuration data in English :
DB101 SCREEN_1_LANG_1 DB for screens in English
DB102 MESSAGE_1_LANG_1 DB for messages in English
DB103 INFO_LANG_1 DB for info texts in English

DBs containing the HMI configuration data in German :
DB104 SCREEN_1_LANG_2 DB for screens in German
DB105 MESSAGE_1_LANG_2 DB for messages in German
DB106 INFO_LANG_2 DB for info texts in German

DBs containing the HMI configuration data in French, Spanish, and Italian:
DB107 to 115

DB127 EVENT_BUFFER DB for backing up the event buffer

UDT 1...6 , 11...16 UDTs for the formation of the DBs for the 
HMI configuration data

DIAGNOSIS DIAGNOSIS Variable table for diagnostics
MESSAGES MESSAGES Variable table for message output
SFC0,1,... C7 CPU 613 system functions
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Action ResultSe-
quence

6 Switch the C7-613 to the STOP state.

To do so, press the operating mode key:

The following message is output on the
LCD display:
“$ 008
CPU is in STOP!”

7 In the STOP state of the CPU download all the blocks
of the “C7-613 Basic” S7 program with PLC > Down-
looad User Program to Memory Card into the
C7-613 connected to your programming device/PC.

The programming device/PC loads the pro-
gram and the HMI configuration to the MMC
of the C7-613.

8 After the loading operation is completed, switch the
C7-613 to RUN mode.
To do so, press the operating mode key:

The HMI configuring data are loaded from
the MMC to the memory of the integrated
HMI module. The following message is out-
put on the LCD display:
“$ 002 transfer
Downloading user data”
After the downloading process has been
completed, the idle message
“SIMATIC C7-613 V...” is displayed.

Step 3: Performing operator inputs
You will next perform the following actions:

� Select a language

� Select a screen

� Enter a value

� Display info texts

� Output and acknowledge fault messages

Selecting a Language:

The sample project is prepared in several languages in which the HMI objects (screens,
messages, info texts) can be displayed. By switching the language, you change the lan-
guage that is currently displayed.
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Se-
quence

Action Result

1 The idle message “SIMATIC C7-613 V...” appears on
the LCD display. Press the “ENTER” key.

You are now in the basic C7-613 screen

= Selection ofBasic screen C7-613

Screens
>>

Msgs.

2 Press the following keys in consecutive order: F4 (>>),
F2 (System), F4 (>>), and F2 (language).

The “Language selection” screen is displayed

Select language:

new: ENG
current: ENG

3 Select your choice of language using the “Cursor up”
and “Cursor down” keys, and then press the “ENTER”
key.

The following display appears in the  new lan-
guage:
“$ 002  transfer
the configuration is running!”
After the parameter assignment operation is
completed, the idle message
“SIMATIC C7-613 V...” is displayed. All HMI
objects are now shown in the selected lan-
guage.
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Selecting a Screen:

The created screens are selected starting from the idle message.

Se-
quence

Action Result

1 The idle message 
“SIMATIC C7-613 V...” appears on the LCD display.
Press the “ENTER” key.

You are now in the basic C7-613 screen

Basic screen C7-613

Screens
>>

Msgs.

2 Press the F2 key (Screens) and then F3 (Start). The first screen is displayed.  It outputs the
date and time.
The screen information is stored in the
“SCREEN_1_LANG_1“ DB as Screen 0,
starting with Byte 32.

3 You can select additional screens with the F1 (<<) and
F4 (>>) keys.

The selected screen is displayed.
The configured screen hierarchy/sequence
is stored in the “MENU_DB_APP” DB for all
languages.

4 Pressing the “ESC” key takes you back to the previous
screen.

Enter a value

You can enter values in the input fields of the screens.

Se-
quence

Action Result

1 Select the “Fixed-Point Representation” screen by
pressing the F4 (>>) key several times.

The “Fix. point rep.” screen is displayed.
The cursor is located on the input field.

2 Press the SHIFT key. You are in input mode. The Shift LED is
switched on.

3 Enter a number using the K-keys. The number is ent-
ered right-justified.

The entered numerals are shifted to the left.

4 You assign the sign using the “Cursor up” and “Cursor
down” keys.

5 The input of the complete
number is confirmed with ...

���

ENTER

Incorrect input is cancelled with  ...

The value is transmitted to the variable. 
The Shift LED is switched off.

The value currently calculated by the CPU
is entered in the field. 
The Shift LED is switched off.

Additional entries can be made in the “Value Input” screen. Select the input field by using
the cursor keys.
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Display info texts

Info texts can be called up in every screen.

Se-
quence

Action Result

1 Call up an info text in a displayed screen.

To do this, press the F2 (Info) key.

The info text assigned to the screen is dis-
played.

The assignment of the F2 key is also stored
in the “MENU_DB_APP” DB.

The info texts are stored in the
“INFO_LANG_1” DB.

2 You can page through the info texts using these cursor
keys.

Which info texts are displayed is stored in
the “INFO_LANG_1” DB:

Press the “Cursor down” key: The info text displayed under 
“REFERENCES.FORWARD” is displayed.

Press the “Cursor up” key: The info text displayed under 
“REFERENCES.BACKWARD” is displayed.

3 Pressing the “ESC” key takes you back to the previous
screen.

Output and acknowledge fault messages

If a fault occurs, a fault message is read out.

Se-
quence

Action Result

1 Press the key “K1” and keep it pressed. A fault is generated and the following
message is output flashing:

In this example, faults are simulated by pressing a K-
key to simply trigger a message.
The user program has been written in such a way that
detection of a “K1” key activation triggers the message
by setting Bit 32.0 in DB 10 in the message area.

“Message 1
Fault message
Acknowledgement required
Acknowledge with ENTER”

The position of the message area is specified using the
“EVENTS” parameter in the “HMI EVENT” FB.

Message 1 is stored in the

“MESSAGE_1_LANG_1” DB starting with
Byte 180.

2 Release the “K1” key. The fault is eliminated when the key is
released. Bit 32.0 is reset.

However, since the message has not been
acknowledged, it continues to flash on the
display.

3 Acknowledge the message by pressing the “ENTER”
key.

The “HMI EVENT” FB sets Bit 48.0 in the
acknowledgement area in DB 10.

The “ACKS” parameter in the “HMI EVENT” FB
specifies the position of the acknowledgement area.

The message is no longer displayed.
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Step 4: Expanding the Configuration
In this step you carry out the following actions by using the configuration interface:

� Create a new screen

� Include a new screen in the menu DB

� Reload the application

� Add a new message

� Create a new info text

Create a new screen

To add an additional screen to the “SCREEN_1_LANG_1” DB, edit the static text of the
screen and specify a variable.

Se-
quence

Action Result

1 Double-click on the “CONFIG” DB. The configuration interface is opened.

2 In the “Process screens” tab, select “English (’ENG’)” in
the “Language”  drop-down selection box.

The language  “English (’ENG’)” is set.

3 In the “Process screens” tab, select “New screen” in
the “Screen No.” drop-down selection box .

The screen number 7 is entered in the
“Screen No.” drop-down selection box.

4 Carry out the entries shown in the screen. In order to position the input cursor, click on the field to be
described. You can also use the cursor keys of the keyboard in order to move the input cursor within
the 80 fields. You can write continuously within a line. Existing characters are overwritten. The Delete
key is used to delete the character at the position of the input cursor. The Backspace key is used to
delete the character to the left of the input cursor in the same line.

5 Click on the “Variable...” command button in the
“Process screens” tab.

The “Variable in process screen” dialog box
is opened.
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Action ResultSe-
quence

6 Carry out the entries shown in the screen in the “Variable” dialog box. This defines a decimal variable
having a length of 5 with one decimal position and with non-flashing display at Position 42 (line 3,
column 2)

7 Click on “OK” in the “Variable” dialog box. The “Variable” dialog box is closed.

8 Save the process screen by using File > Save. The process screen is stored in the
“SCREEN_1_LANG_1” DB.

9 Select the “SCREEN_1_LANG_1” DB in the SIMATIC
Manager and download it into the C7-613 by using
PLC > Download.

The programming device/PC loads the
block to the MMC of the C7-613.

10 For the new screen to be displayed, you must perform
the following two steps:

1. Include the new screen in the screen hierarchy

2. Reload the application

Include the new screen in the screen hierarchy

In this example, the screen hierarchy is structured in such a way that you can switch to
the previous screen using the softkey F1, and to the subsequent screen using the softkey
F4. In Screen 6 F4 is used to progress to Screen 0 (initial screen). In Screen 0 F1 is used
to progress to Screen 6.

In order to include the new process screen 7 in the existing screen hierarchy between
Screen 6 and Screen 0, change the transitions of the process screens 0, 6 and 7 to each
other in the “Process screens” tab.

Se-
quence

Action Result

1 In the “Process screens” tab, select the Screen No.
0 in the “Screen No.” drop-down selection box.

The contents of Screen 0 are displayed.

2 Click on the “F1” command button. The “Screen hierarchy” dialog box is opened.

3 Activate the “Screen No.” radio button in the
“Screen hierarchy” dialog box and select Screen
No. 7 in the drop-down selection box.

The transition from Screen 0 to Screen 7 with
the softkey F1 is prepared.

4 Confirm the entry with OK. The “Screen hierarchy” dialog box is closed.

5 Select Screen No. 6 in the drop-down box of the
“Process screen” tab.

The contents of Screen 6 are displayed.

6 Click on the “F4” command button. The “Screen hierarchy” dialog box is opened.
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Action ResultSe-
quence

7 Activate the “Screen No.” radio button in the
“Screen hierarchy” dialog box and select Screen
No. 7 in the drop-down selection box.

The transition from Screen 6 to Screen 7 with
the softkey F4 is prepared.

8 Confirm the entry with OK. The “Screen hierarchy” dialog box is closed.

9 Select Screen No. 7 in the drop-down selection box
of the “Process screen” tab.

The contents of Screen 7 are displayed.

10 Click on the “F1” command button. The “Screen hierarchy” dialog box is opened.

11 Activate the “Screen No.” radio button in the
“Screen hierarchy” dialog box and select Screen
No. 6 in the drop-down selection box.

The transition from Screen 7 to Screen 6 with
the softkey F1 is prepared.

12 Confirm the entry with OK. The “Screen hierarchy” dialog box is closed.

13 Select Screen No. 7 in the drop-down selection box
of the “Process screen” tab.

The contents of Screen 7 are displayed.

14 Click on the “F4” command button. The “Screen hierarchy” dialog box is opened.

15 Activate the “Screen No.” radio button in the
“Screen hierarchy” dialog box and select Screen
No. 0 in the drop-down selection box.

The transition from Screen 7 to Screen 0 with
the softkey F4 is prepared.

16 Confirm the entry with OK. The “Screen hierarchy” dialog box is closed.

17 Save the modifications by using File > Save. The modified screen hierarchy is stored in the
“MENU_DB_APP” DB in your project.

18 Select the “MENU_DB_APP” DB in the
SIMATIC Manager and download it into the C7-613
by using PLC > Download.

The programming device/PC loads the block to
the MMC of the C7-613.

19 For the screen to be displayed, you must now per-
form the “Reload application” step.

Reload the application

The MMC will load changes you made to the HMI configuration to the memory of the inte-
grated HMI module only during power-up following a power ON, general reset, or when
the language is changed. For this reason, you must download DBs that you changed
from the MMC to the memory of the integrated HMI module using the “Reload applica-
tion” function.
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Se-
quence

Action Result

1 Press the “ESC” key on the C7-613 repeatedly until the
idle message “SIMATIC C7-613 V...” is displayed.

Then, press the “ENTER” key.

You are now in the basic C7-613 screen.

2 Press the F4 key (>>) and then the F2 key (System). The “System functions” screen is displayed

3 Press the F2 key (Reload application). In the subse-
quent screen, confirm by pressing F3.

If you have not created an own system
message, the following is displayed in the
system language:

“$ 002    transfer

Downloading User-Data

After the parameter assignment operation is
completed, the idle message
“SIMATIC C7-613 V...” is displayed.

Screen 7 is now included in the screen hierarchy between Screen 6 and Screen 0.
Check the modified transition at the C7-613:

Se-
quence

Action Result

1 Press the key F4 in Screen 6. You move to Screen 7.

2 Press the key F4 in Screen 7. You move to Screen 0 (initial screen).

3 Press the key F1 in Screen 0. You move to Screen 7.

4 Press the key F1 in Screen 7. You move to Screen 6.

Add a new message

You add a message to the “MESSAGE_1_LANG_1” DB and trigger it by using the varia-
ble table “MESSAGES”.

Se-
quence

Action Result

1 In the “Info texts” tab, select “English (’ENG’)” in the
“Language”  drop-down selection box.

The language  “English (’ENG’)” is set.

2 In the “Info texts” tab, select “New Info texts” in the
“Info text No.” drop-down selection box.

The number 11 is entered in the drop-down
selection box.
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Action ResultSe-
quence

3 Carry out the entries shown in the screen.

4 Save the message by using File > Save. The message is stored in the
“MESSAGE_1_LANG_1” DB.

5 Select the “MESSAGE_1_LANG_1” DB in the
SIMATIC Manager and download it into the C7-613 by
using PLC > Download.

The programming device/PC loads the data
to the MMC of the C7-613.

6 For the message to be displayed, you must perform
the “Reload application” step (see Page 11).

The MMC transfers the DB to the memory of
the integrated HMI module.

7 In your project, select the variable table “MESSAGES“
and open it with a double-click.

The variable table is opened.

8 Switch to “Online” with PLC > Connect to >
Configured  CPU

The connection to the C7-613 is set up.

9 Switch to “Monitor” with Variable > Monitor The current status value is displayed.

10 To trigger Message 11:

Enter a “1” as the control value for the message area
of Message 11 (DB10.DBX33.2), and set the value to
“1” with Variable > Modify.

The message area is specified in the “HMI EVENT” FB
using the “EVENTS” parameter

Message 11 appears on the C7-613 display
as a flashing message.
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Action ResultSe-
quence

10 Then reset DB10.DBX33.2 to “0”, and accept the value
with Variable > Modify.

The fault is now eliminated, but Message 11
is still displayed flashing.

11 To acknowledge Message 11:

Enter a “1” as the control value for the acknowledge-
ment area of Message 11 (DB10.DBX49.2), and set
the value to “1” with Variable > Modify.

The acknowledgement area is specified in the “HMI
EVENT” FB using the “ACKS” parameter

Message 11 is no longer displayed.

Create a New Info Text

You specify a separate info text for Screen 7.

Se-
quence

Action Result

1 In the “Messages” tab, select “English (’ENG’)” in the
“Language”  drop-down selection box.

The language  “English (’ENG’)” is set.

2 In the “Info texts” tab, select “New info text” in the “Info
text No.” drop-down selection box.

The number 7 is entered in the drop-down
selection box.

3 Carry out the entries shown in the screen.

4 Save the Info text 7 with File > Save. Info text 7 is stored in the “INFO_LANG_1”
DB.

5 Select the “INFO_LANG_1” DB in the SIMATIC Mana-
ger and download it into the C7-613 by using
PLC > Download.

The programming device/PC loads the data
to the MMC of the C7-613.
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Action ResultSe-
quence

6 To assign the Info text 7 to the function key F2 of
Screen 7:
In the “Process screens” tab, select the Screen No. 7
in the “Screen No.” drop-down selection box.

Process screen 7 is displayed.

7 Click on the “F2” command button. The “Screen hierarchy” dialog box is ope-
ned.

8 Activate the “Info text No.” radio button in the “Screen
hierarchy” dialog box and select Info text No. 7 in the
drop-down selection box.

The transition from Screen 7 to Info text 7
with the softkey F2 is prepared.

9 Confirm the entry with OK. The “Screen hierarchy” dialog box is closed.

10 Save the modifications by using File > Save. The modified screen hierarchy is stored in
the “MENU_DB_APP” DB in your project.

11 Download the “MENU_DB_APP” DB into the C7-613
by using PLC > Download.

The programming device/PC loads the
block to the MMC of the C7-613.

12 For the info text to be displayed, you must perform the
“Reload application” step (see Page 11).

The MMC transfers the DB to the memory of
the integrated HMI module.
When displaying Screen 7, the new Info text
7 is output by pressing the “F2” function key.

Diagnostics/Fault Removal
By means of the error code (parameter return value “RETVAL”), the FBs provide informa-
tion about error occurrences and the status of the HMI functions and the integrated HMI
module.

You can obtain further information about the existing error code in the “HMI API” FB
using the “ADDINFO” parameter. These values are displayed in the variable table
“DIAGNOSIS”.

Se-
quence

Action Result

1 In your project, select the variable table “DIAGNOSIS“
and open it with a double-click.

The variable table is opened. The “HMI API”
FB displays the “RETVAL” and “ADDINFO”
parameters. The “HMI EVENT” and
“HMI MENU” FBs display the “RETVAL” pa-
rameter.

2 Switch to “Online” with PLC > Connect to >
Configured  CPU

The connection to the C7-613 is set up.

3 Switch to “Monitor” with Variable > Monitor The current status value is displayed.

The various error information is explained in the Appendix B.1 of the manual.
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