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component, is in conformity with the guideline 98/37 ECC.
Faultless and safe operation of the product presupposes proper transportation, proper storage, erection
and installation as well as careful operation and maintenance.

Trademarks
The registered trademarks of the Siemens AG can be found in the preface. The remaining trademarks
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Preface

Purpose

This document forms part of the documentation package for the ProTool CS
configuration software. It provides all information required for the creation and
configuration of projects.

Documentation

• ProTool User Manual (this document)
The User Manual is supplied in a printed version and addresses
development engineers. It contains configuration basics, details on
configurable objects as well as samples.

• Installation guide
The Installation Guide is supplied in a printed version. It addresses system
administrators who want to install the ProTool CS configuration software on
a PC.

• ProAgent/PC and ProAgent/MP User Manual
The printed version of this User Manual is supplied with ProAgent/PC and
ProAgent/MP. It addresses systems engineers who want to configure
system-specific process diagnostics for error detection an troubleshooting
routines.
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Notation

Different font formats simplify orientation within the text:

"Messages" dialog box Names of dialog boxes, fields and buttons are shown in
quotation marks.

"System" > "ProTool" Menu items are shown in quotation marks. Successive
submenus/options are separated by arrows. The complete
route to the menu option in question is always shown.

History of the documentation

This documentation describes the configuration of text displays with ProTool.

The various issues of the documentation correspond to the following product
versions:

Issue 07/98 Configuring Windows-based systems.
Valid for ProTool/Pro CS 5.0 or higher.

Issue 01/99 Inclusion of MP 270 and editorial reworking of manual.
Software runs under Windows 95, Windows 98, Windows
NT 4.0 and higher.
Valid for ProTool/Pro CS 5.1 or higher.

Issue 12/99 Extensions and inclusions of new operating units.
Software runs under Windows 95/98, Windows 2000 and
Windows NT 4.0 and higher.
Valid for ProTool/Pro CS 5.2 or higher.

Issue 07/00 Extensions, new operating units and new PLC drivers.
Applies to ProTool/Pro CS version 5.2 or higher plus
Service Pack 2

Issue 03/01 Incorporation of MP 370 and SIMOTION PLC drivers.

Applies to ProTool/Pro CS version 5.2 or higher plus
Service Pack 3

Issue 12/01 Valid for ProTool CS 6.0 or higher.

Trademarks

The following names are registered trademarks of the Siemens AG:

• SIMATIC®

• SIMATIC HMI®

• SIMATIC Multi Panel®

• SIMATIC Multifunctional Platform®

• SIMATIC Panel PC®

• HMI®

• MP 270®

• ProAgent®

• ProTool®

• ProTool/Lite®

• ProTool/Pro®
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Customer and Technical Support

Available worldwide 24 hours!

Johnson City
Nuernberg

Singapore

SIMATIC Hotline

Worldwide (Nuernberg)

Technical Support

(FreeContact)

Local Time: Mo. - Fr. 7:00 AM -
5:00 PM

Telephone: +49 (180) 5050-222

Fax: +49 (180) 5050-223

E-mail: techsupport@
ad.siemens.de

GMT: +1:00

Worldwide (Nuernberg)

Technical Support

(charged, only with SIMATIC Card)

Local Time: Mo. - Fr. 0:00 to 24:00

Telephone: +49 (911) 895-7777

Fax: +49 (911) 895-7001

GMT: +01:00

Europe/Africa (Nuernberg)

Authorization

Local Time: Mo. - Fr. 7:00 AM -
5:00 PM

Telephone: +49 (911) 895-7200

Fax: +49 (911) 895-7201

E-mail: authorization@
nbgm.siemens.de

GMT: +1:00

America (Johnson City)

Technical Support and
Authorization

Local Time: Mo. - Fr. 8:00 to 19:00

Telephone: +1 423 461-2522

Fax: +1 423 461-2289

E-mail: simatic.hotline@
sea.siemens.com

GMT: -5:00

Asia/Australia (Singapore)

Technical Support and
Authorization

Local Time: Mo. - Fr. 8:30 to 17:30

Telephone: +65 740-7000

Fax: +65 740-7001

E-mail: simatic.hotline@
sae.siemens.com.sg

GMT: +8:00

The languages spoken by the SIMATIC Hotlines are generally German and
English, the Authorization Hotline is also provided in French, Italian and
Spanish.
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Other support

In the case of technical queries, please contact the Siemens representatives in
the subsidiaries and branches responsible for your area.

SIMATIC Customer Support Online Services

• General information on SIMATIC products is available on the Internet under
http://www.ad.siemens.de/simatic

• Helpful up-to-date product information and downloads are found on the
Internet under

– http://www.ad.siemens.de/simatic-cs or

– on the Bulletin Board System (BBS) in Nuremberg (SIMATIC Customer
Support Mailbox), dial-in number +49 (911) 895-7100.
Dial in to the Mailbox using a modem up to V.34 (28.8 kbps) with the
parameters set to:
– 8,N,1,ANSI.
– You can also dial in per ISDN (x.75, 64 kbps).

• You can find your local partner for Automation & Drives in our Partner
Database on the Internet under

– http://www3.ad.siemens.de/partner/search.asp

Up-to-date information on ProTool

• You can obtain general information on ProTool on the Internet URL

– http://www1.ad.siemens.de/hmi/html_00/products/software/pro_tool/inde
x.htm or

– http://www1.ad.siemens.de/hmi/html_76/products/software/pro_tool/inde
x.htm (English).

• The ProTool Online Support with information on FAQs (Frequently Asked
Questions), spare parts as well as Tips & Tricks is also found on the
Internet. Available downloads are, for example, Firmware Updates, Service
Packs or helpful applications.
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SIMATIC HMI-documentation

This manual is part of the SIMATIC HMI documentation. The table below
shows where to find what information.

Documentation Target Group Content

Getting Started

Brief instructions

New users This documentation guides you step by step
through configuring

a screen with different objects,
a change of screens,
a message.

This documentation is available for
text-based displays
graphics displays
Windows-based systems

ProTool Configuring
Windows
-based systems

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to Windows-based
systems.

ProTool Configuring
Graphics Displays

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to graphics-based
display units.

ProTool Configuring
Text Displays

User's Guide

Programmers Provides information about working with the
configuration software. It contains

information about installation,
background to configuration,
detailed description of configurable objects
and functions.

This document applies to text-based display
units.

ProTool

Online Help

Programmers Provides information on the configuration
computer during a ProTool session. Online
Help contains

direct Help
extensive instructions and examples
detailed information
all information from the User's Guide

ProTool/Pro
Runtime

User's Guide

Commissioning
technicians,
users

Describes how to install the ProTool/Pro RT
visualization software and commissioning and
operation of the software on Windows-based
systems.
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Documentation Target Group Content

Software Security

Commissioning
instructions

Commissioning
technicians,
users

The ProTool/Pro Runtime visualization
software is protected against unauthorized
use. These instructions contain information
about installing, repairing and uninstalling
user authorization.

Example application

Commissioning
instructions

New users ProTool is supplied with a number of
specimen configurations together with the
corresponding PLC programs. This
documentation describes how you

load the examples onto the operating unit and
the PLC,
run the example and
how you can extend the connection to the
PLC for your application.

SIMATIC Panel PC
670
Equipment Manual

SIMATIC Panel PC
870
Equipment Manual

SIMATIC Panel PC
IL
Equipment Manual

Commissioning
technicians,
users

Describes the computing unit and the control
unit of the SIMATIC Panel PC 670.

Equipment Manuals:
MP 270
MP 270B/OP
270/TP 270
MP 370
TP 170B/OP 170B
TP 170A
TP 070

Commissioning
technicians,
users

Describes the hardware and operation of
Windows-based devices in general:

installation and commissioning,
device description,
operation,
connection of PLC, printer and configuration
computer,
maintenance and servicing.

OP 37/Pro
Equipment Manual

Commissioning
technicians,
users

Describes the hardware, installation and
incorporation of extensions and options for the
OP 37/Pro.

TP 27, TP 37
Equipment Manual

OP 27, OP 37
Equipment Manual

OP 25, OP 35, OP
45
Equipment Manual

OP 7, OP 17
Equipment Manual

OP 5, OP 15
Equipment Manual

TD17 Equipment
Manual

Commissioning
technicians,
users

Describes the hardware and operation of the
devices in general:

installation and commissioning,
device description,
connection of PLC, printer and configuration
computer,
operating modes,
operation,
description of supplied standard screens and
their usage,
installation of options,
maintenance and replacement of spare parts.
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Documentation Target Group Content

OP 3
Equipment Manual

Commissioning
technicians,
users,
programmers

Describes the hardware of the OP 3, its
general operation and how to connect it to the
SIMATIC S7.

PP7, PP17
Equipment manual

Commissioning
technicians,
users

Describes the hardware, installation and
commissioning of Push-Button Panels PP7
and PP17.

Communication

User's Guide

Programmers Provides information about connecting text-
and graphics-oriented operating units to the
following PLCs:

SIMATIC S5,
SIMATIC S7,
SIMATIC 500/505,
drivers for other PLCs.

This documentation describes:

the configuration and parameters required to
connect the devices to the PLC and the
network, as well as

the user data areas used for exchanging data
between the operating unit and the PLC.

Communication for
Windows-based
Systems

User's Guide

Programmers Provides information about connecting
Windows-based systems to the following
PLCs:

SIMATIC S5,
SIMATIC S7,
SIMATIC 500/505,
SIMATIC WinAC,
SIMOTION,
drivers for other PLCs.

This documentation describes:

the configuration and parameters required to
connect the devices to the PLC and the
network,

the user data areas used for exchanging data
between the operating unit and the PLC.

Other PLCs

Online Help

Programmers Supplies information about connecting the
operating units to PLCs such as

Allen-Bradley,
GE Fanuc,
LG (Lucky Goldstar) GLOFA GM,
Mitsubishi,
Modicon Modbus,
OMRON,
OPC,
Telemecanique.

The relevant online Help is installed at the
same time as the drivers are installed.
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Documentation Target Group Content

ProAgent for OP

User's Guide

ProAgent/MP and
ProAgent/PC

User's Guide

Programmers Supplies the following information about the
ProAgent software package (process
diagnostics):

configuring system-specific process
diagnostics,

determining process errors, finding the cause
of an error and troubleshooting,

customizing the supplied diagnostic screens
to satisfy your own requirements.
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1 Introduction to ProTool

Configuring text-based displays

ProTool/Lite is an innovative configuration software package for the text-based
displays of the SIMATIC HMI device family. You use the same configuration
software to configure all the devices in the family. Regardless of the device for
which you are creating your project, ProTool always presents you with the same,
familiar user interface.

Example of the structure

Example of PC as configuration computer and OP 17 as operating unit

ProTool is easy to use

ProTool is a Windows application for Windows 95, Windows 98, Windows 2000
and Windows NT. The fully graphical user interface allows you to create object-
oriented projects easily by mouse click. No special programming knowledge is
required.
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ProTool is versatile

The editors provided in ProTool can be called simultaneously. You can also open
different projects, even those of different devices, simultaneously and transfer data
via the clipboard from one project to another.

ProTool can also be integrated in the SIMATIC STEP 7 configuration software,
thus allowing you to select SIMATIC STEP 7 symbols and data blocks as tags in
ProTool. This not only saves you time and money but also eliminates the possibility
of errors made when entering the same data several times.

You fill find more information about the configuration of ProTool with SIMATIC
STEP 7 at "Configuring with ProTool integrated in SIMATIC STEP 7".

Offline configuration

With ProTool you create and edit your projects offline. The device need not yet be
available at this time. The configuration computer displays the configured project
data as displayed later on the device.

On completion of configuration you can download the executable project file from
the configuration computer to the device.
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1.1 Overview of the documentation

The SIMATIC HMI documentation is made up of a combination of manuals,
instructions and online Help in keeping with the range of target groups. This
chapter provides a broad outline.

1.1.1 ProTool for the whole SIMATIC HMI device family

The SIMATIC HMI device family

The SIMATIC HMI device family is a complete family of text displays, operator
panels, touch panels and Windows-based systems for efficient machine operation
and monitoring. The performance and convenience of the devices are finely tuned
to suit the individual demands made of them.

SIMATIC HMI operating units

The great advantage is that you configure all the devices with the same
configuration software.
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1.1.2 ProTool for Windows-based systems

Devices

The "ProTool - Configuring Windows-Based Systems" documentation tells you how
to configure the following devices:

• Panels
– TP 170A
– TP 170B
– TP 170B Color
– TP 270 (6" and 10")
– OP 170B
– OP 270 (6" and 10")

• Multi Panels
– MP 270B
– MP 270
– MP 370
– MP 370 TOUCH

• Panel PCs
– FI 25
– FI 45
– PC 670 10’’
– PC 670 12’’
– PC 670 15’’
– PC 670 12’’ TOUCH
– PC 670 15’’ TOUCH
– PC 870 12"
– PC 870 15"
– PC 870 15" TOUCH
– PC IL70 12" TOUCH
– PC IL70 15" TOUCH

• SINUMERIK Panels
– OP 010
– OP 012
– OP 015

• SIMOTION Panels

• PC
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Example: MP 370
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1.1.3 ProTool for graphical displays

Devices

The "ProTool - Configuring Graphics Displays" documentation tells you how to
configure the following operating units:

• Graphics-oriented operator panels
– OP 27
– OP 37

• Touch panels
– TP 27-6
– TP 27-10
– TP 37

• C7 devices
– C7-626 (OP 25 with integrated S7-CPU)

Example: TP 37
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1.1.4 ProTool for text-based displays

Devices

The "ProTool - Configuring Text-Based Displays" documentation tells you how to
configure the following operating units:

• Text-oriented operator panels
– OP 3
– OP 7
– OP 17

• Text displays
– TD 17

• C7 devices
– C7-621 (OP 3 with integrated S7-CPU)
– C7-623 (OP 5 with integrated S7-CPU)
– C7-624 (OP 15 with integrated S7-CPU)
– C7-633 (OP 7 with integrated S7-CPU)
– C7-634 (OP 17 with integrated S7-CPU)

Example: OP 7
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2 Getting started in ProTool

Here you learn how to start ProTool, configure text-based systems, and what you
should look out for while you are configuring.

2.1 Starting ProTool

Starting ProTool

After ProTool has been installed, you will find a folder on the Start menu called
Simatic, containing the following icons:

ProTool Pro CS v. 6.0

Calls online Help.

Starts the configuration software.

Shows late-breaking information on the configuration software.

Starts Setup in order, say, to change the ProTool language or to add a
component.

ProTool Pro RT v. 6.0

Copies the compiled project file in compressed form.

Starts the runtime software.

Shows late-breaking information on the runtime software.

Starts the simulation software.

Starts the Loader.
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2.2 Configuring text-based displays

Getting Started

If you are not all that familiar with the ProTool visualization software, we would
recommend you read the short guide and get started with ProTool with the help of
the example. The printed version is enclosed with the manual.

Requirements for working with the brief introduction

To do the exercises for ProTool in this brief introduction, you require

• a PC as a configuration computer

• the SIMATIC ProTool software package, version 5.2 or higher

• an operating unit - for example, an OP 17

Other documents on ProTool

You will find the electronic manuals on the installation CD at:
Docs\..\UsersManual_Text. pdf

You can find all the information contained in this manual in ProTool's online Help.
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2.3 Notes on the configuration computer

Notes on the configuration computer

So that you can work as efficiently as possible when you are configuring, give due
consideration to the following notes for your configuration computer:

• Close applications
Close all other programs. In this way more main memory will be available for
ProTool.

• Configurations on a local drive
Do not start projects from networks, but from your local drive. Network access
times are frequently too long.

• Available disk storage
Your drive should have free disk storage space. Take note of Microsoft's
recommendations for the Windows system in this respect.

• More working memory
Memory requirements rise in proportion to the number and size of the screen
objects you are using. An increase in available main memory reduces
processing times considerably.

• System resources
Make sure when you are working with ProTool that you have 20 to 40 MB of
main memory available and at least 65% free system resources. You will find
information on this topic in Explorer by choosing "Help" > "About". Increase the
size of your main memory with additional RAM or virtual memory, as
necessary. Additional system resources are released by closing other
applications.

• Environment tag TEMP
In Windows, a temporary file is created for files when they are opened and
processed. You decide where this temporary file is stored by means of the
TEMP environment tag.

• The path of the TEMP environment tag is normally set in the autoexec.bat®
file. If the TEMP environment tag is not placed in the autoexec.bat
system file, the temporary file is stored in the local Windows directory. If an
error message is issued by ProTool that indicates an error upon write access,
the storage space on the drive might be too small for the temporary file.
In Windows 2000, the environment variable "TEMP" is set at "Start" >
"Settings" > "Control Panel" > "System" > "Advanced" tab > "Environment
variables" button.
In Win NT 4.0, you set it at "Start" > "Settings" > "Control Panel > "System",
"Environment" tab.
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3 ProTool integrated in SIMATIC STEP 7

Requirements

If the PLC you are using is a SIMATIC PLC and you have installed STEP 7
configuration software on your system, you can integrate ProTool in SIMATIC
STEP 7.

Advantages of STEP 7 integration

With integrated configuration, you access the database that you created when you
configured the PLC in SIMATIC STEP 7. You then have the following advantages:

• You can use SIMATIC Manager as a central point for creating, editing and
managing ProTool projects.

• The communication parameters of the PLC are created as default values when
you create your ProTool project and reset when SIMATIC STEP 7 is changed.

Example of the "Driver Parameters" dialog box with STEP 7 integration: network
parameters and parameters of the peer are set as default values.



ProTool integrated in SIMATIC STEP 7 Release 12/01

ProTool User Manual How to configure text-based units
3-2 A5E00149249

• When configuring tags and area pointers, you can directly access the STEP 7
data in ProTool. Simply select the STEP 7 icon in the ProTool tag dialog box to
which you wish to connect a tag. Changes to the symbol table in SIMATIC
STEP 7 are updated in ProTool.

• You assign symbolic names once only and use them in SIMATIC STEP 7 and
ProTool.
For this purpose, you must assign as name to a DB (data block) in the
SIMATIC STEP 7 symbol table. If this is not the case, this DB is not offered for
selection in the ProTool "Tags" dialog box.

• ALARM_S messages configured in SIMATIC STEP 7 are supported by
ProTool and can be output to the operating unit.

Switching STEP 7 integration from ProTool

A ProTool installation with integration in SIMATIC STEP 7 provides you the menu
item "ProTool Integration in STEP 7" under the "File" menu in ProTool. This allows
you to integrate ProTool in SIMATIC STEP 7 or to operate it in stand-alone mode.
After changing to integration mode, ProTool is automatically restarted.

Integration of ProTool in SIMATIC STEP 7 is still possible in "ProTool Setup",
irrespective of this.

In integrated mode it is also possible to copy single configurations from STEP 7.
You can then edit them in ProTool stand-alone mode (e.g. on another configuration
computer).

Integrating specific ProTool configurations and copying them from STEP 7

Configurations generated in ProTool stand-alone mode cannot be called directly in
SIMATIC Manager. To be able to implement such configurations in a STEP 7
project, you need to integrate them.

Execute by selecting the menu item "File" > "Integrate in STEP 7 project" in
ProTool.

Vice versa, if you want to use ProTool in stand-alone mode to edit projects created
in SIMATIC STEP 7 in integrated mode and without having SIMATIC STEP 7
available, you must first generate a copy of these configuration files offline of
STEP 7.

To do this, select the menu item "File" > "Copy from STEP 7 project" in your
ProTool application.

Note

When you open a stand-alone project, there can no longer be automatic
synchronization of the database between SIMATIC STEP 7 and ProTool. You
therefore have to ensure that the shared database is resynchronized (for example,
by re-integrating) if changes are made to the STEP 7 program.
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3.1 How to start ProTool in SIMATIC STEP 7

General

There are two ways in which you can start ProTool in SIMATIC STEP 7:

• By means of SIMATIC Manager

• Directly in Windows

Starting ProTool with SIMATIC Manager

Procedure:

1 Start SIMATIC Manager.

2 Select a STEP 7 project, or create a new STEP 7 project.

3 Choose the "Paste" > "Station" > "SIMATIC OP" option from the menu, and
enter a name for the ProTool project.

4 Start ProTool by double-clicking the ProTool project. Then select the
operating unit for the project.

Starting ProTool on a SIMATIC PC station

Procedure:

1 Start SIMATIC Manager.

2 Select a STEP 7 project, or create a new STEP 7 project.

3 Choose the "Paste" > "Station" > "SIMATIC PC Station" option from the
menu, and enter a name for the SIMATIC PC station.

4 Select the "Open Object" from the shortcut menu of the SIMATIC PC station
(right click).

The "HW Config" and "PC" dialog boxes appear.

5 Select the "Paste" > "Hardware Components" option from the menu.

The "Hardware Catalog" dialog box appears.

6 Select "SIMATIC PC Station" > "HMI" and drag the entry "SIMATIC
ProTool/Pro RT" to a spare slot in the "PC" dialog box.

7 Close the "HW Config" dialog box.

8 Start ProTool by double-clicking the ProTool project. Then select the
operating unit for the project.
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Starting ProTool in Windows

Start ProTool directly under Windows. Choose "File" > "New" from the menu to
open a dialog box in which you can select a STEP 7 project and create a ProTool
project in it. You then select the operating unit.

Example of the "New" dialog box for integrating STEP 7
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4 Creating and editing projects

Here you obtain an overview over:

• the ProTool project structure

• the procedure for creating a project

• copying objects

• displaying project information

4.1 Fundamental considerations when creating a project

Objective

You want to operate and monitor a machine or process. To do this, you map the
machine or process on the operating unit as accurately as is necessary.

System configuration

Communication takes place between the operating unit and the machine or
process by means of "tags" via the PLC. The value of a tag is written to a memory
area (address) on the PLC, from where it is read by the operating unit.

The following diagram provides an overview of the fundamental structure:

A typical structure
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Before you begin

If you are creating a project for the first time, note the following recommendations:

• Use the standard screens from the standard projects.

• When creating a new project, you can select a "standard project" for your
system (operating unit and PLC) in the "project assistant".

• At ...\ProTool\Samples you will also find the example project "Quickmix",
which is implemented for various operating units and PLCs.

• Consider also whether you can use parts of existing projects. Message text
and graphics are suitable for this, for example.

• In the case of operating units from a single device family, it is also possible to
copy entire project sections via the Clipboard.

• The fixed window in the source and destination projects should be the same
size.

Note

The prerequisite for successful copying between projects is that the system limits
of the operating unit for which you want to use the copied sections must not be
exceeded.
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4.2 Defining an operating philosophy

Basic procedure

Consider which process values or states of the machine you want to display on the
operating unit or work with and which object types you will have to configure for the
purpose.

1. Create a user interface

Screens are the central components of the project, with which you visualize the
states of the machine or process and create the prerequisites for operating the
machine or process.

Example of screen creation

You can create a number of screens with display elements and controls - for
switching between screen,for example - for the user interface with which the
operator is subsequently faced on the operating unit.

2. Process data entry and transfer

In order to enter process data or set new values, you configure input/output fields,
for example. This is also possible as a symbolic display.

3. Report process states

To acquire and log process and operating states on the operating unit or to archive
them, configure messages.
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4. Defining communication areas

A defined address area on the PLC for data interchange with the operating unit is
addressed by means of an area pointer.

The number of area pointers available varies depending on the selected operating
unit
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4.3 Components of a ProTool project

What objects are there in ProTool?

When you open a new or an existing project, the project window opens.

The project window displays the object types you can configure on the left and the
different objects on the right. The objects that you can configure depend on the
type of the operating unit.

The various objects are linked directly in ProTool with the tool required to edit
them.

What is displayed in the project window?

The project data of a ProTool project is stored in the form of objects. The objects in
a project are arranged in a tree structure.

The "Project" window displays object types that belong to the project and you can
configure for the selected operating unit. The project window is comparable with
Windows Explorer. The object types contain objects with properties that can be set.

The project window is structured as follows:

• The title bar contains the project name.

• Depending on the operating unit, the configurable object types are displayed in
the left half of the window and the objects you create in the right half.

Example of a project window with tags

Note

If you maximize the project window, tabs are displayed for the open windows along
the bottom border to enable you to change easily from one window to another.
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4.4 Objects in the project window

Overview

Object symbol Object type Object name (default)

ProTool project PRO1

Screens PIC_1

Messages "---"

Recipes:
not OP 3, C7-621

REC_1

Tags VAR_1

PLCs PLC_1

Headers/footers: not OP 3, C7-621 ---

Text or graphic lists LIST_1

Scheduler:
OP 15, OP 17, C7-624, C7-634 only

ALARM_1



Release 12/01 Creating and editing projects

ProTool User Manual How to configure text-based units
A5E00149249 4-7

4.5 Steps to be taken when creating a project

Basic procedure

1. Create a new project ("File" > "New" or "File" > "Open").
Choose "File" > "New" to create a new project. The project assistant guides
you through a number of selection dialogs.

2. Select your PLC.
Select a driver for your PLC. Only those drivers with which the operating unit
can be run are displayed.

3. Use a standard project.
Select a "standard project" in order to use it as a basis. The project assistant
asks you whether you want to enter any more information about the project in
the "summary". Click the "Create" button to open the project window.

4. Define communication areas (project window: "Area Pointers").
Define share communication areas (area pointers) so that specific functions
such as the "bit message procedure" or "synchronous data record transfer" can
be used.

5. Create your project
This involves the most work. You can approach it in one of two ways: Either
you create all the individual parts first and then link them to form a meaningful
structure (the bottom > up approach), or you begin by designing a structure
and then fill it with the individual elements (the top > down approach). As a
general rule, perform the following steps for this: Create a user interface with
display elements and controls. Configure tags to allow data exchange with the
PLC. Configure messages to receive information about the machine status or
the process.

6. In addition, you can configure additional objects, such as recipes, depending
on the operating unit.
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4.6 PLC drivers

Available PLC drivers

Select the PLC driver with the project assistant in the "Select PLC" dialog box.

You can also define or later edit the parameters there if you select PLC
"Properties" in the project window.

Note

You will find information about the various PLC drivers at "Start" > "SIMATIC" >
"ProTool 6.0" > "ProTool Information System" in the topic "Process
communication".

You can select the following drivers for devices with a text-based display:

SIMATIC S5 - AS511

SIMATIC S5 - FAP

SIMATIC S5 - L2-DP

SIMATIC S7-300/400

SIMATIC S7-200

SIMATIC S7-NC

SIMATIC 500/505

Allen-Bradley DF1

Allen-Bradley DH485

GE Fanuc SNP/SNPX

FREE SERIAL

MITSUBISHI FX

Modicon Modbus

OMRON Hostlink / Multilink

Telemecanique Uni-Telway

Repercussions for tags

The address depends on the PLC you are using. The way in which the address of
a tag with a PLC connection is displayed depends on the PLC you selected.

You select the available data types and data formats in the "Tags" dialog box at
"Type" or "Format".

You will find an overview of the available data types and data formats that you can
select for the PLC driver concerned in the "Communication" user's manual.
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4.7 Area pointers

What are area pointers for?

A defined address area on the PLC for data interchange with the operating unit is
addressed by means of an area pointer.

You create area pointers in the project window at "Area pointers". You can edit
area pointers with all the commands available in the shortcut menu – for example,
copy and then paste in another project.

What area pointers are available?

The number of area pointers available varies depending on the selected operating
unit.

For information on how large the area pointers should be when you create them,
and the structure they have to have, refer to the "Communication" user's manual.

The overview below lists the various area pointers and what they are used for. The
order in which they are listed corresponds to that in ProTool.

Area pointers Explanation

User version The user version identifies the version of the project. A
version check is performed on the PLC by means of this
area pointer.

Event messages You can configure an event message for each bit in this
data area. The bits are assigned to the message numbers
in ascending order.

As soon as the PLC sets a bit in this data area, the
operating unit recognizes that the assigned event message
has "arrived". Conversely, the operating unit interprets the
message as "departed" after the bit is reset on the PLC.

Screen number In this data area the operating unit stores information on
the current screen. You can evaluate this information in the
PLC program to call another screen, for example.

Data mailbox The data mailbox is a data area on the PLC. It is used as
intermediate storage to download data records from the
operating unit to the PLC. The data mailbox contains only
the values of the tag. The addresses are not transferred.

Function keyboard The operating unit transfers keystrokes of the function keys
via this data area. You can evaluate this information in the
PLC program in order to indicate incorrect operation by
means of a message, for example.

LED assignment The PLC can use this area pointer to drive the light-emitting
diodes on the function keys of the operating unit.

OP
Acknowledgement

The operating unit uses this area pointer to indicate to the
PLC which alarm messages have been acknowledged on
the operating unit.
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Area pointers Explanation

PLC
Acknowledgement

Messages can be acknowledged from the PLC using this
area.

Recipe mailbox The recipe mailbox is a data area on the SIMATIC S5. It is
used as intermediate storage to download data records
from the operating unit to the PLC. Not only the values of
tags but also their addresses are transferred to the recipe
mailbox.

Successive recipe
mailbox

The successive recipe mailbox is a data area on the
SIMATIC S5 for transferring data records. You have to
create it only when the recipe mailbox cannot
accommodate the largest data record to occur.

Recipe number The recipe number mailbox is a data area on the SIMATIC
S5. It is required for transferring data records between the
operating unit and the PLC.

The recipe number mailbox contains the recipe number and
the number of the data record to be transferred.

Interface area The interface area is the interface between PLC program
and operating unit. It contains data and pointers to areas
required for exchanging data between the PLC and the
operating unit.

Alarm messages You can configure an alarm message for each bit in this
data area. The bits are assigned to the message numbers
in ascending order.

As soon as the PLC sets a bit in this data area, the
operating unit recognizes that the assigned alarm message
has "arrived". Conversely, the operating unit interprets the
message as "departed" after the bit is reset on the PLC.

System keyboard The operating unit transfers keystrokes of the system keys
via this data area. You can evaluate this information in the
PLC program in order to indicate incorrect operation by
means of a message, for example.

Note

There are no area pointers for the SIMATIC S7-NC.
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4.8 Editing projects

Here you will learn:

• How to convert existing projects. For example, you can convert a project for a
specific device to a project for another device to use it as a basis for a new
project.

• How to copy objects within a project and from one project to another.

• How to undo and redo actions.

4.8.1 Convertible projects

Conversion options in ProTool

You can convert a ProTool project that you created for an OP x5 operator panel
into a project for an OP x7. This also applies to projects for the corresponding "C7
devices".

You can convert the following projects:

Source Objective

OP 5 > OP 7

OP 15C > OP 17

OP 25 > OP 27

OP 35 > OP 37
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4.8.2 Copying objects: Between projects and within a project

Principle

You can cut or copy selected parts of your project and paste them from one project
to another via the Clipboard. For example you can copy text and fields from the
alarm message editor to the event message editor, or graphic elements from one
screen to another.

A requirement for successfully copying from one project to another is that the
system limits of the destination project are exceeded.

You can also copy objects between projects with different resolution. If the
destination system uses a lower resolution than the source system, then the icons
of soft keys, for example, are cleanly adjusted to the new resolution by an anti-
aliasing mechanism.

Preparations for new projects

Before starting to copy objects from an existing project, you should without fail
carry out the following global settings in the new project. This will ensure that no
loss of data occurs due to different settings during copying.

• At "System" > "Screen/Keys", adjust the partition of the screen display to that
in the source project.

• Make the option for Full Screen mode the same as in the source project by
choosing "System" > "Settings" from the "View" menu.

• Make the name and driver of the "PLC" the same as in the source project.

• Make the language settings the same as in the source project by choosing
"System" > "Language Assignment".

Pasting objects in the destination project

To paste objects from the Clipboard to the destination project, choose "Edit" >
"Paste" from the menu.
The object is pasted from the Clipboard to the destination project. If there is
already an object of the same name in the destination project, the object is pasted
under a new name.

Note

With "Paste", ProTool always checks the lower-level objects (such as the limit
value tags of a tag which has been copied) to ensure that existing objects are
reusable.

If there is already an object of the same name in the destination project, the object
to be pasted will be renamed if necessary. It is given the next available name in the
destination project.
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Example:

Tag VAR_4 will be renamed VAR_11 if tags VAR_1 through VAR_10 already exist
in the destination project.

What is copied?

You can copy the following via the Clipboard:

• All objects listed in the project window, such as screens, text or graphic lists,
tags etc.

• Objects from screens (trends, fields, graphics etc.) in the screen editor.

• Messages and objects from messages (message text, fields, Help text etc.) in
the message editor.

• Area pointers

• Global and local function key assignments

An object is copied complete with its attributes and all cross-referenced objects.
Special situations encountered during copying are reported in the "system
message window" at "Clipboard". This gives you information about any objects that
have not been copied or renamed, for example.

Special situation with screens

If the object to be copied refers to a screen that does not exist in the destination
project, the underlying screen is not copied; instead a blank screen is created as a
dummy if the destination project does not contain a screen that can be reused.

This ensures that you will not copy the complete source project by mistake along
with the start screen.

Afterward, when you paste the screen via the Clipboard, the dummy screen in the
destination project will be automatically replaced by the proper screen.

Special feature with tags

Perform the steps listed below so that tags with a PLC connection can be inserted
completely in the destination project when copying from one project to another:

• Assign a self-explanatory symbolic name for the PLC in the source project and
do not use the system default setting (for example, PLC_1).

• Copy the PLC object to the destination project first so that it is present in both
projects with identical parameters. The copy the tags belonging to this PLC.

Special feature of recipes

With Windows-based systems, you can also copy recipes via the Clipboard. You
will find more information about this at "Compatibility of recipes".
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What is not copied?

These objects are not copied:

• Objects that are unknown in the destination project (such as functions or
command buttons when copying from TP 170 to OP 170)

• Character sets

• In the case of multilingual projects, only the languages available in the
destination project are copied. No new languages will be created. If necessary,
create them before copying.

• Settings at "System" - for example, Language Assignment or Full Screen
mode.

4.8.3 Replacing a project and project parts

Purpose

If you would like to introduce new or updated standard components (say, from
ProAgent) of one project in your project, you can do so with the ProTool's Replace
function.

Substituting a complete project

By choosing "File" > "Insert/Replace" > "Settings" from the menu, you can set the
object types which should be taken into account when replacing whole projects.
For this, select the "Replace whole projects" option and then select the object
types.
The settings will be saved in the project concerned; if this project is used as a
source project for the substitution, the settings are taken input.

If you choose "File" > "Insert/Replace" > "Start" from the menu, you can select a
project to replace your currently open project.

The source project must be of the same type as the destination project.

Using the object name, a check is made for all the objects present in the source
project as to whether an object having the same name is already present in the
destination project.

If there is no such object present, a new object is created with the name used in
the source file. If the object is already present in the destination project, it will be
replaced by the object in the source project.

Object linking is not changed by the substitution; merely the contents of the object
are inserted and additional linking added.

Should errors occur in the project during the substitution operation, they are
reported in the same way as other errors when the project is compiled.

Replacement of a complete project cannot be undone.
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Note

PLCs are not replaced as a general rule.

Replacing objects

You ca also copy individual project objects from a source project and paste them in
another project with the Replace function:

• Choose "Edit" > "Insert/Replace" from the menu to replace the objects in an
object group from the project window (such as screens)

• By choosing "Replace" from the shortcut menu of an object, only the selected
object is replaced

To do this, choose "File" > "Insert/Replace" > "Settings" from the menu and select
the "Replace individual objects" option. Then select the object types which you
want to be taken into account in the substitution. The settings for replacing
individual objects are common to all projects.

Example

An archive is configured for the tag which you copied to the Clipboard in the source
project. If you have selected "archive" as the object type in the "Setting Replace"
dialog box, the archive is replaced in the destination project.

Object linking is not changed by the substitution; merely the contents of the object
are inserted and additional linking added. All the objects referenced by the inserted
objects are also pasted in the destination project.

Should errors occur in the project during the substitution operation, they are
reported in the same way as other errors when the project is compiled.

The replacement of individual objects can be undone. Further, Replace is
supported differently by various objects, including between projects of different
types; thus, for example, you can paste objects from a graphics project in a
Windows-based project.

What you must bear in mind

You cannot insert more objects with Replace than the number allowed by the
quantity structure of the destination project.

If the destination project has a smaller range of functions than the source project, it
is possible that not all objects will be applied.

Object attributes that have not been defined in the source project will be assigned
default values in the destination project.
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4.8.4 Undoing and redoing actions

Purpose

During configuration, it may become necessary to cancel actions which have been
performed, or to reconstruct actions which have been discarded. The two
commands "Undo" and "Redo" on the "Edit" menu are used for this purpose.

• Undo The "Undo" command (key combination Ctrl + Z) cancels the last action
performed. If you keep selecting the command, you can cancel up to 30
successive modifications.

• Redo The "Redo" command (key combination CTRL+ Y)revokes the last
action canceled, thus restoring the status before the last "Undo" command was
executed.

Principle

Each active editor (project window, screen editor, drivers) has its own undo history.
Thus, for example, if three screens are opened at the same time, three separate
Undo Histories will be created. When a screen is closed, the actions listed in the
accompanying History are deleted. When the project is saved, all the Undo
Histories for the current project are deleted.

The last recorded action is displayed in abbreviated form in the menu. The tooltips
contain detailed texts for the "Undo" and "Redo" buttons and for the status bar.

Example of menu

Undo: VAR_5 edited Ctrl + Z

Redo: PIC_2 edited CTRL+ Y

Example of tooltip/status bar

Undo: property edited of tag VAR_5

Redo: contents edited of screen PIC_2

Until the corresponding undo history is deleted, deleted objects in the cross-
reference continue to be listed as used objects. The status of these objects is
shown in brackets after each object - for example, PIC_5 (deleted).
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General Information

The commands "Undo" and "Redo" only work with actions taken since the last time
the project was saved. If, for example, you move a screen object and then save
your project, you cannot later cancel this action.

These are some of the rules that apply to "Undo/Redo":

• Settings in dialog boxes (properties of a field) can only be canceled in their
entirety. It is not possible to open the dialog box and discard individual entries.

• With multilevel dialog boxes, only changes to the primary object are recorded.
Modifications to underlying objects, or creations or deletions cannot be
reversed. Example (project window):
"Edit Tag" > "Edit Limit Value Tag"
You can only undo changes to the tag here.

• "Undo/Redo" is special to ProTool. With a project integrated in SIMATIC STEP
7, the Undo buffer cannot be accessed by a higher-level SIMATIC Step 7 Undo
Manager.
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4.8.5 Undoing the last action

Possible procedures

To cancel your last action in ProTool, choose one of the three following options:

• Choose "Edit" > "Undo" from the menu.
The last action that can be undone (canceled) is shown in abbreviated form
after the menu command. A longer description is given in the status bar.

• Click the "Undo" button on the toolbar.
This opens a tooltip which shows you the last action that can be undone
(canceled). You are given the same information in the status bar.

• Press CTRL and Z simultaneously.
In contrast to the first two options, you are not given any feedback about which
action has been canceled.

If you keep executing the "Undo" command, you can successively cancel all the
recorded modifications.

4.8.6 Redoing the last action

Possible procedures

To restore your last canceled action in ProTool, choose one of the three following
options:

• Choose the "Edit" > "Redo" command from the menu
The last undone action is shown in abbreviated form after the menu option. A
longer description is given in the status bar.

• Click the "Redo" button on the toolbar.
This opens a tooltip which shows you the last canceled action. You are given
the same information in the status bar.

• Press CTRL and Y simultaneously.
In contrast to the first two options, you are not given any feedback about which
action has been restored.

If you keep executing the "Redo" command, you can successively restore all the
recorded cancellations.
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4.9 Retrieving project information

Tools

The following tools are available to you for displaying or storing information on a
project.

• Cross references

• Project information

4.9.1 Display in "Cross-Reference" window

Usage

When you have to add to or modify a project and need to check where and how a
particular object is being used in your project, you open the "Cross-Reference"
window.

You select an object in this window, and all the references to this object in the
project are then displayed to you.

Example from a project

You open the "Cross-Reference" window by choosing the "View" > "Cross-
Reference" option from the menu. The active object is displayed with a red border
around it.

The selected object is at the uppermost level, and all the objects in which the
selected object is used appear under it.

The cross-reference list also contains objects in the current Undo history (undo and
restore actions). The status of these objects is shown in brackets after each object
- for example, PIC_5 (deleted).

Note

You can use the "Cross-Reference" window efficiently for troubleshooting.
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4.9.2 What can you view under "Project Information"?

"Project Information" dialog box

To obtain information about a project when projects change or are adapted, open
the "Project Information" dialog box. To do so, choose "File" > "Project Information"
from the menu.

The "Project Information" dialog box displays general "project data" and the
"memory requirements" for the project. Project information is spread according to
subjects over three tab controls:

• General

• Description

• Statistics

Example relating to the "Statistics" tab
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General

The "General" tab shows information on the device type, project name, path name
of the stored project file and person who created the project. You fill in the "Created
by" field and all the other fields are updated automatically by ProTool when the
project is saved.

Description

The "Description" tab contains an input field for the project description. Here you
can enter any information you like that are important for your project.

Statistics

The "Statistics" tab shows when the project was created, modified, generated and
downloaded, the ProTool version last used to edit the project and the memory
required by the project after it has been downloaded to the flash memory on the
operating unit. The memory requirement is determined and displayed "following the
first download operation".

Exception:
With text-based displays OP 3, OP 5 and OP 15A/C, the memory requirement is
determined and displayed following initial compilation.
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4.10 Example of creating projects

These examples show you how to create a project for an OP 5.

4.10.1 How to create an OP 5 project

Objective

You want to create a project for an OP 5 and the SIMATIC S7-300 or SIMATIC S7-
400 PLC.

Procedure

Procedure:

1

Click this symbol or choose"File" > "New".

2 In the "Select Device" dialog box at "Text-based operator panels", select an
"OP 5". Click the "Next" button.

3 In the "Select PLC" dialog box, enter the name of the PLC. From the list
below this, select the driver you want to use for communication between the
operating unit and the PLC.

4 Click the "Parameters" button to set the driver parameters Click the "Next"
button.

You can also set the driver parameters later on.

5 In the "Standard projects" dialog box, select "Use standard project". This puts
you on the standard project.

6 Double-click in the left of the project window on "Area Pointers" to configure
the communication area for "event messages". Select this at "Type" and then
click OK.

7 Enter the following values in the "Event Message" dialog box:
DB: 70 Length: 4
Confirm with OK. You can then configure 64 event messages.

This data block must also be available in your PLC program.

8 Proceed to configure the event messages. If you enter more than 64
messages, more than messages 0000 to 0063 cannot be issued to the
operating unit, since only 4 words of area pointer have been created.

9 Save your project with "File" > "Save".
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5 Configuration techniques

In this chapter you will learn how to:

• Create screens

• Configure controls and display elements

• Use tags

• Configure messages

After that we will show you, for example, how to:

• Use functions

• Create recipes

• Assigning operator authorization

• Create multi-lingual projects
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5.1 What are screens?

Example

Screens are an image of the process. You can display processes on screens and
specify process values. The figure below shows an illustrated example of a mixing
unit for producing different juices. Ingredients are filled into a mixer from different
tanks and then mixed. The liquid levels in the tanks and in the mixer and also the
actual speed of the mixer are displayed. You can specify the required speed of the
mixer in an input field.

Configured screen for a mixing unit

Components of a screen

You can configure several "screen entries" for a screen. A screen entry has display
size. You can see the entry numbers on the left border of the screen editor. The
maximum number of screen entries for a screen depends on which device you are
using.

A screen can consist of static and dynamic components. Static components are
text, whereas dynamic components are "fields" which are linked to the PLC and
display values from the PLC memory. Dynamic components are also inputs made
by the operator on the operating unit and written to the PLC memory. The
connection to the PLC is established by means of tags (refer to "Using tags").

Depending on the operating unit you are using, fields can be used for input, output
and combined input/output.
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Screen editor

Screens are created with a separate editor in ProTool. The operating unit is
displayed when you call the screen editor. Open the screen editor by:

• double-clicking on "Screens" in the left half of the project window to create a
new screen

• double-clicking in the right half of the project window on an existing configured
screen to open the screen for editing.

Screens are stored under a symbolic name. You enter a name by choosing "Edit" >
"Properties" from the menu. This name has to be specified when you edit,
reference or delete the screen. In addition, screens are numbered automatically.

Start screen

Declare one screen in every project as the "start screen". The start screen is the
screen that is displayed after the operating unit has started up.

To identify a screen as the start screen, select the screen and assign it as the start
screen by choosing "Edit " > "Properties" from the menu. On the "General" tab,
select the "Start screen" check box.

Soft keys

Soft keys are function keys with screen-dependent assignment. When you
configure a soft key, you assign functions to it. You can point out the task of a soft
key with a piece of explanatory text.

You can use soft keys to open another screen, turn a motor on and off or display
the message buffer, for example.

Select screen

Every configured screen has to be integrated into the control process so that it can
be opened at run time on the operating unit. You can select a screen in either one
of two ways:

• "Select Screen" function
You an assign this function to an input field or a function key, for example. You
specify the name of the screen as the parameter. This means that a screen
can be displayed by means of an input field or a function key.
With input fields and soft keys, the function can be used only locally on that
screen. Should you wish the function to be available on every screen, you have
to configure the function on a global function key on the operating unit.

• Screen directory
Include the screen in the screen directory. To do so, choose "Edit" >
"Properties" and click the "Screen to Directory" check box on the "General" tab.
Enter text specifically for that screen on the "Title" tab for display in the
directory. This means that you can select the screen on the operating unit by
means of the "Screens" > "Edit" standard screen.



Configuration techniques Release 12/01

ProTool User Manual How to configure text-based units
5-4 A5E00149249

5.2 Configuring display elements

Purpose

You use display elements to monitor the machine or the system on the operating
unit. You can display current information, such as actual values from the PLC,
process and operating modes and malfunctions, on the operating unit as a
numerical value or in plain language.

Overview

There are essentially two types of display element available for the different tasks:

• Static display elements
A static display element is text not having a connection to the PLC. Static
display elements do not react to user inputs and cannot be modified in Runtime
on the operating unit. Use static display elements, for example, for
explanations of controls and dynamic display elements.

• Dynamic display elements
Dynamic display elements are output fields that are connected to the PLC by
means of tags. They visualize current values from the PLC in alphanumeric
form. Output fields can change their display spontaneously in Runtime on the
operating unit without the operator intervening.

Use output fields for all tasks associated with monitoring the process, a
machine or the system.
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5.2.1 What is static text?

Principle

Static text is text that is not linked to the PLC. It cannot be modified at run time on
the operating unit. Use static text, for example, to label controls and output fields.
The relative importance of different text strings on a screen can be illustrated by
means of different character formats - for example, by means of flashing or
uppercase text.

You can configure static text separately for any language available on the
operating unit. You enter text strings directly into the screen editor.
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5.2.2 What are output fields?

Purpose

Output fields display current values from the PLC on the operating unit. The values
may be output optionally in numerical, alphanumeric or symbolic form.

Configure output fields by selecting the symbol illustrated or by choosing
"Insert" > "Input/Output Field" from the menu.

Numerical and alphanumeric output

Output fields for numerical or alphanumeric values show the value as a number or
as text. A numerical value, for example, is the number 80 as the actual value of a
temperature. An example of an alphanumeric value is the text string Valve_12.

Symbolic output

Output fields for symbolic values do not display the true value but a text string from
a text list. For example, you can store the two states of a valve in a text list. When
the valve is open, the output field then points, for example, to the text string OPEN.

By using output fields for symbolic values, you eliminate misinterpretations on the
part of the operator to a large extent, since a symbolic value often presents a state
more lucidly than an abstract numerical value, for instance.
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5.3 Configuring controls

Purpose

You use controls on the operating unit to intervene directly in the process. They are
used, for example, to specify setpoints, trigger functions, open screens and
acknowledge messages. You can assign a password level to controls in order to
prevent operation by unauthorized persons.

Overview

The following controls are available in ProTool for the different tasks:

• Input fields

• Input/output fields

• Function keys
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5.3.1 What are input fields?

Purpose

In input fields you enter values on the operating unit that are transferred to the
PLC. The values may be input optionally in numerical, alphanumeric or symbolic
form. If you define limit values for the input field tag, you can reject inputs on the
operating unit that are outside the specified range of values.

You can prevent access by unauthorized persons by assigning a password level.

Create input/output fields by selecting the symbol illustrated or by
choosing "Insert" > " Input/Output Field" from the menu.

Numerical and alphanumeric input

In input fields for numerical and alphanumeric values you enter the value one
character at a time on the operating unit. A numerical value, for example, is the
number 80 as the setpoint for a temperature. An example of an alphanumeric
value is the text string Valve_12.

Symbolic input

In input fields for symbolic values you do not enter the value one character at a
time but select this value on the operating unit from a text list. During configuration
you assign symbolic text on the text list to every value of a tag. In this way, for
example, you can turn a motor on and off by means of the two entries ON and OFF.

By using input fields for symbolic values, you prevent misinterpretations to a large
extent, since the operating unit accepts only the configured values on the text list.
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5.3.2 What are combined input/output fields?

Purpose

Combined input/output fields display current values from the PLC on the operating
unit. You can also enter values that are transferred to the PLC at the same time.
The values may be input and output optionally in numerical, alphanumeric or
symbolic form. During input, the value you want to be output is not updated on the
operating unit.

You can prevent access by unauthorized persons by assigning a password level. If
you define limit values for the input/output field tag, you can reject inputs on the
operating unit that are outside the specified range of values.

Combined input fields are created on the open screen on the "Screen
Objects" toolbar by choosing the illustrated button or at "Insert" >
"Input/Output Field".
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5.3.3 What are function keys?

Purpose

A function key is a key on the operating unit for configuring a function assignment.
You can assign one or more functions to any function key in ProTool. The functions
are triggered as soon as the key is pressed. The function key assignment may be
locally or globally significant. You can assign a password level to function keys in
order to prevent operation by unauthorized persons.

Global assignment

Globally assigned function keys always trigger the same function, irrespective of
the current control situation. You can use them, for example, to open a screen,
display the current alarm message or print the contents of a screen.

By using globally assigned function keys, you cut your configuration effort
considerably since you do not have to assign individual functions to global keys on
every screen.

Assign function keys globally by choosing "System" > "Screen/Keys" from
the menu. To do this, click in the Screen/Keys dialog box on one of the
keys "K1" through "Kx" or "F1" through "Fx". You can specify the functions
you have assigned to specific keys on the operating unit by means of
labeling strips (not OP 3).

Local assignment

Locally assigned function keys trigger different actions on the operating unit
depending on the situation. A function key whose assignment may vary from
screen to screen is referred to as a "soft key".

Assign soft keys locally in the screen editor. To do so, click in the screen
on one of the keys "F1" through "Fx", which are arranged directly around
the operating unit screen.

You can also assign soft keys globally. A global assignment is active on all screens
to which you do not assign a screen-specific function. Use globally assigned soft
keys, for example, to change from any screen to the same system screen.

Note

Do not assign functions that have to be permanently available on the operating unit
to soft keys.
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5.4 Using tags

Purpose

Since tags are the most important means of communication between the operating
unit and the PLC and for exchanging data, a detailed explanation is presented here
of what tags are and what types of tag are used in ProTool.

Definition

A tag has a symbolic name and a defined data type. The value of the tag changes
while the PLC program is being executed.

Tags with a PLC link are referred to as global tags. Tags without a PLC link are
known as local tags.

• Global tags
A tag with a PLC link occupies a defined memory address on the PLC, to
which read and write access is possible from both the operating unit and the
PLC.

• Local tags
Local tags are not connected to the PLC. They are available only on the
operating unit. You create local tags, for example, so that the operator can
enter limit values on the operating unit.

Tag types

ProTool recognizes the following tag types (but these are not available on every
PLC):

data type Bit System Range of Values

BYTE
(OP 7/17
only)

8 bit 0 through 255

INT 16 bit - 32768 through 32767

UINT 16 bit 0 through 65535

LONG 32 bit - 2147483648 through 2147483647

ULONG 32 bit 0 through 4294967295

FLOAT 32 bit Upper limit: ± 3.402823 e+38
Lower limit: ± 1.175495 e-38

DOUBLE
(OP 7/17
only)

64 bit Approx. 12 valid digits

BOOL true (1), false (0)

STRING 1 to 128 bytes
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data type Bit System Range of Values

ARRAY tags This tag type combines a
random number of tags of
the same type to form a
total, which can be handled
as a whole.

Online tags for S5

Data type Bit system

KF 16 bit, fixed-point

KH 16 bit, hexadecimal

KM 16 bit, binary

KY 8 bit, 8 bit (2 x 8 bit, comma separated)

KC (ASCII character)

KT (S5 timer)

KZ (S5 counter)

BCD4: 16 bit, BCD

DF 64 bit, fixed-point

DH 64 bit, hexadecimal

KG Floating point

Online tags for S7

data type Bit System

CHAR 8 bit

BYTE 8 bit

INT 16 bit, fixed-point

WORD 16 bit

DINT 32 bit, fixed-point

DWORD 16 bit

REAL 32 bits floating point

BOOL 1 bit

STRING ASCII character

TIMER Timer (S5#Time)

COUNTER Counter

Note

The details "fixed-point", "hexadecimal", etc., refer to the representation of the
CPU. They have no bearing on the display options on the OP.
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5.4.1 Properties of tags

Tag definition (Section A)

To define a tag, open the "Tag" dialog box.

The figure shows an example of the "Tag" dialog box for SIMATIC S7 integrated in
SIMATIC STEP 7.

"Tag" dialog box for the SIMATIC S7

The available data types and data formats depend on the PLC you selected. You
choose at "Type" in the "Tag" dialog box between "Format" and "Decimal places".

Updating tags

The acquisition cycle determines the time interval in which the value of a tag is
updated on the operating unit.

System default setting: 1 sec

The acquisition cycle is a multiple of the "standard clock pulse", which you
configure for every PLC in the "PLC" dialog box. You globally modify the
acquisition cycles for all the tags of a project by setting the standard clock pulse.
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Array tags

An array tag represents a number of tags of the same type with consecutive
memory addresses. If you wish to define an array tag, enter the number of
elements in the array in the "Tag" dialog box at "Number of elements".

The system default setting is 1, in other words, the tag is not defined as an array.

The maximum number of elements in an array is 255.

All elements are automatically read in when an array tag is accessed. To avoid as
many delays as possible at run time, you should use arrays only when values are
not frequently changed.
If the array is connected to a PLC, the whole array is transferred to the PLC every
time an array element is modified. An array must therefore not be written from the
PLC and from the HMI device for this reason.

Address (Section B)

The address determines the memory location of a global tag on the PLC. The
address therefore depends on the PLC you are using.

The display of the address depends on the PLC you selected. This section of the
"Tag" dialog box adjusts dynamically to the programmable address areas.

ProTool integrated in SIMATIC STEP 7 (Section C)

If you have installed ProTool integrated in SIMATIC STEP 7, you can access the
"STEP 7" symbol table directly in the "Tag" dialog box. The symbol table is
displayed in the "Symbols" floater when you select the "With symbol" check box.

For performance reasons, ProTool does not automatically update the STEP 7
symbol table after every change. In order to make the latest changes to the STEP
7 symbol table available in ProTool, update the display of the symbol table in the
"Tag" dialog box by clicking the "Update" button.

Setting a start value

You can set a "start value" for the tag at "Options". When the project is
downloaded, the tag is assigned the start value. The start value is displayed only
on the operating unit and is not stored on the PLC.

Example:

If tags are used for scaling bar graphs, the initial value may be the start value of
the scaling.

Setting limit values

An upper and a lower limit value can be configured at Limit values for tags.

If the tag value is outside the defined range, in other words, it is higher or lower
than the limit value concerned - this has the following effect on the input fields, for
example. If the operator enters a value outside the configured limit values, the
input is rejected.
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Configuring tags with functions

You can assign functions to tags in input/output fields - for example, the "Select
Screen" function. The screen is selected as soon as the value of the tag changes.

Note

A function which you have configured for an internal tag (without PLC connection)
whose value is modified by another function is not executed.
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5.4.2 Tag lists

Purpose

With each input field, you generally set in advance which array element is assigned
to the input field. With a tag list, this assignment is not static for the OP 7 and OP
17 devices, but it can be influenced by the operator. Thus you directly access an
element in the array that supplies the input field with data in Runtime.

Principle

The figure shows the principle of a tag list. When configuring the input field, define
a "selection tag" VAR_2 as well for tag VAR_1 of the input field . The selection tag
is an array. Use the configured value for the "height" of the input field to set how
many elements of the array you want to appear on the display. If the number of
array elements is higher than the "height", you can scroll in the displayed "list" of
tags. At run time, the value (6), entered in the input field, will determine the index in
the selection tag and supply the input field with the value saved at the associated
address in the PLC.

Tag list (principle)
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5.4.3 Address multiplexing

Requirements

• Address multiplexing of tags is possible only with operating units OP 7, OP 17
and TD 17.

• Use a SIMATIC S7-300 or SIMATIC S7-400 or SIMATIC S7-NC PLC.

Definition

With address multiplexing, the address parameters of a tag are modified as a
function of the value of the multiplex tag.

Purpose of address multiplexing

With address multiplexing, you can reference a number of memory addresses in
the address area of the PLC (S7-CPU) with a single tag. You can read or write to
the addresses without having to define a tag for every single address, that is, it is a
very efficient method of processing data.

Principle of address multiplexing

The following figure illustrates the principle of address multiplexing with tags:

Address multiplexing with tags
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Configuring a multiplex tag

You define the multiplex tag by pressing this button shown in the "Tag" dialog
box next to the address.

Pay attention to the following when configuring multiplex tags:

• The multiplex tag must not be multiplexed.

• The "type" of multiplex tag must match the type of address parameter which
the multiplex tag is defining.

The following figure shows the result of the address multiplexing for tags:

Address multiplexing with tags

Note

If one of the multiplex tags is modified during operation, the multiplexed tag is not
modified until the next recording cycle. If you want immediate updating, configure
the "Update Screen" function for every multiplex tag.



Release 12/01 Configuration techniques

ProTool User Manual How to configure text-based units
A5E00149249 5-19

5.4.4 Examples of configuring tags

Using examples, we will show you here how to configure a multiplex tag, set the
acquisition cycle and the standard clock pulse of a tag, and scale tags.

5.4.4.1 How to set the acquisition cycle and the standard clock pulse

Settings

System default setting: standard clock pulse 200 ms, acquisition cycle 1 s.

Set the standard clock pulse in the "PLC" dialog box. If you increase the standard
clock pulse to 600 ms, the acquisition cycle for all tags is increased to 3 s.

Note

In order not to overtax communication between the PLC and the operating unit, the
times you set for the standard clock pulse should not be too short. This would
mean that other processes, such as the updating of trends or the execution of PLC
jobs, would take considerably longer.



Configuration techniques Release 12/01

ProTool User Manual How to configure text-based units
5-20 A5E00149249

5.4.4.2 Tag scaling

Configuring functions

The scaling of tags is configured as a function for a tag. The following functions are
available for this:

• Scaling Linear 1 and Scaling Linear 2

If you configure no scaling, the tag value on the PLC corresponds to the tag value
on the operating unit.

Linear scaling

Scaling can be configured for any tag in the form
y = a*x + b.

• X = displayed value/input value
The Y value read from the PLC undergoes linear scaling before being
displayed on the operating unit as the X value. Inputs X on the operating unit
undergo scaling before being written to the PLC as the Y value.

• Y = displayed value/input value
The X value read from the PLC undergoes linear scaling before being
displayed on the operating unit as the Y value. Inputs Y on the operating unit
undergo scaling before being written to the PLC as the X value.

Example

You have configured 3 as the value of a 6 as the value of b. The value 21 is
transferred from the PLC. It is included in the scaling function: 21 = 3 * X + 6. This
results in 5 being the value for X. This is the value displayed on the operating unit.
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5.4.4.3 How to configure a multiplex tag

Procedure

To multiplex an address, create the following tag, for example:

Procedure:

1 Select "Insert" > "Object" to configure a new tag for any object.

2 In the "Tag"dialog box, enter Variable_1 as the name of the new tag.

3 On the "Address tab", select INT at Type and enter the address as:
DB 50
DBB 0

4

Click this button to open the "Address Multiplexing" dialog box.

5 Activate address multiplexing.

6 Enter Multiplex_1 as the name of the new multiplex tag.

7
Click this button to define the multiplex tag.

8 On the address tab, select BYTE at Type and enter the address:
F W 20

9 The multiplex tag can assume values between 0 and 255, in other words you
can reference 256 different addresses with the tag Variable_1.

Apply the settings by clicking OK.

Note

If you want to make use of the maximum range of values of the multiplex tag, DB
50 in the STEP 7 program has to be created with at least 128 data words.
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Result

The name of the multiplex tag is displayed as the address of the tag Variable_1:
DB 50
DBB [MULTIPLEX_1]

Example: configuring a multiplex tag
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5.4.5 Details on configuring tags

At "Details" you will find more information on the subject of tags.

5.4.5.1 Decimal places with tags

Overview

The following list shows the possible number of decimal places of the different
types as a function of the PLC selected:

PLC Type Decimal places

SIMATIC S5 KF 0 through 4

KG 0 through 6

DF 0 through 8

DH, KH, KM, KC, KY,
KT, KZ, BCD4

---

SIMATIC S7 INT 0 through 4

REAL 0 through 6

DINT 0 through 8

BOOL, STRING, Timer,
Counter, CHAR, BYTE,
WORD, DWORD

---

SIMATIC S7-NC INT_16, UINT_16 0 through 4

FLOAT 0 through 6

INTEGER, LONG,
UINT32, DOUBLE

0 through 8

BOOL, CHAR, STRING ---

SIMATIC 500/505 +/- INT, INT 0 through 4

REAL 0 through 6

+/- DOUBLE, DOUBLE 0 through 8

BIT, ASCII ---

No PLC INT, UINT 0 through 4

FLOAT 0 through 6

LONG, ULONG 0 through 8

BOOL, STRING ---
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5.4.5.2 Address and type of a tag

Dependence of tags on the PLC

The address and the data type (the data format) of a tag depends on the PLC.

Note

You will find information about the various PLCs at "Start" > "SIMATIC" > "ProTool
6.0" > "ProTool Information System" in the topic "Process communication".

Available PLCs

SIMATIC S5 - AS511

SIMATIC S5 - DP

SIMATIC S7-300/400

SIMATIC WinAC

SIMATIC S7-200

SIMATIC 500/505

SIMATIC 500/505-DP

SIMOTION

OPC (Client/Server)

Allen-Bradley DF1

Allen-Bradley DH485

LG GLOFA-GM

MITSUBISHI FX

MITSUBISHI Protocol 4

Modicon Modbus

Telemecanique Uni-Telway

GE Fanuc SNP/SNPX

Omron Host-Link
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5.5 Headers and footers

Constraints

Note

Headers and footers can only be configured for the OP 5, OP 7, OP 15 and OP 17
and the corresponding C7 devices.

What objects can you use in headers and footers?

You can configure "static text" and "output fields" in headers and footers. Two lines
of 80 characters are available in all instances.

At "Usage", you can choose between "date", "time" and "page number". This also
sets "display" and "field length".

For what uses can you configure headers and footers?

You can set headers and footers for the following printouts from the operating unit.

Printout Content

Message Report Messages for which you have configured "Print" are output
to the printer.

EM Chronological The contents of the event buffer are printed in chronological
order of the messages.

EM Together The contents of the event buffer are printed in message
number order.

AM Chronological The contents of the alarm buffer are printed in chronological
order of the messages.

AM Together The contents of the alarm buffer are printed in message
number order.

Overflow When the buffer overflows, the messages are output to the
printer.

Print Screen A screen that you have selected is printed.

Print Recipe The recipe specified in the function parameter of the
function "Print All Data Records" is printed out complete with
all its data records.
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5.6 What are text or graphic lists?

Purpose

Text is often more meaningful than an abstract value. For example, the pieces of
text full and empty present the state of a tank more lucidly than the
corresponding numerical values. Which is why ProTool gives you the opportunity to
configure text or graphic lists. These "text lists" are lists in which you assign a text
element from the list to each tag value.

Usage

With text or graphic lists, you can display texts in output fields and select texts for
input in input fields. To a large extent, this eliminates misinterpretations in the
display and operator errors during input.

A text or graphic list assigns a text to every value of a tag. At run time, the tag
value determines which text is selected from the list and displayed, for example, in
an input/output field on the operating unit.

To create a new text or graphic list, double-click "Text or graphic lists" in
the project window.
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5.7 Configuring schedulers

Constraint

Note

Schedulers are available only for the OP 15 and OP 17 operating units.

Tasks of a scheduler

A scheduler defines a regularly recurring time at which a particular function is to be
executed.

The following types of scheduled times are available:

• hourly

• daily

• weekly

• annually

Scheduler dialog box
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The following table shows which time entries you can specify for which scheduler
types:

Scheduler type Required time entries

hourly Minute

daily Hour, minute

weekly Day of the week, hour, minute

annually Month, day, hour, minute

Functions linked to a scheduler

If you subsequently want to change or deactivate the scheduled time on the
operating unit, you can insert it in a screen entry. At a scheduled time, the
associated scheduler bit is set on the PLC (in the interface area) and the
configured function executed.

For example, you can configure print functions for a scheduler:

• Events - Print Buffer

• Alarms - Print Buffer

• Print Screen

• Print Data Record

Scheduler without functions

It is not essential to configure a function. If no function is configured, the scheduler
bit is set when the scheduler is executed, but of course no function is executed.
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5.8 Configure messages

To display process and operating states or to acquire and log process data on the
operating unit that you obtain on the process from the PLC, configure "messages".

Messages are initiated by the PLC and can be displayed on the operating unit.

5.8.1 Displaying operating and process states

What do you use to display operating and process states?

To display process and operating states or to acquire and log process data on the
operating unit that you obtain on the process from the PLC, configure "messages".

Messages are initiated by the PLC and can be displayed on the operating unit.

There are the following message types in ProTool:

• Event messages: Display routine operating and process states and processes.

• Alarm messages: Display critical or hazardous operating and process states
and require operating personnel to react by issuing an "acknowledgement".

• System messages: Display states and errors of the operating unit, the PLC or
the communications between them. They are issued by the operating unit or by
the PLC.

• System messages on the S7-NC and S7-FM (OP 7 and OP 17 only): Display
states and errors of the PLC or during communication.

For what purpose do you use messages?

The messaging system is responsible for the following tasks:

• Signaling events or states that can occur on the system or in the process:

• A state is reported immediately following its occurrence.

• The messages are presented to the operator as a function of their significance
(priority).

• Support in eliminating the cause of error conditions:

• Messages provide in-depth information on the causes of errors (diagnostics).

• The process might be influenced as a result of the message.

• Reporting: The message events are output to a printer.
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5.8.2 The components of a message

Message structure

A message consists of:

• Message number

• Message text

• Message tag

• Help text

The following messages are displayed on the operating unit but cannot be edited in
ProTool:

• The message number cannot be modified in system messages, standard
diagnostic results (S7 system messages) and NC alarms. (Only with OP 7 and
OP 17).

• Message numbers of user defined diagnostic results can be freely defined in
SIMATIC STEP 7 within certain limits.

• The message number is assigned to Alarm_S messages in SIMATIC STEP 7.

Message number

The message number is used to reference a message. In ProTool, you have a free
choice of message number (within the range 0 to 2000) and message text.

Message text

Message text contains the description of a message. The length of the message
text depends on the operating unit. The number of characters per line is marked by
this character (A) at the top border of the window during configuration.

By choosing "Edit" > "Style" from the menu, you can select the following styles, for
example, for the message text, depending on the operating unit: flashing,
underscore, italic.

Note

You can also configure operator instructions as a message.
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Message tags

A message can contain output fields with tags. They are also referred to as
"message tags".

By choosing "Edit" > "Style" from the menu, you can select from the following
styles for output fields, depending on the operating unit: flashing, underscore, italic.

Insert an output field by selecting the symbol illustrated.

Note

The values of message tags are updated in the message buffer when messages
are active or are cleared, but not when messages are acknowledged.

Help text

Help text containing further details on a message can be configured for every
message. Help text is displayed for the operator in a separate window on the
operating unit by pressing the "HELP" key.

Enter Help text by selecting the button illustrated or by using the menu
command "View" > "Help Text".

Other message components

When configuring message views for certain devices, other message components
can be displayed - for example, details of the error location (on the PLC).
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5.8.3 Message properties

Configurable properties

You can configure the following parameters for messages:

• Priority

• Acknowledgement group

• Print

Priority

High-priority messages are displayed before low-priority messages on the
operating unit. The lowest priority is 1.

• If several messages having the same priority are waiting to be displayed, the
most recent (last) is displayed.

• If several unacknowledged alarm messages having the same priority are
waiting to be displayed, you can choose whether the most recent (last ) or the
oldest (first) should be displayed.

Configure the priority in the "Attributes" dialog box for every single message. Set
the sort criterion by choosing "System" > "Messages" > "Settings" from the menu.

Acknowledgement group

Alarm messages can be assigned to acknowledgement groups. Configure the
assignment to an acknowledgement group for every single message. If you
acknowledge an alarm message in one acknowledgement group, all the alarm
messages in that group are acknowledged simultaneously ("group
acknowledgement").

Print

If you select "Print", the message event (active, cleared, acknowledged) is logged
automatically on the printer if you selected "Print upon Message Event " after
choosing "System" > "Messages" > "Settings" from the menu.

Configure printing in the "Attributes" dialog box for every single message.
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5.8.4 Acknowledging messages

Principle

An alarm message can be acknowledged either by the operator on the operating
unit or by the PLC program. By acknowledging an alarm message, you confirm that
you have taken notice of it.

Assigning acknowledgement groups

You can assign several alarm messages to a single acknowledgement group when
you configure alarm messages. This means that when the first alarm message is
acknowledged for example, the cause of the malfunction- all the other alarm
messages in the same acknowledgement group (consequential malfunctions) are
acknowledged together.

A blank field in the attribute window of the message is synonymous with entering 0.
The value 0 results in "individual acknowledgement" - in other words, only that
particular alarm message is acknowledged in the alarm message
acknowledgement process. If you acknowledge an alarm message in one
acknowledgement group, all the alarm messages in that group are acknowledged
simultaneously ("group acknowledgement").

You can allocate the messages to one of 4 acknowledgement groups.
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5.8.5 Settings for message classes

Properties of message classes

You can configure the following parameters for message classes:

• Acknowledgement

• Printout

Acknowledgement

Alarm messages have to be acknowledged. Alarm messages are displayed until
they have been acknowledged.

• Single acknowledgement:
When you acknowledge a message, only that particular message is
acknowledged.

• Group acknowledgement:
When you acknowledge a message belonging to an acknowledgement group,
all the queued messages of this group are acknowledged, too.

Printout

Printing is enabled or disabled by selecting the "Print" attribute, or is enabled when
the message buffer overflows. The messages are printed on a printer attached to
the operating unit.

Configure your printout by choosing "System" > "Messages" > "Settings" from the
menu.



Release 12/01 Configuration techniques

ProTool User Manual How to configure text-based units
A5E00149249 5-35

5.8.6 System messages

Displaying system messages

System messages are always implemented on the operating unit and cannot be
configured in ProTool. They are displayed in a process window.

What is reported?

A system message consists of a "message number" and "message text". The
message text may contain internal system tags that provide further details on the
cause of an error message.

System messages provide information on operating unit operating states. The
wealth of possible system messages ranges from notes to serious errors.

Note

You will find a list of system messages of the operating units, their causes and, if
possible, remedial action in an appendix to the equipment manuals and the
"Communication User's Guide".

Displaying system messages

Choose "System" > "Messages" > "System Messages" from the menu system to
set the length of time you want to have the system messages displayed on the
operating unit.

Note

The 0 setting means the display is static. The process window is not closed until
you press ESC.

On operating units OP 7 and OP 17 (and accordingly C7-633 and C7-634) you can
also activate display of the following "system messages (example)":

• SIMATIC S7 (Minimal): The message numbers of the S7 system messages
(time stamped) are output. You can refer to the cause of the error in your S7
manual by means of the number.

• SIMATIC S7 (Standard): In addition to minimal display, the message text of the
S7 system message is output and you can display it using the arrow keys.

• SIMATIC S7-FM: The message text of FM system messages is output.

• SIMATIC S7-NC: The message text of NC system messages is output.

Note

The ..\PROTOOL\SYSMSG folder contains system messages for the S7-NC and
the S7-FM in several languages.
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5.8.7 Logging messages

Enabling and disabling message logging

To output messages to the printer, open the "Attributes - Message" dialog box by
choosing "View" > "Message Attributes" from the menu and select "Print". The
messages are logged when their status changes (active, cleared, acknowledged).

By choosing "System" > "Messages" > "Settings" from the menu, you can select
the following settings for message logging:

• Message event
Message logging is activated for all message events.

• Buffer overflow
When the specified remaining buffer capacity is reached, all messages are
printed out irrespective of whether printing is enabled or not. The message
buffer is then deleted.

• Off
Message logging is disabled.

You use the "Message Log ON/OFF" function to enable and disable automatic
printing of messages.

5.8.8 Configuring printers for the operating unit

Printer for logging

Attach a printer to your operating unit to log process states or process data reports.

For this you can configure one or more printers.

• In ProTool, some printers in the list box have already been defined.
Parameters have already been assigned to these printers.

• You can add more "new printers" to the list box in ProTool. You have to enter
the specific control characters contained in the printer manuals concerned for
these printers.

Perform the settings for the printers and the interface parameters by choosing
"System" > "Printer" from the menu.



Release 12/01 Configuration techniques

ProTool User Manual How to configure text-based units
A5E00149249 5-37

5.8.9 Displaying messages on the operating unit

Principle

Messages are displayed in special output windows. You can still operate the
operating unit when messages are queued and displayed.

Set the display of messages on the operating unit by choosing "System" >
"Messages > "Settings" from the menu.

Select "Separate" or "Together":

• "Together"
The display on the operating unit is split. Event messages are displayed in the
one half and alarm messages in the other. If no event messages or alarm
messages are queued, the corresponding section remains empty.

• "Separate"
Event messages and alarm messages are displayed separately from each
other on the operating unit. They are displayed according to priority:

- Unacknowledged alarm messages

- Event messages

- Acknowledged alarm messages

- Standby message

If, for example, at least one unacknowledged message is pending, no event
messages are displayed.

Sort criterion for alarm messages

If several unacknowledged alarm messages of the same priority are queued, select
the sort criterion by choosing "System" > "Messages" > "Settings" from the menu:

"First" The first (oldest) alarm message is displayed first.

"Last" The last (most recent) alarm message is displayed first.

If you configure the function Select Function Screen and configure "Screen
Name" using the value "AM First/Last" as the parameter, you can change the sort
order on the operating unit.

Note

This function has already been implemented on the System Settings standard
screen.



Configuration techniques Release 12/01

ProTool User Manual How to configure text-based units
5-38 A5E00149249

Standby message

The "standby message" is a special event message. The standby message is the
event message having message number 0. It is displayed when no other
messages are queued on the operating unit.

Note

The standby message can have only message text and output fields containing the
date and time.
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5.8.10 Contents of message buffers

Definition

A message buffer is a buffered memory area in the operating unit RAM in which
message events are stored in chronological order. It takes the form of a FIFO
buffer with a specified size and does not have to be explicitly configured.

The message buffer can store 256 alarm message events as well as 256 event
message events.

Data storage in message buffer

Every message event is stored with the following information:

• Message number

• Identification of the event
("K" for Active, "G" for Cleared, "Q" for Acknowledged)

• Time stamp consisting of date and time

• Acknowledgement group "QG" (with alarm messages only)

• Message text

• Value of the message tag at the time of arrival or departure

Example

Below is an example of output from the message buffer to the printer:

0010 G 11:58:08 27.03.98 QGR02
Boiler pressure too high: 7.9 bar

0029 Q 11:40:47 03.27.98 QGR00
Oil supply shut off
0029 KQ 11:38:09 03.27.98 QGR00

Oil supply shut off.
0010 Q 11:35:18 03.27.98 QGR02

Boiler pressure too high: #### bar
0010 KQ 11:34:26 03.27.98 QGR02

Boiler pressure too high: 12.7 bar
If a message contains process values, then those values that were available when
the message event arrived or departed are stored in the message buffer. In the
case of the "acknowledged" message status, the operating unit does not acquire
any current process values.
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Note

The last four characters cannot be displayed on the operating unit on the first line
of the message buffer on account of the message number being displayed. If a
message tag has been configured at this point, it is not displayed.

Behavior on overflow

Choose "System" > "Messages" > "Settings" from the menu to select whether an
overflow warning should be output when the specified remaining buffer capacity is
reached.

Before the messages are deleted, they are output to the printer. This applies to all
messages even if they are not marked with the "Print" attribute .

Using a standard screen

The following functions have already been implemented on the standard screen
known as "Event Messages" (Z_MESS_EVENT):

• Display event message buffer

• Print event buffer

• Delete event buffer

• Output Overflow Warning

• Display number of event messages

The following functions have already been implemented on the standard screen
known as "Alarm Messages" (Z_MESS_ALARM):

• Display alarm message buffer

• Print Alarms Buffer

• Delete alarm buffer

• Output Overflow Warning

• Show number of alarm messages
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5.8.11 Exporting message text and screens

Export file

An export file is a text file that you edit with an editor in ANSI format and can then
reimport.

For more on this subject refer to the example relating to an export file with event
messages.

Usage

You choose "Edit" > "Export" from the menu to export strings of "message text and
screen entries" which you want to apply to another project, for example, or which
you want to translate in another editor.

5.8.12 Importing message text and screens

Import file

The import file is a text file that you created with an editor in ANSI format or
exported from a project.

Usage

You choose "Edit" > "Import" from the menu to import strings of "message text and
screen entries" which you want to borrow from other projects, for example, or
which you have translated into another language.

For more on this subject refer to the example relating to an export file with event
messages.

Note

Before creating an import file, you should export a message or a screen in order to
familiarize yourself with the syntax used.
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5.8.13 Communication areas for messages

Communication area required for operating unit/PLC communication

For communication between the operating unit and the PLC to function properly,
establish an assignment to the following communication areas in the project
window of your ProTool project at "Area Pointers": "Event messages" and/or
"Alarm messages".

These areas are imperative if you configure event messages and alarm messages.

They must be chosen at least large enough for a bit to be available for every
configured message. If the communication area is not made large enough, a
warning will be issued during compilation of the project.

If you wish, you can create the following communication areas:

• PLC Acknowledgement

• OP Acknowledgement

Optional communication areas: Acknowledgement areas for messages

If the PLC is required to send an acknowledgement automatically, create the
following acknowledgement areas in the project window at "Area Pointers".

• "PLC Acknowledgement"
The acknowledgement bit is set by the PLC program and thus causes
acknowledgement of the corresponding alarm message to be displayed on the
operating unit.
The "PLC Acknowledgement" acknowledgement area
- must be contiguous with the associated alarm message area
- must have the same acquisition cycle as the alarm message area
- must not be longer than the associated alarm message area.

• "OP Acknowledgement"
The operator acknowledges an alarm message on the operating unit and thus
sets the acknowledgement bit of this alarm message on the PLC. When he
does so, the entire acknowledgement area is transferred to the PLC. The "OP
Acknowledgement" acknowledgement area must not be longer than the
associated alarm message area.
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5.8.14 Message procedure:

Message bit procedure

The message procedure identified the transfer path of messages and thus also the
parameters of the messages. The message procedure in ProTool is the message
bit procedure.

With this message procedure, the operating unit detects the arrival, departure or
acknowledgement of a message by setting a bit in the address area, the bit being
assigned by choosing "System" > "Area Pointers" from the menu to the
event/alarm message area.

Message number procedure

The second message procedure used in ProTool is the message number
procedure "ALARM_S".

A message is event-driven and is issued when a bit is set in the PLC. The setting
and resetting of the bit and acknowledgement are known as a message event.

Active (K) The message bit has been set and the message is waiting to
be displayed.

Cleared (G) The message bit has been reset because the cause that gave
rise to the message no longer exists.

Acknowledge (Q) With alarm messages only:
The operator (or the PLC) acknowledges the message to
confirm that note has been taken of the message.

The message events have been acquired by the operating unit and time stamped.

The operating unit automatically enters all message events in the message buffer.
In this way the message events can be viewed at a later time again.

Communication areas for messages

The display of messages on the operating unit is initiated by the PLC by a bit being
set on it in a defined communication area.
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You can see which communication areas for messages have to be created on the
PLC in the following figure:

Displaying messages
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5.8.15 Examples of configuring messages

These examples show you:

• How to configure an alarm message.

• How to create message areas for different devices.

• How system messages might appear, depending on the operating unit.

• The contents of the export file for event messages.

5.8.15.1 How to configure alarm messages

Objective

You would like to set the alarm message area first and configure an alarm
message with a SIMATIC 300 or a SIMATIC 400 PLC.

Procedure

Procedure:

1 Left double-click in the project window on "Area pointers" to create the alarm
message area. The "Area Pointers" dialog box is opened.

2 Here you select the "Alarm Messages" area pointer. Click OK.
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Procedure:

3 The "Alarm Messages" dialog box is opened. Enter the following at "Address":
DB: 10
DW: 2
Length: 2
PLC: PLC_1

You have then created an alarm message area for 32 alarm messages.

4 Confirm all settings by clicking OK.

5 Double-click the Alarm Messages window to open it. Position the cursor at
message No. 2.

6 Enter the following message:
Motor temperature too high

7 Perform the following settings in the "Attributes" window:
Priority: 1
Acknowledgement: 1
Print: �

The figure shows the configured alarm message:
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5.8.15.2 How to create message areas

Objective

Create the following message areas taking an OP 17 and a SIMATIC S7-300 as an
example:

Procedure

Procedure:

1 Double-click "Area Pointers" on the left of the project window.

2 Select "Event Messages" at "Type" and then click OK. A new dialog box is
opened.

3 Select the PLC on the "Address" tab. Enter 4 at "Length".

4 At "Area" enter "DB 60" and confirm by clicking OK.

5 To configure the other communication areas, repeat steps 2 to 4 and enter
the corresponding values.

Result

Areas have been created for "event messages" and "alarm messages". At
"Length", four words have been panned , meaning that you can configure 4*16 =
64 messages in each case.

Note

The "PLC acknowledgement" area must be contiguous with the "alarm messages"
area.
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5.8.15.3 Message areas for SIMATIC S5

Memory on a SIMATIC S5

The message area is defined in memory words - for example:

FW 50
Length 2

5.8.15.4 Message areas for SIMATIC S7

Data words on a SIMATIC S7

The message area is defined in a data block - for example:

DB 70
DBW 0
Length 4
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5.8.15.5 Examples of displaying system messages

Introduction

You will find examples of system messages and how they are displayed on the
operating unit in the following

SIMATIC OP

The system messages of the operating unit are read out.

For example, $ 339 startup completed

Some system messages expect confirmation or a decision by the operator - for
example:

557 Save data record?
0 Yes / 1 No

You decide on how you want to proceed by entering 0 (Yes) or 1 (No).

SIMATIC S7 (Minimal)

The message numbers of the S7 system messages are output. You can refer to
the cause of the error in your S7 manual by means of the number.

MESSAGE S4303 03.07.98 15:16:34

SIMATIC S7 (Standard)

In addition to the minimal display, the message text of the S7 system message is
output. For this, select the corresponding message with the help of the arrow key.

MESSAGE S4303 07.03.98 15:16:34

If you press the RIGHT arrow key:

PLC_1:
STOP by operating Stop switch

SIMATIC S7-FM

The message text of FM system messages is output.

SIMATIC S7-NC

The message text of NC system messages is output.
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5.8.15.6 Event messages export file

Structure

Below you can see how the export file of the illustrated event messages is
structured:

SIMATIC ProTool/Pro B5.0.0.20 d 16.06.98 11:31:20

Legend:

:N: = Number

:T: = Text

:I: = Help text

:A: = Attributes

:V: = Tag

:L: = Text lists

Pieces of text may be distributed over several ':T:' lines,

Help text may be distributed over several ':I:' lines.

In message text (:T:), the following control characters are possible:

'\n' = New line

'\b' = Flash (Start/End)

'\u' = Underscore (Start/End)

'#' or '&' = Placeholders for message tags
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The following identifications are used in the attribute line:

Px = Priority x

Ax = Output (port number) x

R+- = Relay ON (+) or OFF(-)

D+- = Print (+) or do not print (-)

:N: 0001

:T: "Tank1 empty:####"

:A: P1 A0 D+ R-

:V: "Z_BAUDR" Dd TO

. . .

:N: 0005

:T: "Mixer full, \n"

:T: "Valves of Tanks 1 to 3 closed"

:A: P1 A0 D- R-
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5.9 Use functions

Basic principle

In ProTool you can link "events" (such as "Key pressed") with predefined functions.
If the event occurs during operation, the function executes a specific action on the
operating unit or the PLC.

For example, the "Select Screen" function on the operating unit opens a particular
project screen.

Triggering a function

Areas of application

In general, you can use functions to:

• Set up the project for specific processes
(for example, to switch from one screen to another)

• Control the process
(for example, to set a bit in order to switch on a motor with it)

• Use features of the operating unit
(for example, to display or print out the message buffer)

• Perform system settings online on the operating unit
(for example, change modes)

In most cases you can configure the behavior of the functions precisely by means
of parameters. If you wish to initiate several actions, you can also combine different
functions.
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Configuration

You configure functions on the "Functions" tab in the "Properties" dialog box of the
object in question.

In addition, you can define global entry points (for example, for change of screens,
buffer overflow and change of password) for many operating units by choosing
"System" > "Functions" from the menu.

5.9.1 Events for triggering functions

Necessity

The execution of a function is always linked to a specific event. The function is only
triggered when this event occurs.

The events that can be linked to a function depend on the type of the function.
Many functions are only effective with certain specific events.

Examples of events

Examples of events that can trigger functions are the events "press key" and
"release key". In the case of the former, the function is executed the moment a
particular function key is pressed; in the latter case, it is executed the moment the
function key is released again.

Object-linked functions

Functions and events are generally linked to a specific object. The following
objects can be linked to functions, for example:

• Function keys, soft keys and buttons

• Screen objects

• Screens

• Tags

Functions with tags are triggered only if the tag is displayed on the screen (default)
or "Read Continuously" is selected on the "Options" tab in the Properties dialog
box for the tag.

A function which you have configured for an internal tag (without PLC connection)
whose value is modified by another function is not executed.Functions are
executed only as a result of changes of values triggered by the PLC.

Note

Depending on the operating unit, it might not be possible to configure functions for
all these objects.
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Global functions

You can also link some functions to global, object-independent events - for
example:

• Changing screen

• Buffer overflow

• Change of password

The configurable global events depend on the operating unit:

You will find a detailed description of all the permissible events in online Help
under the keyword"Configurable events".

5.9.2 Function parameters

Necessity

Many functions can only execute one particular action. For example, the Events
- Delete Buffer function empties the buffer for event messages.

Function without input parameters

However, many functions can also work in various ways.
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Input parameters

Imagine that you want to open another screen using a key on the operating unit. To
do this, you configure the Select Screen function. However, your project will
generally have several screens. Which of these screens should ProTool open?

You therefore have to give the function more information. This is done using
parameters. For the Select Screen function, you specify as a parameter the
name of the screen to be opened, for example.

Another example is the Language function. In this case, the parameter you specify
is the language to be set.

Function with input parameters

Some functions require a single parameter; others require several.

Output parameters

Some functions write the result of their execution (i.e. the current status) to a tag.
You can then further evaluate the value of this tag, for example in order to display
a setting-dependent text on the operating unit.

One example is the function Scaling Linear. Specify tag values as input
parameters; the function provides the scaling result as the output value.

Note

Output parameters cannot be configured for all operating units.

Function with input and output parameters

Special case: program-controlled behavior

In the case described above, the behavior of the functions does not change at run
time. However, in the case of some operating units and some functions, you can
also pass the value of a tag as an input parameter. The behavior of the function
can thus be controlled by the program.
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General principle

The following figure illustrates the principle of how a function works:

How a function works

An input parameter is specified for the function. This can be either constant or read
from a tag. The tag may be local or it may have a connection to the PLC. If there is
a connection to the PLC, the value is set by the process. The result of the function
is written to a tag, which itself can either be local or have a connection to the PLC.
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5.9.3 Combining multiple functions

Multiple functions with one object

You can also assign an event several functions. The functions are then initiated
one after the other. You set the order in which this occurs in the "Functions" dialog
box during configuration. You can change the order of the functions by using the
"Up" and "Down" buttons.

Multiple functions with one object

Note

On the OP 3, OP 5 and OP 15 operating units you can only configure a single
function for each object.

Sequence

The list of functions is processed from the top down.

Note

If an error occurs during the processing of a function list (for example, a limit value
is exceeded), processing is aborted. The subsequent functions in the list are not
executed in this case.
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5.9.4 Function screens

Select Function Screen function

The Select Function Screen function accesses internal screens. These
screens are stored in the firmware of the operating units and cannot be changed in
the project. When a function screen is called, a screen is displayed in which the
operator can then execute the function.

The function screens are integrated during configuration by means of the Select
Function Screen function. Some functions can be called both directly by means
of a function (individual function) and by means of a function screen. Other
functions are available only via function screens or only as individual functions.

In the case of an individual function, you specify a parameter. The function is then
executed directly with the set parameter. In function screens, the operator can
select a parameter and then execute the function.

If a function exists in the project as both an individual function and a function
screen, the current status of the function is displayed when the function screen is
called.

All the existing function screens are used with the supplied standard screens.

Example

A soft key is assigned the function Alarms - Display First/Last and the
parameter Last. If you press the key on the operating unit, the setting Last is
applied.

Another soft key is assigned the function Function Screen and the parameter
Alarms - Display First/Last. If you press this key on the operating unit,
the function screen for setting the alarm message display is called.

It indicates the current status:

Message Display: Last

You can then use the arrow keys on the operating unit to select a different setting
and then press ENTER to accept it.
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5.9.5 Special features with conversion functions

Problems

When conversion functions are applied to tags that use the same tag as a
parameter, incorrect calculations can result.

Example

You have configured a screen with two tags, x and y: tag x for an input/output, tag
y for an output. Both are PLC tags.

Tag x has been assigned the Scale Value function as follows: y=10*x. The
function is to be executed when a value is entered.

Process

Let us assume that the value of x is currently 1 on the PLC and the operating unit.
If you then enter 2 as the value of x on the operating unit, the wrong value of 10 will
appear for y. The reason for this is as follows:

The function is executed when a value is entered. However, the new value x is not
yet on the PLC. The function thus takes the old value for x from the PLC.
Consequently, the result is incorrect.

Action

In order to get around this problem, set Value Output as the condition for
execution. The function is thus not triggered until the value changes on the PLC.

Note

The usage of this function with OP 7/17 and the connection to a SIMATIC S5 can
lead to rounding errors, as with the OP 7/17 internal calculations are made with
double values which are then redisplayed as integer tags.
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5.9.6 Example of configuring a function

This example shows you how to configure the "Mode" function with parameters so
that "Online" and "Offline" modes can be set with function keys. In addition, the
result of the operation will appear on the operating unit.

5.9.6.1 How to change the operating mode

Objective

You want to set the Online and Offline operating modes by means of two
function keys. To do this, you configure the Mode function with a parameter.

Procedure

Procedure:

1 Create and open the screen in which the switchover and display take place.

2 Click the function key that you want to use to enable the Online operating
mode.

The "Function Key" dialog box appears.

3 Select the "Functions" tab.

4 Select the "Display Selectable Functions" check box.
The "Select Function" window appears.

5 Select the Mode function at the "Toggle" function group:

.



Release 12/01 Configuration techniques

ProTool User Manual How to configure text-based units
A5E00149249 5-61

Procedure:

6 Click the "Add" button.
The "Parameters" dialog box appears.

7 Select the Operating Mode parameter from the list, and enter the value 0
in the input field under the list. This parameter controls the behavior of the
"Mode" function, so the mode changes to online.
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Procedure:

8 Click OK to close the "Parameters" dialog box.
The function then appears in the "Selected Functions" list.

9 Close the "Function Key" dialog box by clicking "OK".
Your configuration of the function for enabling the Online operating mode is
thus complete.

10 Repeat steps 2 to 9 for the second function key. In step 7, however, use 1
this time as the parameter .

At run time, the operator can then set the operating mode using the two
configured function keys.
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5.10 Create recipes

Requirements

In order to be able to configure recipes, you require one of the following operating
units:

• OP 5, OP 15

• OP 7, OP 17

• C7-623, C7-624

• C7-633, C7-634

Purpose

The purpose of recipes is to transfer a group of related data to the PLC, "together"
and "synchronously".

Recipe and data record

The terms "recipe" and "data record" are defined below using the example of a
bottling plant for a fruit juice system:

Recipe and data record illustrated by analogy with a filing cabinet
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• "Recipe"
Recipes correspond to the drawers of the filing cabinet in the figure (for
example, Orange or Lemon). The reference value fields (tags) that belong to
the recipe are defined in the recipe. You use the recipe to define the data
structure in your ProTool project. You cannot change this structure
subsequently on the operating unit. You can configure up to 99 recipes in
ProTool.

• "Data record"
Data records correspond to the filing cards in the drawers of the cabinet (Drink,
Juice and Nectar). A data record contains the values for a recipe. You create,
delete and modify data records on the operating unit. You can create up to 99
data records for a recipe.

Example of a recipe

The filling station above is used to produce orange drink, orange juice and orange
nectar. The mixing proportions for each of these are different. The ingredients are
always the same.

Let us assume that a recipe called "Mixture" is created, containing the following
data structure:

Tag Designation

Var_23 Name

Var_11 l orange

Var_7 l water

Var_19 kg sugar

Var_21 g flavor

The tag designations Name, l orange, g flavor etc. are known as "entry
names". The entry names are displayed as well on the operating unit. Tag Var_11,
for example, can thus be identified as the tag designating the mixture ingredient
orange.

The data records contain the values for the different drink types. The data records
could be as follows, for example:

Data record name Orange drink
value

Orange juice value Orange nectar
value

Name "Drink" "Juice" "Nectar"

l orange "90" "95" "70"

l water "10" "5" "30"

kg sugar "1,5" "0,5" "1,5"

g flavor "200" "100" "400"
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Same tags in screens and the recipe

For each ingredient (orange, water, etc.) there is a separate screen in the above
example, containing a supply tank, valves, an overview of the quantities used and
other information. The screens contain input fields that allow you to set the various
supply quantities for the mixer. You can thus enter the mixing proportions screen
by screen. The mixer is then started. This process is repeated for each drink type.

If the tags of the input fields are formed into a recipe, you can store finished
mixtures for the different drink types by creating data records on the operating unit.
The figure below shows how to use the same tags in screens and in the recipe.

To produce a specific drink type, the corresponding data record is transferred to
the PLC. All tags are thus assigned the required values at the same time.

Same tags in screens and the recipe
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5.10.1 Configuring a recipe

Identifying a recipe on the operating unit

You create a recipe in your project with a symbolic name. This name is only
relevant on the configuration computer, not on the operating unit. The recipe is
identified on the operating unit by means of the "recipe number" and "recipe
heading" set in the project.

You create the recipe heading in the recipe editor by choosing "Edit" >
"Properties". In addition, ProTool automatically assigns a number to the recipe.
You can also change this number by choosing "Edit" > "Properties".

Both the recipe number/name and recipe heading are visible on the operating unit
and enable you to select the recipe from the recipe directory.

Identifying a data record

You create a data record on the operating unit with a symbolic name. This name is
only relevant on the operating unit. In addition, the operating unit automatically
assigns a number to the data record. When a data record is transferred to the PLC,
only the recipe number and data record number are transferred with the data, not
the symbolic names.

Since the data record's number is its unique identification attribute, you can create
several data records with the same name but not with the same data record
number.

The operating unit writes the data and number of the data record and of the
associated recipe to specified locations on the PLC:

SIMATIC S5

Numbers: Recipe number mailbox

Data: Recipe mailbox,
possibly successive recipe mailbox

SIMATIC S7

Numbers: Data mailbox

Data: To the addresses directly

You will find more information on the recipe number mailbox, recipe mailbox,
successive recipe mailbox and data mailbox in the "Communication User's
Manual".
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Tags in recipes

Tags that you use in recipes must have an address on the PLC. Only these tags
will be transferred to the PLC when a data record is transferred. Tags without an
address are not transferred.

Note

Functions you have assigned to recipe tags are not executed in recipes.

Standard screen for recipes

The standard screen Z_RECORD is available so that you can create, edit, delete
and transfer data records on the operating unit. This screen is already integrated in
the standard project and can be displayed on the operating unit by means of a
function key.

Recipe entries

Recipes consist of individual entries. Each entry consists of a maximum of one
input field and an optional text. You can configure direct or symbolic entries for the
input field. By way of example, the figure below shows the "mixture" recipe with its
entries.
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In contrast to screens, the operating unit can display several entries for recipes at
the same time. The table shows how many lines and characters per line are
available with the different operating units.

Operating Unit Lines Characters per line

OP 5 2 17

OP 7 2 17

OP 15A 1 36

OP 15C 2 17 / 36

OP 17 2 17 / 36

C7-623 2 17

C7-624 2 17

C7-633 2 17

C7-634 2 17 / 36

Recipe entries: number of available lines and characters per line

Note

When you download a new project to the operating unit, the configuration memory
is deleted, and with it all the data records created there.
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5.10.2 Transferring data records

Note

How to create data records and transfer them to the PLC is described in detail in
the manual of your operating unit.

Transferring data records when working on the operating unit (standard case)

The transfer of data records from the operating unit to the PLC and vice versa is
the standard case. The special cases are described in the "Communication User's
Manual". We recommend that you only transfer data records by using the operating
unit. To do this, use the standard screen Z_RECORD.

• Creating data records
Data records can only be created on the operating unit and saved in the flash
memory there. The operating unit automatically creates a data record with the
number 1 for each recipe. All the values of the data record are preset with 0.

Copy this data record and save it by a different name in order to create other
data records.

• Synchronization during transfer
An essential feature of recipes is that the data are transferred with
synchronization and uncontrolled overwriting of the data is thus prevented. In
order to ensure coordinated operation when data records are transferred, bits
are set in the control and acknowledgment area of the interface area.

The interface area for the SIMATIC PLCs is described in the "Communication
User's Manual". For non-SIMATIC PLCs, the interface area is described in
"Communication areas for non-SIMATIC PLCs".

• Functions
ProTool offers functions for:
– Transferring data records from the PLC to the operating unit
– Transferring data records from the operating unit to the PLC

Assign a function like this to a function key. The parameters of the function
contain the recipe name and the data record number.

• Transfer screen
A transfer screen is available on the operating unit for transferring data
records. This allows you to transfer data records in the following directions:
– From the operating unit to the PLC
– From the PLC to the operating unit
– From the operating unit to the operating unit
(which corresponds to copying a data record)

Transferring data records by means of a PLC program

You can transfer data records from the PLC to the operating unit and the other way
round by means of PLC jobs 69 and 70. Data records can be read directly into the
FLASH memory or read from it using PLC jobs.
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5.11 Prompting the operator

Purpose

In addition to the option of customizing the user interface of your operating unit to
make it easier for you to use, ProTool features other options for supporting and
prompting you on your operating unit as a function of the situation. This means you
can implement mechanisms and decision-making aids that can prevent possible
incorrect operations on the operating unit.

ProTool makes the following methods available for the implementation of operator
prompting:

• Providing Help text

• Assigning dynamic attributes

• Evaluating key operation

• Driving light-emitting diodes

• Assigning operator authorization
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5.11.1 Help information on the operating unit

Purpose

Help text provides additional information and operator instructions on screens,
input and output fields, and buttons and messages to the operator at run time. Help
text provides additional information that can be defined for screens, input/output
fields, buttons and messages when configuring with ProTool. For example, Help
text may be in the form of the permissible range of values for an input field or the
cause and elimination of a malfunction in the case of an alarm message. Help text
is displayed on the operating unit in the language you set.

You configure Help text on the "Help Text" tab in the "Properties" dialog box of the
object in question.

In addition to Help text, you can configure tooltips, which are displayed at run time,
for some devices and screen objects.

Displaying Help text on the operating unit

• Operator Panels
The availability of Help text is indicated on the operating unit by the lit "HELP"
LED. On touch panels, the "HELP" button is displayed. The configured Help
text can be output by pressing the "HELP" key.

Detailed information about activating Help texts is given in the equipment manual
for your operating unit.
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5.11.2 Dynamic attributes

Purpose

To draw the operator's attention on the operating unit to specific situations for
example, specified limit values have been reached or exceeded you can configure
the dynamic attribute "Flashing" for output fields. This enables you activate or
deactivate the flashing attribute for the displayed text according to the value of a
tag.

Index tag

You can either link the dynamic attribute directly to the tag of an output field or you
can define a separate index tag for it. You can influence several output fields
simultaneously with a separate index tag.

5.11.3 Evaluating key operation

Purpose

Keystrokes executed on the operating unit can be transferred to and evaluated by
the PLC. This means, for example, that you can issue a message that will draw the
operator's attention to the incorrect operation of a key.

Requirements

For the PLC to be able to evaluate whether and, possibly, which key has been
operated on the operating unit, you have to create specific data areas on the PLC
and specify them in your project, in the project window, at "Area Pointers". These
are the two data areas "system keyboard assignment" and "function keyboard
assignment", depending on which keys you wish to evaluate. You set the
assignment of the function keys to the bits in the function keyboard assignment
when you configure the function keys.

You will find a description of the keyboard assignments for the different operating
units in the "Communication User's Manual".

You will find more information on communication by your operating unit with a non-
SIMATIC PLC in "Keyboard assignment of the operating unit".



Release 12/01 Configuration techniques

ProTool User Manual How to configure text-based units
A5E00149249 5-73

5.11.4 Light-emitting diodes on the operating unit

Purpose

The light-emitting diodes (LEDs) on the function keys of the operator panel can be
driven on the PLC. By means of a light-emitting or flashing LED, you can indicate
to the operator that, for example, the device is expecting a certain function key to
be operated.

Requirements

For the PLC to be able to drive the LEDs, you have to create the "LED assignment"
data area on the PLC and specify it in your project, in your project window, at "Area
pointers". Set the assignment of the individual LEDs to the bits in the LED
assignment when you configure the function keys.

You will find a description of the LED assignment and the LED functions for the
different operating units in the "Communication User's Manual".

You will find more information on communication by your operating unit with a non-
SIMATIC PLC in "LED assignment of the operating unit".
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5.11.5 Assigning operator permissions

Purpose

ProTool allows you to use a password to prevent controls such as input fields and
function keys from being used by those unauthorized to do so. This means that
when you are creating your project you can restrict the use of functions that relate
to security to specific people or groups of operators. Important parameters and
settings can thus only be changed by authorized personnel.

The access protection that you configure allows you to guard against incorrect
usage and increase the security of the system or machine.

Password hierarchy

During the configuration phase you can assign operator authorization to specific
groups. At run time, individuals can be allocated to one of these groups, as
appropriate, and they thus automatically receive the access rights of that group.

ProTool provides hierarchically organized password levels from level 0 to 9. If a
user is assigned password level 4, for example, this user is authorized to execute
the functions of password levels 0 to 4.

• Password level 0
Password level 0 is the default in ProTool. Use this lowest level in the
hierarchy for functions that have little or no effect on the operational sequence.
These are generally functions that do not required any input, such as the
display of messages. There is no need to enter a password on the operating
unit in order to execute functions with password level 0.

• Password levels 1 to 8
Assign functions to password levels 1 to 8 according to their importance.
Before you execute these functions, the operating unit prompts the operator to
enter a password.

• Password level 9
The authorization to execute functions at password level 9 is granted only to
the system administrator or service engineer. He has access to all the
functions of the operating unit.

You define the password of the system administrator by choosing "System" >
"Settings" from the menu. The default setting is 100.

The administrator's password setting cannot be changed on the operating unit at
run time. All other passwords are entered at run time; you have to configure a
password list for this.

You can find more information on password administration in the equipment
manual for your operating unit.
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Logging into and out of the operating unit

• When a password-protected operation is executed, the operating unit
automatically prompts the operator to enter an appropriate password. In order
to eliminate the possibility of unauthorized persons gaining access, a password
level greater than 0 should not remain active on the operating unit for any
length of time.

• If you do not enter an input on the operating unit for a configured period of time
(logout time), the operating unit automatically resets the current password level
to 0. You set the logout time by choosing "System" > "Settings" from the
menu. The system default setting is 5 minutes.

Note

Login and logout operations are automatically output as system messages. If you
have configured a message archive, all login and logout operations on the
operating unit will be archived.

Setting the password level on the operating unit

The following PLC jobs are available for setting a defined password level on the
operating unit:

• You can use PLC job 23 to set a password level of your choice on the
operating unit from the PLC in order to allow access by a defined user group,
for example.

• You can use PLC job 24 to reset the password level back to 0 from the PLC.

In online Help, you will find a list of all possible PLC jobs with job numbers and
parameters in PLC jobs in alphabetical order and PLC jobs in numerical order.
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5.12 Configuring in foreign languages

This chapter shows you what you need to know in order to create a project with a
user interface in a foreign language.

You can create a monolingual or a multilingual project. In a multilingual project you
can decide:

• Whether to make several languages available on an OP and provide the user
with a key for switching between them.

• Whether to download only one language to a specific OP.

5.12.1 System requirements for foreign languages

Languages available

With the exception of Russian, you can configure all foreign languages without
having to make changes to your Windows system configuration.

To be able to configure in Russian (OP 7, OP 15C, OP 17 and TD 17 only), you
have to enable Russian language support in Windows 98 ("Control Panel" >
"Software" > "Windows Setup" > "Language Support" > "Details"). This is not
necessary in Windows NT.

Alternatively, of course, you can also install a Russian version of Windows.

Not all the characters of the ANSI font can be displayed on the screen, depending
on the panel. The precise assignment of ANSI code and displayed character will be
found in the character map for the operating unit concerned.
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5.12.2 Languages in ProTool

User interface language and project languages

ProTool makes a distinction between two language levels:

• The "user interface language" in ProTool
This is the language in which the menu and dialog box text blocks are
displayed when you configure in ProTool/Pro CS. The user interface language
is selected from ProTool's Setup.

• The "project languages"
These are the languages in which the blocks of text in your project appear on
the operating unit. You can create the project in any language available in
Windows on the configuration computer.

The two language levels are completely independent of each other. For example,
you can create French projects with an English ProTool, or English projects with a
French ProTool.

Multi-lingual projects

If you want your project to run in different languages, store all language-dependent
objects in the desired languages in the project. This applies, for example, to:

• Event messages

• Alarm messages

• Screens

• Recipes

• Text lists

• Help texts

You can store text for any project in as many project languages as you like. When
creating your configuration, however, note that the languages supported at run
time depend on the operating unit.

You cannot edit system messages in ProTool. They have been stored for every
operating unit for a number of languages already. If you are configuring a language
for which no system messages are available, all the system messages will appear
in English.

Editing language

The project language in which you edit text at any given time on the configuration
computer is the "editing language".

The toolbar and the status bar show the current editing language setting.
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Reference language

One of the project languages can be used as the "reference language". You can
first create all the blocks of text in the Reference language and then use them as a
basis for other translations when you enter your translated text directly into the
project.

When you are configuring, you can toggle between the reference language and the
editing language you have set.

Online languages on the operating unit

You can even download several of these project languages simultaneously to the
operating unit, depending on the operating unit. For the operator to be able to
toggle between these languages, you must provide him with a suitable control.

When creating your configuration, note that the languages supported at run time
depend on the operating unit.

Language levels in ProTool

Exchanging text with translators

If you wish to send the blocks of text in the reference language for translation, you
can export all blocks of text in a project from ProTool. The translator can edit the
blocks of text outside ProTool, either in Excel, for example, or a text editor. The
translated blocks of text are then imported into your ProTool project and
automatically inserted at the correct places.
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5.12.3 Configurable languages

Languages

You can create projects for text-based devices in the following languages:

• OP 7, OP 17, TD 17
- Danish
- German
- English
- Finnish
- Flemish
- French
- Greek
- Italian
- Norwegian
- Polish
- Portuguese
- Russian
- Swedish
- Spanish
- Czech
- Turkish
- Hungarian

• OP 3, OP 5, OP 15A/C
- German
- English
- French
- Italian
- Spanish

In addition, you can use Russian for the OP 15C.

Note

If you make do without language dependent special characters, you can enter text
in a different language too.

For example, you can select "English" as the language in ProTool, but enter text in
Dutch. However, all system messages will continue to appear in English, since
they cannot be edited in ProTool.
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Standard projects

The following languages are supplied in the standard projects supplied as part of
the package:

• German

• English

• French

• Italian

• Russian

• Spanish

Should you wish to configure another language, you have to add it yourself and
also translate the pieces of text in the standard projects.
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5.12.4 Language dependent keyboard assignment

Language dependence

The characters on a PC keyboard are language dependent. For example, no
German or French special characters are available on an English keyboard.
Further, the letters are arranged somewhat differently.

As soon as you change the editing language in ProTool, it modifies the assignment
of your keyboard to the layout of the foreign language concerned.

On-screen keyboard

In order to facilitate the assignment of the characters printed on your keyboard and
those actually entered, ProTool displays a language-dependent on-screen
keyboard. You can see on the on-screen keyboard where the deviating characters
are located.

There are two options to choose from for entering a language-specific character:

• Orientate yourself on the on-screen keyboard and enter the character on the
keyboard of the configuration computer.

• Click your mouse to enter the character directly via the on-screen keyboard.

Example of language-dependent on-screen keyboard with French as the editing
language

The on-screen keyboard is hidden automatically as soon as you reset the editing
language back to the current Windows language. You can also enable and disable
display of the on-screen keyboard by choosing "View" > "Keyboard".

Note

You can only use the on-screen keyboard if the corresponding keyboard layout has
been installed under Windows. Enable the keyboard at "Start" > "Settings" >
"Keyboard". If you have not done it, ProTool will resort to the international (US)
layout.
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5.12.5 Reference text

Principle

When you create a project for several languages, you normally configure all the
pieces of text in your native tongue first.

If you then change the editing language to enter text in a foreign language, all the
text fields appear blank again.

ProTool features a user-friendly reference text function so that you have a basis for
your translations. In dialog boxes and in screen editors, you can display an
additional window with blocks of reference text.

Reference text

In the editor you can insert the translation of the blocks of text in the reference
window text without having to switch from one language to another.

Note

Text can be exported by choosing "Edit" > "Language" > "Export" from the menu or
by using the shortcut menu in the project window. The blocks of text can be
translated independently of ProTool in this way, and then imported in your project.
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5.12.6 Steps to creating a multilingual project

Scenarios

The basic approach is identical no matter whether:

• You configure a project in a language other than that of your ProTool
installation. (Example: you have ProTool in German and would like to create a
French project.)

• You want to sell a project to several countries, in the language of the countries
concerned. (Example: you are sending a machine to Germany, England and
France. You want all pieces of text to be displayed on the operating unit in the
language of the countries concerned.)

• You supply a project to a multilingual country. (Example: you are selling a
machine to Switzerland. You want the operator to be able to choose between
German, French and Italian on the operating unit.)

In any case, you should always attempt to create and test the project in one
language first. This language then acts as your reference language for the
translations.

Steps

Configuring in foreign languages consists of the following specific work steps:

1. Satisfy the necessary system requirements.
2. Define the configured languages (choose "Edit" > "Language" > "Select" from

the menu).
3. Select a language as the first editing language (choose "Edit" > "Language" >

"Select" from the menu).
Create and test the complete project in this language first, before proceeding to
translate all the pieces of text together later .

4. Configure a language switch (only if you want to offer several languages
simultaneously on one operating unit).

5. Translate the pieces of text.
If you want to enter blocks of text in a foreign language, switch the "editing
language" (choose "Edit" > "Language" > "Select" from the menu). You select
the language in which you have created the project to be your "reference
language" (likewise option "Edit" > "Language" > "Select"). You can now have
reference language text displayed and enter the text in the editing language.
If you want to send text for translation, you can export it in csv format (choose
"Edit" > "Language" > "Export" on the menu). After being translated external to
ProTool, you can accept them into your project (choose "Edit" > "Language" >
"Import" from the menu).

6. Select the languages to be downloaded to a specific operating unit (choose
"System" > "Language Assignment" from the menu). You can select up to
three languages simultaneously.

7. Compile the project.
8. Download the project to the operating unit.
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Note

Avoid moving fields in event messages and alarm messages when you modify a
project that has been created in several languages. Since there is no permanent
assignment between the field and its position within the text, you should move the
pieces of text if necessary instead of the fields.
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5.12.7 Exchanging text with translators

Editing blocks of text external to ProTool

If you configure a project in several languages, the simplest approach is to create
and test the complete project in one language first.

You can then pass all the blocks of text to translation and, after that, include the
translated text in your project.

The advantages of this procedure are as follows:

• The workload of the configuration engineer is reduced, since he only has to
create the user interface in a language familiar to him.

• The translator can edit the blocks of text outside ProTool, either in Excel or a
text editor.

• The translated blocks of text will be complete and consistent.

Scope of text export/import

Using the ProTool's text export/import function, you can export and import blocks of
text for the whole project, text from specific editors or text of separate objects. The
scope of export/import depends on the command:

• Export/import blocks of text for the complete project.
When you issue a command to export/import text by choosing "Edit" >
"Language" > "Export" or "Import" on the menu, all blocks of text for the
complete project are exported or imported. The import operation cannot be
undone. But you can remove all blocks of text in a language from the project by
deleting that language. You will find detailed information by referring to
"Deleting a project language".

• Export/import blocks of text of a certain editor or object.
You can start exporting/importing text in the project window by means of the
shortcut menu (right-click) of the editors and objects. Only those blocks of text
can be exported or imported that belong to the selected editor or object. A text
import operation started from the shortcut menu can be undone.

Exporting different text types

When exporting, you can select the types of text you would like to export:

• Text visible on the screen (such as labeling, names)
It is stored in the file called "Labeling.csv".

• Info text (such as Help text for screen objects and messages)
It is stored in the file called "InfoHelptext.csv".

• Message text (event messages and alarm messages)
It is stored in the file called "MessageText.csv".

• Other text (message settings, text lists)
It is stored in the file called "MiscText.csv".
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The default setting is export of all text types.

The classification of the text types is done in accordance with the requirements that
have to be taken into account in translation. For example, the placeholders have to
be preserved in message text, and when text visible on the screen is translated it
might be necessary to take the limited text length into account.

Importing text

You can insert translated blocks of text in your project by choosing "Edit" >
"Language" > "Import" or by using the shortcut menu of the editors and objects in
the project window. The individual blocks of text are automatically assigned to the
objects in the project.

Note

You can undo an import of alarm message text.

To view imported text in foreign languages, set the editing language to the
language concerned.

• If you did not specify a target language for the translation when you exported
the text, you must specify the language into which the text was translated when
you import it.

• If this language is not available as a "configured language" in your project, it is
created automatically.

Note

Remember not to change or add text manually in the time between exporting and
importing the text but to have these changes translated in good time. Manually
changed or added text will be overwritten by the text in the import file on being
imported.
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5.12.8 Special characters and language dependent characters

Special characters and language dependent characters

Special characters and language dependent characters can also be used when
configuring text. This applies to:

• Messages

• Screens

• Recipes

• Information text

• Text or graphic lists

• Headers and footers

The characters can be viewed right on the screen.

Characters that cannot be represented

However, the operating unit cannot represent all characters. On certain equipment
variants, a language is loaded complete with its language dependent characters. It
is not possible to mix language dependent characters such as ä and é.

If you edit in a character that cannot be represented on the operating unit, a space
is displayed instead.

Cyrillic font

Operator panels OP 7, OP 15 C and OP 17 as well as text display TD 17 can also
display the Cyrillic character set. If you have selected Russian by choosing "Edit" >
"Language" > "Select", from the menu, you can enter both Cyrillic and Latin
characters on the keyboard:

• All lowercase letters produce Cyrillic characters.

• All uppercase letters produce Latin characters.

• Digits and punctuation continue to be available.

The precise assignment of Latin and Cyrillic characters depends on the operating
unit. You will find more on this topic in the character map for the OP 7, OP 15C,
OP 17 and TD 17.

Character maps for the different operating units

From the character map applicable to the configured operating unit you can see

• which characters can be displayed on the operating units, and

• how the assignment is between the displayed character and the ANSI Code.
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Entering special characters

You can enter special characters on the numeric keypad on the keyboard. Enter
ALT + "0XXX", where "XXX" is the ANSI Code from the character map applicable
to the configured operating unit.

By choosing "Window" > "keyboard" from the menu, you can open a keyboard
assignment on the screen. If you keep ALT GR pressed down, the on-screen
keyboard displays ANSI characters. You then enter these characters either on your
keyboard or on the on-screen keyboard by clicking the mouse on the
corresponding keys.

5.12.8.1 Character map for OP 7, OP 15C, OP 17 and TD 17

Entering special characters

You can enter special characters on the numeric keypad on the keyboard. Enter
"ALT" + "0XXX", where "XXX" is the ANSI code from the character map.

If you choose "Window" > "Keyboard" from the menu, you can open a keyboard
assignment on the screen. If you keep ALT GR pressed down, the on-screen
keyboard displays ANSI characters. You then enter these characters either on your
keyboard or on the on-screen keyboard by clicking the mouse on the
corresponding keys.

Cyrillic font

Operator panels OP 7, OP 15 C and OP 17 as well as text display TD 17 can also
display the Cyrillic character set. If you have selected Russian by choosing "Edit" >
"Languages" > "Select" from the menu, you can enter both Cyrillic and Latin
characters on the keyboard:

Refer to the following table for the assignment of keys and the ANSI Code:
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5.12.8.2 Character map for OP 3, OP 5, OP 15A (with LCD)

Entering special characters

You can enter special characters on the numeric keypad on the keyboard. Enter
"ALT" + "0XXX", where "XXX" is the ANSI code from the character map.

By choosing "Window" > "keyboard" from the menu, you can open a keyboard
assignment on the screen. If you keep ALT GR pressed down, the on-screen
keyboard displays ANSI characters. You then enter these characters either on your
keyboard or on the on-screen keyboard by clicking the mouse on the
corresponding keys.
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5.12.8.3 Character map for OP 15A-VF (with VF display)

Entering special characters

You can enter special characters on the numeric keypad on the keyboard. Enter
"ALT" + "0XXX", where "XXX" is the ANSI code from the character map.

By choosing "Window" > "keyboard" from the menu, you can open a keyboard
assignment on the screen. If you keep ALT GR pressed down, the on-screen
keyboard displays ANSI characters. You then enter these characters either on your
keyboard or on the on-screen keyboard by clicking the mouse on the
corresponding keys.
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6 Testing projects

Principle

Once you have completed your entire project or self-contained parts within it, the
"test phase" starts.

The following steps must be taken:

1. Compile your project: Your project is transformed into a file that is capable of
running on the operating unit.

2. Download your project: The project is downloaded to the operating unit.
You have to perform some settings for this.

3. Test your project: Should you find other errors, troubleshoot them and start
again at step 1.

Note

If you are using a SIMATIC S5 or S7, configure "Status/Force" in order to test
specific tags in the PLC program.
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6.1 Downloading the executable project file

Basic procedure

To download the project file, you have to do the following:

1. Set the transfer mode.
2. Select an interface on the configuration computer.
3. Select a storage medium on the operating unit.
4. Download the project file.

Note on text-based displays

When a new project file is downloaded to the operating unit, the memory is
deleted, and with it all the data records on the operating unit.

Special features

These deviations from the basic procedure are only to be carried out the first time:

• Download mode: The first download is always a "serial download".

• Firmware: Before a compiled project file can be downloaded to the operating
unit for the first time, the firmware of the operating unit is downloaded
automatically. A corresponding status message is issued.

Download not possible

If no connection to the operating unit can be established, a status message to this
effect is output. Check the physical connection between the operating unit and the
configuration computer.

Note

The project file must not be downloaded directly from the configuration computer to
the module, but must first be loaded into the flash memory on the operating unit,
since the memory organization of the two storage media differs. If the project file
were to be downloaded directly to the module and then loaded into the flash
memory on an operating unit, error states can result.

In the DRAM the data are lost when the operating unit is switched off.
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6.2 Peculiarities of MPI download

Requirements

• MPI download is possible with the following operating units: all graphics
displays and OP 3, C7-623, and C7-624.

• An MPI module is required on the configuration computer.

• The configuration computer and operating unit are connected physically to the
MPI network.

• An MPI network can only be set up with a SIMATIC S7 PLC.

Setting the MPI address on the operating unit

If you have downloaded the compiled project file for the first time, and serially at
that, the operating unit has the configured MPI address.

To carry out an "MPI download", the standard screen "System Settings" must be
configured in the project and the "MPI Download" operating mode must be
selected.

Multiple operating units in the MPI configuration

If you want to integrate multiple operating units in the MPI configuration, you can
only do it successively.

1. Connect the first operating unit physically.
2. Change to serial transfer mode, and download first the firmware and then the

compiled project file.
3. Then connect the next operating unit physically, and so on.

Note

If you were to connect several operating units physically and then download the
project, this would lead to an address conflict. All the operating units would have
the same default MPI address, namely 1 which is not permissible in the MPI
configuration.
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6.3 Directly accessing values on the PLC (Status/Force tag)

Purpose

At runtime you can directly access the connected PLC (SIMATIC S5 and SIMATIC
S7) from the operating unit to read and write values. This means you can monitor
and change the PLC operands easily on the operating unit without having to
connect a programming device or PC to the PLC as well.

This is very advantageous particularly during the testing and commissioning phase
of your project.

Requirements

In order to be able to access values on the PLC directly at runtime, the following
requirements must be met:

• The connected PLC must be a SIMATIC S5 or SIMATIC S7

• You must have integrated the two standard screens "Status Tag" and/or "Force
Tag" in your project.

Standard screens

The programming device function "STATUS TAG" is called in the standard screen
"Status Tag". This allows you to monitor PLC operands on the operating unit. Write
access is not possible in this screen.

The programming device function "FORCE TAG" is called in the standard screen
"Force Tag". This allows you to monitor and change PLC operands on the
operating unit.

You will find detailed descriptions about working with the two standard screens in
the "equipment manual" for your operating unit.
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6.4 Troubleshooting

If error messages are issued in the course of working with your project, such as
when you are compiling or downloading your project, you will learn here how you
take remedial action.

6.4.1 Error messages during compilation

Possible messages

While the ProTool compiler is compiling a project, status messages on the
progress of the compilation process are output to a window.

The following messages make a check of your project necessary:

• Notes: It is possible that logical operations in the project are either not correct
or do not exist. Check the project for logical relationships in accordance with
the messages. The compilation process has been properly completed.

• Warnings: The project contains errors that might result in incomplete display on
the operating unit. The full compilation process has been completed.

• Errors: Correct the errors listed and recompile the project. The compilation
process is not completed.
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6.4.2 Error messages while downloading

Possible problems while downloading

While a project is being downloaded to the operating unit, status messages on the
progress of the compilation process are output to a window.

If problems occur while the project is being downloaded to the operating unit, the
cause in the majority of cases is too high a baud rate or the simultaneous use of
other drivers on the configuration computer for example, when connected to a
network.

The most common causes of discontinuation of the download process are listed
below.

Downloading is aborted after a Line Error message

Possible Cause Action

The connecting cable is too long. Select a lower baud rate.

The connecting cable is poorly shielded or
spurious signals are imported onto the
cable by other devices.

Select a lower baud rate.

Computer performance is inadequate. Select a lower baud rate.

Another driver is running in the background
for example, with networking.

Select a lower baud rate.

Downloading stops and crashes

Possible Cause Action

Computer performance is inadequate. Select a lower baud rate.

Downloading does not take place

Possible Cause Action

Connection to the operating unit cannot be
established (message in the system
message window).

Check the physical connection
between the configuration computer
and the operating unit.

The standard communication driver is not
entered in the Windows device manger.

Check the device status of the COM
port in the Properties window of the
device manager.

Interrupt problems.
Various modules are using the same
interrupt.

Modify the configuration of your
computer or install ProTool on a
stand-alone computer.

Other programs block the interface for
example, STEP 5.

Exit from the programs and reboot
your computer, if necessary.
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7 Documenting and managing projects

This chapter details the multiplicity of functions offered by ProTool for printing out,
documenting and managing and archiving your project data.

7.1 Printing project data

Print function

ProTool provides a comprehensive printout function that can be accessed by
choosing "File" > "Print" from the menu. It provides detailed lists for documenting
all project-relevant data such as screens, messages, tags, symbol tables, etc.

Print function in ProTool

In this way it provides the facility for documenting your complete project. An up-to-
date printout can also be very helpful while you are configuring.

Note

When configuring, as an alternative to the printout function, there is also the user-
friendly cross-reference function offered by ProTool.

Chapter

ProTool subdivides printouts into "sections" arranged by subject according to
object types. For example, one chapter contains all the definitions on the subject of
screens, another contains a list of all the tags and yet another a list of all the
defined text or graphic lists.

You can print several chapters at once or just print single chapters.
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Reports

ProTool offers you the facility of customizing printouts to suit your individual
requirements.

• You can limit a printout to single chapters or single pages.

• You can set the order in which the chapters appear.

• You can decide which data you want to output within a chapter.

• You can set margins, define your own headers and footers and embed your
own graphic in the cover.

These definitions are stored in a "report". Frequently required reports have been
defined in ProTool in advance. But you can also create your own reports, as you
wish. All reports are common to all projects.

Every time you want to print, you choose the report with which you would like your
output to conform.

7.2 Project management with integrated operation

ProTool integrated in SIMATIC STEP 7

If you are working with ProTool integrated in SIMATIC STEP 7, use SIMATIC
Manager to manage your projects. You can then copy, move, back up and restore
your projects in the same way as you have been used to from SIMATIC STEP 7.
For further information refer to the documentation on SIMATIC Manager.

Note

ProTool's Project Manager is not available to you in the event of integrated
operation. ProTool data can no longer be viewed independently in this event, since
the data is always linked to a STEP 7 project. It therefore has to be managed and
backed up using this application.
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7.3 Managing projects in stand-alone operation

Project Manager

If you installed ProTool as a "stand-alone" application – in other words, if you are
not operating it under SIMATIC STEP 7 – there is a user-friendly project manager
integrated in ProTool instead of SIMATIC Manager. You can use it to manage your
projects in a user-friendly way.

Usage

With Project Manager, it is simple for you to:

• Archive projects (Backup), using more than one floppy disk too

• Restore archived projects (Restore)

• Open projects

• Delete projects

Backup and restore

The Backup and Restore functions are not possible between devices of different
types.

Backup and Restore are directly possible on the operating units. Refer to your
equipment manual for further information.
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Call

You start Project Manager by choosing "File" > "Project Manager" from the menu.
When you call Project Manager for the first time, the "Find" dialog box is displayed
initially. Here you choose the drives and directories which have to be searched for
ProTool files. Only those projects that are located within these directories are
displayed by Project Manager.

"Find" dialog box

After you have selected the appropriate directories, or when you call Project
Manager later again, the Project Manager window proper appears.
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Display

Project Manager

In the left segment of the Project Manager you will see a hierarchical structure of
all the projects located in the directories in which Project Manager searched. Here
you can select a project in order to open it, delete it or back it up.

In the center segment of the window you will find detailed information on the
project highlighted on the list.

Using the buttons in the area on the right, you can extend the list of scanned
directories ("Find" button), have the directories searched again ("Update" button)
and have the list sorted by different project data such as "project name", "device
type", "date created", etc. ("Sort" button).
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7.4 Constraints with printing

Printer drivers

Note the following constraints with certain printer drivers:

• It might not be possible to print the project with CANON drivers. Printing will be
discontinued in this case.

• With the Apple laser printer, the first line is not printed. This problem does not
occur with drivers for the HP LaserJet III, PostScript or PostScript printers.

ASCII character set

With some printers, it is not enough simply to set the ASCII character set in the
project. Make sure the ASCII character set is set on the printer too.
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7.5 Example of documenting a project

This example shows you how to create a customized printout.

7.5.1 How to create a customized printout

Objective

You wish to print all the data in your project. Unlike the default setting, you do not
want the ProTool graphic but your company logo, which you have already used in
your project under the name of LOGO, to be printed on the cover sheet. You want to
leave a margin for handwritten comments on the right side of the printout.

Procedure

Procedure:

1 Open the project from which you wish to print data.

2 Choose "File" > "Print" from the menu.

3 In the "Print" dialog box at "Reports", choose the Complete report. You will
now see the individual chapters in the "Contents" list in the order in which
they will later be output.
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Procedure:

4 Click the "Preview" button. The print preview shows you how your printout will
look later. You want to replace the graphic on the first page (cover) with your
company logo. You want the right border to be much wider.

5 Exit from the preview by clicking the "Print" button.

6 To perform the changes you require, click the "Reports" button.
The "Reports" dialog box is opened.
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Procedure:

7 To modify the margin, click the "Page" button.

8 Enter the value you require for the right border at "Right" - for example, 3 for
3 cm. If you like, you can specify a piece of text here for the headers and
footers at the same time.

9 Confirm your input by clicking OK. You are now back in the "Reports" dialog
box.

10 To modify the definition for the cover sheet, select the entry Cover Sheet in
the "Contents" list and click the "Parameters" button.

11 In the "Cover Sheet" dialog box, select the graphic called LOGO with your
company logo at "Graphic".

12 Click OK twice until you are back in the "Print" dialog box.

13 Finally, click the OK button to activate the printing process.
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8 Tips for efficient configuration

Here you can obtain useful tips on how to design your configuration in ProTool
even more efficiently.

8.1 Optimizing performance

Principle

If you want to optimize performance to the maximum possible while the operating
unit is operating, the best way to achieve this is by having the best possible setting
for the "update time and acquisition cycle".

The acquisition times specified for the area pointers and the acquisition times of
the tags are important factors for the update times that can actually be achieved.

The following applies to calculation of the update time:

Update time = acquisition cycle plus transfer time plus processing time.

You achieve optimum update times by taking the following points into account
while you are configuring:

• Create the different data areas as small as possible and as large as necessary.

• Define contiguous data areas where they belong. The actual update time
improves if you create one large area instead of several small ones.

• If you select too small an acquisition cycle, it has an adverse degrades overall
performance. Set the acquisition cycle in line with the update rate of the
process values.
Example:
The temperature variation of a furnace, for example, is considerably less
dynamic than the variation in speed of an electric drive.

The guide figure for the acquisition cycle is approx. 1 second.

• If necessary, dispense with the cyclic download of user data areas (data entry
cycle 0) to improve update times. Instead, use PLC jobs to download user data
areas spontaneously.

• Place all message or screen tags in a data area.

• For the operating unit to be able reliably to detect changes on the PLC, the
changes must be queued during the actual acquisition cycle.
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8.2 Using a tag in several fields

Background

If you use a tag on the operating unit in an input field and simultaneously in an
output field, this may result in unexpected display behavior. The value of the tag at
this address can be modified both by the PLC and by means of an input on the
operating unit.

Example:
You enter a new value on the operating unit. The output field is updated
immediately with the new value. In the meantime, a value is read from the PLC
which is still the old value. The old value is then displayed briefly in the output field
and in the input field. While that is happening, the new value is being transferred to
the PLC. The new value is then displayed in both fields upon the next update.

Action

We recommend for this reason that you configure different tags for the input field
and the output field.

8.3 Tags with configured decimal places

Special features when inputting limit values

Limit values for tags are entered without a point. The constant for the limit value is
interpreted differently, depending on whether decimal places have been specified
for the tag.

The number of specified decimal places determines how many places of the limit
value are interpreted as decimal places.

The table shows an example.

Decimal places Limit Value Entered Interpreted by ProTool

0 2275 2275

1 2275 227,5

2 2275 22,75
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A HMI System Messages

In this chapter

This chapter contains a selection of important HMI system messages for Windows–
based systems. The table indicates when the messages occur and how they, or
their cause, can be cleared. Not every message is relevant for each operating unit.

HMI system message parameters

The HMI system messages may contain parameters which are not decoded for the
user but which are relevant in respect of the cause of an error since they provide a
reference to the source code of the runtime software. These parameters are issued
according to the text “Error code:”.

Notice
HMI system messages are issued in the language currently set on the operating
unit.

Procedure in the case of “internal errors”

Please proceed as follows in the case of all system messages related to “internal
errors”:

Start up the operating unit again.

Download the configuration again.

Switch the operating unit off, stop the PLC and then restart both.

If the error occurs again, please contact the SIMATIC Customer Support. Make
reference to the specified error number and message tags.

Number Effect/Cause Remedy

10000 The print job could not be started or was
terminated for an unknown reason.
The printer is incorrectly configured.
Or: There are no rights for a network
printer available.

Check the printer
settings and cable
connections.
If a fault occurs
repeatedly, contact the
hotline.

10001 No printer has been installed or no
standard printer configured.

Install a printer and/or
mark one as standard
printer.

10002 The intermediate buffer for printing
graphics is full. Up to two graphics can
be buffered.

Do not issue print jobs
so quickly in
succession.

10003 Graphics can be buffered again. -



HMI System Messages Release 12/01

ProTool User Manual How to configure text-based units
A-2 A5E00149249

Number Effect/Cause Remedy

10004 The intermediate buffer for printing lines
in text mode (e.g. messages) is full. Up
to 1000 lines can be buffered.

Do not issue print jobs
so quickly in
succession.

10005 Lines of text can be buffered again. -

10006 The Windows print system reports an
error. For information on the cause, refer
to the text printed and, if available, the
error number.
Printing is not performed or it is
incorrect.

Repeat the action, if
necessary.

20010 A fault has occurred in the script line
called in from the specified script.
Execution of the script function was,
therefore, terminated.
In this case, it is advisable to check any
previous system messages too.

Select the specified
script line in the
configuration.
Check tags, whether the
types used are
permissible.
Check Functions,
whether the number and
types of parameter are
correct.

20011 An error has occurred in a script called
in by the script specified. Execution of
the script function– has, therefore, been
terminated in the subscript.
In this case, it is advisable to check any
previous system messages too.

Select the scripts from
the configuration which
are called in directly or
indirectly via the
specified script.
Check tags, whether the
types used are
permissible.
Check Functions,
whether the number and
types of parameter are
correct.

20012 Inconsistent configuration data is
present. Therefore, the script could not
be created.

Compile the
configuration again.

20013 VBScript.dll is not correctly installed.
Therefore, no scripts can be executed.

Re–install ProTool/Pro
RT.

20014 A value is returned by the script function
which is not written in any configured
return tag.

Select the specified
script in the
configuration.
Check whether the
script name has been
assigned a value.
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Number Effect/Cause Remedy

20015 Too many scripts have been triggered in
quick succession.
If more than 20 scripts are queued to be
processed, any subsequent scripts are
rejected.
In this case, the script indicated in the
message is not executed.

Check where the scripts
are being triggered
from.
Extend the times, e.g.
the polling time of the
tags, which trigger the
scripts.

30010 The tag could not accept the function
result, e.g. in the case of exceeding the
value range.

Check the tag type of
the function parameter.

30011 A function could not be executed
because the function was assigned an
invalid value or type in the parameter.

Check the parameter
value and tag type of
the invalid parameter.
If a tag is used as a
parameter, check its
value.

40010 The function could not be executed
since the parameters could not be
converted to a common tag type.

Check the parameter
types in the
configuration.

40011 The function could not be executed
since the parameters could not be
converted to a common tag type.

Check the parameter
types in the
configuration.

50000 The operating unit receives data faster
than it is capable of processing.
Therefore, no further data is received
until the data currently available has
been processed. Data exchange then
resumes.

-

50001 Data exchange has been resumed. -

60000 This message is generated by the
function “Display system messages”.
The text to be displayed is transferred to
the function as a parameter.

-

60010 The file could not be copied in the
direction defined because one of the two
files is currently open or the
source/target path is not available.
It is possible that the Windows NT user
has no access rights to one of the two
files.

Restart the function or
check the paths of the
source/target files.
Using Windows NT with
NTFS: The user
executing ProTool/Pro
RT must be granted
access rights for the
files.
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Number Effect/Cause Remedy

60011 An attempt was made to copy a file to
itself.
It is possible that the Windows NT user
has no access rights to one of the two
files.

Check the path of the
source/target file.
Using Windows NT with
NTFS: The user
executing ProTool/Pro
RT must be granted
access rights for the
files.

70010 The application could not be started
because it could not be found in the path
specified or insufficient memory space
was available.

Check whether the
application exists in the
specified path or close
other applications.

70011 The system time could not be modified.
The error message only appears in
connection with area pointer Date/Time
PLC. Possible causes:

- an impermissible time was transferred
in the PLC job,

- the Windows NT user has no user
rights to modify the system time.
If the first parameter in the system
message is displayed with the value 13,
the second parameter indicates the byte
containing the incorrect value.

Check the time which is
to be set.
Under Windows NT:
The user executing
ProTool/Pro RT must be
assigned the rights to
modify the system time
from Windows NT
(administration/user
manager, guidelines).

70012 An error occurred when executing the
function Exit Runtime with the option
Exit also Windows.
Windows and ProTool/Pro RT are not
terminated.
A possible cause is that other
applications cannot be terminated.

Terminate all
applications currently
running.
Then terminate
Windows.

70013 The system time could not be modified
because an invalid value was entered.
Incorrect separators may have been
used.

Check the time which is
to be set.

70014 The system time could not be modified.
Possible causes:

- an impermissible time was transferred

- the Windows NT user has no user
rights to modify the system time,

- Windows rejects the setting request.

Check the time which is
to be set.
Under Windows NT:
The user executing
ProTool/Pro RT must be
assigned the rights to
modify the system time
from Windows NT
(administration/user
manager, guidelines).

70015 The system time could not be read
because Windows rejects the reading
function.

-
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Number Effect/Cause Remedy

70016 An attempt was made to select a screen
by means of a function or job. This is not
possible because the screen number
specified does not exist.
Or: a screen could not be generated due
to insufficient system memory.

Check the screen
number in the function
or job with the screen
numbers configured.
Refer the number to a
screen, if necessary.

70017 Date/Time is not read from the area
pointer because the address set in the
PLC is either not available or has not
been set up.

Change the address or
set up the address in
the PLC.

70018 Acknowledgement that the password list
has been successfully imported.

-

70019 Acknowledgement that the password list
has been successfully exported.

-

70020 Acknowledgement for activation of
message recording.

-

70021 Acknowledgement for deactivation of
message recording.

-

70022 Acknowledgement to starting the Import
Password List action.

-

70023 Acknowledgement to starting the Export
Password List action.

-

70027 Backing up the RAM file system has
been started.

-

70028 Backing up of the RAM file system has
been completed successfully.
The files from the RAM have been
copied in the Flash memory. Following a
restart, these saved files will be copied
back in the RAM file system.

-

70029 Backup of the RAM file system has
failed.
No backup copy of the RAM file system
has been made.

Check the settings in
the OP Properties
dialog and save the
RAM file system using
the Save Files button in
the Persistent Storage
tab control.

70030 The parameters configured for the
function are faulty.
The connection to the new PLC was not
established.

Compare the
parameters configured
for the function with the
parameters configured
for the PLC and correct
them as necessary.
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Number Effect/Cause Remedy

70031 The PLC configured in the function is not
an S7 PLC.
The connection to the new PLC was not
established.

Compare the S7 PLC
name parameter
configured for the
function with the
parameters configured
for the PLC and correct
them as necessary.

80001 The archive specified is filled to the size
defined (in percent) and must be stored
elsewhere.

Store the file or table by
executing a ‘move’ or
‘copy’ function.

80002 A line is missing in the specified archive. -

80003 The copying process for archiving was
not successful.
In this case, it is advisable to check any
subsequent system messages, too.

-

80006 Since archiving is not possible, this
causes a permanent loss of the
functionality.

In the case of
databases, check
whether the
corresponding data
source exists and start
up the system again.

80009 A copying action has been completed
successfully.

-

80010 Since the path was incorrectly entered in
ProTool, this causes a permanent loss
of the functionality.

Configure the path for
the respective archive
again and restart the
system when the full
functionality is required.

80012 Archive values are stored in a buffer. If
the values are read to the buffer faster
than they can be physically written (e.g.
using a hard disk), overloading may
occur and recording is then stopped.

Archive less values.
Or increase the
recording interval.

80013 The overload status no longer applies.
Archiving resumes the recording of all
values.

-

80014 The same action was triggered twice in
quick succession. Since the process is
already in operation, the action is only
carried out once.

-

80016 The archives are separated by the
function Close archive and the incoming
entries exceed the defined buffer size.
All the jobs in the buffer are deleted.

Reconnect the archives.
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Number Effect/Cause Remedy

80017 The incoming entries cause the defined
buffer size to be exceeded. This can be
caused, e.g. by several copying actions
being activated at the same time.
All the copy jobs in the buffer are
deleted.

Terminate the copy
process.

80018 All the archives are reconnected by
means of the DB layer, e.g. after
executing the function Open_archive.
Values are then written back into the
tables.

-

80019 All the archives are separated from the
DB layer and all connections terminated,
e.g. after executing the function
Close_archive.
Values are temporarily buffered and
written in the tables when the connection
is re–established.
There is no connection to the storage
medium and a change can take place.

-

80020 The max. number of simultaneously
activated copy actions has been
exceeded.
Copying is not executed.

Wait until the current
copying actions have
been completed and
restart the last copy
action.

80021 An attempt was made to delete an
archive which is still involved with a copy
action.
Deletion has not been executed.

Wait until the current
copying action has been
completed and restart
the last action.

80022 An attempt was made to start a
sequence archive, which is not a
sequence archive, from an archive using
the function Start_sequence_archive.
No sequence archive is created.

Check the project for
the following:

- the function
Start_sequence_archive
is correctly configured.

- the variable
parameters are being
correctly provided at the
operating unit.

80023 An attempt was made to copy an archive
to itself.
The archive is not copied.

Check the project for
the following:

- the function
Copy_archive is
correctly configured.

- the variable
parameters are being
correctly provided at the
operating unit.
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80024 The function Copy_archive is configured
not to permit copying when the target
archive already contains data
(Parameter: Write mode).
The archive is not copied.

Modify the function
Copy_archive in the
project, if necessary.
Before initiating the
function, delete the
target archive.

80025 The copy action is interrupted.
Data written up to this point is retained.
Deletion of the target table (if
configured) is not executed.
The cancellation is documented by an
error entry $RT_ERR$ at the end of the
target table.

-

80026 The message is issued after all the
archives have been successfully
initialized. Values are written in the
archives from this moment on. Prior to
this, no values are archived even though
the runtime software is operating.

-

80027 The internal Flash memory has been
specified as the memory location for an
archive. This is not permissible.
No values will be archived for this
archive and the archive will not be
created.

Configure ”Storage
Card” as the memory
location or a network
path.

80028 The message serves as a status
acknowledgment that initialization of the
archives is currently running. No values
are archived until system message
80026 is issued.

-

80029 The number of archives specified in the
message could not be initialized.
Initialization of the archives has been
completed.
The faulty archives are not available for
archiving jobs.

Evaluate the additional
system message,
related to this message,
which is also issued.
Check the configuration,
the ODBC (Open
Database Connectivity)
and the specified drive.

80030 The structure of the table(s) available
does not match the archiving structure
expected.
The archiving process is stopped for this
archive.

Delete the existing
tables manually, in
advance.
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80032 Archives can be configured with a
function trigger. This is triggered as son
as the archive is full. If runtime is started
and the archive is already full, the trigger
function will not be initiated.
The archive specified no longer archives
data since it is full.

Stop the runtime, delete
the archive and restart
the runtime again.
Or:
Configure a button in
the runtime which
contains the same
actions as the function
trigger and press it.

110000 The operating mode status has been
changed. The operating mode is now
offline.

-

110001 The operating mode status has been
changed. The operating mode is now
online.

-

110002 The operating mode status has not been
changed.

Check the connection to
the PLCs.
Check whether the
address area for the
area pointer
“Coordination” in the
PLC is available.

110003 The operating status of the PLC
specified is changed by the function
Connect/Disconnect PLC.
The operating mode is now offline.

-

110004 The operating status of the PLC
specified is changed by the function
Connect/Disconnect PLC.
The operating mode is now online.

-

110005 An attempt was made to use the
function Connect/Disconnect PLC to
switch the specified PLC to operating
mode online although the entire system
is in operating mode Offline. This
switch–over is not permissible.
The PLC remains in operating mode
offline.

Switch the complete
system to operating
mode online and
execute the function
again.

110006 The Colorado system has been
extended by the addition of the User
Version area pointer.
If the user version is not correct, the
runtime is stopped.

Check the user
versions.
Either the wrong version
was entered in the PLC
or configuration or the
wrong configuration was
started for the PLC user
version.

120000 The trend is not displayed because an
incorrect axis to the trend, or incorrect
trend, has been configured.

Change the
configuration.
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Number Effect/Cause Remedy

120001 The trend is not displayed because an
incorrect axis to the trend, or incorrect
trend, has been configured.

Change the
configuration.

120002 The trend is not displayed because the
tag assigned tries to access an invalid
PLC address.

Check whether the data
area for the tag exists in
the PLC, the configured
address is correct or the
value range for the tag
is correct.

130000 The action was not executed. Close other
applications.
Delete files no longer
required from the hard
disk.

130001 The action was not executed. Delete files no longer
required from the hard
disk.

130002 The action was not executed. Close other
applications.
Delete files no longer
required from the hard
disk.

130003 No target data carrier is inserted. The
process is stopped.

Check, for example,
whether:

- access has been
made to the correct data
carrier

- the data carrier has
been inserted

130004 The target data carrier is write–
protected. The process is stopped.

Check whether access
has been made to the
correct data carrier.
Remove the write
protection.

130005 The file is write–protected. The process
is stopped.

Check whether access
has been made to the
correct file. Modify the
file attributes, if
necessary.

130006 No access to file is possible. The
process is stopped.

Check, for example,
whether:

- access has been
made to the correct file

- the file exists

- a different action
prevents simultaneous
access to the file
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140000 Online connection to the PLC has been
successfully established.

-

140001 Online connection to the PLC has been
disconnected.

-

140003 No tag updating or writing is executed. Check the connection
and whether the PLC is
switched on.
Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.
Restart the system.

140004 No tag updating or writing is executed
because the access point or the subrack
configuration is incorrect.

Check the connection
and whether the PLC is
switched on.
Check the access point
or the subrack
configuration (MPI, PPI,
PROFIBUS) in the
Control Panel with “Set
PU/PC interface”.
Restart the system.

140005 No tag updating or writing is executed
because the address of the operating
unit is incorrect (possibly too high).

Use a different
operating unit address.
Check the connection
and whether the PLC is
switched on.
Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.
Restart the system.

140006 No tag updating or writing is executed
because the baud rate is incorrect.

Select a different baud
rate in ProTool/Pro
(according to subrack,
profile, communication
peer, etc.).
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140007 No tag updating or writing is executed
because the bus profile is incorrect
(see %1).
The following parameters could not be
entered in the registry:
1: Tslot
2: Tqui
3: Tset
4: MinTsdr
5: MaxTsdr
6: Trdy
7: Tid1
8: Tid2
9: Gap Factor
10: Retry Limit

Check the user defined
bus profile.
Check the connection
and whether the PLC is
switched on.
Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.
Restart the system.

140008 No tag updating or writing is executed
because the configuration data is
incorrect:
The following parameters could not be
entered in the registry:
0: General errors
1: Incorrect version
2: Profile cannot be entered in the

registry.
3: Sub–network type cannot be

entered in the registry.
4: Target rotation time cannot be

entered in the registry.
5: Highest address (HSA) incorrect.

Check the connection
and whether the PLC is
switched on.
Check the parameter
definitions in the Control
Panel using “Set PU/PC
interface”.
Restart the system.

140009 No tag updating or writing is executed
because the module for the S7
communication was not found.

Re–install the module in
the Control Panel using
“Set PU/PC interface”.

140010 No S7 communication peer could be
found because the PLC is switched off.
DP/T:
The option “Is not active as the only
master” is set in the Control Panel under
“Set PU/PC interface”.

Switch the PLC on.
DP/T:
If only one master is
connected to the
network, deactivate the
option “Is not active as
the only master” in “Set
PU/PC interface”.
If the network has more
than one master, switch
this master on. Do not
modify any settings
here, otherwise a bus
fault may occur.

140011 No tag updating or writing is executed
because communication is interrupted.

Check the connection
and that the
communication peer is
switched on.
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140012 There is an initialization problem (e.g.
when ProTool/Pro RT has been
terminated in the Task Manager).
Or: another application (e.g. STEP7,
WINCC) is active with different bus
parameters and the driver cannot be
started with the new bus parameters
(e.g. baud rate).

Restart the operating
unit.
Or start ProTool/Pro RT
first and then the other
applications.

140013 The MPI cable is not plugged in and,
thus, there is no power supply.

Check the connections.

140014 - Modify the operating
unit address in the
configuration in PLC.

140015 Incorrect baud rate
Or: incorrect bus parameter (e.g. HSA)
Or: OP address HSA
Or: incorrect interrupt vector (interrupt
does not arrive at the driver)

Correct the incorrect
parameters.

140016 - Change the interrupt
number.

140017 - Change the interrupt
number.

140018 The consistency check was deactivated
by Simotion Scout.
Only one appropriate note appears.

Activate the consistency
check with Simotion
Scout again and load
the configuration in the
project once more.

140019 Simotion Scout loads a new project in
the PLC.
Connection to the PLC is interrupted.

Wait until the end of the
reconfiguration.

140020 The version in the PLC and that in the
configuration (FWD file) do not match.
Connection to the PLC is interrupted.

Remedy:

- Load the current
version in the PLC using
Simotion Scout.

- Generate the anew
project using ProTool
CS, end ProTool RT
and start with the new
configuration.

150000 No more data is read or written.
Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.
Reboot the system if the
system message is
displayed continuously.
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150001 Connection is re–established because
the cause of the interruption has been
eliminated.

-

160000 No more data is read or written.
Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.
Reboot the system if the
system message is
displayed continuously.

160001 Connection is re–established because
the cause of the interruption has been
eliminated.

-

160010 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.
Values cannot be read or written.

Check the access
rights.

160011 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.
Values cannot be read or written.

Check, for example,
whether:

- the server name is
correct

- the computer name is
correct

- the server is registered

160012 There is no connection to the server
because the server identification (CLS–
ID) cannot be established.
Values cannot be read or written.

Check, for example,
whether:

- the server name is
correct

- the computer name is
correct

- the server is registered

Information for
experienced users:
Interpret the value from
HRESULT.

160013 The specified server was started as
InProc Server. This has not been
released and may possibly lead to
incorrect behavior because the server is
running in the same process area as the
ProTool/Pro RT runtime software.

Configure the server as
OutProc Server or Local
Server.
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160014 Only one OPC server project can be
started on a PC/MP. An error message
appears when an attempt is made to
start a second project.
The second project has no OPC server
functionality and cannot be located as
an OPC server from external sources.

Do not start a second
project with OPC server
functionality on the
computer.

170000 1) S7 diagnostics messages are not
displayed because it is not possible to
logon to the S7 diagnostics with this unit.
The service program is not supported.

-

170001 1) The S7 diagnostics buffer cannot be
displayed because communication with
the PLC has been switched off.

Switch the PLC online

170002 1) The S7 diagnostics buffer cannot be
displayed because reading in the
diagnostics buffer (SZL) was terminated
due to an error.

-

170003 1) The display of an S7 diagnostics
message is not possible. An internal
error %2 has been reported.

-

170004 1) The display of an S7 diagnostics
message is not possible. An internal
error with error class %2, error number
%3 has been reported.

-

170007 1) It is not possible to read in the S7
diagnostics buffer (SZL) because it was
terminated with an internal error with
error class %2 and error code %3.

-

1) The optional parameter %1 at the start
of the message may contain an
identification for the S7 connection when
several S7s are in parallel operation and
are connected to diagnostics equipment.

180000 A component/OCX receives
configuration data with a version
identification which is not supported.

Install a newer
component.



HMI System Messages Release 12/01

ProTool User Manual How to configure text-based units
A-16 A5E00149249

Number Effect/Cause Remedy

180001 The system is overloaded because too
many actions have been activated
simultaneously.
Not all the actions can be executed,
some are rejected.

Remedy:

- Increase the
configured cycle times
or basic clock.

- Generate the
messages slower
(polling).

- Trigger the scripts and
functions at greater
intervals.

- If the message
appears more
frequently:
Restart the operating
unit.

180002 The screen keyboard could not be
activated.
Possible causes:

- The screen keyboard is not generally
supported under Windows 95.

- The file “TouchInputPC.exe” was not
registered due to an incorrectly executed
Setup.

If Windows 95 is not
available:
Install the runtime
software again.

190000 It is possible that the tag will not be
updated.

-

190001 The tag is updated following an error
status after the cause of the last error
state has been eliminated (return to
normal operation).

-

190002 The tag is not updated because
communication to the PLC has been
switched off.

Switch on
communication via the
function “Set Online”.

190004 The tag is not updated because the
configured address is not available for
this tag.

Check the configuration.

190005 The tag is not updated because the
configured PLC type does not exist for
this tag.

Check the configuration.

190006 The tag is not updated because it is not
possible to map the PLC type in the tag
type.

Check the configuration.

190007 The tag values are not modified because
the connection to the PLC has been
terminated or the tag is offline.

Switch Online or re–
establish connection to
the PLC.
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190008 The threshold values configured for the
tag have been violated, e.g. by

- an entered value,

- a function,

- a script.

Observe the configured
or current threshold
value of the tag.

190009 An attempt has been made to assign a
value to a tag which is outside the value
range permitted for this type.
E.g. a value of 260 entered for a byte
tag or a value of –3 for a signless word
tag.

Observe the value
range for the tag type.

190010 The tag is described with values too
often (e.g. in a loop triggered by a
script).
Values are lost because the maximum of
100 event have been stored in the
buffer.

Increase the time
interval between the
multi–writing tasks.

190011 Possible causes:

- The value entered could not be written
to the configured PLC tag because it
was either above or below the value
range.

- The input is rejected and the original
value is reset.

Ensure that the value
entered is within the
value range of the PLC
tags.

190011 Possible causes:

- Connection to the PLC has been
interrupted.

Check the connection to
the PLC.

190012 It is not possible to convert a value from
a source format to a target format, e.g.:

- A value should be assigned to a
counter which is outside the valid, PLC–
dependent value range.

- A tag of the type Integer should be
assigned a value of the type String.

Check the value range
or type of the variable.
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190100 The area pointer is not updated because
the configured address for this area
pointer is not available.
Type:
1 Event messages
2 Alarm messages
3 PLC acknowledgment
4 Operating unit acknowledgment
5 LED assignment
6 Trend request
7 Trend transfer 1
8 Trend transfer 2
No.:
is the consecutive number displayed in
ProTool/Pro.

Check the configuration.

190101 The area pointer is not updated because
it is not possible to map the PLC type in
the area pointer type.
Parameter type and no.:
See message 190100

-

190102 The area pointer is updated following an
error status after the cause of the last
error state has been eliminated (return
to normal operation).
Parameter type and no.:
See message 190100

-

200000 Coordination is not executed because
the address configured in the PLC does
not exist/has not been set up.

Change the address or
set up the address in
the PLC.

200001 Coordination is not executed because
the address configured in the PLC
cannot be written.

Change the address or
set up the address in
the PLC in an area
which can be written.

200002 Coordination is not carried out at the
moment because the address format of
the area pointer does not match the
internal storage format.

Internal error

200003 Coordination can be executed again
because the last error status has been
eliminated (return to normal operation).

-

200004 It is possible that coordination is not
executed.

-

200005 No more data is read or written.
Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- The system is overloaded.

Check that the cable is
connected and the PLC
is in order.
Reboot the system if the
system message is
displayed continuously.
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210000 Jobs are not processed because the
address configured in the PLC does not
exist/has not been set up.

Change the address or
set up the address in
the PLC.

210001 Jobs are not processed because the
address configured in the PLC cannot
be written to/read from.

Change the address or
set up the address in
the PLC in an area
which can be written
to/read from.

210002 Commands are not executed because
the address format of the area pointer
does not match the internal storage
format.

Internal error

210003 The job mailbox is processed again
because the last error status has been
eliminated (return to normal operation).

-

210004 It is possible that the job mailbox is not
processed.

-

210005 A PLC job was triggered by an
impermissible number.

Check the PLC
program.

210006 A fault occurred while attempting to
execute the PLC job. The PLC job is,
therefore, not executed.
Observe the subsequent/previous
system message, if appropriate.

Check the parameter
types in the PLC job.
Compile the
configuration again.

220000 2) - -
2) A WinCC channel provides the message

texts via an interface. This text is issued
via this message. ProTool/Pro RT has
no influence on this texts.

220001 The tag is not downloaded because the
associated channel/the unit does not
support downloading the data type
bool/bit.

Change the
configuration.

220002 The tag is not downloaded because the
associated channel/the unit does not
support downloading the data type byte.

Change the
configuration.

220003 The associated driver could not be
uploaded. It is possible that the driver is
not installed.

Install the driver by re–
installing ProTool/Pro
RT.

220004 Communication is terminated and no
update is executed because the cable is
not connected or is defect etc.

Check the connection.

220005 Communication is running. -

220006 The connection is established to the
specified PLC at the specified interface.

-
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220007 The connection to the specified PLC at
the specified interface is disconnected.

Check that:

- the cable is plugged in

- the PLC is OK

- the correct interface is
used

- the configuration is OK
(interface parameters,
protocol settings, PLC
address).

Reboot the system if the
system message is
displayed continuously.

220008 The PLC driver cannot access the
specified interface or open it. It is
possible that another application is using
this interface or an interface is used
which is not available on the target
device.
There is no communication with the
PLC.

Terminate all the
programs which access
the interface and reboot
the computer.
Use another interface
which is available in the
system.

230000 The value entered could not be
accepted. The entered value is rejected
and the previous value is specified
again.
Either the value range has been
exceeded or impermissible characters
were entered.

Enter a permissible
value.

230002 Since the current password level is
inadequate or the password dialog box
was closed with ESC, the entry is
rejected and the previous value is
specified again.

Activate an adequate
password level using
Login.

230003 Changeover to the specified screen is
not executed because the screen is not
available/configured. The current screen
remains selected.

Configure the screen.
Check the selection
function.

240000 3) Runtime is operating in Demo mode.
There is either no Stopcopy license or it
is defect.

Load the license.

240001 3) Runtime is operating in Demo mode.
Too many tags are configured for the
installed version.

Load an adequate
license / powerpack.

240002 3) Runtime is operating with a time–limited
standby authorization.

Restore the full
authorization.

3) The specified text comes from the
component resources.
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240003 Authorization cannot be executed.
ProTool/Pro RT is running in Demo
mode.

Restart ProTool/Pro RT
or reinstall it.

240004 Error during reading the standby
authorization.
ProTool/Pro RT is running in Demo
mode.

Restart ProTool/Pro RT,
install the authorization
or repair the
authorization (see
Commissioning
Instructions Software
Protection).

250000 The tag in the specified line in
Status/Control is not updated because
the address configured for this tag is not
available.

Check the set address
and then check that the
address has been set
up in the PLC.

250001 The tag in the specified line in
Status/Control is not updated because
the PLC type configured for this tag is
not available.

Check the set address.

250002 The tag in the specified line in
Status/Control is not updated because it
is not possible to map the PLC type in
the tag type.

Check the set address.

250003 No connection could be established to
the PLC. The tags will not be updated.

Check the connection to
the PLC. Check that the
PLC is switched on and
online is activated.

260000 A password has been entered which is
unknown to the system. Therefore, the
lowest password level has been set.
This corresponds to the status following
Logout.

Enter a known
password in the
password input field
(with corresponding
level).

260001 A password has been entered whose
assigned level does not permit execution
of the function.
The password level currently set is
displayed for information purposes.

Modify the password
level in the password
input field enter a
password with a
sufficiently high level.

260003 The user has logged off from the
system. If the password level is 0, no
user is logged on.

-

270000 A tag is not displayed in the message
because it attempts to access an invalid
address in the PLC.

Check whether the data
area for the tag exists in
the PLC, the configured
address is correct or the
value range for the tag
is correct.
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270001 There is a unit–dependent limit as to
how many messages may be queued
simultaneously in order to be displayed
(see GHB). This limit has been
exceeded.
The display no longer contains all the
messages.
However, all the messages are recorded
in the message buffer.

-

270002 Messages are displayed from an archive
are displayed for which there is no data
in the current project.
Placeholders are issued for the
messages.

Delete older archive
files, if necessary.

270003 The service cannot be set up because
too many devices was to set up this
service.
A maximum of four devices can execute
this action.

Connect fewer
operating units which
want to use the service.

280000 Connection is re–established because
the cause of the interruption has been
eliminated.

-

280001 No more data is read or written.
Possible causes:

- The cable is defective.

- The PLC does not respond, is
defective, etc.

- Connection is established via the
wrong interface.

- The system is overloaded.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.
Reboot the system if the
system message is
displayed continuously.

280002 A connection is used which requires a
function module in the PLC.
The function block has replied.
Communication can now proceed.

-
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280003 A connection is used which requires a
function module in the PLC.
The function block does not reply.

Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.
Reboot the system if the
system message is
displayed continuously.
The remedy is
dependent on the error
code:
1: The function block
must set the COM bit in
the response container.
2: The function block
may not set the ERROR
bit in the response
container
3: The function block
must respond within the
specified time (timeout)
4: Establish an online
connection to the PLC

280004 The online connection to the PLC has
been interrupted. There is no data
exchange at present.

Check the PLC
parameters in ProTool
Pro: baud rate, block
length, station address.
Check that the cable is
plugged in, the PLC is
operational, the correct
interface is used.
Reboot the system if the
system message is
displayed continuously.

290000 The tag could not be read or written. It is
assigned the start value.
The message can be entered in the
message buffer for up to four more failed
tags, if necessary. After that, the
message number 290003 is issued.

Check in the
configuration that the
address has been set
up in the PLC.

290001 An attempt has been made to assign a
value to a tag which is outside the value
range permitted for this type.
The message can be entered in the
message buffer for up to four more failed
tags, if necessary. After that, the
message number 290004 is issued.

Observe the value
range for the tag type.
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290002 It is not possible to convert a value from
a source format to a target format.
The message can be entered in the
message buffer for up to four more failed
tags, if necessary. After that, the
message number 290005 is issued.

Check the value range
or type of the variable.

290003 This message is issued when message
number 290000 is triggered more than
five times.
In this case, no further individual
messages are generated.

Check in the
configuration that the
tag addresses have
been set up in the PLC.

290004 This message is issued when message
number 290001 is triggered more than
five times.
In this case, no further individual
messages are generated.

Observe the value
range for the tag type.

290005 This message is issued when message
number 290002 is triggered more than
five times.
In this case, no further individual
messages are generated.

Check the value range
or type of the variable.

290006 The threshold values configured for the
tag have been violated by values
entered.

Observe the configured
or current threshold
value of the tag.

290007 There is a difference between the
source and target structure of the recipe
currently being processed. The target
structure contains an additional data
record tag which is not available in the
source structure.
The data record tag specified is
assigned its start value.

Insert the specified data
record tag in the source
structure.

290008 There is a difference between the
source and target structure of the recipe
currently being processed. The source
structure contains an additional data
record tag which is not available in the
target structure and therefore cannot be
assigned.
The value is rejected.

Remove the specified
data record tag in the
specified recipe from
the project.

290010 The storage location configured for the
recipe is not permitted.
Possible causes:
Impermissible characters, write
protected, data medium full or does not
exist.

Check the path
specification configured.

290011 The data record specified by the number
does not exist.

Check the source for
the number (constant or
variable value).
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290012 The recipe specified by the number does
not exist.

Check the source for
the number (constant or
variable value).

290013 An attempt was made to save a data
record under a data record number
which already exists.
The process is not executed.

Remedy:

- Check the source for
the number (constant or
variable value).

- Delete the data record
beforehand.

- Change the function
parameter
“Overwrite”.

290014 The file specified to be imported could
not be found.

Check that:

- Check the file name.

- Ensure that the file is
in the specified
directory.

290020 Acknowledgement that downloading of
data records from operating unit to PLC
has started.

-

290021 Acknowledgement that downloading of
data records from operating unit to PLC
has been completed without any errors.

-

290022 Acknowledgement that downloading of
data records from operating unit to PLC
has been terminated due to an error.

Check the configuration:

- have the tag
addresses been set up
in the PLC?

- does the recipe
number exist?

- does the data record
number exist?

- has the function
parameters ”Overwrite”?

290023 Acknowledgement that downloading of
data records from the PLC to the
operating unit has started.

-

290024 Acknowledgement that downloading
data records from the PLC to the
operating unit has been completed
without any errors.

-
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290025 Acknowledgement that downloading of
data records from the PLC to the
operating unit has been terminated due
to an error.

Check the configuration:

- have the tag
addresses been set up
in the PLC?

- does the recipe
number exist?

- does the data record
number exist?

- has the function
parameters ”Overwrite”?

290026 An attempt has been made to read/write
a data record although the data mailbox
is not free at present.
This error may occur in the case of
recipes for which downloading with
synchronization has been configured.

Set the data mailbox
status to zero.

290027 No connection to the PLC can be
established at present. Therefore, the
data record can neither be read nor
written.
Possible causes:
No physical connection to the PLC (no
cable plugged in, cable is defect) or the
PLC is switched off.

Check the connection to
the PLC.

290030 This message is issued after reselecting
a screen that contains a recipe display in
which a data record has already been
selected.

Reload the data record
from the data medium
or retain the current
values.

290031 While saving, it was detected that a data
record with the specified number already
exists.

Overwrite the data
record or cancel the
process.

290032 While exporting data records, it was
detected that a file with the specified
name already exists.

Overwrite the file cancel
the process.

290033 Confirmation request before deleting
data records.

-
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290040 A data record error with error code %1
has occurred which cannot be described
in more detail.
The action was canceled.
It might be that the data mailbox has not
been installed correctly on the PLC.

Check that the data
carrier, the data record,
the data mailbox and, if
necessary, the
connection to the PLC.
Trigger the action again
after waiting a short
period.
If the error occurs again,
please contact the
Customer Support.
Specify the error code
displayed.

290041 A data record or file cannot be saved
because the data medium is full.

Delete files no longer
required.

290042 An attempt was made to execute several
recipe actions simultaneously.
The last action was not executed.

Trigger the action again
after waiting a short
period.

290043 Confirmation request before storing data
records.

-

290044 The data store for the recipe has been
destroyed and will be deleted.

-

290050 Acknowledgement that the exportation
of data records has started.

-

290051 Acknowledgement that the exportation
of data records has been completed
successfully.

-

290052 Acknowledgement that the exportation
of data records has been terminated due
to errors.

Ensure that the
structure of the data
records on the data
medium and the current
recipe structure on the
operating unit are
identical.

290053 Acknowledgement that the importation
of data records has been started.

-

290054 Acknowledgement that the importation
of data records has been completed
successfully.

-

290055 Acknowledgement that the importation
of data records has been terminated due
to errors.

Ensure that the
structure of the data
records on the data
medium and the current
recipe structure on the
operating unit are
identical.
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290056 The value in the specified line/column
could not be read/written without errors.
The action was canceled.

Check the specified
line/column.

290057 The tags of the recipe specified have
been switched from operating mode
“offline” to “online”.
Each modification of a tag in this recipe
is now immediately transferred to the
PLC.

-

290058 The tags of the recipe specified were
switched from operating mode “online”
to “offline”.
Modifications to tags in this recipe are
no longer immediately transferred to the
PLC but must be transferred there
explicitly by means of downloading a
data record, if necessary.

-

290059 Acknowledgement that the specified
data record has been stored
successfully.

-

290060 Check–back message that the data
record memory has been successfully
erased.

-

290061 Check–back message, that erasing the
data record memory was aborted with
errors.

-

290068 Request to confirm whether all data
records in the recipe should be deleted.

-

290069 Request to confirm whether all data
records of all recipes should be deleted.

-

290070 The data record specified is not
contained in the import file.

Check the source of the
data record number or
data record name
(constant or tag value).

300000 Process monitoring (e.g. using PDiag or
S7–Graph) has been incorrectly
programmed: More messages are
queued than specified in the technical
data of the CPU. No further ALARM_S
messages can be managed by the CPU
and reported to operating systems.

Change the CPU
configuration.

310000 An attempt is being made to print too
many protocols simultaneously.
Since only one protocol can be printed
at a time, the print job is rejected.

Wait until printout of the
last active protocol has
been concluded.
Repeat the print job, if
necessary.
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310001 An error occurred on triggering the
printer. The protocol is either not printed
or printed with errors.

Evaluate the additional
system message,
related to this message,
which is also issued.
Repeat the print job, if
necessary.

320000 The movements have already been
indicated by another device.
The movements can no longer be
served.

Select the movements
on the other display
units and select the
movement screen on
the required display
unit.

320001 The network is too complex.
The defective operands cannot be
displayed.

Display the network in
AWL.

320002 No diagnostics–capable alarm
messages have been selected.
The units related to the alarm messages
could not be selected.

Select a diagnostics–
capable alarm message
in the message screen
ZP_ALARM.

320003 No alarm messages exist in respect of
the selected unit.
No network can be displayed in the
detail display.

Select the defective unit
in the general view
screen.

320004 The required signal statuses could not
be read by the PLC.
The defective operands cannot be
established.

Check the consistency
between the
configuration on the
display unit and the PLC
program loaded.

320005 The project contains ProAgent partitions
which are not installed.
No ProAgent diagnostics can be
performed.

In order to run the
project, install the
ProAgent option packet.

320014 The selected PLC cannot be evaluated
for ProAgent.
The message display configured with
the Evaluate_message_display_fault
function could not be found.

Check the parameters
of the
Evaluate_message_dis-
play_fault
function.
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B Standard screens reference

Screens in standard projects

The standard projects supplied with ProTool contain various screens that have
already been configured; these are called standard screens. The names of the
screens all start with the character "Z_. You can use standard screens in your
projects without changing them or you can customize them to suit your
requirements.

The following table shows the applications implemented in the different standard
screens.

Note

Many of the screens and functions listed below are not available for all operating
units.

Screen Name Usage Constraints

Z_SYSTEM_MEN Basic standard screen.

You can jump from this screen to
other standard screens.

Z_MESS_EVENT Event messages:

View
Print
Display number
Delete buffer
Overflow warning ON/OFF
Display text

Not OP 3 or C7-621

Z_MESS_ALARM Alarm messages:

View
Print
Display number
Delete buffer
Overflow warning ON/OFF
Display text

Not OP 3 or C7-621

Z_SETTINGS System settings:

Mode change
Display first/last alarm message
Display system message buffer
Language
Set date and time
Printer parameters
Interface parameters

Display first/last alarm
message: not OP 3 or
C7-621

Z_SCREEN Screens:

Edit
Print

Print:
not OP 3 or C7-621
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Z_PASSWORD Password:

Login
Logout
Edit

Login:
not OP 3 or C7-621

Z_RECORD Data records:

Edit
Print
Transfer

Not OP 3 or C7-621

Z_COUNTER Counter setpoints/actual values for
S7-CPU314 or S7-CPU214:

Set
Display

OP 3 and C7-621 only

Z_TIMER Integrated timer:

Set
Display

OP 3 and C7-621 only
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C Communication areas for non-SIMATIC PLCs

Overview

This description applies to communication with the following PLCs:

• Allen-Bradley

• Mitsubishi

• Modicon

• Omron

• Telemecanique

The data areas for the SIMATIC PLCs are described in the "Communication User's
Manual".

The operating unit and the PLC communicate with each other via these data areas:

• Interface area (refer to "Structure of the interface area")

• Keyboard assignment (refer to "Keyboard assignment of the operating unit")

• LED assignment (refer to "LED assignment of the operating unit")

The data areas are only required if you want to use the corresponding functions on
your operating unit. Create the required data areas on the PLC, and enter them as
area pointers in your project, in the project window, at "Area pointers".

The table provides you with an overview of which user areas are in principle
possible with which operating unit.

Device-specific user data areas:

User data area Operating Unit

Event messages TD 17, OP 3, OP 5, OP 7, OP 15, OP 17

Alarm messages OP 5, OP 7, OP 15, OP 17

PLC jobs TD 17, OP 5, OP 7, OP 15, OP 17

Recipes OP 5, OP 7, OP 15, OP 17

System keyboard assignment TD 17, OP 3, OP 5, OP 7, OP 15, OP 17

Function keyboard assignment OP 5, OP 7, OP 15, OP 17

LED assignment OP 3, OP 5, OP 7, OP 15, OP 17

Scheduler OP 15, OP 17

Date and time TD 17, OP 3, OP 5, OP 7, OP 15, OP 17

User version TD 17, OP 3, OP 5, OP 7, OP 15, OP 17

Screen number OP 3, OP 5, OP 7, OP 15, OP 17

User version TD 17, OP 3, OP 5, OP 7, OP 15, OP 17
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Structure of the interface area for non-SIMATIC PLCs

Use of the interface area

The interface area is required when you use the functions for the following:

• Sending PLC jobs to the operating unit

• Comparing the date and time between the PLC and the operating unit

• Checking the version number

• Editing recipes (downloading data records)

• Detecting the startup of the operating unit in the PLC program

• Determining the operating mode of the operating unit in the PLC program

• Determining the life bit of the operating unit in the PLC program

Setting up the interface area

Set the interface area in the project window at "Area pointers". The area must also
exist on the PLC. The figure below shows the structure of the interface area.

Structure of the interface area in data words
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Note

You will find a description of the interface area for SIMATIC PLCs in the
"Communication User's Manual".

Control and acknowledgement bits for non-SIMATIC PLCs

Count direction of the bits

The count direction of the bits in a data word depends on the PLC. Each data word
is shown below in two figures. In the explanation of the bits, the bit number is
represented as follows depending on the count direction:

• From right to left (right > left), beginning with 0: without bracket

• From left to right (left > right), beginning with 1: with bracket

Structure of the control and acknowledgement bits

One word each is available in the interface area for the control and
acknowledgement bits:

• "Word n+0"
Contains the control bits. These are written by the PLC and read by the
operating unit.

• "Word n+6"
Contains the acknowledgement bits. These are written by the operating unit
and read by the PLC.
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The figures below show in detail the structure of the control and acknowledgement
bits for different count directions.

Control and acknowledgement bits for the count direction right > left

Control and acknowledgement bits for the count direction left > right
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Operating unit startup

"Bit 0 (16) in acknowledgement bits":

1 = Operating unit has started up

0 = Operating unit is starting up

The bit is set by the operating unit on completion of startup.

Operating unit operating mode

"Bit 1 (15) in acknowledgement bits":

1 = operating unit is offline

0 = operating unit is in normal mode

The bit is set if the operating unit is switched offline by the operator. When the
operating unit is online, the bit is at 0.

Life bit

"Bit 2 (14) in acknowledgement bits":

The purpose of the life bit is to detect any interruption of the connection from the
operating unit to the PLC immediately. The operating unit inverts the life bit in the
interface area at regular intervals.

Synchronizing the download of data records

• Control bits:

"Bit 10 (6)"
1 = Data record/tag has an error
0 = No evaluation has taken place

"Bit 9 (7)"
1 = Data record/tag is error-free
0 = No evaluation has taken place

• Acknowledgement bits:

"Bit 9 (7)"
1 = Data transfer completed
0 = No evaluation has taken place

"Bit 8 (8)"
1 = Data mailbox is inhibited
0 = Data mailbox is free

The control and acknowledgement bits in the interface area synchronize the
transfer of data records. By default the transfer is initiated by the operator at the
operating unit.
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Download from the operating unit to the PLC

The sequence described below indicates how the operating unit sets the
synchronization bits and how the PLC program must respond to it.

1. The operating unit checks bit 8 (8) of the acknowledgement bits.
If the bit is set to 1 (data mailbox inhibited), the transfer is terminated with a
system error message. If the bit is set to 0 (data mailbox free), the operating
unit sets the bit to 1.

2. The operating unit enters the identifiers in the data mailbox.

3. In the case of a data record to be transferred "indirectly" (not with text-based
displays), the values of the tags are written to the data mailbox.

In the case of a data record to be transferred "directly", the tag values are
written to the configured address.

4. The operating unit sets bit 9 (7) of the acknowledgement bits to 1
(data transfer terminated).

5. Acknowledge in the PLC program whether or not the transfer was error-free:
Error-free: control bit 9 (7) is set to 1
Failed: control bit 10 (6) is set to 1

6. The operating unit resets bits 9 (7) and 8 (8) of the acknowledgement bits.

7. Reset control bits 10 (6) and 9 (7) in the control program.

Note

You will find a description of the control and acknowledgement bits for SIMATIC
PLCs in the "Communication User's Manual".

Data areas in the interface area for non-SIMATIC PLCs

Overview

The PLC triggers an action on the operating unit via the job mailbox. All the other
bytes are areas to which the operating unit writes data. These areas can be
evaluated by the PLC program.

Job mailbox

Word n+2 to n+5:

You can transfer PLC jobs to the operating unit via the job mailbox and thus trigger
actions on the operating unit.

The job mailbox consists of four words. The job number is in the first word of the
job mailbox. The job parameters (up to 3) are entered in the subsequent words.
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The figure below shows the structure of the job mailbox.

Structure of the job mailbox

If the first word of the job mailbox is not equal to zero, the operating unit evaluates
the PLC job. The operating unit then sets this data word to zero again. For this
reason the parameters must be entered in the job mailbox first, followed by the job
number.

You will find a list of all possible PLC jobs with job numbers and parameters in
"PLC jobs in alphabetical order" and "PLC jobs in numerical order".

Version number

Word n+8:

The operating unit enters the version number of the driver in word n+8. You can
evaluate the version number in the PLC program.

Date and time

Time: Word n+9 to n+11
Date: Word n+12 to n+14

PLC job 41 allows you to initiate the transfer of the date and time from the
operating unit to the PLC.

The figure below shows the structure of the data area. All the information is BCD-
encoded.

Structure of the "time" and "date" data areas
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Note

You will find a description of the interface area for SIMATIC PLCs in the
"Communication User's Manual".

In order to be able to verify that the date and time have been transferred, you
should set the data words to 0 before sending off the PLC job.

Keyboard assignment of the operating unit for non-SIMATIC PLCs

Usage and prerequisite

Keystrokes executed on the operating unit can be transferred to and evaluated by
the PLC. This means, for example, that you can issue a message to notify the
operator of incorrect usage of a key.

In order to be able to do this, you must set up corresponding data areas known as
assignments in the PLC and specify them as "area pointers" during configuration.

Download

The keyboard assignments are downloaded spontaneously to the PLC. The
download takes place whenever a change is registered on the operating unit. It is
therefore not necessary to configure a polling time. Only one depressed key is
transferred.

The following applies to the keys of the operating unit (except to SHIFT):
For as long as the key is held down, the value of the relevant bit in the keyboard
assignment is 1. Otherwise, its value is 0.

Note

If the operating unit is switched off or disconnected from the PLC with a key held
down, the corresponding bit in the keyboard assignment remains set.

System keyboard assignment

The system keyboard assignment is a data area with a fixed length of three data
words. In order to be able to use the system keyboard assignment, you must set
up a data area of the type "system keyboard" in your project at "Area Pointers".

Precisely one bit in the system keyboard assignment is assigned to each key on
the system keyboard on a fixed basis. The figures below show the keyboard
assignments for the OP 7/OP 17 and TD 17.
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Keyboard assignment for the OP 7/OP 17

Keyboard assignment for the TD 17

Note

Unused bits cannot be overwritten by the user program.

Keyboard communication bit

The keyboard communication bit is a control bit. Each time the keyboard
assignment is transferred from the operating unit to the PLC, it is set to 1 and
should be reset by the user program after evaluation of the data area.

Regular reading of the communication bit makes it possible in the user program to
establish whether the assignment of the system keyboard has been transferred
again.

Function keyboard assignment

The assignment of the function keyboard can be subdivided into up to 4 separate
data areas. The total length of these data areas must not exceed 4 data words. In
order to be able to use the function keyboard assignment, you must set up a data
area of the type "function keyboard" in your project at "Area Pointers".

Key assignment

Set the assignment of the individual keys to the bits of the data areas when you
"configure the function keys". For each key you specify the number in the
assignment area.

Keyboard communication bit

The highest bit in the last data word of "each" data area is the keyboard
communication bit. This is a control bit. Each time the keyboard assignment is
downloaded from the operating unit to the PLC, the keyboard communication bit is
set to 1. After the data area has been evaluated by the user program, the keyboard
communication bit should be reset.



Communication areas for non-SIMATIC PLCs Release 12/01

ProTool User Manual How to configure text-based units
C-10 A5E00149249

Regular reading of the communication bit makes it possible in the user program to
establish whether a block has been downloaded again.

Note

You will find a description of the keyboard assignment for SIMATIC PLCs in the
"Communication User's Manual".

LED assignment of the operating unit for non-SIMATIC PLCs

Usage

The light-emitting diodes (LEDs) on the function keys of the operating unit can be
driven on the PLC. This makes it possible, for example, for a key LED to show the
operator which key to press in a particular situation.

Data areas

The LED assignment can be subdivided into up to 4 separate data areas. The total
length of these data areas must not exceed 9 data words. In order to be able to
use the LED assignment, you must set up a data area of the type "LED
assignment" in your project at "Area Pointers".

Polling time

If you specify a polling time of 0 for a data area, this is not downloaded cyclically to
the operating unit. You must then use PLC job No. 42 to drive the LEDs.

LED assignment

Set the assignment of the individual LEDs to the bits of the data areas when you
"configure the function keys". For each LED you specify the number of the
assignment area and the bit number in this area.

Bit number n in the following tables designates the first of two successive bits that
control a total of four different LED states.

Bit n + 1 Bit n LED function

0 0 Off

0 1 Flashing at approx. 2 Hz

1 0 Flashing at approx. 0.5 Hz

1 1 On continuously

LED function for the right > left count direction
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Bit n + 1 Bit n LED function

0 0 Off

0 1 Flashing at approx. 0.5 Hz

1 0 Flashing at approx. 2 Hz

1 1 On continuously

LED function for the left > right count direction

The OP 17 has two-color LEDs integrated in the K keys. This results in the
following LED functions:

Bit n + 1 Bit n LED function

0 0 Off

0 1 Flashing red

1 0 Continuous red light

1 1 Continuous green light

LED function for the right > left count direction

Bit n + 1 Bit n LED function

0 0 Off

0 1 Continuous red light

1 0 Flashing red

1 1 Continuous green light

LED function for the left > right count direction

Note

You will find a description of the LED assignment for SIMATIC PLCs in the
"Communication User's Guide".
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D Abbreviations

Overview

The meanings of the abbreviations used in this documentation are as follows:

ANSI American National Standards Institute

AS 511 Protocol of the PU interface on the SIMATIC S5

ASCII American Standard Code for Information Interchange

CPU Central Processing Unit

DP Distributed I/O

FM Function module

HMI Human Machine Interface

LED Light-emitting diode

MPI Multipoint Interface (SIMATIC S7)

OP Operator panel

PC Personal Computer

PU Programming unit

RAM Random access memory: memory with random access (working
memory)

PLC Programmable logic control

TD Text-based display
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